[jitsi-users] Help needed: Jitsi fails in registering users


#1

Is the following a problem due to Java version (which Java version is
to be used) or due to some other problem? I think the jitsi is not
receiving the "ack" from OpenSIPS server or is not able to process.
When I ran the build from the local source (not changed) it threw
errors (mentioned at the end of this post). before that let me describe
what is not working here.

I used Jitsi latest /nightly build and also used local rebuild of
MAC-based jitsi source. NONE of them was successful in registering a
user to a running OpenSIPS server running on 1.2.3.4 IP.

My OS is MAC -- tried on 10.6 and 10.8. The JAVA I use is: build
1.6.0_35-b10-428-11M3811.

Jitsi used to work earlier but now it is not working.

Details:
I. Started jitsi, and created an account sipuser123@1.2.3.4.

2. when I log onto OpenSIPS server at 1.2.3.4 and supply "opensipsctl
ul show" to show the list of users, it shows sipuser123 as online.
Before the step 1, I had made sure there is no such user already on the
server.

3. But jitsi responds after few seconds that jitsi failed connecting to
the server.

error thrown:

[copy] Copying 3 files to /Users/sipuser2012/jitsi/sc-bundles

run:
     [java] warning: The VAD has been replaced by a hack pending a
complete rewrite
     [java] ERROR: Bundle [81] Error starting
reference:file:sc-bundles/growlnotification.jar
(org.osgi.framework.BundleException: Unresolved constraint in bundle
[81]: Unable to resolve 81.0: missing requirement [81.0] package;
(package=org.growl4j))
     [java] org.osgi.framework.BundleException: Unresolved constraint
in bundle [81]: Unable to resolve 81.0: missing requirement [81.0]
package; (package=org.growl4j)
     [java] at
org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
     [java] at
org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
     [java] at
org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
     [java] at
org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
     [java] at java.lang.Thread.run(Thread.java:680)