[jitsi-users] GThread-ERROR **: GThread system may only be initialized once.


#1

I installed jitsi-2.2 on a CentOS-6.4 x86_64 host. When I run it as a
non-privileged user then I see this error:

$ jitsi
ALSA lib pcm.c:2209:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2209:(snd_pcm_open_noupdate) Unknown PCM
cards.pcm.center_lfe
ALSA lib pcm.c:2209:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports
only playback stream

GThread-ERROR **: GThread system may only be initialized once.
aborting...
Aborted

and it dies.

If instead I run it as a privileged user then I see this:

$ sudo jitsi
[sudo] password for byrnejb:
ALSA lib pcm.c:2209:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2209:(snd_pcm_open_noupdate) Unknown PCM
cards.pcm.center_lfe
ALSA lib pcm.c:2209:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports
only playback stream
java.lang.UnsatisfiedLinkError:
/usr/share/jitsi/lib/native/libglobalshortcut.so:
/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found
(required by /usr/share/jitsi/lib/native/libglobalshortcut.so)
  at java.lang.ClassLoader$NativeLibrary.load(Native Method)
  at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1939)
  at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1864)
  at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1854)
  at java.lang.Runtime.loadLibrary0(Runtime.java:845)
  at java.lang.System.loadLibrary(System.java:1084)
  at
net.java.sip.communicator.impl.globalshortcut.NativeKeyboardHook.<clinit>(NativeKeyboardHook.java:254)
  at
net.java.sip.communicator.impl.globalshortcut.GlobalShortcutServiceImpl.<init>(GlobalShortcutServiceImpl.java:56)
  at
net.java.sip.communicator.impl.globalshortcut.GlobalShortcutActivator.start(GlobalShortcutActivator.java:104)
  at
org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:629)
  at org.apache.felix.framework.Felix.activateBundle(Felix.java:1904)
  at org.apache.felix.framework.Felix.startBundle(Felix.java:1822)
  at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
  at
org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
  at java.lang.Thread.run(Thread.java:722)

And it works. What is going on and how do I fix it?

···

--
*** E-Mail is NOT a SECURE channel ***
James B. Byrne mailto:ByrneJB@Harte-Lyne.ca
Harte & Lyne Limited http://www.harte-lyne.ca
9 Brockley Drive vox: +1 905 561 1241
Hamilton, Ontario fax: +1 905 561 0757
Canada L8E 3C3