[jitsi-users] Get session-id error


#1

Hi guys

I'm having a problem with the authentication after my last upgrade. I'm getting this "Get session-id error" and despite that this issue was exposed on 2016, I'm trying to follow the advise about modify the line 17 in the index.html adding the current jitsi-meet version, however it doesn't work. Any clue about it?

Thank you.

···

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa mi brevedad.


#2

Hi,

Not sure what is the "modify the line 17 in the index.html", what you
are trying to achieve?
I know there were few bugs fixed for the authentication and should be fine now.

Regards
damencho

···

On Wed, Feb 1, 2017 at 7:46 AM, Jack Freakazoid <freakazoid@riseup.net> wrote:

Hi guys

I'm having a problem with the authentication after my last upgrade. I'm
getting this "Get session-id error" and despite that this issue was exposed
on 2016, I'm trying to follow the advise about modify the line 17 in the
index.html adding the current jitsi-meet version, however it doesn't work.
Any clue about it?

Thank you.
--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa mi
brevedad.
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

It's in a post from 2016

"The easiest way is to manually edit https://github.com/jitsi/jitsi-meet/blob/master/index.html#L17 and specify current jitsi-meet version there, so browser will know that it should load file from the server.
More tricky way is to configure caching on your http server"

https://github.com/jitsi/jitsi-meet/issues/505

Cheers.

···

El 1 de febrero de 2017 11:57:50 a. m. GMT-05:00, Damian Minkov <damencho@jitsi.org> escribió:

Hi,

Not sure what is the "modify the line 17 in the index.html", what you
are trying to achieve?
I know there were few bugs fixed for the authentication and should be
fine now.

Regards
damencho

On Wed, Feb 1, 2017 at 7:46 AM, Jack Freakazoid <freakazoid@riseup.net> >wrote:

Hi guys

I'm having a problem with the authentication after my last upgrade.

I'm

getting this "Get session-id error" and despite that this issue was

exposed

on 2016, I'm trying to follow the advise about modify the line 17 in

the

index.html adding the current jitsi-meet version, however it doesn't

work.

Any clue about it?

Thank you.
--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor,

disculpa mi

brevedad.
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa mi brevedad.


#4

Hi,

This line and those posts are no longer relevant. The problem
referenced there was fixed. So you should be hitting another problem,
not sure what it is. Do you have any errors in the js console, what
about jicofo logs any error there?

Regards
damencho

···

On Wed, Feb 1, 2017 at 11:02 AM, Jack Freakazoid <freakazoid@riseup.net> wrote:

It's in a post from 2016

"The easiest way is to manually edit
https://github.com/jitsi/jitsi-meet/blob/master/index.html#L17 and specify
current jitsi-meet version there, so browser will know that it should load
file from the server.
More tricky way is to configure caching on your http server"

https://github.com/jitsi/jitsi-meet/issues/505

Cheers.

El 1 de febrero de 2017 11:57:50 a. m. GMT-05:00, Damian Minkov > <damencho@jitsi.org> escribió:

Hi,

Not sure what is the "modify the line 17 in the index.html", what you
are trying to achieve?
I know there were few bugs fixed for the authentication and should be fine
now.

Regards
damencho

On Wed, Feb 1, 2017 at 7:46 AM, Jack Freakazoid <freakazoid@riseup.net> >> wrote:

Hi guys

I'm having a problem with the authentication after my last upgrade. I'm
getting this "Get session-id error" and despite that this issue was
exposed
on 2016, I'm trying to follow the advise about modify the line 17 in the
index.html adding the current jitsi-meet version, however it doesn't
work.
Any clue about it?

Thank you.
--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa
mi
brevedad.
________________________________

users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

________________________________

users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa mi
brevedad.


#5

No man the problem is not solved as you say, otherwise I wouldn't have it. I have the last version of the unstable repository from yesterday afternoon. I don't have any other problem but this. No errors no nothing.

Cheers

···

El 1 de febrero de 2017 12:36:33 p. m. GMT-05:00, Damian Minkov <damencho@jitsi.org> escribió:

Hi,

This line and those posts are no longer relevant. The problem
referenced there was fixed. So you should be hitting another problem,
not sure what it is. Do you have any errors in the js console, what
about jicofo logs any error there?

Regards
damencho

On Wed, Feb 1, 2017 at 11:02 AM, Jack Freakazoid ><freakazoid@riseup.net> wrote:

It's in a post from 2016

"The easiest way is to manually edit
https://github.com/jitsi/jitsi-meet/blob/master/index.html#L17 and

specify

current jitsi-meet version there, so browser will know that it should

load

file from the server.
More tricky way is to configure caching on your http server"

https://github.com/jitsi/jitsi-meet/issues/505

Cheers.

El 1 de febrero de 2017 11:57:50 a. m. GMT-05:00, Damian Minkov >> <damencho@jitsi.org> escribió:

Hi,

Not sure what is the "modify the line 17 in the index.html", what

you

are trying to achieve?
I know there were few bugs fixed for the authentication and should

be fine

now.

Regards
damencho

On Wed, Feb 1, 2017 at 7:46 AM, Jack Freakazoid ><freakazoid@riseup.net> >>> wrote:

Hi guys

I'm having a problem with the authentication after my last

upgrade. I'm

getting this "Get session-id error" and despite that this issue

was

exposed
on 2016, I'm trying to follow the advise about modify the line 17

in the

index.html adding the current jitsi-meet version, however it

doesn't

work.
Any clue about it?

Thank you.
--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor,

disculpa

mi
brevedad.
________________________________

users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

________________________________

users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor,

disculpa mi

brevedad.

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa mi brevedad.


#6

Hi,

Ok I need to configure and test it on my side in order to see what is going on.
Can you at least paste the error you see about the "session-id error"
you are mentioning.
What is your setup, you have enabled authentication in prosody and you
have configured in meet config.js - authdomain and anonymousdomain?

Regards
damencho

···

On Wed, Feb 1, 2017 at 11:40 AM, Jack Freakazoid <freakazoid@riseup.net> wrote:

No man the problem is not solved as you say, otherwise I wouldn't have it. I
have the last version of the unstable repository from yesterday afternoon. I
don't have any other problem but this. No errors no nothing.

Cheers

El 1 de febrero de 2017 12:36:33 p. m. GMT-05:00, Damian Minkov > <damencho@jitsi.org> escribió:

Hi,

This line and those posts are no longer relevant. The problem
referenced there was fixed. So you should be hitting another problem,
not sure what it is. Do you have any errors in the js console, what
about jicofo logs any error there?

Regards
damencho

On Wed, Feb 1, 2017 at 11:02 AM, Jack Freakazoid <freakazoid@riseup.net> >> wrote:

It's in a post from 2016

"The easiest way is to manually edit
https://github.com/jitsi/jitsi-meet/blob/master/index.html#L17 and
specify
current jitsi-meet version there, so browser will know that it should
load
file from the server.
More tricky way is to configure caching on your http server"

https://github.com/jitsi/jitsi-meet/issues/505

Cheers.

El 1 de febrero de 2017 11:57:50 a. m. GMT-05:00, Damian Minkov >>> <damencho@jitsi.org> escribió:

Hi,

Not sure what is the "modify the line 17 in the index.html", what you
are trying to achieve?
I know there were few bugs fixed for the authentication and should be
fine
now.

Regards
damencho

On Wed, Feb 1, 2017 at 7:46 AM, Jack Freakazoid <freakazoid@riseup.net> >>>> wrote:

  Hi guys

  I'm having a problem with the authentication after my last upgrade.
I'm
  getting this "Get session-id error" and despite that this issue was
exposed
  on 2016, I'm trying to follow the advise about modify the line 17 in
the
  index.html adding the current jitsi-meet version, however it doesn't
work.
  Any clue about it?

  Thank you.
  --
  Enviado desde mi dispositivo Android con K-9 Mail. Por favor,
disculpa
mi
  brevedad.
________________________________

  users mailing list
  users@jitsi.org
  Unsubscribe instructions and other list options:
  http://lists.jitsi.org/mailman/listinfo/users

________________________________

users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa
mi
brevedad.

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa mi
brevedad.


#7

Hi Damian

Yes sure..

Herein a screenshot about the error.

I have setup in the config.js the authdomain and anonymousdomain. The authdomain in Prosody is with internal_plain and I create a user in prosody for that authdomain (prosodyuser@authdomain.xxxx.xxxx)

The problem is when I try to login I have this Get session-id error but if I disable the authentication, everything works properly.

Thank you,

Chheers.

···

El 2017-02-01 12:49, Damian Minkov escribió:

Hi,

Ok I need to configure and test it on my side in order to see what is going on.
Can you at least paste the error you see about the "session-id error"
you are mentioning.
What is your setup, you have enabled authentication in prosody and you
have configured in meet config.js - authdomain and anonymousdomain?

Regards
damencho

On Wed, Feb 1, 2017 at 11:40 AM, Jack Freakazoid > <freakazoid@riseup.net> wrote:

No man the problem is not solved as you say, otherwise I wouldn't have it. I
have the last version of the unstable repository from yesterday afternoon. I
don't have any other problem but this. No errors no nothing.

Cheers

El 1 de febrero de 2017 12:36:33 p. m. GMT-05:00, Damian Minkov >> <damencho@jitsi.org> escribió:

Hi,

This line and those posts are no longer relevant. The problem
referenced there was fixed. So you should be hitting another problem,
not sure what it is. Do you have any errors in the js console, what
about jicofo logs any error there?

Regards
damencho

On Wed, Feb 1, 2017 at 11:02 AM, Jack Freakazoid >>> <freakazoid@riseup.net> >>> wrote:

It's in a post from 2016

"The easiest way is to manually edit
https://github.com/jitsi/jitsi-meet/blob/master/index.html#L17 and
specify
current jitsi-meet version there, so browser will know that it should
load
file from the server.
More tricky way is to configure caching on your http server"

https://github.com/jitsi/jitsi-meet/issues/505

Cheers.

El 1 de febrero de 2017 11:57:50 a. m. GMT-05:00, Damian Minkov >>>> <damencho@jitsi.org> escribió:

Hi,

Not sure what is the "modify the line 17 in the index.html", what you
are trying to achieve?
I know there were few bugs fixed for the authentication and should be
fine
now.

Regards
damencho

On Wed, Feb 1, 2017 at 7:46 AM, Jack Freakazoid >>>>> <freakazoid@riseup.net> >>>>> wrote:

  Hi guys

  I'm having a problem with the authentication after my last upgrade.
I'm
  getting this "Get session-id error" and despite that this issue was
exposed
  on 2016, I'm trying to follow the advise about modify the line 17 in
the
  index.html adding the current jitsi-meet version, however it doesn't
work.
  Any clue about it?

  Thank you.
  --
  Enviado desde mi dispositivo Android con K-9 Mail. Por favor,
disculpa
mi
  brevedad.
________________________________

  users mailing list
  users@jitsi.org
  Unsubscribe instructions and other list options:
  http://lists.jitsi.org/mailman/listinfo/users

________________________________

users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa
mi
brevedad.

--
Enviado desde mi dispositivo Android con K-9 Mail. Por favor, disculpa mi
brevedad.