[jitsi-users] GChat setup, login failure


#1

Hi,

I am attempting to use Jitsi as a chat client with GChat, instead of being
logged into gmail and using the browser popup. My impression is that this
should be possible, based on the following:
http://lists.jitsi.org/pipermail/dev/2015-July/024676.html
and
https://github.com/jitsi/jitsi/issues/169

Since these discussions refer to versions of Jitsi after July 2015, and the
Stable release is from March 2015, I have installed the nightly build:
2.9.5500.

When I follow the instructions to set up a Google Talk account
https://jitsi.org/Documentation/SetUpGoogleTalk
and I try to Sign In, I get a popup saying:
"The xxx@gmail.com (Google Talk) server has requested your authentication."
I am asked for my password, and upon entering it I get:
"Authentication failed for xxx@gmail.com (Google Talk). The password you
entered is not valid."

This behavior does not agree with what I would expect based on the
discussions at the first two links in my post. I do not see any popup
providing a link to use OAuth2. And the instructions for how to set up
Google Talk are obviously out of date. Any help would be most welcome.

Thanks!
-Andrew


#2

I am attempting to use Jitsi as a chat client with GChat, instead of
being logged into gmail and using the browser popup. My impression is
that this should be possible, based on the following:
http://lists.jitsi.org/pipermail/dev/2015-July/024676.html and
https://github.com/jitsi/jitsi/issues/169

This is for the address book only. It has absolutely nothing to do with the chat.

Since these discussions refer to versions of Jitsi after July 2015, and
the Stable release is from March 2015, I have installed the nightly
build: 2.9.5500.

When I follow the instructions to set up a Google Talk account
https://jitsi.org/Documentation/SetUpGoogleTalk and I try to Sign In, I
get a popup saying: "The xxx@gmail.com <mailto:xxx@gmail.com> (Google
Talk) server has requested your authentication." I am asked for my
password, and upon entering it I get: "Authentication failed for
xxx@gmail.com <mailto:xxx@gmail.com> (Google Talk). The password you
entered is not valid."

Please try adding a regular XMPP account, using xxx@gmail.com as the username and your normal password. If you have 2-factor auth enabled for Gmail, you need to create an application password.

This behavior does not agree with what I would expect based on the
discussions at the first two links in my post. I do not see any popup
providing a link to use OAuth2. And the instructions for how to set up
Google Talk are obviously out of date. Any help would be most welcome.

Thanks!
-Andrew

Ingo