[jitsi-users] Fwd: "call not secure" (03)


#1

and before I forget: this problem persists even with the latest nightly build (2.3.4807)

-------- Originalnachricht --------

I have done some more testing and I think I have come to the bottom of
it, even though the real reasons are still opaque

1. forget everything what I said below
2. The problem rests with the Jitsi WASAPI driver(s)
3. The problem has nothing to do with the "Exclusive mode"
4. so both of you were right in the first place; and it seems that I
did not relaunch Jitsi when testing WASAPI vs PortAudio

My tests have now shown that whenever Jitsi is launched with WASAPI
configured, the mic does not work under Jitsi. This with or without
exclusive mode; and even though the mic clearly works on other recording
SW

This leads me to the question: why is WASAPI offered as an option? What
are the possible advantages over PortAudio?
M.H.

-------- Originalnachricht --------

I have checked further into the audio issue and have found one possible
ground for problems; namely the Win7 sound manager. Although I cannot
be
entirely sure - this needs further testing; will report later - it
seems
that under 'Microphone properties, Advanced', one needs to enable
"Exclusive Mode" otherwise Jitsi may be "pushed under" by other
applications, such as Audacity.

It seems that without that, the mic is not always working

ยทยทยท

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Thanks Boris; but I think that WASAPI can be ruled out as the culprit;
because I tried the same person also with PortAudio; and the call stayed
unsecure (this may have been a different call and might not show up on
the logfile sent)

At least the log you sent shows a problem with WASAPI which lead to a
failure initializing ZRTP (the mic-noise is used to seed a random
number
generator, RNG). Failure to initialize it could hence very well be the
culprit.
If PortAudio works, have you restarted Jitsi between changing the audio
systems? The RNG is only initialized at startup.

M.H.

Ingo