[jitsi-users] Force TCP over UDP for Audio/Video calls?


#1

I've seen no topic or suggestion about it & hopefully i am writing this
to the right place,

If i know well, my current (2.8.5426 or any) jitsi client uses UDP
(normally ~5000-6000 ports) for A/V calls.
I realized that if my friend travels to abroad A/V calls are not working
at all (ERROR: ICE failed or no relay found) only the chat which is
"running on the TCP port" i think.
I had this ERROR before because of the Audio Encodings setting did not
match, so i checked and it was correct and worked fine with "homeland's
ISP", so this setting can not be the reason i think.
We tried with VPN and with disabled router's firewall also without success.

Does it mean, "they" are responsible for it? They might be fighting
against torrent that way, no idea. Is there a possibility or an option
to change or try to do something against it?

I tried [Mumble](https://github.com/mumble-voip/mumble) which has this
option (Force TCP mode) and Audio call worked just fine.

Am i "groping" at the right place in this situation?
If not, what options could solve this issue? What could be causing this?

Regards,
sanyy


#2

Hello,

I've seen no topic or suggestion about it & hopefully i am writing this
to the right place,

If i know well, my current (2.8.5426 or any) jitsi client uses UDP
(normally ~5000-6000 ports) for A/V calls.
I realized that if my friend travels to abroad A/V calls are not working
at all (ERROR: ICE failed or no relay found) only the chat which is
"running on the TCP port" i think.
I had this ERROR before because of the Audio Encodings setting did not
match, so i checked and it was correct and worked fine with "homeland's
ISP", so this setting can not be the reason i think.
We tried with VPN and with disabled router's firewall also without success.

Does it mean, "they" are responsible for it? They might be fighting
against torrent that way, no idea. Is there a possibility or an option
to change or try to do something against it?

I tried [Mumble](https://github.com/mumble-voip/mumble) which has this
option (Force TCP mode) and Audio call worked just fine.

>
> Am i "groping" at the right place in this situation?
> If not, what options could solve this issue? What could be causing this?
>

That a firewall somewhere blocks your UDP traffic and causes Jitsi's calls to fail is certainly possible. The Jitsi desktop client doesn't support media transport over TCP. You could give a try to our jitsi-meet based service, which supports fallback to TCP if UDP doesn't work:
https://meet.jit.si

Regards,
Boris

ยทยทยท

On 12/12/2016 12:30, Sanyy wrote: