[jitsi-users] Force Prosody-authentication in Jitsi-meet


#1

Hi again,

Responding to my own post here, but it seems that jicofo is reporting the
problem at least and that I am not the only one having the problem:

https://github.com/jitsi/jicofo/issues/22

jicofo errors out with:

Sep 24, 2015 5:46:24 PM org.jivesoftware.smack.PacketReader
notifyConnectionError
SEVERE: Closes the connection temporary
stream:error (text)
        at
org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:264)
        at
org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
        at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)

Sep 24, 2015 5:46:44 PM net.java.sip.communicator.util.Logger error
SEVERE:
net.java.sip.communicator.service.protocol.OperationFailedException: Failed
to connect
net.java.sip.communicator.service.protocol.OperationFailedException: Failed
to connect
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:182)
        at org.jitsi.jicofo.util.RegisterThread.run(RegisterThread.java:49)
Caused by: No response from the server.:
        at
org.jivesoftware.smack.NonSASLAuthentication.authenticate(NonSASLAuthentication.java:73)
        at
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:217)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.register(XmppProtocolProvider.java:177)
        ... 1 more

complete log here: https://paste.debian.net/313242/

Any ideas?

Kindest regards,
Mathias

···

2015-09-23 19:28 GMT+02:00 Mathias Friman <mathias@workplays.se>:

Hi,

I now have configured Prosody in my in-house Jitsi-meet-server to
authenticate via Active Directory. I have also enabled the secure domain
following this guide: https://github.com/jitsi/jicofo#secure-domain

So when creating a new conference I get a message saying:

"
Waiting for the host...
The conference *chat * has not yet started. If you are the host then
please authenticate. Otherwise, please wait for the host to arrive."

Clicking on "I am the host" and logging in with wrong username I get

"Error
Connection failed: host-unknown"

However when logging in with correct username and correct _or_ incorrect
password i get

"Connecting
Connecting"

The jvb.log does not tell me anything and jicofo.log keeps squirting out

"2015-08-23 19:22:28.708 INFO: [58]
org.jitsi.jicofo.xmpp.FocusComponent.handleConferenceIq().377 Focus request
for room: chat5@conference.10.1.3.16"

endlessly. prosody.err doesn't tell me anything either, but prosody.log
says this:

Sep 23 19:25:00 bosh0cd5fa28-5a02-42ef-8453-f0310392eb3a info BOSH
client disconnected
Sep 23 19:25:00 mod_bosh info Client tried to use sid
'0cd5fa28-5a02-42ef-8453-f0310392eb3a' which we don't know about
Sep 23 19:25:00 mod_bosh info Client tried to use sid
'0cd5fa28-5a02-42ef-8453-f0310392eb3a' which we don't know about
Sep 23 19:25:01 mod_bosh info New BOSH session, assigned it sid
'28a7f933-82a6-4bfd-b270-09d512b47231'
Sep 23 19:25:01 bosh28a7f933-82a6-4bfd-b270-09d512b47231 info
Authenticated as 9f97257a-5c24-42ca-a172-dd52ef4216e3@guest.10.1.3.16

And after I try to login it says:

Sep 23 19:25:26 mod_bosh info New BOSH session, assigned it sid
'a4a1b27f-2403-468a-bf16-0d740710d073'

And then it just sits there...

I don't have any DNS name assigned to the server, can that be the problem?

Kindest regards,
Mathias