[jitsi-users] Files and host unknown


#1

Hello everybody,

I'm trying to set up my own Jitsi-Meet server on a rental server with Fedora 25.

I used the detailed installation description and was able to get Prosody, Nginx and the Jitsi videobridge to run and (with some difficulties) to build Jicofo.

But I still have 2 problems:

Problem 1:
When I start jicofo with "./jicofo.sh --host=127.0.0.1 --domain=jitsi.(myserver) --secret=(...) --user_domain=auth.jitsi.(myserver) --user_name=focus --user_password=(...)", I get the following error message:

Jicofo 2017-01-20 13:30:35.808 SEVERE: [30] org.jitsi.meet.ComponentMain.call().278 host-unknown, host:127.0.0.1, port:5347

How can 127.0.0.1 be unknown? I already tried to use localhost instead of it but with the same result. Jitsi videobridge has no problem with localhost.

Problem 2:

When I open jitsi.(myserver) with Firefox, I see a page with the following error:

"Uh oh! We couldn't fully download everything we needed :frowning:
We will try again shortly. In the mean time, check for problems with your Internet connection!"

So I had a look into the error.log file of Nginx, where I found these 3 errors repeatedly:

2017/01/20 13:43:17 [error] 26172#0: *43 open() "/srv/jitsi.(myserver)/libs/lib-jitsi-meet.min.js" failed (2: No such file or directory), client: 46.182.19.206, server: jitsi.(myserver), request: "GET /libs/lib-jitsi-meet.min.js?v=139 HTTP/1.1", host: "jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"
2017/01/20 13:43:17 [error] 26172#0: *43 open() "/srv/jitsi.(myserver)/libs/app.bundle.min.js" failed (2: No such file or directory), client: 46.182.19.206, server: jitsi.(myserver), request: "GET /libs/app.bundle.min.js?v=139 HTTP/1.1", host: "jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"
2017/01/20 13:43:17 [error] 26172#0: *43 open() "/srv/jitsi.(myserver)/css/all.css" failed (2: No such file or directory), client: 46.182.19.206, server: jitsi.(myserver), request: "GET /css/all.css HTTP/1.1", host: "jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"

And yes these, files are missing in the Jitsi folder! There is not even a "libs" subfolder even as I just cloned Jitsi-Meet from the git server. Do I have to download something extra to the Jitsi-Meet sources?

Perhaps anybody had the same problem(s) and can give me a hint for the solution(s). I'm not sure, if the 2 Problems have anything to do with each other.
Thanks a lot!

Regards
Marco


#2

Hello everybody,

I'm trying to set up my own Jitsi-Meet server on a rental server with Fedora 25.

I used the detailed installation description and was able to get Prosody, Nginx and the Jitsi videobridge to run and (with some difficulties) to build Jicofo.

But I still have 2 problems:

Problem 1:
When I start jicofo with "./jicofo.sh --host=127.0.0.1 --domain=jitsi.(myserver) --secret=(...) --user_domain=auth.jitsi.(myserver) --user_name=focus --user_password=(...)", I get the following error message:

Jicofo 2017-01-20 13:30:35.808 SEVERE: [30] org.jitsi.meet.ComponentMain.call().278 host-unknown, host:127.0.0.1, port:5347

How can 127.0.0.1 be unknown? I already tried to use localhost instead of it but with the same result. Jitsi videobridge has no problem with localhost.

The domain name is unknown. Probably jicofo.jitsi.myserver is not registered as a component in prosody.

Problem 2:

When I open jitsi.(myserver) with Firefox, I see a page with the following error:

"Uh oh! We couldn't fully download everything we needed :frowning:
We will try again shortly. In the mean time, check for problems with your Internet connection!"

So I had a look into the error.log file of Nginx, where I found these 3 errors repeatedly:

2017/01/20 13:43:17 [error] 26172#0: *43 open() "/srv/jitsi.(myserver)/libs/lib-jitsi-meet.min.js" failed (2: No such file or directory), client: 46.182.19.206, server: jitsi.(myserver), request: "GET /libs/lib-jitsi-meet.min.js?v=139 HTTP/1.1", host: "jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"
2017/01/20 13:43:17 [error] 26172#0: *43 open() "/srv/jitsi.(myserver)/libs/app.bundle.min.js" failed (2: No such file or directory), client: 46.182.19.206, server: jitsi.(myserver), request: "GET /libs/app.bundle.min.js?v=139 HTTP/1.1", host: "jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"
2017/01/20 13:43:17 [error] 26172#0: *43 open() "/srv/jitsi.(myserver)/css/all.css" failed (2: No such file or directory), client: 46.182.19.206, server: jitsi.(myserver), request: "GET /css/all.css HTTP/1.1", host: "jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"

And yes these, files are missing in the Jitsi folder! There is not even a "libs" subfolder even as I just cloned Jitsi-Meet from the git server. Do I have to download something extra to the Jitsi-Meet sources?

Try running "make" inside the jitsi-meet directory.

Perhaps anybody had the same problem(s) and can give me a hint for the solution(s). I'm not sure, if the 2 Problems have anything to do with each other.

No, these seem like two separate problems.

Regards,
Boris

···

On 20/01/2017 06:59, Marco wrote:


#3

Yes, that helped! Thanks a lot.
So now, I still have the problem that Jicofo doesn't know 127.0.0.1.
Does anybody know what could be the reason?

Regards,
Marco

···

Am 20.01.2017 um 17:17 schrieb Boris Grozev:

On 20/01/2017 06:59, Marco wrote:

Hello everybody,

I'm trying to set up my own Jitsi-Meet server on a rental server with
Fedora 25.

I used the detailed installation description and was able to get
Prosody, Nginx and the Jitsi videobridge to run and (with some
difficulties) to build Jicofo.

But I still have 2 problems:

Problem 1:
When I start jicofo with "./jicofo.sh --host=127.0.0.1
--domain=jitsi.(myserver) --secret=(...)
--user_domain=auth.jitsi.(myserver) --user_name=focus
--user_password=(...)", I get the following error message:

Jicofo 2017-01-20 13:30:35.808 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:127.0.0.1,
port:5347

How can 127.0.0.1 be unknown? I already tried to use localhost
instead of it but with the same result. Jitsi videobridge has no
problem with localhost.

The domain name is unknown. Probably jicofo.jitsi.myserver is not
registered as a component in prosody.

Problem 2:

When I open jitsi.(myserver) with Firefox, I see a page with the
following error:

"Uh oh! We couldn't fully download everything we needed :frowning:
We will try again shortly. In the mean time, check for problems with
your Internet connection!"

So I had a look into the error.log file of Nginx, where I found these
3 errors repeatedly:

2017/01/20 13:43:17 [error] 26172#0: *43 open()
"/srv/jitsi.(myserver)/libs/lib-jitsi-meet.min.js" failed (2: No such
file or directory), client: 46.182.19.206, server: jitsi.(myserver),
request: "GET /libs/lib-jitsi-meet.min.js?v=139 HTTP/1.1", host:
"jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"
2017/01/20 13:43:17 [error] 26172#0: *43 open()
"/srv/jitsi.(myserver)/libs/app.bundle.min.js" failed (2: No such
file or directory), client: 46.182.19.206, server: jitsi.(myserver),
request: "GET /libs/app.bundle.min.js?v=139 HTTP/1.1", host:
"jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"
2017/01/20 13:43:17 [error] 26172#0: *43 open()
"/srv/jitsi.(myserver)/css/all.css" failed (2: No such file or
directory), client: 46.182.19.206, server: jitsi.(myserver), request:
"GET /css/all.css HTTP/1.1", host: "jitsi.(myserver)", referrer:
"http://jitsi.(myserver)/?rCounter=2"

And yes these, files are missing in the Jitsi folder! There is not
even a "libs" subfolder even as I just cloned Jitsi-Meet from the git
server. Do I have to download something extra to the Jitsi-Meet sources?

Try running "make" inside the jitsi-meet directory.

Perhaps anybody had the same problem(s) and can give me a hint for
the solution(s). I'm not sure, if the 2 Problems have anything to do
with each other.

No, these seem like two separate problems.

Regards,
Boris


#4

It's not about "127.0.0.1", it's about the domain name you pass. Check the prosody configuration for such a component.

Boris

···

On 21/01/2017 09:40, Marco wrote:

Am 20.01.2017 um 17:17 schrieb Boris Grozev:

On 20/01/2017 06:59, Marco wrote:

Hello everybody,

I'm trying to set up my own Jitsi-Meet server on a rental server with
Fedora 25.

I used the detailed installation description and was able to get
Prosody, Nginx and the Jitsi videobridge to run and (with some
difficulties) to build Jicofo.

But I still have 2 problems:

Problem 1:
When I start jicofo with "./jicofo.sh --host=127.0.0.1
--domain=jitsi.(myserver) --secret=(...)
--user_domain=auth.jitsi.(myserver) --user_name=focus
--user_password=(...)", I get the following error message:

Jicofo 2017-01-20 13:30:35.808 SEVERE: [30]
org.jitsi.meet.ComponentMain.call().278 host-unknown, host:127.0.0.1,
port:5347

How can 127.0.0.1 be unknown? I already tried to use localhost
instead of it but with the same result. Jitsi videobridge has no
problem with localhost.

The domain name is unknown. Probably jicofo.jitsi.myserver is not
registered as a component in prosody.

Problem 2:

When I open jitsi.(myserver) with Firefox, I see a page with the
following error:

"Uh oh! We couldn't fully download everything we needed :frowning:
We will try again shortly. In the mean time, check for problems with
your Internet connection!"

So I had a look into the error.log file of Nginx, where I found these
3 errors repeatedly:

2017/01/20 13:43:17 [error] 26172#0: *43 open()
"/srv/jitsi.(myserver)/libs/lib-jitsi-meet.min.js" failed (2: No such
file or directory), client: 46.182.19.206, server: jitsi.(myserver),
request: "GET /libs/lib-jitsi-meet.min.js?v=139 HTTP/1.1", host:
"jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"
2017/01/20 13:43:17 [error] 26172#0: *43 open()
"/srv/jitsi.(myserver)/libs/app.bundle.min.js" failed (2: No such
file or directory), client: 46.182.19.206, server: jitsi.(myserver),
request: "GET /libs/app.bundle.min.js?v=139 HTTP/1.1", host:
"jitsi.(myserver)", referrer: "http://jitsi.(myserver)/?rCounter=2"
2017/01/20 13:43:17 [error] 26172#0: *43 open()
"/srv/jitsi.(myserver)/css/all.css" failed (2: No such file or
directory), client: 46.182.19.206, server: jitsi.(myserver), request:
"GET /css/all.css HTTP/1.1", host: "jitsi.(myserver)", referrer:
"http://jitsi.(myserver)/?rCounter=2"

And yes these, files are missing in the Jitsi folder! There is not
even a "libs" subfolder even as I just cloned Jitsi-Meet from the git
server. Do I have to download something extra to the Jitsi-Meet sources?

Try running "make" inside the jitsi-meet directory.

Perhaps anybody had the same problem(s) and can give me a hint for
the solution(s). I'm not sure, if the 2 Problems have anything to do
with each other.

No, these seem like two separate problems.

Regards,
Boris

Yes, that helped! Thanks a lot.
So now, I still have the problem that Jicofo doesn't know 127.0.0.1.
Does anybody know what could be the reason?