[jitsi-users] Error on creating account: For input string: ""


#1

Folks

I tried to change the encodings on my jit.si account and I got a null
error when trying to sign in. I deleted the account and attempted to
add it again, and I got this error:
        We failed to create your account due to the following error: For
        input string: ""
I don't know what it means or why I get it or what to do about it. And
I don't know why I couldn't change the encodings.

Thank you in advance for your help.

Pablo


#2

Regarding my query..

I should add that I am using 2.3.4707.9876 nightly build on Ubuntu
13.04. Also I have recently added UART to my ttyS0 and ttyS1 serial
port settings, in case that has anything to do with it.

And I am still able to make SIP calls fine.

Pablo

···

El vie, 05-07-2013 a las 19:28 -0500, Carola y Pablo escribió:

Folks

I tried to change the encodings on my jit.si account and I got a null
error when trying to sign in. I deleted the account and attempted to
add it again, and I got this error:
        We failed to create your account due to the following error: For
        input string: ""
I don't know what it means or why I get it or what to do about it. And
I don't know why I couldn't change the encodings.

Thank you in advance for your help.

Pablo


#3

I tried to change the encodings on my jit.si account and I got a null
error when trying to sign in. I deleted the account and attempted to
add it again, and I got this error:
        We failed to create your account due to the following error: For
        input string: ""
I don't know what it means or why I get it or what to do about it. And
I don't know why I couldn't change the encodings.

Thank you in advance for your help.

Please send us your logs. Couldn't reproduce anything by changing encodings
or removing/re-adding my account.

Pablo

Ingo


#4

Thank you for your response. I am attaching a log file generated after
trying to add the account. I am also attaching images of the error
messages.

thank you

2013-07-06@06.14.15-logs.zip (238 KB)

···

El sáb, 06-07-2013 a las 11:24 +0200, Ingo Bauersachs escribió:

> I tried to change the encodings on my jit.si account and I got a null
> error when trying to sign in. I deleted the account and attempted to
> add it again, and I got this error:
> We failed to create your account due to the following error: For
> input string: ""
> I don't know what it means or why I get it or what to do about it. And
> I don't know why I couldn't change the encodings.
>
> Thank you in advance for your help.

Please send us your logs. Couldn't reproduce anything by changing encodings
or removing/re-adding my account.

> Pablo

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi,

The reason of this error is that jitsi-defaults.properties file could
not be loaded on startup and there are no default values loaded into
the wizard which results in this error message. This file is normally
located under {jitsi installation dir}\lib\jitsi-defaults.properties.
Do you have any idea why this could happen ?

06:10:22.722 INFO: [13]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() No
defaults property file loaded: jitsi-defaults.properties. Not a
problem.
06:10:22.723 INFO: [13]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() No
defaults property file loaded: jitsi-default-overrides.properties. Not
a problem.

Devs,

Do you think that default values should be hardcoded for case this
file is not found ? We should probably change the message or throw an
exception when jitsi-defaults.properties can't be loaded.

Regards,
Pawel

···

On Sat, Jul 6, 2013 at 1:21 PM, Carola y Pablo <stuckybyler2@yahoo.es> wrote:

Thank you for your response. I am attaching a log file generated after
trying to add the account. I am also attaching images of the error
messages.

thank you

El sáb, 06-07-2013 a las 11:24 +0200, Ingo Bauersachs escribió:

> I tried to change the encodings on my jit.si account and I got a null
> error when trying to sign in. I deleted the account and attempted to
> add it again, and I got this error:
> We failed to create your account due to the following error: For
> input string: ""
> I don't know what it means or why I get it or what to do about it. And
> I don't know why I couldn't change the encodings.
>
> Thank you in advance for your help.

Please send us your logs. Couldn't reproduce anything by changing encodings
or removing/re-adding my account.

> Pablo

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

The reason of this error is that jitsi-defaults.properties file could
not be loaded on startup and there are no default values loaded into
the wizard which results in this error message. This file is normally
located under {jitsi installation dir}\lib\jitsi-defaults.properties.
Do you have any idea why this could happen ?

06:10:22.722 INFO: [13]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() No defaults
property file loaded: jitsi-defaults.properties. Not a problem.
06:10:22.723 INFO: [13]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() No defaults
property file loaded: jitsi-default-overrides.properties. Not a problem.

I committed a fix that does an empty check instead of only a null check on
the missing property, but that probably procrastinates the problem to a
later point. But What I'm not sure now: are these default properties copied
into the account when it is created? If so, I think this shouldn't be the
case (after all the defaults haven't changed, so why override them with the
same value?).

Devs,

Do you think that default values should be hardcoded for case this
file is not found?

No! The entire idea of having this file was to get rid of the hardcoded
values.

We should probably change the message or throw an
exception when jitsi-defaults.properties can't be loaded.

Yes, I guess we need to fail the startup if the jitsi-defaults is not
present. However, this is only valid for Jitsi itself. For libjitsi, the
message is correct. (Which now accentuates why I don't like having the
config service implementation in libjitsi...)

Regards,
Pawel

Ingo


#7

Hmmm. I confess I don't understand what you are saying, but I will
standby for the resolution of this dilemma and what steps I should take.
Thank you very much for your help.
Pablo

···

El sáb, 06-07-2013 a las 14:03 +0200, Ingo Bauersachs escribió:

> The reason of this error is that jitsi-defaults.properties file could
> not be loaded on startup and there are no default values loaded into
> the wizard which results in this error message. This file is normally
> located under {jitsi installation dir}\lib\jitsi-defaults.properties.
> Do you have any idea why this could happen ?
>
> 06:10:22.722 INFO: [13]
> org.jitsi.impl.configuration.ConfigurationServiceImpl.info() No defaults
> property file loaded: jitsi-defaults.properties. Not a problem.
> 06:10:22.723 INFO: [13]
> org.jitsi.impl.configuration.ConfigurationServiceImpl.info() No defaults
> property file loaded: jitsi-default-overrides.properties. Not a problem.

I committed a fix that does an empty check instead of only a null check on
the missing property, but that probably procrastinates the problem to a
later point. But What I'm not sure now: are these default properties copied
into the account when it is created? If so, I think this shouldn't be the
case (after all the defaults haven't changed, so why override them with the
same value?).

> Devs,
>
> Do you think that default values should be hardcoded for case this
> file is not found?

No! The entire idea of having this file was to get rid of the hardcoded
values.

> We should probably change the message or throw an
> exception when jitsi-defaults.properties can't be loaded.

Yes, I guess we need to fail the startup if the jitsi-defaults is not
present. However, this is only valid for Jitsi itself. For libjitsi, the
message is correct. (Which now accentuates why I don't like having the
config service implementation in libjitsi...)

> Regards,
> Pawel

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Hi Ingo,

···

On Sat, Jul 6, 2013 at 2:03 PM, Ingo Bauersachs <ingo@jitsi.org> wrote:

The reason of this error is that jitsi-defaults.properties file could
not be loaded on startup and there are no default values loaded into
the wizard which results in this error message. This file is normally
located under {jitsi installation dir}\lib\jitsi-defaults.properties.
Do you have any idea why this could happen ?

06:10:22.722 INFO: [13]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() No defaults
property file loaded: jitsi-defaults.properties. Not a problem.
06:10:22.723 INFO: [13]
org.jitsi.impl.configuration.ConfigurationServiceImpl.info() No defaults
property file loaded: jitsi-default-overrides.properties. Not a problem.

I committed a fix that does an empty check instead of only a null check on
the missing property, but that probably procrastinates the problem to a
later point. But What I'm not sure now: are these default properties copied
into the account when it is created? If so, I think this shouldn't be the
case (after all the defaults haven't changed, so why override them with the
same value?).

Yes, they are copied on account creation. I can try removing this
behaviour and check if it won't introduce any problems. I'll do it on
monday.

Regards,
Pawel


#9

Hmmm. I confess I don't understand what you are saying, but I will
standby for the resolution of this dilemma and what steps I should take.

Please have a look into your Jitsi installation directory and it's subfolder "lib". There should be a file "jitsi-defaults.properties". If it isn't, then either the installation went wrong or possibly our .deb doesn't take care of putting it there yet.

In either case, you can put the attached file there and should be good to go (after a restart of Jitsi).

Thank you very much for your help.
Pablo

Ingo

jitsi-defaults.properties (2.27 KB)


#10

Do I go to /usr/share/jitsi/lib and paste the attached file? If that is
where I go, when I attempt to past the file there, I am told that
permission is denied. I read the help instructions on granting
permissions to folders, but wasn't able to follow them. (Or is the
Jitsi installation directory somewhere else?) I am sure this is
something simple. I recognize my ignorance and thank you for your
patience and help.

Pablo

···

El sáb, 06-07-2013 a las 15:09 +0200, Ingo Bauersachs escribió:

> Hmmm. I confess I don't understand what you are saying, but I will
> standby for the resolution of this dilemma and what steps I should take.

Please have a look into your Jitsi installation directory and it's subfolder "lib". There should be a file "jitsi-defaults.properties". If it isn't, then either the installation went wrong or possibly our .deb doesn't take care of putting it there yet.

In either case, you can put the attached file there and should be good to go (after a restart of Jitsi).

> Thank you very much for your help.
> Pablo

Ingo
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

Do I go to /usr/share/jitsi/lib and paste the attached file?

Yes, this is where it should live.

If that is
where I go, when I attempt to past the file there, I am told that
permission is denied.

You need to do this as root.

I read the help instructions on granting
permissions to folders, but wasn't able to follow them.

Don't change the permissions of the folder. Save the file to a temporary location (with your regular user account) and then copy it to /usr/share/jitsi/lib (as root).

(Or is the
Jitsi installation directory somewhere else?) I am sure this is
something simple. I recognize my ignorance and thank you for your
patience and help.

This file is relatively new and our Linux installers have a bug: they don't copy it yet. So this is definitely not a fault of yours, and if you can wait a couple of days, our installers will be fixed.

Pablo

Ingo


#12

Forgive my limited knowledge. My problem is, precisely, that I don't
know how to copy this as root. Please give me instructions on how to do
so.

Thank you.

Pablo

···

El dom, 07-07-2013 a las 05:58 +0200, Ingo Bauersachs escribió:

> Do I go to /usr/share/jitsi/lib and paste the attached file?

Yes, this is where it should live.

> If that is
> where I go, when I attempt to past the file there, I am told that
> permission is denied.

You need to do this as root.

> I read the help instructions on granting
> permissions to folders, but wasn't able to follow them.

Don't change the permissions of the folder. Save the file to a temporary location (with your regular user account) and then copy it to /usr/share/jitsi/lib (as root).

> (Or is the
> Jitsi installation directory somewhere else?) I am sure this is
> something simple. I recognize my ignorance and thank you for your
> patience and help.

This file is relatively new and our Linux installers have a bug: they don't copy it yet. So this is definitely not a fault of yours, and if you can wait a couple of days, our installers will be fixed.

> Pablo

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#13

My apologies for asking about root. I solved that. I successfully
pasted the file in /usr/share/jitsi/lib and rebooted jitsi but the error
persists. Should I paste it in /usr/share/jitsi/lib/native?

Pablo

···

El dom, 07-07-2013 a las 05:58 +0200, Ingo Bauersachs escribió:

> Do I go to /usr/share/jitsi/lib and paste the attached file?

Yes, this is where it should live.

> If that is
> where I go, when I attempt to past the file there, I am told that
> permission is denied.

You need to do this as root.

> I read the help instructions on granting
> permissions to folders, but wasn't able to follow them.

Don't change the permissions of the folder. Save the file to a temporary location (with your regular user account) and then copy it to /usr/share/jitsi/lib (as root).

> (Or is the
> Jitsi installation directory somewhere else?) I am sure this is
> something simple. I recognize my ignorance and thank you for your
> patience and help.

This file is relatively new and our Linux installers have a bug: they don't copy it yet. So this is definitely not a fault of yours, and if you can wait a couple of days, our installers will be fixed.

> Pablo

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#14

My apologies for asking about root. I solved that. I successfully
pasted the file in /usr/share/jitsi/lib and rebooted jitsi but the error
persists. Should I paste it in /usr/share/jitsi/lib/native?

Could you please try updating to build 4713 and see if this solves the problem?

Pablo

Ingo


#15

I updated to Build 4714. This time I got a different error--null. I am
attaching a screenshot and the log.

Pablo

2013-07-08@08.07.32-logs.zip (109 KB)

···

El lun, 08-07-2013 a las 13:42 +0200, Ingo Bauersachs escribió:

> My apologies for asking about root. I solved that. I successfully
> pasted the file in /usr/share/jitsi/lib and rebooted jitsi but the error
> persists. Should I paste it in /usr/share/jitsi/lib/native?

Could you please try updating to build 4713 and see if this solves the problem?

> Pablo

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#16

Hi all,

do you know of this bug, or have you encountered it yet?

···

-----

I don't know if this bug has already been reported (I certainly didn't find anything like it when browsing through the Mailing List), but whenever I choose to show more than 22 previous messages in the chat window (via Preferences > General > Log Messages - I am using the German UI, so I'm translating these options back on the fly), current chat messages are not displayed in the chat window anymore. I am using the nightly build of July 4th, but used the stable version 2.2 until today (have upgraded hoping to resolve the issue).

Now the 22 displayed messages doesn't seem to be the breaking point, as my gf (using version Jitsi 2.2) has the exact same issue with even less than 22 displayed messages (don't have the time to empirically test to the fullest extent).

Can someone please confirm the issue and fix this so I can display a full history of chat messages to the other person? I know that I have a separate history option, bit I find it hard to use.

Thank you in advance,

Am 08.07.2013 13:42, schrieb Ingo Bauersachs:

My apologies for asking about root. I solved that. I successfully
pasted the file in /usr/share/jitsi/lib and rebooted jitsi but the error
persists. Should I paste it in /usr/share/jitsi/lib/native?

Could you please try updating to build 4713 and see if this solves the problem?

Pablo

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#17

I updated to Build 4714. This time I got a different error--null. I am
attaching a screenshot and the log.

Now this starting to get strange. Could you verify the jitsi-default.properties is present at /usr/share/jitsi/lib?

Pablo

Ingo


#18

Hi all,

guys, I don't want to spam this mailing list, but is there really no one here who ever encountered this problem? For a description, please see below:

···

-----

I don't know if this bug has already been reported (I certainly didn't find anything like it when browsing through the Mailing List), but whenever I choose to show more than 22 previous messages in the chat window (via Preferences > General > Log Messages - I am using the German UI, so I'm translating these options back on the fly), current chat messages are not displayed in the chat window anymore. I am using the nightly build of July 4th, but used the stable version 2.2 until today (have upgraded hoping to resolve the issue).

Now the 22 displayed messages doesn't seem to be the breaking point, as my gf (using version Jitsi 2.2) has the exact same issue with even less than 22 displayed messages (don't have the time to empirically test to the fullest extent).

Can someone please confirm the issue and fix this so I can display a full history of chat messages to the other person? I know that I have a separate history option, bit I find it hard to use.

Thank you in advance,


#19

Yes, the file you sent me is in the location you indicate.

I am attaching the detailed error message.

Could the error have anything to do with my having recently added UART to my ttyS0 and ttyS1 serial
port settings? I wouldn't think it would have any relation, but it is the only change I have made recently.

Jitsi continues to work for SIP communication, for example.

Pablo

···

El lun, 08-07-2013 a las 15:31 +0200, Ingo Bauersachs escribió:

> I updated to Build 4714. This time I got a different error--null. I am
> attaching a screenshot and the log.

Now this starting to get strange. Could you verify the jitsi-default.properties is present at /usr/share/jitsi/lib?

> Pablo

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#20

Yes, the file you sent me is in the location you indicate.

We needed to correct some more files, so if you don't mind, could you please once again try with the newest version?

I am attaching the detailed error message.

Could the error have anything to do with my having recently added UART to my
ttyS0 and ttyS1 serial
port settings? I wouldn't think it would have any relation, but it is the
only change I have made recently.

No, definitely not. This bug is due to recent changes in Jitsi's configuration core libraries.

Jitsi continues to work for SIP communication, for example.

Pablo

Ingo