[jitsi-users] Error Jibri


#1

I am trying to start jibri manually and I am having the following error
when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN]
[YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such file or
directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such file or
directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such file
or directory*


#2

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

···

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

I am trying to start jibri manually and I am having the following error
when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such file or
directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such file
or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such file
or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

···

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> wrote:

I am trying to start jibri manually and I am having the following error
when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such file
or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such file
or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such file
or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore tokenid-youtube
(Like it is done at
https://github.com/jitsi/jibri/blob/master/jibri-xmpp-client/app.py#L552)

If you are running from you computer, it will probably stream your screen
(display 0). If you are running from a VM or docker container, it will
stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

···

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com> wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >> wrote:

I am trying to start jibri manually and I am having the following error
when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such file
or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such file
or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such
file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to youtube?

How can I run app.py using my youtube ID?

Thank you...

···

2017-03-08 18:42 GMT-05:00 Camilo <camilo@camilo.fm>:

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore tokenid-youtube
(Like it is done at https://github.com/jitsi/jibri/blob/master/jibri-xmpp-
client/app.py#L552)

If you are running from you computer, it will probably stream your screen
(display 0). If you are running from a VM or docker container, it will
stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com> > wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >>> wrote:

I am trying to start jibri manually and I am having the following error
when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such file
or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such
file or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such
file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

1)
Black screen -> not working.

Have you installed ffmpeg?
Have you done 'modprobe snd-aloop'? You may need to sudo it.

If you are running from your computer, ffmpeg will fail because hw:0,1,0 is
not the loopback device. It will be hw:X,1,0, X>0 and Jibri assumes it is
0, so it other stuff will not work as well.
The Youtube stream works. I just changed hw:0,1,0 to hw:0, so it got my
sound input (instead of the loopback)

2)
Yes, app.py is basically Jibri. It calls all shell scripts. The only thing
that Jibri doesn't do well for me is Jicofo identifying it. So I start the
stream manually with custom_stanza_user.py.

···

On Wed, Mar 8, 2017 at 9:03 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com> wrote:

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to youtube?

How can I run app.py using my youtube ID?

Thank you...

2017-03-08 18:42 GMT-05:00 Camilo <camilo@camilo.fm>:

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore tokenid-youtube
(Like it is done at https://github.com/jitsi/ji
bri/blob/master/jibri-xmpp-client/app.py#L552)

If you are running from you computer, it will probably stream your screen
(display 0). If you are running from a VM or docker container, it will
stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com> >> wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >>>> wrote:

I am trying to start jibri manually and I am having the following
error when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such
file or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such
file or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such
file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Camilo, gracias...

First I want to clarify that I am running ubuntu Server 16 on an instance
of EC2

I have executed the command
Modprobe snd-aLoop

And I left the following error:
Modprobe: FATAL: Module snd-aLoop not found in directory
/lib/modules/4.4.0-66-generic

Do not really understand :frowning:

···

2017-03-08 20:23 GMT-05:00 Camilo <camilo@camilo.fm>:

1)
Black screen -> not working.

Have you installed ffmpeg?
Have you done 'modprobe snd-aloop'? You may need to sudo it.

If you are running from your computer, ffmpeg will fail because hw:0,1,0
is not the loopback device. It will be hw:X,1,0, X>0 and Jibri assumes it
is 0, so it other stuff will not work as well.
The Youtube stream works. I just changed hw:0,1,0 to hw:0, so it got my
sound input (instead of the loopback)

2)
Yes, app.py is basically Jibri. It calls all shell scripts. The only thing
that Jibri doesn't do well for me is Jicofo identifying it. So I start the
stream manually with custom_stanza_user.py.

On Wed, Mar 8, 2017 at 9:03 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com> > wrote:

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to youtube?

How can I run app.py using my youtube ID?

Thank you...

2017-03-08 18:42 GMT-05:00 Camilo <camilo@camilo.fm>:

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore tokenid-youtube
(Like it is done at https://github.com/jitsi/ji
bri/blob/master/jibri-xmpp-client/app.py#L552)

If you are running from you computer, it will probably stream your
screen (display 0). If you are running from a VM or docker container, it
will stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com >>> > wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >>>>> wrote:

I am trying to start jibri manually and I am having the following
error when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such
file or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such
file or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such
file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Alfredo,

We have had a similar issue. I nstall the linux-image-extra-virtual package

Then add to /etc/modules

snd-aloop

Test to make sure it loads now:

mod probe snd-aloop .

Camilo, have similar issues to Alfredo.
FFMPEG installed, Hw set to 0, snd-aloop loaded in kernel.

execute : ./launch_recording.sh Https://meetingurl ignore tokenid-youtube
After few seconds command line prompt comes back, with nothing hitting Youtube of log. Any suggestions?

#The Input device was hw:0,1,0 and I changed to hw:0,0. This solved an input I/O error.

: ${INPUT_DEVICE:= 'hw:0,0' }

: ${MAX_BITRATE:= '2976' }

···

----- Original Message -----

From: "Alfredo Guzman" <alfredo.sil.gt@gmail.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Wednesday, March 8, 2017 6:53:37 PM
Subject: Re: [jitsi-users] Error Jibri

Camilo, gracias...

First I want to clarify that I am running ubuntu Server 16 on an instance of EC2

I have executed the command
Modprobe snd-aLoop

And I left the following error:
Modprobe: FATAL: Module snd-aLoop not found in directory /lib/modules/4.4.0-66-generic

Do not really understand :frowning:

2017-03-08 20:23 GMT-05:00 Camilo < camilo@camilo.fm > :

1)
Black screen -> not working.

Have you installed ffmpeg?
Have you done 'modprobe snd-aloop'? You may need to sudo it.

If you are running from your computer, ffmpeg will fail because hw:0,1,0 is not the loopback device. It will be hw:X,1,0, X>0 and Jibri assumes it is 0, so it other stuff will not work as well.
The Youtube stream works. I just changed hw:0,1,0 to hw:0, so it got my sound input (instead of the loopback)

2)
Yes, app.py is basically Jibri. It calls all shell scripts. The only thing that Jibri doesn't do well for me is Jicofo identifying it. So I start the stream manually with custom_stanza_user.py.

On Wed, Mar 8, 2017 at 9:03 PM, Alfredo Guzman < alfredo.sil.gt@gmail.com > wrote:

<blockquote>

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to youtube?

How can I run app.py using my youtube ID?

Thank you...

2017-03-08 18:42 GMT-05:00 Camilo < camilo@camilo.fm > :

<blockquote>

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore tokenid-youtube
(Like it is done at https://github.com/jitsi/jibri/blob/master/jibri-xmpp-client/app.py#L552 )

If you are running from you computer, it will probably stream your screen (display 0). If you are running from a VM or docker container, it will stream an empty desktop because of the Xorg instance you created. The browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman < alfredo.sil.gt@gmail.com > wrote:

<blockquote>

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo < camilo@camilo.fm > :

<blockquote>

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami) /var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" < alfredo.sil.gt@gmail.com > wrote:

<blockquote>

I am trying to start jibri manually and I am having the following error when I ran this line

./scripts/launch_recording.sh < URL > < OUTPUT_FILENAME > [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such file or directory
./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such file or directory
./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such file or directory

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

</blockquote>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

</blockquote>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

</blockquote>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

</blockquote>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

</blockquote>

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Alfredo,

We have had a similar issue. Install the linux-image-extra-virtual package
Then add to /etc/modules
snd-aloop
Test to make sure it loads now:
mod probe snd-aloop .
Camilo, have similar issues to Alfredo. FFMPEG installed, Hw set to 0,
snd-aloop loaded in kernel.

execute : ./launch_recording.sh Https://meetingurl ignore tokenid-youtube

The correct way is ./launch_recording.sh ignore ignore ignore tokenid-youtube.
Although documentation has the URL there, it does open the website anymore
in the launch_recording.sh script;

After few seconds command line prompt comes back, with nothing hitting

Youtube of log. Any suggestions?

If it comes back, ffmpeg is probably not running.

#The Input device was hw:0,1,0 and I changed to hw:0,0. This solved an
input I /O error.

: *${INPUT_DEVICE:=**'hw:0,0'**}*

: *${MAX_BITRATE:=**'2976'**}*

No. It has to be hw:0,1,0 as defined in the asoundrc
<https://github.com/jitsi/jibri/blob/master/asoundrc> file. Dmix will
multiplex many streams into one (chrome needs multiplex audio or audio is
not sent to Loopback device) and Dsnoop will demultiplex one stream into
several others to store accordingly. When you did that change, you are
setting an audio input instead of output to ffmpeg,

To debug, I suggest to run the exec from this script
<https://github.com/jitsi/jibri/blob/master/scripts/start-ffmpeg.sh#L24>
without
output redirection and background option (Remove > /tmp/jibri-ffmpeg.out
2>&1 &), so you can check what is the error of ffmpeg.

Other questions:
did you check if a Xorg instance is running with dummy video driver ? icewm
needs to be running as well
Do you have the audo/video codecs working? libmp3lame and libx264

···

On Thu, Mar 9, 2017 at 12:45 AM, <royblog@comcast.net> wrote:

------------------------------

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Wednesday, March 8, 2017 6:53:37 PM
*Subject: *Re: [jitsi-users] Error Jibri

Camilo, gracias...

First I want to clarify that I am running ubuntu Server 16 on an instance
of EC2

I have executed the command
Modprobe snd-aLoop

And I left the following error:
Modprobe: FATAL: Module snd-aLoop not found in directory
/lib/modules/4.4.0-66-generic

Do not really understand :frowning:

2017-03-08 20:23 GMT-05:00 Camilo <camilo@camilo.fm>:

1)
Black screen -> not working.

Have you installed ffmpeg?
Have you done 'modprobe snd-aloop'? You may need to sudo it.

If you are running from your computer, ffmpeg will fail because hw:0,1,0
is not the loopback device. It will be hw:X,1,0, X>0 and Jibri assumes it
is 0, so it other stuff will not work as well.
The Youtube stream works. I just changed hw:0,1,0 to hw:0, so it got my
sound input (instead of the loopback)

2)
Yes, app.py is basically Jibri. It calls all shell scripts. The only
thing that Jibri doesn't do well for me is Jicofo identifying it. So I
start the stream manually with custom_stanza_user.py.

On Wed, Mar 8, 2017 at 9:03 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com> >> wrote:

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to youtube?

How can I run app.py using my youtube ID?

Thank you...

2017-03-08 18:42 GMT-05:00 Camilo <camilo@camilo.fm>:

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore tokenid-youtube
(Like it is done at https://github.com/jitsi/
jibri/blob/master/jibri-xmpp-client/app.py#L552)

If you are running from you computer, it will probably stream your
screen (display 0). If you are running from a VM or docker container, it
will stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman < >>>> alfredo.sil.gt@gmail.com> wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >>>>>> wrote:

I am trying to start jibri manually and I am having the following
error when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such
file or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such
file or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No such
file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

Sorry. I said a few mistakes.

1. Although documentation has the URL there, it does *NOT* open the website
anymore in the launch_recording.sh script;

2. That's okay that the prompt comes back. Just check if ffmpeg is running
after it.
I ran a different version of the script, so my version did not come back to
prompt.

···

On Thu, Mar 9, 2017 at 8:57 AM, Camilo <camilo@camilo.fm> wrote:

On Thu, Mar 9, 2017 at 12:45 AM, <royblog@comcast.net> wrote:

Alfredo,

We have had a similar issue. Install the linux-image-extra-virtual
package
Then add to /etc/modules
snd-aloop
Test to make sure it loads now:
mod probe snd-aloop .
Camilo, have similar issues to Alfredo. FFMPEG installed, Hw set to 0,
snd-aloop loaded in kernel.

execute : ./launch_recording.sh Https://meetingurl ignore tokenid-youtube

The correct way is ./launch_recording.sh ignore ignore ignore tokenid-youtube.
Although documentation has the URL there, it does open the website anymore
in the launch_recording.sh script;

After few seconds command line prompt comes back, with nothing hitting

Youtube of log. Any suggestions?

If it comes back, ffmpeg is probably not running.

#The Input device was hw:0,1,0 and I changed to hw:0,0. This solved an
input I /O error.

: *${INPUT_DEVICE:=**'hw:0,0'**}*

: *${MAX_BITRATE:=**'2976'**}*

No. It has to be hw:0,1,0 as defined in the asoundrc
<https://github.com/jitsi/jibri/blob/master/asoundrc> file. Dmix will
multiplex many streams into one (chrome needs multiplex audio or audio is
not sent to Loopback device) and Dsnoop will demultiplex one stream into
several others to store accordingly. When you did that change, you are
setting an audio input instead of output to ffmpeg,

To debug, I suggest to run the exec from this script
<https://github.com/jitsi/jibri/blob/master/scripts/start-ffmpeg.sh#L24> without
output redirection and background option (Remove > /tmp/jibri-ffmpeg.out
2>&1 &), so you can check what is the error of ffmpeg.

Other questions:
did you check if a Xorg instance is running with dummy video driver ?
icewm needs to be running as well
Do you have the audo/video codecs working? libmp3lame and libx264

------------------------------

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Wednesday, March 8, 2017 6:53:37 PM
*Subject: *Re: [jitsi-users] Error Jibri

Camilo, gracias...

First I want to clarify that I am running ubuntu Server 16 on an instance
of EC2

I have executed the command
Modprobe snd-aLoop

And I left the following error:
Modprobe: FATAL: Module snd-aLoop not found in directory
/lib/modules/4.4.0-66-generic

Do not really understand :frowning:

2017-03-08 20:23 GMT-05:00 Camilo <camilo@camilo.fm>:

1)
Black screen -> not working.

Have you installed ffmpeg?
Have you done 'modprobe snd-aloop'? You may need to sudo it.

If you are running from your computer, ffmpeg will fail because hw:0,1,0
is not the loopback device. It will be hw:X,1,0, X>0 and Jibri assumes it
is 0, so it other stuff will not work as well.
The Youtube stream works. I just changed hw:0,1,0 to hw:0, so it got my
sound input (instead of the loopback)

2)
Yes, app.py is basically Jibri. It calls all shell scripts. The only
thing that Jibri doesn't do well for me is Jicofo identifying it. So I
start the stream manually with custom_stanza_user.py.

On Wed, Mar 8, 2017 at 9:03 PM, Alfredo Guzman <alfredo.sil.gt@gmail.com >>> > wrote:

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to
youtube?

How can I run app.py using my youtube ID?

Thank you...

2017-03-08 18:42 GMT-05:00 Camilo <camilo@camilo.fm>:

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore
tokenid-youtube
(Like it is done at https://github.com/jitsi/ji
bri/blob/master/jibri-xmpp-client/app.py#L552)

If you are running from you computer, it will probably stream your
screen (display 0). If you are running from a VM or docker container, it
will stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman < >>>>> alfredo.sil.gt@gmail.com> wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >>>>>>> wrote:

I am trying to start jibri manually and I am having the following
error when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such
file or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No such
file or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No
such file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

thanks royblog, Your solution worked for me.
Exec "*modprobe snd-aloop" *And does not show me error.
I think it's okay.

I already checked the audio and video by running the check scripts...

LOG CHECK AUDIO:

···

=====================================================================================
Recording raw data '/tmp/jibri-audio_check.wav' : Signed 16 bit Little
Endian, Rate 44100 Hz, Stereo

Hardware PCM card 0 'Loopback' device 1 subdevice 0

Its setup is:

  stream : CAPTURE
  access : RW_INTERLEAVED
  format : S16_LE
  subformat : STD
  channels : 2
  rate : 44100
  exact rate : 44100 (44100/1)
  msbits : 16
  buffer_size : 22052
  period_size : 5513
  period_time : 125011
  tstamp_mode : NONE
  tstamp_type : MONOTONIC
  period_step : 1
  avail_min : 5513
  period_event : 0
  start_threshold : 1
  stop_threshold : 22052
  silence_threshold: 0
  silence_size : 0
  boundary : 6207086186423386112
  appl_ptr : 0
  hw_ptr : 0

I think it went well.

Out Check Video:

*No log, but the file has been created
/tmp/jibri-ffmpeg.out

I think it went well.

BUT!

now i get a new Error... :frowning:

When I execute the following command:

*/launch_recording.sh ignore ignore ignore MY-ID-TOKEN*

Output:

*No protocol specified*

*Error: Can't open display: (null)*

*Failed creating new xdo instance*

What am I doing wrong?
Thanks!

2017-03-09 7:03 GMT-05:00 Camilo <camilo@camilo.fm>:

Sorry. I said a few mistakes.

1. Although documentation has the URL there, it does *NOT* open the
website anymore in the launch_recording.sh script;

2. That's okay that the prompt comes back. Just check if ffmpeg is running
after it.
I ran a different version of the script, so my version did not come back
to prompt.

On Thu, Mar 9, 2017 at 8:57 AM, Camilo <camilo@camilo.fm> wrote:

On Thu, Mar 9, 2017 at 12:45 AM, <royblog@comcast.net> wrote:

Alfredo,

We have had a similar issue. Install the linux-image-extra-virtual
package
Then add to /etc/modules
snd-aloop
Test to make sure it loads now:
mod probe snd-aloop .
Camilo, have similar issues to Alfredo. FFMPEG installed, Hw set to 0,
snd-aloop loaded in kernel.

execute : ./launch_recording.sh Https://meetingurl ignore
tokenid-youtube

The correct way is ./launch_recording.sh ignore ignore ignore tokenid-youtube.
Although documentation has the URL there, it does open the website anymore
in the launch_recording.sh script;

After few seconds command line prompt comes back, with nothing hitting

Youtube of log. Any suggestions?

If it comes back, ffmpeg is probably not running.

#The Input device was hw:0,1,0 and I changed to hw:0,0. This solved an
input I /O error.

: *${INPUT_DEVICE:=**'hw:0,0'**}*

: *${MAX_BITRATE:=**'2976'**}*

No. It has to be hw:0,1,0 as defined in the asoundrc
<https://github.com/jitsi/jibri/blob/master/asoundrc> file. Dmix will
multiplex many streams into one (chrome needs multiplex audio or audio is
not sent to Loopback device) and Dsnoop will demultiplex one stream into
several others to store accordingly. When you did that change, you are
setting an audio input instead of output to ffmpeg,

To debug, I suggest to run the exec from this script
<https://github.com/jitsi/jibri/blob/master/scripts/start-ffmpeg.sh#L24> without
output redirection and background option (Remove > /tmp/jibri-ffmpeg.out
2>&1 &), so you can check what is the error of ffmpeg.

Other questions:
did you check if a Xorg instance is running with dummy video driver ?
icewm needs to be running as well
Do you have the audo/video codecs working? libmp3lame and libx264

------------------------------

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Wednesday, March 8, 2017 6:53:37 PM
*Subject: *Re: [jitsi-users] Error Jibri

Camilo, gracias...

First I want to clarify that I am running ubuntu Server 16 on an
instance of EC2

I have executed the command
Modprobe snd-aLoop

And I left the following error:
Modprobe: FATAL: Module snd-aLoop not found in directory
/lib/modules/4.4.0-66-generic

Do not really understand :frowning:

2017-03-08 20:23 GMT-05:00 Camilo <camilo@camilo.fm>:

1)
Black screen -> not working.

Have you installed ffmpeg?
Have you done 'modprobe snd-aloop'? You may need to sudo it.

If you are running from your computer, ffmpeg will fail
because hw:0,1,0 is not the loopback device. It will be hw:X,1,0, X>0 and
Jibri assumes it is 0, so it other stuff will not work as well.
The Youtube stream works. I just changed hw:0,1,0 to hw:0, so it got my
sound input (instead of the loopback)

2)
Yes, app.py is basically Jibri. It calls all shell scripts. The only
thing that Jibri doesn't do well for me is Jicofo identifying it. So I
start the stream manually with custom_stanza_user.py.

On Wed, Mar 8, 2017 at 9:03 PM, Alfredo Guzman < >>>> alfredo.sil.gt@gmail.com> wrote:

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to
youtube?

How can I run app.py using my youtube ID?

Thank you...

2017-03-08 18:42 GMT-05:00 Camilo <camilo@camilo.fm>:

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore
tokenid-youtube
(Like it is done at https://github.com/jitsi/ji
bri/blob/master/jibri-xmpp-client/app.py#L552)

If you are running from you computer, it will probably stream your
screen (display 0). If you are running from a VM or docker container, it
will stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman < >>>>>> alfredo.sil.gt@gmail.com> wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >>>>>>>> wrote:

I am trying to start jibri manually and I am having the following
error when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such
file or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No
such file or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No
such file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#12

Do you mean to stream to facebook? I did not.

···

On Thu, Mar 9, 2017 at 8:27 PM, <royblog@comcast.net> wrote:

Camilo,

Thanks, ffmpeg is running, appears we are good.

Curious have you tried Facebook?

------------------------------
*From: *"Camilo" <camilo@camilo.fm>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Thursday, March 9, 2017 4:03:51 AM

*Subject: *Re: [jitsi-users] Error Jibri

Sorry. I said a few mistakes.

1. Although documentation has the URL there, it does *NOT* open the
website anymore in the launch_recording.sh script;

2. That's okay that the prompt comes back. Just check if ffmpeg is running
after it.
I ran a different version of the script, so my version did not come back
to prompt.

On Thu, Mar 9, 2017 at 8:57 AM, Camilo <camilo@camilo.fm> wrote:

On Thu, Mar 9, 2017 at 12:45 AM, <royblog@comcast.net> wrote:

Alfredo,

We have had a similar issue. Install the linux-image-extra-virtual
package
Then add to /etc/modules
snd-aloop
Test to make sure it loads now:
mod probe snd-aloop .
Camilo, have similar issues to Alfredo. FFMPEG installed, Hw set to 0,
snd-aloop loaded in kernel.

execute : ./launch_recording.sh Https://meetingurl ignore
tokenid-youtube

The correct way is ./launch_recording.sh ignore ignore ignore tokenid-youtube.
Although documentation has the URL there, it does open the website anymore
in the launch_recording.sh script;

After few seconds command line prompt comes back, with nothing hitting

Youtube of log. Any suggestions?

If it comes back, ffmpeg is probably not running.

#The Input device was hw:0,1,0 and I changed to hw:0,0. This solved an
input I /O error.

: *${INPUT_DEVICE:=**'hw:0,0'**}*

: *${MAX_BITRATE:=**'2976'**}*

No. It has to be hw:0,1,0 as defined in the asoundrc
<https://github.com/jitsi/jibri/blob/master/asoundrc> file. Dmix will
multiplex many streams into one (chrome needs multiplex audio or audio is
not sent to Loopback device) and Dsnoop will demultiplex one stream into
several others to store accordingly. When you did that change, you are
setting an audio input instead of output to ffmpeg,

To debug, I suggest to run the exec from this script
<https://github.com/jitsi/jibri/blob/master/scripts/start-ffmpeg.sh#L24> without
output redirection and background option (Remove > /tmp/jibri-ffmpeg.out
2>&1 &), so you can check what is the error of ffmpeg.

Other questions:
did you check if a Xorg instance is running with dummy video driver ?
icewm needs to be running as well
Do you have the audo/video codecs working? libmp3lame and libx264

------------------------------

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Wednesday, March 8, 2017 6:53:37 PM
*Subject: *Re: [jitsi-users] Error Jibri

Camilo, gracias...

First I want to clarify that I am running ubuntu Server 16 on an
instance of EC2

I have executed the command
Modprobe snd-aLoop

And I left the following error:
Modprobe: FATAL: Module snd-aLoop not found in directory
/lib/modules/4.4.0-66-generic

Do not really understand :frowning:

2017-03-08 20:23 GMT-05:00 Camilo <camilo@camilo.fm>:

1)
Black screen -> not working.

Have you installed ffmpeg?
Have you done 'modprobe snd-aloop'? You may need to sudo it.

If you are running from your computer, ffmpeg will fail
because hw:0,1,0 is not the loopback device. It will be hw:X,1,0, X>0 and
Jibri assumes it is 0, so it other stuff will not work as well.
The Youtube stream works. I just changed hw:0,1,0 to hw:0, so it got my
sound input (instead of the loopback)

2)
Yes, app.py is basically Jibri. It calls all shell scripts. The only
thing that Jibri doesn't do well for me is Jicofo identifying it. So I
start the stream manually with custom_stanza_user.py.

On Wed, Mar 8, 2017 at 9:03 PM, Alfredo Guzman < >>>> alfredo.sil.gt@gmail.com> wrote:

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to
youtube?

How can I run app.py using my youtube ID?

Thank you...

2017-03-08 18:42 GMT-05:00 Camilo <camilo@camilo.fm>:

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore
tokenid-youtube
(Like it is done at https://github.com/jitsi/
jibri/blob/master/jibri-xmpp-client/app.py#L552)

If you are running from you computer, it will probably stream your
screen (display 0). If you are running from a VM or docker container, it
will stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman < >>>>>> alfredo.sil.gt@gmail.com> wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown $(whoami):$(whoami)
/var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >>>>>>>> wrote:

I am trying to start jibri manually and I am having the following
error when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No such
file or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No
such file or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No
such file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#13

I'm trying to run run.sh to integrate directly with jitsi-meet

Log run.sh

···

======================================================

* RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized
/><text>The response provided by the client doesn&apos;t match the one we
calculated.</text></failure>*

*2017-03-09 22:49:30,153 INFO Authentication failed: not-authorized*

*2017-03-09 22:49:30,153 DEBUG Event triggered: failed_auth*

*2017-03-09 22:49:30,154 DEBUG SEND (IMMED): <auth
xmlns="urn:ietf:params:xml:ns:xmpp-sasl"
mechanism="PLAIN">AGZvY3VzAHJNYllpQGpR</auth>*

*2017-03-09 22:49:30,154 DEBUG RECV: <failure
xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized /><text>Unable to
authorize you with the authentication credentials you&apos;ve
sent.</text></failure>*

*2017-03-09 22:49:30,155 INFO Authentication failed: not-authorized*

*2017-03-09 22:49:30,155 DEBUG Event triggered: failed_auth*

*2017-03-09 22:49:30,155 ERROR No appropriate login method.*

*2017-03-09 22:49:30,155 DEBUG Event triggered: no_auth*

*2017-03-09 22:49:30,155 DEBUG Event triggered: failed_auth*

*2017-03-09 22:49:30,155 DEBUG Event triggered: session_end*

*2017-03-09 22:49:30,155 DEBUG SEND (IMMED): </stream:stream>*

*2017-03-09 22:49:30,155 INFO Waiting for </stream:stream> from server*

*2017-03-09 22:49:34,156 DEBUG Waiting for 3 threads to exit.*

*2017-03-09 22:49:34,156 DEBUG Finished exiting read_thread thread after
early termination from disconnect() call. 3 threads remain.*

*2017-03-09 22:49:34,156 DEBUG Stopped event runner thread. 2 threads
remain.*

*2017-03-09 22:49:34,245 DEBUG Stopped send thread. 1 threads remain.*

*2017-03-09 22:49:34,928 DEBUG Quitting Scheduler thread*

*2017-03-09 22:49:34,929 DEBUG Stopped scheduler thread. 0 threads
remain.*

*2017-03-09 22:49:34,929 DEBUG Event triggered: disconnected*

*2017-03-09 22:49:34,929 DEBUG ==== TRANSITION connected ->
disconnected*

*2017-03-09 22:49:34,929 ERROR Can not read from closed socket.*

I have an authentication error

this is my config.js

*{*

    *"jidserver_prefix"**:**"auth."**,*

    *"mucserver_prefix"**:**"conference."**,*

    *"boshdomain_prefix"**:**"recorder."**,*

    *"password"**:**"PASSWORD"**,*

    *"jid_username"**:**"focus"**,*

    *"roomname"**:**"TheBrewery"**,*

    *"xmpp_domain"**:**"live.mydomain.com <http://live.mydomain.com>"**,*

    *"selenium_xmpp_prefix"**:**"jitsi-videobridge."**,*

    *"selenium_xmpp_username"**:**"jitsi-videobridge"**,*

    *"selenium_xmpp_password"**:**"PASSWORD2"**,*

    *"servers"**:**[**"127.0.0.1"**]**,*

    *"environments"**:{*

    *}*

*}*

*Some things to consider* **The domain is not index to the IP (I have
config HOSTS local)*

** I do not have SSL certificate*

*Thanks*

2017-03-09 19:02 GMT-05:00 Camilo <camilo@camilo.fm>:

Do you mean to stream to facebook? I did not.

On Thu, Mar 9, 2017 at 8:27 PM, <royblog@comcast.net> wrote:

Camilo,

Thanks, ffmpeg is running, appears we are good.

Curious have you tried Facebook?

------------------------------
*From: *"Camilo" <camilo@camilo.fm>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Thursday, March 9, 2017 4:03:51 AM

*Subject: *Re: [jitsi-users] Error Jibri

Sorry. I said a few mistakes.

1. Although documentation has the URL there, it does *NOT* open the
website anymore in the launch_recording.sh script;

2. That's okay that the prompt comes back. Just check if ffmpeg is
running after it.
I ran a different version of the script, so my version did not come back
to prompt.

On Thu, Mar 9, 2017 at 8:57 AM, Camilo <camilo@camilo.fm> wrote:

On Thu, Mar 9, 2017 at 12:45 AM, <royblog@comcast.net> wrote:

Alfredo,

We have had a similar issue. Install the linux-image-extra-virtual
package
Then add to /etc/modules
snd-aloop
Test to make sure it loads now:
mod probe snd-aloop .
Camilo, have similar issues to Alfredo. FFMPEG installed, Hw set to
0, snd-aloop loaded in kernel.

execute : ./launch_recording.sh Https://meetingurl ignore
tokenid-youtube

The correct way is ./launch_recording.sh ignore ignore ignore tokenid-youtube.
Although documentation has the URL there, it does open the website anymore
in the launch_recording.sh script;

After few seconds command line prompt comes back, with nothing hitting

Youtube of log. Any suggestions?

If it comes back, ffmpeg is probably not running.

#The Input device was hw:0,1,0 and I changed to hw:0,0. This solved an
input I /O error.

: *${INPUT_DEVICE:=**'hw:0,0'**}*

: *${MAX_BITRATE:=**'2976'**}*

No. It has to be hw:0,1,0 as defined in the asoundrc
<https://github.com/jitsi/jibri/blob/master/asoundrc> file. Dmix will
multiplex many streams into one (chrome needs multiplex audio or audio is
not sent to Loopback device) and Dsnoop will demultiplex one stream into
several others to store accordingly. When you did that change, you are
setting an audio input instead of output to ffmpeg,

To debug, I suggest to run the exec from this script
<https://github.com/jitsi/jibri/blob/master/scripts/start-ffmpeg.sh#L24> without
output redirection and background option (Remove > /tmp/jibri-ffmpeg.out
2>&1 &), so you can check what is the error of ffmpeg.

Other questions:
did you check if a Xorg instance is running with dummy video driver ?
icewm needs to be running as well
Do you have the audo/video codecs working? libmp3lame and libx264

------------------------------

*From: *"Alfredo Guzman" <alfredo.sil.gt@gmail.com>
*To: *"Jitsi Users" <users@jitsi.org>
*Sent: *Wednesday, March 8, 2017 6:53:37 PM
*Subject: *Re: [jitsi-users] Error Jibri

Camilo, gracias...

First I want to clarify that I am running ubuntu Server 16 on an
instance of EC2

I have executed the command
Modprobe snd-aLoop

And I left the following error:
Modprobe: FATAL: Module snd-aLoop not found in directory
/lib/modules/4.4.0-66-generic

Do not really understand :frowning:

2017-03-08 20:23 GMT-05:00 Camilo <camilo@camilo.fm>:

1)
Black screen -> not working.

Have you installed ffmpeg?
Have you done 'modprobe snd-aloop'? You may need to sudo it.

If you are running from your computer, ffmpeg will fail
because hw:0,1,0 is not the loopback device. It will be hw:X,1,0, X>0 and
Jibri assumes it is 0, so it other stuff will not work as well.
The Youtube stream works. I just changed hw:0,1,0 to hw:0, so it got
my sound input (instead of the loopback)

2)
Yes, app.py is basically Jibri. It calls all shell scripts. The only
thing that Jibri doesn't do well for me is Jicofo identifying it. So I
start the stream manually with custom_stanza_user.py.

On Wed, Mar 8, 2017 at 9:03 PM, Alfredo Guzman < >>>>> alfredo.sil.gt@gmail.com> wrote:

ey camilo, thank you very much.

Let me see if I understand

1. if I execute

./launch_recording.sh ignore ignore ignore tokenid-youtube

Should it transmit to youtube, but would it be a black screen?

* I have already done it and on youtube I still do not receive data :frowning:
(I do not see any log)

2. if I run app.py should I broadcast the video from the room to
youtube?

How can I run app.py using my youtube ID?

Thank you...

2017-03-08 18:42 GMT-05:00 Camilo <camilo@camilo.fm>:

Well, that is just an auxiliary shell script.
You can do: ./launch_recording.sh ignore ignore ignore
tokenid-youtube
(Like it is done at https://github.com/jitsi/ji
bri/blob/master/jibri-xmpp-client/app.py#L552)

If you are running from you computer, it will probably stream your
screen (display 0). If you are running from a VM or docker container, it
will stream an empty desktop because of the Xorg instance you created. The
browser is not called from this script.

It works if you use the XMPP client tho.

On Wed, Mar 8, 2017 at 7:30 PM, Alfredo Guzman < >>>>>>> alfredo.sil.gt@gmail.com> wrote:

Thanks, it worked for me.

But now it runs and closes, it shows me nothing logs.

So I'm trying:

./launch_recording.sh https://live.mydomain.com/test
tokenid-youtube

But it closes when I run it.

what am I doing wrong?
Thank you.

2017-03-08 16:20 GMT-05:00 Camilo <camilo@camilo.fm>:

Try: sudo mkdir -p /var/run/jibri && sudo chown
$(whoami):$(whoami) /var/run/jibri

On Mar 8, 2017 4:33 PM, "Alfredo Guzman" <alfredo.sil.gt@gmail.com> >>>>>>>>> wrote:

I am trying to start jibri manually and I am having the following
error when I ran this line

./scripts/launch_recording.sh <URL> <OUTPUT_FILENAME> [TOKEN] [YOUTUBE_STREAM_ID]

I get follow error:

*./launch_recording.sh: line 15: /var/run/jibri//Xorg.pid: No
such file or directory*
*./launch_recording.sh: line 23: /var/run/jibri//icewm.pid: No
such file or directory*
*./launch_recording.sh: line 43: /var/run/jibri//ffmpeg.pid: No
such file or directory*

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users