[jitsi-users] Error: Could not establish connection (ICE failed) out/in google talk/voice failure


#1

Getting Ice Failures 100% of the time never has worked. Don't know was just
seeing if I missed something. I have tried turning off google experimental
in the ice no dice. I have tried leaving jut that on same issue.

I have updated my router to ensure UDP packets are AOK.

Endpoint Independent
Once a LAN-side application has created a connection through a specific
port, the NAT will forward any incoming connection requests with the same
port to the LAN-side application regardless of their origin. This is the
least restrictive option, giving the best connectivity and allowing some
applications (P2P applications in particular) to behave almost as if they
are directly connected to the Internet.

  Still same error. Anyone else have any ideas? I can place the call
like it dials the number and the remote end picks up, then the error
happens. So the call is going through.

Thanks

Robert


#2

This is expected behaviour as all this is going over the signaling
channel (your chat, essentialy) but it seems impossible to find a
transport channel (a more or less direct connection between the two
partners).
Have you added any kind of stun server? if you did remove them, they
might fail and jitsi will not fall back to the jitsi stun servers.
If your router supports it enabling upnp might be a good idea, but be
sure you informed yourself about the security implications. NAT-PMP
would be the better choice there.

your logs would help a lot.

- --
Yannik V�lker

···

On 15.06.2013 01:51, Robert Feldhousen wrote:

Getting Ice Failures 100% of the time never has worked. Don't know
was just seeing if I missed something. I have tried turning off
google experimental in the ice no dice. I have tried leaving jut
that on same issue.

I have updated my router to ensure UDP packets are AOK.

Endpoint Independent Once a LAN-side application has created a
connection through a specific port, the NAT will forward any
incoming connection requests with the same port to the LAN-side
application regardless of their origin. This is the least
restrictive option, giving the best connectivity and allowing some
applications (P2P applications in particular) to behave almost as
if they are directly connected to the Internet.

Still same error. Anyone else have any ideas? I can place the
call like it dials the number and the remote end picks up, then the
error happens. So the call is going through.


#3

I have not tried to add any stun servers/or remove any... (Don't know how
or where to do that).

I have emailed you my logs. If there is instructions/info on how to get
google voice to work with Jitsi I am all ears but everything I have tried
has resulted in failures.. (ICE fail)

Thanks

Robert

···

On Fri, Jun 14, 2013 at 8:56 PM, Yannik Völker <yannikv@yahoo.de> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 15.06.2013 01:51, Robert Feldhousen wrote:
> Getting Ice Failures 100% of the time never has worked. Don't know
> was just seeing if I missed something. I have tried turning off
> google experimental in the ice no dice. I have tried leaving jut
> that on same issue.
>
> I have updated my router to ensure UDP packets are AOK.
>
> Endpoint Independent Once a LAN-side application has created a
> connection through a specific port, the NAT will forward any
> incoming connection requests with the same port to the LAN-side
> application regardless of their origin. This is the least
> restrictive option, giving the best connectivity and allowing some
> applications (P2P applications in particular) to behave almost as
> if they are directly connected to the Internet.
>
> Still same error. Anyone else have any ideas? I can place the
> call like it dials the number and the remote end picks up, then the
> error happens. So the call is going through.
This is expected behaviour as all this is going over the signaling
channel (your chat, essentialy) but it seems impossible to find a
transport channel (a more or less direct connection between the two
partners).
Have you added any kind of stun server? if you did remove them, they
might fail and jitsi will not fall back to the jitsi stun servers.
If your router supports it enabling upnp might be a good idea, but be
sure you informed yourself about the security implications. NAT-PMP
would be the better choice there.

your logs would help a lot.

- --
Yannik Völker
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.20 (GNU/Linux)

iQIcBAEBAgAGBQJRu7vBAAoJEDqk81AiCyXKrOAP/3nLCmAki4tO44weqlgHzhKn
yzG3lIcdllblzHs6B9b+QhkkbJ7p2VFhVGwgq+rFhY5ysS9Qc1395yz6MJJMuvvi
Z1ct65y3zTQtbKtxc01KuXXqunY0VnrBoM1V8rnneSjStqvy7nJelJc7jjutZct9
VWvS0M6Qps5OeD9BlJp70TJkog+iJ2wLiE3kqiJztVWXQtYGKAiDtVkywYtkP11c
uNwdO+OTJoM/E1lPPUR0+yrEXPafcyRqUpl7WS5VqRVOfxFBi+KsXngBnFSc/W5w
QMCuEtCwYxHGspZ387E/KxTUftXUy1i5afAEtObLDFNXQ5Tg8KFMvWG+vT47UtYx
B/krGY04t1c3fdc4uWZ/Ort0VRUAdl4VOX6aKm8K68JelTqEOSVb67zcsdSkruhz
c7mQKtNwC9gcYSoARoNXcvg6fGfaBc2yFx/NLblgyBINywNLCSUimkgL+yAD2rc3
iVmLkwns+pmksyr2Cv5E0vxP9pEovvTRqC/BojW6DqaryikdhW9eX1xDIfDhknND
7hhAriM7dhDh8A1WuiU3oPyyUtvQ8OXv3q5D+TO1y+2oU63PR9iH/Tiyu/qnbpzn
OR/9M5+LfveKf3Z1bg83R6xn4VdpgIkZoY8VyPH9J0LRmeCuV2qKKPSezauDBx+1
NyVWJWjue2lcwQXfnjVb
=ziVL
-----END PGP SIGNATURE-----

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

2 problems:
1.: google voice will not work for much longer as google migrates it
to hangouts and those are incompatible with jingle (the xmpp-extension
for multimedia)
2.: it looks like the ports jitsi tries to listen on are allready used
(5000& upwards (to 6000 if i remember correctly)) so either you are
running some other program which uses those ports or some strange
firewall (in that case you should stop doing so)

- --
Yannik V�lker

···

On 15.06.2013 03:27, Robert Feldhousen wrote:

I have not tried to add any stun servers/or remove any... (Don't
know how or where to do that).

I have emailed you my logs. If there is instructions/info on how
to get google voice to work with Jitsi I am all ears but everything
I have tried has resulted in failures.. (ICE fail)


#5

Good tips I will try it out.. Thank you for taking the time to provide the
info.

-Robert