[jitsi-users] Enabling REST API on Jitsi Videobridge


#1

Greetings,

Inorder to capture statistics using the REST, we have configured
"sip-communicator.properties" on Jitsi Videobridge and rebooted:

root@ubuntu16:~/.sip-communicator# cat sip-communicator.properties
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart

org.jitsi.videobridge.rest.jetty.port=8080

org.jitsi.videobridge.ENABLE_STATISTICS=True

org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

org.jitsi.videobridge.STATISTICS_INTERVAL=1000

But even after that, we are able to gather any stats on http://
<IP>:8080/colibri/stats.

Could you please let us know, if we are missing any other configuration.

Thanks in advance.

Regards,
Ravi C


#2

*Correction:*

But even after that, we *aren't* able to gather any stats on http://
<IP>:8080/colibri/stats.

*Few interesting error logs:*

*1. /var/log/jitsi/jicofo.log*

Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]
org.jitsi.meet.ComponentMain.call().278 not-authorized, host:localhost,
port:5347

*2. /var/log/jitsi/jvb.log*

JVB 2016-08-10 11:51:02.302 SEVERE: [17]
org.jitsi.meet.ComponentMain.call().278 not-authorized, host:localhost,
port:5347

*3. /var/log/prosody/prosody.log*

Aug 10 11:52:50 c2s30a8fb0 info Client connected

Aug 10 11:52:50 sasl warn Client is violating RFC 3920 (section 6.1,
point 7).

Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component connection

Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component connection

Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component info
Component authentication failed for jitsi-videobridge.10.20.130.50

Aug 10 11:52:52 mod_component info Disconnecting component,
<stream:error> is: <stream:error><not-authorized
xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match
calculated token</text></stream:error>

Aug 10 11:52:52 jcp4ac19d0 info component disconnected:
jitsi-videobridge.10.20.130.50 (false)

Aug 10 11:52:52 focus.10.20.130.50:component info Component
authentication failed for focus.10.20.130.50

Aug 10 11:52:52 mod_component info Disconnecting component,
<stream:error> is: <stream:error><not-authorized
xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match
calculated token</text></stream:error>

Aug 10 11:52:52 jcp40b6b90 info component disconnected:
focus.10.20.130.50 (false)

···

On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary <rc.chaudhary@gmail.com> wrote:

Greetings,

Inorder to capture statistics using the REST, we have configured
"sip-communicator.properties" on Jitsi Videobridge and rebooted:

root@ubuntu16:~/.sip-communicator# cat sip-communicator.properties
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=
falseRestart

org.jitsi.videobridge.rest.jetty.port=8080

org.jitsi.videobridge.ENABLE_STATISTICS=True

org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

org.jitsi.videobridge.STATISTICS_INTERVAL=1000

But even after that, we are able to gather any stats on http://
<IP>:8080/colibri/stats.

Could you please let us know, if we are missing any other configuration.

Thanks in advance.

Regards,
Ravi C


#3

Hi,

you definitely had problems registering the components to prosody,
check your secret in prosody config and in jicofo and jvb config, did
they match?
Also to enable rest you need in /etc/jitsi/videobridge/config
JVB_OPTS="--apis=xmpp,rest"

Regards
damencho

···

On Wed, Aug 10, 2016 at 7:18 AM, Ravi Chaudhary <rc.chaudhary@gmail.com> wrote:

Correction:

But even after that, we aren't able to gather any stats on
http://<IP>:8080/colibri/stats.

Few interesting error logs:

1. /var/log/jitsi/jicofo.log

Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]
org.jitsi.meet.ComponentMain.call().278 not-authorized, host:localhost,
port:5347

2. /var/log/jitsi/jvb.log

JVB 2016-08-10 11:51:02.302 SEVERE: [17]
org.jitsi.meet.ComponentMain.call().278 not-authorized, host:localhost,
port:5347

3. /var/log/prosody/prosody.log

Aug 10 11:52:50 c2s30a8fb0 info Client connected

Aug 10 11:52:50 sasl warn Client is violating RFC 3920 (section 6.1,
point 7).

Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component connection

Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component connection

Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component info
Component authentication failed for jitsi-videobridge.10.20.130.50

Aug 10 11:52:52 mod_component info Disconnecting component,
<stream:error> is: <stream:error><not-authorized
xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match
calculated token</text></stream:error>

Aug 10 11:52:52 jcp4ac19d0 info component disconnected:
jitsi-videobridge.10.20.130.50 (false)

Aug 10 11:52:52 focus.10.20.130.50:component info Component
authentication failed for focus.10.20.130.50

Aug 10 11:52:52 mod_component info Disconnecting component,
<stream:error> is: <stream:error><not-authorized
xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match
calculated token</text></stream:error>

Aug 10 11:52:52 jcp40b6b90 info component disconnected:
focus.10.20.130.50 (false)

On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary <rc.chaudhary@gmail.com> > wrote:

Greetings,

Inorder to capture statistics using the REST, we have configured
"sip-communicator.properties" on Jitsi Videobridge and rebooted:

root@ubuntu16:~/.sip-communicator# cat sip-communicator.properties

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart

org.jitsi.videobridge.rest.jetty.port=8080

org.jitsi.videobridge.ENABLE_STATISTICS=True

org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

org.jitsi.videobridge.STATISTICS_INTERVAL=1000

But even after that, we are able to gather any stats on
http://<IP>:8080/colibri/stats.

Could you please let us know, if we are missing any other configuration.

Thanks in advance.

Regards,
Ravi C

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Greetings Damencho,
Thanks for the pointer. Here is the config of jicofo, videobridge & prosody
files.

*/etc/jitsi/jicofo/config*

*# sets the secret used to authenticate as an XMPP
componentJICOFO_SECRET=6h85vKcQ# sets the port to use for the XMPP
component connectionJICOFO_PORT=5347*
*/etc/jitsi/videobridge/config*

*# sets the port of the XMPP server (default: 5275)JVB_PORT=5347# sets the
shared secret used to authenticate to the XMPP serverJVB_SECRET=217TkZFo#
extra options to pass to the JVB daemonJVB_OPTS="--apis=rest"*

*cat /etc/prosody/conf.d/10.20.130.50.cfg.lua*

*VirtualHost "10.20.130.50" authentication = "anonymous" ssl =
{ key = "/var/lib/prosody/10.20.130.50.key"; certificate =
"/var/lib/prosody/10.20.130.50.crt"; } modules_enabled = {
"bosh"; "pubsub"; }VirtualHost "auth.10.20.130.50"
authentication = "internal_plain"Component "conference.10.20.130.50"
"muc"Component "jitsi-videobridge.10.20.130.50" component_secret =
"YOURSECRET1"Component "focus.10.20.130.50" component_secret =
"YOURSECRET2"*


*1) Do we need to update the 'prosody' file with the respective SECRET of
Videobridge & Jicofo?*
*2) Also how can i verify, if the Colibri stats are being accessible on
port 8080?*

*FYI: O/P of cat /root/.sip-communicator/sip-communicator.properties*

*org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestartorg.jitsi.videobridge.rest.jetty.port=8080org.jitsi.videobridge.ENABLE_STATISTICS=Trueorg.jitsi.videobridge.STATISTICS_TRANSPORT=colibriorg.jitsi.videobridge.STATISTICS_INTERVAL=1000*
Regards,
Ravi C

···

On Wed, Aug 10, 2016 at 7:25 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

you definitely had problems registering the components to prosody,
check your secret in prosody config and in jicofo and jvb config, did
they match?
Also to enable rest you need in /etc/jitsi/videobridge/config
JVB_OPTS="--apis=xmpp,rest"

Regards
damencho

On Wed, Aug 10, 2016 at 7:18 AM, Ravi Chaudhary <rc.chaudhary@gmail.com> > wrote:
> Correction:
>
> But even after that, we aren't able to gather any stats on
> http://<IP>:8080/colibri/stats.
>
> Few interesting error logs:
>
>
> 1. /var/log/jitsi/jicofo.log
>
>
>
> Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]
> org.jitsi.meet.ComponentMain.call().278 not-authorized, host:localhost,
> port:5347
>
>
>
> 2. /var/log/jitsi/jvb.log
>
>
>
> JVB 2016-08-10 11:51:02.302 SEVERE: [17]
> org.jitsi.meet.ComponentMain.call().278 not-authorized, host:localhost,
> port:5347
>
>
>
> 3. /var/log/prosody/prosody.log
>
>
>
> Aug 10 11:52:50 c2s30a8fb0 info Client connected
>
> Aug 10 11:52:50 sasl warn Client is violating RFC 3920 (section
6.1,
> point 7).
>
> Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component
connection
>
> Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component
connection
>
> Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component info
> Component authentication failed for jitsi-videobridge.10.20.130.50
>
> Aug 10 11:52:52 mod_component info Disconnecting component,
> <stream:error> is: <stream:error><not-authorized
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match
> calculated token</text></stream:error>
>
> Aug 10 11:52:52 jcp4ac19d0 info component disconnected:
> jitsi-videobridge.10.20.130.50 (false)
>
> Aug 10 11:52:52 focus.10.20.130.50:component info Component
> authentication failed for focus.10.20.130.50
>
> Aug 10 11:52:52 mod_component info Disconnecting component,
> <stream:error> is: <stream:error><not-authorized
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match
> calculated token</text></stream:error>
>
> Aug 10 11:52:52 jcp40b6b90 info component disconnected:
> focus.10.20.130.50 (false)
>
>
>
>
> On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary <rc.chaudhary@gmail.com> > > wrote:
>>
>> Greetings,
>>
>> Inorder to capture statistics using the REST, we have configured
>> "sip-communicator.properties" on Jitsi Videobridge and rebooted:
>>
>> root@ubuntu16:~/.sip-communicator# cat sip-communicator.properties
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=
falseRestart
>>
>> org.jitsi.videobridge.rest.jetty.port=8080
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=True
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>>
>> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>>
>> But even after that, we are able to gather any stats on
>> http://<IP>:8080/colibri/stats.
>>
>> Could you please let us know, if we are missing any other configuration.
>>
>> Thanks in advance.
>>
>> Regards,
>> Ravi C
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Greetings Damencho,
Thanks for the pointer. Here is the config of jicofo, videobridge & prosody
files.

/etc/jitsi/jicofo/config
# sets the secret used to authenticate as an XMPP component
JICOFO_SECRET=6h85vKcQ

# sets the port to use for the XMPP component connection
JICOFO_PORT=5347

/etc/jitsi/videobridge/config
# sets the port of the XMPP server (default: 5275)
JVB_PORT=5347

# sets the shared secret used to authenticate to the XMPP server
JVB_SECRET=217TkZFo

# extra options to pass to the JVB daemon
JVB_OPTS="--apis=rest"

in order jicofo to work you need JVB_OPTS="--apis=xmpp,rest"

cat /etc/prosody/conf.d/10.20.130.50.cfg.lua
VirtualHost "10.20.130.50"
    authentication = "anonymous"
    ssl = {
        key = "/var/lib/prosody/10.20.130.50.key";
        certificate = "/var/lib/prosody/10.20.130.50.crt";
    }
    modules_enabled = {
        "bosh";
        "pubsub";
    }

VirtualHost "auth.10.20.130.50"
    authentication = "internal_plain"

Component "conference.10.20.130.50" "muc"
Component "jitsi-videobridge.10.20.130.50"
    component_secret = "YOURSECRET1"
Component "focus.10.20.130.50"
    component_secret = "YOURSECRET2"

1) Do we need to update the 'prosody' file with the respective SECRET of
Videobridge & Jicofo?

YOURSECRET1 should be 217TkZFo and YOURSECRET2 should be 6h85vKcQ.

···

On Wed, Aug 10, 2016 at 10:15 AM, Ravi Chaudhary <rc.chaudhary@gmail.com> wrote:

2) Also how can i verify, if the Colibri stats are being accessible on port
8080?

FYI: O/P of cat /root/.sip-communicator/sip-communicator.properties
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart

org.jitsi.videobridge.rest.jetty.port=8080

org.jitsi.videobridge.ENABLE_STATISTICS=True

org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

org.jitsi.videobridge.STATISTICS_INTERVAL=1000

Regards,
Ravi C

On Wed, Aug 10, 2016 at 7:25 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

you definitely had problems registering the components to prosody,
check your secret in prosody config and in jicofo and jvb config, did
they match?
Also to enable rest you need in /etc/jitsi/videobridge/config
JVB_OPTS="--apis=xmpp,rest"

Regards
damencho

On Wed, Aug 10, 2016 at 7:18 AM, Ravi Chaudhary <rc.chaudhary@gmail.com> >> wrote:
> Correction:
>
> But even after that, we aren't able to gather any stats on
> http://<IP>:8080/colibri/stats.
>
> Few interesting error logs:
>
>
> 1. /var/log/jitsi/jicofo.log
>
>
>
> Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]
> org.jitsi.meet.ComponentMain.call().278 not-authorized, host:localhost,
> port:5347
>
>
>
> 2. /var/log/jitsi/jvb.log
>
>
>
> JVB 2016-08-10 11:51:02.302 SEVERE: [17]
> org.jitsi.meet.ComponentMain.call().278 not-authorized, host:localhost,
> port:5347
>
>
>
> 3. /var/log/prosody/prosody.log
>
>
>
> Aug 10 11:52:50 c2s30a8fb0 info Client connected
>
> Aug 10 11:52:50 sasl warn Client is violating RFC 3920 (section
> 6.1,
> point 7).
>
> Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component
> connection
>
> Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component
> connection
>
> Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component info
> Component authentication failed for jitsi-videobridge.10.20.130.50
>
> Aug 10 11:52:52 mod_component info Disconnecting component,
> <stream:error> is: <stream:error><not-authorized
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match
> calculated token</text></stream:error>
>
> Aug 10 11:52:52 jcp4ac19d0 info component disconnected:
> jitsi-videobridge.10.20.130.50 (false)
>
> Aug 10 11:52:52 focus.10.20.130.50:component info Component
> authentication failed for focus.10.20.130.50
>
> Aug 10 11:52:52 mod_component info Disconnecting component,
> <stream:error> is: <stream:error><not-authorized
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
> xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not match
> calculated token</text></stream:error>
>
> Aug 10 11:52:52 jcp40b6b90 info component disconnected:
> focus.10.20.130.50 (false)
>
>
>
>
> On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary <rc.chaudhary@gmail.com> >> > wrote:
>>
>> Greetings,
>>
>> Inorder to capture statistics using the REST, we have configured
>> "sip-communicator.properties" on Jitsi Videobridge and rebooted:
>>
>> root@ubuntu16:~/.sip-communicator# cat sip-communicator.properties
>>
>>
>> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart
>>
>> org.jitsi.videobridge.rest.jetty.port=8080
>>
>> org.jitsi.videobridge.ENABLE_STATISTICS=True
>>
>> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>>
>> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>>
>> But even after that, we are able to gather any stats on
>> http://<IP>:8080/colibri/stats.
>>
>> Could you please let us know, if we are missing any other
>> configuration.
>>
>> Thanks in advance.
>>
>> Regards,
>> Ravi C
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Greetings Damencho,

Thanks again for the pointers.

Update the respective values in < /etc/jitsi/videobridge/config > & <
/etc/prosody/conf.d/10.20.130.50.cfg.lua>

*O/P of netstat -anp | grep 8080*
tcp6 0 0 :::8080 :::*
LISTEN 6297/java

We are still unable to view any statistics on <
*http://10.20.130.50:8080/colibri/stats
<http://10.20.130.50:8080/colibri/stats>* >

*O/P of /root/.sip-communicator/sip-communicator.properties*
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart

org.jitsi.videobridge.rest.jetty.port=8080

org.jitsi.videobridge.ENABLE_STATISTICS=True

org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

org.jitsi.videobridge.STATISTICS_INTERVAL=1000

*O/P of /var/log/jitsi/jicofo.log:*

Jicofo 2016-08-10 18:47:50.517 SEVERE: [16]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to
connect: SASL authentication DIGEST-MD5 failed: text
SASL authentication DIGEST-MD5 failed: text:
        at
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)
        at
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:223)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)
        at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Jicofo 2016-08-10 18:47:50.526 SEVERE: [1961]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.write(BufferedWriter.java:221)
        at java.io.Writer.write(Writer.java:157)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:210)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.527 SEVERE: [1973]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.527 SEVERE: [1981]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.528 SEVERE: [1985]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.529 SEVERE: [1969]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.531 SEVERE: [1965]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.676 SEVERE: [1986]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
java.io.EOFException: no more data available - expected end tag
</stream:stream> to close start tag <stream:stream> from line 1, parser
stopped on END_TAG seen
...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...
@1:613
        at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:3035)
        at org.xmlpull.mxp1.MXParser.more(MXParser.java:3046)
        at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1144)
        at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)
        at
org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:329)
        at
org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
        at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
Jicofo 2016-08-10 18:47:50.677 SEVERE: [1986]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() XMPP connection
closed on error: no more data available - expected end tag </stream:stream>
to close start tag <stream:stream> from line 1, parser stopped on END_TAG
seen
...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...
@1:613
Jicofo 2016-08-10 18:47:50.677 INFO: [1986]
org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP provider
reg state: RegistrationState=Unregistered
Jicofo 2016-08-10 18:47:51.677 INFO: [1989]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting
in: 8
Jicofo 2016-08-10 18:47:52.677 INFO: [1989]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting
in: 7
Jicofo 2016-08-10 18:47:53.677 INFO: [1989]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting
in: 6
Jicofo 2016-08-10 18:47:54.677 INFO: [1989]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting
in: 5
Jicofo 2016-08-10 18:47:55.576 INFO: [16]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnection
successful
Jicofo 2016-08-10 18:47:55.576 SEVERE: [16]
org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged().142 null
java.lang.NullPointerException
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.discoverItems(XmppProtocolProvider.java:488)
        at
org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.getItems(OpSetSimpleCapsImpl.java:53)
        at
org.jitsi.jicofo.ComponentsDiscovery.discoverServices(ComponentsDiscovery.java:238)
        at
org.jitsi.jicofo.ComponentsDiscovery.firstTimeDiscovery(ComponentsDiscovery.java:308)
        at
org.jitsi.jicofo.ComponentsDiscovery.registrationStateChanged(ComponentsDiscovery.java:343)
        at
org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(ProtocolProviderHandler.java:138)
        at
net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:187)
        at
net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:141)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.notifyConnected(XmppProtocolProvider.java:255)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$300(XmppProtocolProvider.java:46)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$XmppConnectionListener.reconnectionSuccessful(XmppProtocolProvider.java:569)
        at
org.jivesoftware.smack.PacketReader.notifyReconnection(PacketReader.java:193)
        at
org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:589)
        at
org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection.java:532)
        at
org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:968)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:210)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)
        at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Jicofo 2016-08-10 18:47:55.577 INFO: [16]
org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP provider
reg state: RegistrationState=Registered
Jicofo 2016-08-10 18:47:55.582 SEVERE: [16]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to
connect: SASL authentication DIGEST-MD5 failed: text
SASL authentication DIGEST-MD5 failed: text:
at
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)
        at
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:223)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)
        at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)

Awaiting on your inputs to gather the statistics

Regards,
Ravi C

···

On Wed, Aug 10, 2016 at 8:52 PM, Damian Minkov <damencho@jitsi.org> wrote:

On Wed, Aug 10, 2016 at 10:15 AM, Ravi Chaudhary <rc.chaudhary@gmail.com> > wrote:
> Greetings Damencho,
> Thanks for the pointer. Here is the config of jicofo, videobridge &
prosody
> files.
>
> /etc/jitsi/jicofo/config
> # sets the secret used to authenticate as an XMPP component
> JICOFO_SECRET=6h85vKcQ
>
> # sets the port to use for the XMPP component connection
> JICOFO_PORT=5347
>
> /etc/jitsi/videobridge/config
> # sets the port of the XMPP server (default: 5275)
> JVB_PORT=5347
>
> # sets the shared secret used to authenticate to the XMPP server
> JVB_SECRET=217TkZFo
>
> # extra options to pass to the JVB daemon
> JVB_OPTS="--apis=rest"

in order jicofo to work you need JVB_OPTS="--apis=xmpp,rest"

>
>
> cat /etc/prosody/conf.d/10.20.130.50.cfg.lua
> VirtualHost "10.20.130.50"
> authentication = "anonymous"
> ssl = {
> key = "/var/lib/prosody/10.20.130.50.key";
> certificate = "/var/lib/prosody/10.20.130.50.crt";
> }
> modules_enabled = {
> "bosh";
> "pubsub";
> }
>
> VirtualHost "auth.10.20.130.50"
> authentication = "internal_plain"
>
> Component "conference.10.20.130.50" "muc"
> Component "jitsi-videobridge.10.20.130.50"
> component_secret = "YOURSECRET1"
> Component "focus.10.20.130.50"
> component_secret = "YOURSECRET2"
>
> 1) Do we need to update the 'prosody' file with the respective SECRET of
> Videobridge & Jicofo?

YOURSECRET1 should be 217TkZFo and YOURSECRET2 should be 6h85vKcQ.

>
> 2) Also how can i verify, if the Colibri stats are being accessible on
port
> 8080?
>
> FYI: O/P of cat /root/.sip-communicator/sip-communicator.properties
> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=
falseRestart
>
> org.jitsi.videobridge.rest.jetty.port=8080
>
> org.jitsi.videobridge.ENABLE_STATISTICS=True
>
> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>
> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>
> Regards,
> Ravi C
>
>
> On Wed, Aug 10, 2016 at 7:25 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>
>> Hi,
>>
>> you definitely had problems registering the components to prosody,
>> check your secret in prosody config and in jicofo and jvb config, did
>> they match?
>> Also to enable rest you need in /etc/jitsi/videobridge/config
>> JVB_OPTS="--apis=xmpp,rest"
>>
>> Regards
>> damencho
>>
>>
>> On Wed, Aug 10, 2016 at 7:18 AM, Ravi Chaudhary <rc.chaudhary@gmail.com > > > >> wrote:
>> > Correction:
>> >
>> > But even after that, we aren't able to gather any stats on
>> > http://<IP>:8080/colibri/stats.
>> >
>> > Few interesting error logs:
>> >
>> >
>> > 1. /var/log/jitsi/jicofo.log
>> >
>> >
>> >
>> > Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]
>> > org.jitsi.meet.ComponentMain.call().278 not-authorized,
host:localhost,
>> > port:5347
>> >
>> >
>> >
>> > 2. /var/log/jitsi/jvb.log
>> >
>> >
>> >
>> > JVB 2016-08-10 11:51:02.302 SEVERE: [17]
>> > org.jitsi.meet.ComponentMain.call().278 not-authorized,
host:localhost,
>> > port:5347
>> >
>> >
>> >
>> > 3. /var/log/prosody/prosody.log
>> >
>> >
>> >
>> > Aug 10 11:52:50 c2s30a8fb0 info Client connected
>> >
>> > Aug 10 11:52:50 sasl warn Client is violating RFC 3920 (section
>> > 6.1,
>> > point 7).
>> >
>> > Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component
>> > connection
>> >
>> > Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component
>> > connection
>> >
>> > Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component info
>> > Component authentication failed for jitsi-videobridge.10.20.130.50
>> >
>> > Aug 10 11:52:52 mod_component info Disconnecting component,
>> > <stream:error> is: <stream:error><not-authorized
>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not
match
>> > calculated token</text></stream:error>
>> >
>> > Aug 10 11:52:52 jcp4ac19d0 info component disconnected:
>> > jitsi-videobridge.10.20.130.50 (false)
>> >
>> > Aug 10 11:52:52 focus.10.20.130.50:component info Component
>> > authentication failed for focus.10.20.130.50
>> >
>> > Aug 10 11:52:52 mod_component info Disconnecting component,
>> > <stream:error> is: <stream:error><not-authorized
>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not
match
>> > calculated token</text></stream:error>
>> >
>> > Aug 10 11:52:52 jcp40b6b90 info component disconnected:
>> > focus.10.20.130.50 (false)
>> >
>> >
>> >
>> >
>> > On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary < > rc.chaudhary@gmail.com> > >> > wrote:
>> >>
>> >> Greetings,
>> >>
>> >> Inorder to capture statistics using the REST, we have configured
>> >> "sip-communicator.properties" on Jitsi Videobridge and rebooted:
>> >>
>> >> root@ubuntu16:~/.sip-communicator# cat sip-communicator.properties
>> >>
>> >>
>> >> org.jitsi.impl.neomedia.transform.srtp.
SRTPCryptoContext.checkReplay=falseRestart
>> >>
>> >> org.jitsi.videobridge.rest.jetty.port=8080
>> >>
>> >> org.jitsi.videobridge.ENABLE_STATISTICS=True
>> >>
>> >> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>> >>
>> >> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>> >>
>> >> But even after that, we are able to gather any stats on
>> >> http://<IP>:8080/colibri/stats.
>> >>
>> >> Could you please let us know, if we are missing any other
>> >> configuration.
>> >>
>> >> Thanks in advance.
>> >>
>> >> Regards,
>> >> Ravi C
>> >
>> >
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Maybe its a firewall issue connecting to 8080.
Jicofo is using to xmpp connections, one is registering as a component
and the second one is as a user. Maybe your secret for the user
account is wrong this is JICOFO_AUTH_PASSWORD? Check whether the user
focus is available in prosody.
The user is created with the following command: prosodyctl register
$JICOFO_AUTH_USER $JICOFO_AUTH_DOMAIN $JICOFO_AUTH_PASSWORD
https://github.com/jitsi/jitsi-meet/blob/master/debian/jitsi-meet-prosody.postinst#L94

···

On Wed, Aug 10, 2016 at 1:58 PM, Ravi Chaudhary <rc.chaudhary@gmail.com> wrote:

Greetings Damencho,

Thanks again for the pointers.

Update the respective values in < /etc/jitsi/videobridge/config > &
</etc/prosody/conf.d/10.20.130.50.cfg.lua>

O/P of netstat -anp | grep 8080
tcp6 0 0 :::8080 :::* LISTEN
6297/java

We are still unable to view any statistics on <
http://10.20.130.50:8080/colibri/stats >

O/P of /root/.sip-communicator/sip-communicator.properties

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart

org.jitsi.videobridge.rest.jetty.port=8080

org.jitsi.videobridge.ENABLE_STATISTICS=True

org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

org.jitsi.videobridge.STATISTICS_INTERVAL=1000

O/P of /var/log/jitsi/jicofo.log:

Jicofo 2016-08-10 18:47:50.517 SEVERE: [16]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to connect:
SASL authentication DIGEST-MD5 failed: text
SASL authentication DIGEST-MD5 failed: text:
        at
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)
        at
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:223)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)
        at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Jicofo 2016-08-10 18:47:50.526 SEVERE: [1961]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.write(BufferedWriter.java:221)
        at java.io.Writer.write(Writer.java:157)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:210)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.527 SEVERE: [1973]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.527 SEVERE: [1981]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.528 SEVERE: [1985]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.529 SEVERE: [1969]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.531 SEVERE: [1965]
org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
        at java.io.BufferedWriter.flush(BufferedWriter.java:253)
        at
org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
        at
org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)
Jicofo 2016-08-10 18:47:50.676 SEVERE: [1986]
org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
connection temporary
java.io.EOFException: no more data available - expected end tag
</stream:stream> to close start tag <stream:stream> from line 1, parser
stopped on END_TAG seen
...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...
@1:613
        at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:3035)
        at org.xmlpull.mxp1.MXParser.more(MXParser.java:3046)
        at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1144)
        at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)
        at
org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:329)
        at
org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
        at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)
Jicofo 2016-08-10 18:47:50.677 SEVERE: [1986]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() XMPP connection
closed on error: no more data available - expected end tag </stream:stream>
to close start tag <stream:stream> from line 1, parser stopped on END_TAG
seen
...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...
@1:613
Jicofo 2016-08-10 18:47:50.677 INFO: [1986]
org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP provider
reg state: RegistrationState=Unregistered
Jicofo 2016-08-10 18:47:51.677 INFO: [1989]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting
in: 8
Jicofo 2016-08-10 18:47:52.677 INFO: [1989]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting
in: 7
Jicofo 2016-08-10 18:47:53.677 INFO: [1989]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting
in: 6
Jicofo 2016-08-10 18:47:54.677 INFO: [1989]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting
in: 5
Jicofo 2016-08-10 18:47:55.576 INFO: [16]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnection
successful
Jicofo 2016-08-10 18:47:55.576 SEVERE: [16]
org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged().142 null
java.lang.NullPointerException
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.discoverItems(XmppProtocolProvider.java:488)
        at
org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.getItems(OpSetSimpleCapsImpl.java:53)
        at
org.jitsi.jicofo.ComponentsDiscovery.discoverServices(ComponentsDiscovery.java:238)
        at
org.jitsi.jicofo.ComponentsDiscovery.firstTimeDiscovery(ComponentsDiscovery.java:308)
        at
org.jitsi.jicofo.ComponentsDiscovery.registrationStateChanged(ComponentsDiscovery.java:343)
        at
org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(ProtocolProviderHandler.java:138)
        at
net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:187)
        at
net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:141)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.notifyConnected(XmppProtocolProvider.java:255)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$300(XmppProtocolProvider.java:46)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$XmppConnectionListener.reconnectionSuccessful(XmppProtocolProvider.java:569)
        at
org.jivesoftware.smack.PacketReader.notifyReconnection(PacketReader.java:193)
        at
org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:589)
        at
org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection.java:532)
        at
org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:968)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:210)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)
        at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)
Jicofo 2016-08-10 18:47:55.577 INFO: [16]
org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP provider
reg state: RegistrationState=Registered
Jicofo 2016-08-10 18:47:55.582 SEVERE: [16]
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to connect:
SASL authentication DIGEST-MD5 failed: text
SASL authentication DIGEST-MD5 failed: text:
at
org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)
        at
org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:223)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)
        at
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)
        at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)

Awaiting on your inputs to gather the statistics

Regards,
Ravi C

On Wed, Aug 10, 2016 at 8:52 PM, Damian Minkov <damencho@jitsi.org> wrote:

On Wed, Aug 10, 2016 at 10:15 AM, Ravi Chaudhary <rc.chaudhary@gmail.com> >> wrote:
> Greetings Damencho,
> Thanks for the pointer. Here is the config of jicofo, videobridge &
> prosody
> files.
>
> /etc/jitsi/jicofo/config
> # sets the secret used to authenticate as an XMPP component
> JICOFO_SECRET=6h85vKcQ
>
> # sets the port to use for the XMPP component connection
> JICOFO_PORT=5347
>
> /etc/jitsi/videobridge/config
> # sets the port of the XMPP server (default: 5275)
> JVB_PORT=5347
>
> # sets the shared secret used to authenticate to the XMPP server
> JVB_SECRET=217TkZFo
>
> # extra options to pass to the JVB daemon
> JVB_OPTS="--apis=rest"

in order jicofo to work you need JVB_OPTS="--apis=xmpp,rest"

>
>
> cat /etc/prosody/conf.d/10.20.130.50.cfg.lua
> VirtualHost "10.20.130.50"
> authentication = "anonymous"
> ssl = {
> key = "/var/lib/prosody/10.20.130.50.key";
> certificate = "/var/lib/prosody/10.20.130.50.crt";
> }
> modules_enabled = {
> "bosh";
> "pubsub";
> }
>
> VirtualHost "auth.10.20.130.50"
> authentication = "internal_plain"
>
> Component "conference.10.20.130.50" "muc"
> Component "jitsi-videobridge.10.20.130.50"
> component_secret = "YOURSECRET1"
> Component "focus.10.20.130.50"
> component_secret = "YOURSECRET2"
>
> 1) Do we need to update the 'prosody' file with the respective SECRET of
> Videobridge & Jicofo?

YOURSECRET1 should be 217TkZFo and YOURSECRET2 should be 6h85vKcQ.

>
> 2) Also how can i verify, if the Colibri stats are being accessible on
> port
> 8080?
>
> FYI: O/P of cat /root/.sip-communicator/sip-communicator.properties
>
> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart
>
> org.jitsi.videobridge.rest.jetty.port=8080
>
> org.jitsi.videobridge.ENABLE_STATISTICS=True
>
> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>
> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>
> Regards,
> Ravi C
>
>
> On Wed, Aug 10, 2016 at 7:25 PM, Damian Minkov <damencho@jitsi.org> >> > wrote:
>>
>> Hi,
>>
>> you definitely had problems registering the components to prosody,
>> check your secret in prosody config and in jicofo and jvb config, did
>> they match?
>> Also to enable rest you need in /etc/jitsi/videobridge/config
>> JVB_OPTS="--apis=xmpp,rest"
>>
>> Regards
>> damencho
>>
>>
>> On Wed, Aug 10, 2016 at 7:18 AM, Ravi Chaudhary >> >> <rc.chaudhary@gmail.com> >> >> wrote:
>> > Correction:
>> >
>> > But even after that, we aren't able to gather any stats on
>> > http://<IP>:8080/colibri/stats.
>> >
>> > Few interesting error logs:
>> >
>> >
>> > 1. /var/log/jitsi/jicofo.log
>> >
>> >
>> >
>> > Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]
>> > org.jitsi.meet.ComponentMain.call().278 not-authorized,
>> > host:localhost,
>> > port:5347
>> >
>> >
>> >
>> > 2. /var/log/jitsi/jvb.log
>> >
>> >
>> >
>> > JVB 2016-08-10 11:51:02.302 SEVERE: [17]
>> > org.jitsi.meet.ComponentMain.call().278 not-authorized,
>> > host:localhost,
>> > port:5347
>> >
>> >
>> >
>> > 3. /var/log/prosody/prosody.log
>> >
>> >
>> >
>> > Aug 10 11:52:50 c2s30a8fb0 info Client connected
>> >
>> > Aug 10 11:52:50 sasl warn Client is violating RFC 3920 (section
>> > 6.1,
>> > point 7).
>> >
>> > Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component
>> > connection
>> >
>> > Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component
>> > connection
>> >
>> > Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component info
>> > Component authentication failed for jitsi-videobridge.10.20.130.50
>> >
>> > Aug 10 11:52:52 mod_component info Disconnecting component,
>> > <stream:error> is: <stream:error><not-authorized
>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not
>> > match
>> > calculated token</text></stream:error>
>> >
>> > Aug 10 11:52:52 jcp4ac19d0 info component disconnected:
>> > jitsi-videobridge.10.20.130.50 (false)
>> >
>> > Aug 10 11:52:52 focus.10.20.130.50:component info Component
>> > authentication failed for focus.10.20.130.50
>> >
>> > Aug 10 11:52:52 mod_component info Disconnecting component,
>> > <stream:error> is: <stream:error><not-authorized
>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not
>> > match
>> > calculated token</text></stream:error>
>> >
>> > Aug 10 11:52:52 jcp40b6b90 info component disconnected:
>> > focus.10.20.130.50 (false)
>> >
>> >
>> >
>> >
>> > On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary >> >> > <rc.chaudhary@gmail.com> >> >> > wrote:
>> >>
>> >> Greetings,
>> >>
>> >> Inorder to capture statistics using the REST, we have configured
>> >> "sip-communicator.properties" on Jitsi Videobridge and rebooted:
>> >>
>> >> root@ubuntu16:~/.sip-communicator# cat sip-communicator.properties
>> >>
>> >>
>> >>
>> >> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart
>> >>
>> >> org.jitsi.videobridge.rest.jetty.port=8080
>> >>
>> >> org.jitsi.videobridge.ENABLE_STATISTICS=True
>> >>
>> >> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>> >>
>> >> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>> >>
>> >> But even after that, we are able to gather any stats on
>> >> http://<IP>:8080/colibri/stats.
>> >>
>> >> Could you please let us know, if we are missing any other
>> >> configuration.
>> >>
>> >> Thanks in advance.
>> >>
>> >> Regards,
>> >> Ravi C
>> >
>> >
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Greetings Damencho,

Thanks a ton.

Yes, i hadn't registered the 'focus' user in prosody.

*Could you perhaps site an example inorder to collect the statistics on
Jitsi Videobridge. Do we need to enable port 8080 for Colibri, in some
other config as well?*
There isn't any firewall blocking port 8080.

*ubuntu@ubuntu16:~$ telnet 10.20.130.50 8080Trying 10.20.130.50...Connected
to 10.20.130.50.Escape character is '^]'.*

Regards,
Ravi C

···

On Thu, Aug 11, 2016 at 1:04 AM, Damian Minkov <damencho@jitsi.org> wrote:

Maybe its a firewall issue connecting to 8080.
Jicofo is using to xmpp connections, one is registering as a component
and the second one is as a user. Maybe your secret for the user
account is wrong this is JICOFO_AUTH_PASSWORD? Check whether the user
focus is available in prosody.
The user is created with the following command: prosodyctl register
$JICOFO_AUTH_USER $JICOFO_AUTH_DOMAIN $JICOFO_AUTH_PASSWORD
https://github.com/jitsi/jitsi-meet/blob/master/debian/
jitsi-meet-prosody.postinst#L94

On Wed, Aug 10, 2016 at 1:58 PM, Ravi Chaudhary <rc.chaudhary@gmail.com> > wrote:
> Greetings Damencho,
>
> Thanks again for the pointers.
>
> Update the respective values in < /etc/jitsi/videobridge/config > &
> </etc/prosody/conf.d/10.20.130.50.cfg.lua>
>
> O/P of netstat -anp | grep 8080
> tcp6 0 0 :::8080 :::*
LISTEN
> 6297/java
>
> We are still unable to view any statistics on <
> http://10.20.130.50:8080/colibri/stats >
>
> O/P of /root/.sip-communicator/sip-communicator.properties
>
> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=
falseRestart
>
> org.jitsi.videobridge.rest.jetty.port=8080
>
> org.jitsi.videobridge.ENABLE_STATISTICS=True
>
> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>
> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>
>
> O/P of /var/log/jitsi/jicofo.log:
>
> Jicofo 2016-08-10 18:47:50.517 SEVERE: [16]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to
connect:
> SASL authentication DIGEST-MD5 failed: text
> SASL authentication DIGEST-MD5 failed: text:
> at
> org.jivesoftware.smack.SASLAuthentication.authenticate(
SASLAuthentication.java:341)
> at
> org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(
XmppProtocolProvider.java:223)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$
000(XmppProtocolProvider.java:46)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(
XmppProtocolProvider.java:191)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(
XmppProtocolProvider.java:186)
> at
> org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
> at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$
ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$
ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
> at
> java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1142)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:617)
> at java.lang.Thread.run(Thread.java:745)
> Jicofo 2016-08-10 18:47:50.526 SEVERE: [1961]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.write(BufferedWriter.java:221)
> at java.io.Writer.write(Writer.java:157)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:210)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(
PacketWriter.java:80)
> Jicofo 2016-08-10 18:47:50.527 SEVERE: [1973]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(
PacketWriter.java:80)
> Jicofo 2016-08-10 18:47:50.527 SEVERE: [1981]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(
PacketWriter.java:80)
> Jicofo 2016-08-10 18:47:50.528 SEVERE: [1985]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(
PacketWriter.java:80)
> Jicofo 2016-08-10 18:47:50.529 SEVERE: [1969]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(
PacketWriter.java:80)
> Jicofo 2016-08-10 18:47:50.531 SEVERE: [1965]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(
PacketWriter.java:80)
> Jicofo 2016-08-10 18:47:50.676 SEVERE: [1986]
> org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
> connection temporary
> java.io.EOFException: no more data available - expected end tag
> </stream:stream> to close start tag <stream:stream> from line 1, parser
> stopped on END_TAG seen
> ...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...
> @1:613
> at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:3035)
> at org.xmlpull.mxp1.MXParser.more(MXParser.java:3046)
> at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1144)
> at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)
> at
> org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:329)
> at
> org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
> at org.jivesoftware.smack.PacketReader$1.run(
PacketReader.java:74)
> Jicofo 2016-08-10 18:47:50.677 SEVERE: [1986]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() XMPP
connection
> closed on error: no more data available - expected end tag
</stream:stream>
> to close start tag <stream:stream> from line 1, parser stopped on END_TAG
> seen
> ...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...
> @1:613
> Jicofo 2016-08-10 18:47:50.677 INFO: [1986]
> org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP
provider
> reg state: RegistrationState=Unregistered
> Jicofo 2016-08-10 18:47:51.677 INFO: [1989]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnecting
> in: 8
> Jicofo 2016-08-10 18:47:52.677 INFO: [1989]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnecting
> in: 7
> Jicofo 2016-08-10 18:47:53.677 INFO: [1989]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnecting
> in: 6
> Jicofo 2016-08-10 18:47:54.677 INFO: [1989]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnecting
> in: 5
> Jicofo 2016-08-10 18:47:55.576 INFO: [16]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnection
> successful
> Jicofo 2016-08-10 18:47:55.576 SEVERE: [16]
> org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged().142
null
> java.lang.NullPointerException
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.discoverItems(
XmppProtocolProvider.java:488)
> at
> org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.getItems(
OpSetSimpleCapsImpl.java:53)
> at
> org.jitsi.jicofo.ComponentsDiscovery.discoverServices(
ComponentsDiscovery.java:238)
> at
> org.jitsi.jicofo.ComponentsDiscovery.firstTimeDiscovery(
ComponentsDiscovery.java:308)
> at
> org.jitsi.jicofo.ComponentsDiscovery.registrationStateChanged(
ComponentsDiscovery.java:343)
> at
> org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(
ProtocolProviderHandler.java:138)
> at
> net.java.sip.communicator.service.protocol.
AbstractProtocolProviderService.fireRegistrationStateChanged(
AbstractProtocolProviderService.java:187)
> at
> net.java.sip.communicator.service.protocol.
AbstractProtocolProviderService.fireRegistrationStateChanged(
AbstractProtocolProviderService.java:141)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.notifyConnected(
XmppProtocolProvider.java:255)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$
300(XmppProtocolProvider.java:46)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$
XmppConnectionListener.reconnectionSuccessful(
XmppProtocolProvider.java:569)
> at
> org.jivesoftware.smack.PacketReader.notifyReconnection(
PacketReader.java:193)
> at
> org.jivesoftware.smack.XMPPConnection.initConnection(
XMPPConnection.java:589)
> at
> org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(
XMPPConnection.java:532)
> at
> org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:968)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(
XmppProtocolProvider.java:210)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$
000(XmppProtocolProvider.java:46)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(
XmppProtocolProvider.java:191)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(
XmppProtocolProvider.java:186)
> at
> org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
> at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$
ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$
ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
> at
> java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1142)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:617)
> at java.lang.Thread.run(Thread.java:745)
> Jicofo 2016-08-10 18:47:55.577 INFO: [16]
> org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP
provider
> reg state: RegistrationState=Registered
> Jicofo 2016-08-10 18:47:55.582 SEVERE: [16]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to
connect:
> SASL authentication DIGEST-MD5 failed: text
> SASL authentication DIGEST-MD5 failed: text:
> at
> org.jivesoftware.smack.SASLAuthentication.authenticate(
SASLAuthentication.java:341)
> at
> org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(
XmppProtocolProvider.java:223)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$
000(XmppProtocolProvider.java:46)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(
XmppProtocolProvider.java:191)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(
XmppProtocolProvider.java:186)
> at
> org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
> at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$
ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$
ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
> at
> java.util.concurrent.ThreadPoolExecutor.runWorker(
ThreadPoolExecutor.java:1142)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(
ThreadPoolExecutor.java:617)
> at java.lang.Thread.run(Thread.java:745)
>
> Awaiting on your inputs to gather the statistics
>
> Regards,
> Ravi C
>
>
> On Wed, Aug 10, 2016 at 8:52 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>
>> On Wed, Aug 10, 2016 at 10:15 AM, Ravi Chaudhary < > rc.chaudhary@gmail.com> > >> wrote:
>> > Greetings Damencho,
>> > Thanks for the pointer. Here is the config of jicofo, videobridge &
>> > prosody
>> > files.
>> >
>> > /etc/jitsi/jicofo/config
>> > # sets the secret used to authenticate as an XMPP component
>> > JICOFO_SECRET=6h85vKcQ
>> >
>> > # sets the port to use for the XMPP component connection
>> > JICOFO_PORT=5347
>> >
>> > /etc/jitsi/videobridge/config
>> > # sets the port of the XMPP server (default: 5275)
>> > JVB_PORT=5347
>> >
>> > # sets the shared secret used to authenticate to the XMPP server
>> > JVB_SECRET=217TkZFo
>> >
>> > # extra options to pass to the JVB daemon
>> > JVB_OPTS="--apis=rest"
>>
>> in order jicofo to work you need JVB_OPTS="--apis=xmpp,rest"
>>
>> >
>> >
>> > cat /etc/prosody/conf.d/10.20.130.50.cfg.lua
>> > VirtualHost "10.20.130.50"
>> > authentication = "anonymous"
>> > ssl = {
>> > key = "/var/lib/prosody/10.20.130.50.key";
>> > certificate = "/var/lib/prosody/10.20.130.50.crt";
>> > }
>> > modules_enabled = {
>> > "bosh";
>> > "pubsub";
>> > }
>> >
>> > VirtualHost "auth.10.20.130.50"
>> > authentication = "internal_plain"
>> >
>> > Component "conference.10.20.130.50" "muc"
>> > Component "jitsi-videobridge.10.20.130.50"
>> > component_secret = "YOURSECRET1"
>> > Component "focus.10.20.130.50"
>> > component_secret = "YOURSECRET2"
>> >
>> > 1) Do we need to update the 'prosody' file with the respective SECRET
of
>> > Videobridge & Jicofo?
>>
>> YOURSECRET1 should be 217TkZFo and YOURSECRET2 should be 6h85vKcQ.
>>
>> >
>> > 2) Also how can i verify, if the Colibri stats are being accessible on
>> > port
>> > 8080?
>> >
>> > FYI: O/P of cat /root/.sip-communicator/sip-communicator.properties
>> >
>> > org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=
falseRestart
>> >
>> > org.jitsi.videobridge.rest.jetty.port=8080
>> >
>> > org.jitsi.videobridge.ENABLE_STATISTICS=True
>> >
>> > org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>> >
>> > org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>> >
>> > Regards,
>> > Ravi C
>> >
>> >
>> > On Wed, Aug 10, 2016 at 7:25 PM, Damian Minkov <damencho@jitsi.org> > >> > wrote:
>> >>
>> >> Hi,
>> >>
>> >> you definitely had problems registering the components to prosody,
>> >> check your secret in prosody config and in jicofo and jvb config, did
>> >> they match?
>> >> Also to enable rest you need in /etc/jitsi/videobridge/config
>> >> JVB_OPTS="--apis=xmpp,rest"
>> >>
>> >> Regards
>> >> damencho
>> >>
>> >>
>> >> On Wed, Aug 10, 2016 at 7:18 AM, Ravi Chaudhary > >> >> <rc.chaudhary@gmail.com> > >> >> wrote:
>> >> > Correction:
>> >> >
>> >> > But even after that, we aren't able to gather any stats on
>> >> > http://<IP>:8080/colibri/stats.
>> >> >
>> >> > Few interesting error logs:
>> >> >
>> >> >
>> >> > 1. /var/log/jitsi/jicofo.log
>> >> >
>> >> >
>> >> >
>> >> > Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]
>> >> > org.jitsi.meet.ComponentMain.call().278 not-authorized,
>> >> > host:localhost,
>> >> > port:5347
>> >> >
>> >> >
>> >> >
>> >> > 2. /var/log/jitsi/jvb.log
>> >> >
>> >> >
>> >> >
>> >> > JVB 2016-08-10 11:51:02.302 SEVERE: [17]
>> >> > org.jitsi.meet.ComponentMain.call().278 not-authorized,
>> >> > host:localhost,
>> >> > port:5347
>> >> >
>> >> >
>> >> >
>> >> > 3. /var/log/prosody/prosody.log
>> >> >
>> >> >
>> >> >
>> >> > Aug 10 11:52:50 c2s30a8fb0 info Client connected
>> >> >
>> >> > Aug 10 11:52:50 sasl warn Client is violating RFC 3920
(section
>> >> > 6.1,
>> >> > point 7).
>> >> >
>> >> > Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component
>> >> > connection
>> >> >
>> >> > Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component
>> >> > connection
>> >> >
>> >> > Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component
info
>> >> > Component authentication failed for jitsi-videobridge.10.20.130.50
>> >> >
>> >> > Aug 10 11:52:52 mod_component info Disconnecting component,
>> >> > <stream:error> is: <stream:error><not-authorized
>> >> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> >> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not
>> >> > match
>> >> > calculated token</text></stream:error>
>> >> >
>> >> > Aug 10 11:52:52 jcp4ac19d0 info component disconnected:
>> >> > jitsi-videobridge.10.20.130.50 (false)
>> >> >
>> >> > Aug 10 11:52:52 focus.10.20.130.50:component info Component
>> >> > authentication failed for focus.10.20.130.50
>> >> >
>> >> > Aug 10 11:52:52 mod_component info Disconnecting component,
>> >> > <stream:error> is: <stream:error><not-authorized
>> >> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> >> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not
>> >> > match
>> >> > calculated token</text></stream:error>
>> >> >
>> >> > Aug 10 11:52:52 jcp40b6b90 info component disconnected:
>> >> > focus.10.20.130.50 (false)
>> >> >
>> >> >
>> >> >
>> >> >
>> >> > On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary > >> >> > <rc.chaudhary@gmail.com> > >> >> > wrote:
>> >> >>
>> >> >> Greetings,
>> >> >>
>> >> >> Inorder to capture statistics using the REST, we have configured
>> >> >> "sip-communicator.properties" on Jitsi Videobridge and rebooted:
>> >> >>
>> >> >> root@ubuntu16:~/.sip-communicator# cat
sip-communicator.properties
>> >> >>
>> >> >>
>> >> >>
>> >> >> org.jitsi.impl.neomedia.transform.srtp.
SRTPCryptoContext.checkReplay=falseRestart
>> >> >>
>> >> >> org.jitsi.videobridge.rest.jetty.port=8080
>> >> >>
>> >> >> org.jitsi.videobridge.ENABLE_STATISTICS=True
>> >> >>
>> >> >> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>> >> >>
>> >> >> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>> >> >>
>> >> >> But even after that, we are able to gather any stats on
>> >> >> http://<IP>:8080/colibri/stats.
>> >> >>
>> >> >> Could you please let us know, if we are missing any other
>> >> >> configuration.
>> >> >>
>> >> >> Thanks in advance.
>> >> >>
>> >> >> Regards,
>> >> >> Ravi C
>> >> >
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > users mailing list
>> >> > users@jitsi.org
>> >> > Unsubscribe instructions and other list options:
>> >> > http://lists.jitsi.org/mailman/listinfo/users
>> >>
>> >> _______________________________________________
>> >> users mailing list
>> >> users@jitsi.org
>> >> Unsubscribe instructions and other list options:
>> >> http://lists.jitsi.org/mailman/listinfo/users
>> >
>> >
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Greetings Damencho and Ravi,
We have made changes in /etc/jitsi/videobridge/sip-communicator.properties

org.jitsi.videobridge.ENABLE_STATISTICS=Trueorg.jitsi.videobridge.STATISTICS_TRANSPORT=pubsuborg.jitsi.videobridge.STATISTICS_INTERVAL=1000org.jitsi.videobridge.PUBSUB_SERVICE=PubSub serviceorg.jitsi.videobridge.PUBSUB_NODE=PubSub node
# service jits-videobridge restart; service jicofo restart
Log details from /var/log/prosody/prosody.log Aug 11 14:24:36 jcp1d60c90 info component disconnected: jitsi-videobridge.192.168.37.10 (closed)Aug 11 14:24:46 jitsi-videobridge.192.168.37.10:component warn Component not connected, bouncing error for: <iq id='OiCrT-307' type='get' to='jitsi-videobridge.192.168.37.10' from='focus@auth.192.168.37.10/focus79574579721707'>Aug 11 14:25:15 jcp1dacca0 info Incoming Jabber component connectionAug 11 14:25:15 jitsi-videobridge.192.168.37.10:component info External component successfully authenticatedAug 11 14:27:00 jcp1c30010 info component disconnected: focus.192.168.37.10 (false)Aug 11 14:27:01 c2s1ec5db0 info Client disconnected: closedAug 11 14:27:15 c2s1e05d70 info Client connectedAug 11 14:27:20 jcp1cd41c0 info Incoming Jabber component connectionAug 11 14:27:20 focus.192.168.37.10:component info External component successfully authenticatedAug 11 14:27:28 sasl warn Client is violating RFC 3920 (section 6.1, point 7).Aug 11 14:27:28 c2s1e05d70 info Authenticated as focus@auth.192.168.37.10
/var/log/jitsi/jicofo.log
Jicofo 2016-08-11 14:40:17.238 INFO: [10] impl.netaddr.NetworkAddressManagerServiceImpl.start().92 Network Address Manager ...[ STARTED ]Jicofo 2016-08-11 14:40:17.242 INFO: [10] impl.netaddr.NetworkAddressManagerServiceImpl.start().98 Network Address Manager Service ...[REGISTERED]Jicofo 2016-08-11 14:40:17.336 INFO: [10] org.jitsi.version.AbstractVersionActivator.start().119 JiCoFo Version: JiCoFo 1.0.1.0-268Jicofo 2016-08-11 14:40:21.399 INFO: [10] org.jitsi.jicofo.JitsiMeetGlobalConfig.init().140 Jibri requests in PENDING state will be timed out after: 90 secondsJicofo 2016-08-11 14:40:21.784 INFO: [10] org.jitsi.jicofo.BridgeSelector.init().539 Bridge failure reset threshold: 300000Jicofo 2016-08-11 14:40:25.297 INFO: [10] org.eclipse.jetty.server.Server.doStart() jetty-8.1.16.v20140903Jicofo 2016-08-11 14:40:26.705 INFO: [10] org.eclipse.jetty.server.AbstractConnector.doStart() Started SelectChannelConnector@0.0.0.0:8888Jicofo 2016-08-11 14:40:27.124 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().176 Component org.jitsi.jicofo. config:Jicofo 2016-08-11 14:40:27.146 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().177 ping interval: 10000 msJicofo 2016-08-11 14:40:27.149 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().178 ping timeout: 5000 msJicofo 2016-08-11 14:40:27.152 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().179 ping threshold: 3Jicofo 2016-08-11 14:40:35.929 INFO: [15] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().267 New component discovered: auth.192.168.37.10, Version[Prosody(0.9.1,Linux)@-1121594909Jicofo 2016-08-11 14:40:35.934 INFO: [15] org.jitsi.jicofo.JitsiMeetServices.newNodeDiscovered().244 Detected XMPP server version: Version[Prosody(0.9.1,Linux)@-1121594909Jicofo 2016-08-11 14:40:35.968 INFO: [15] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().267 New component discovered: conference.192.168.37.10, nullJicofo 2016-08-11 14:40:35.971 INFO: [15] org.jitsi.jicofo.JitsiMeetServices.newNodeDiscovered().236 MUC component discovered: conference.192.168.37.10Jicofo 2016-08-11 14:40:36.156 INFO: [15] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().267 New component discovered: focus.192.168.37.10, nullJicofo 2016-08-11 14:40:36.293 INFO: [15] org.jitsi.jicofo.ComponentsDiscovery.discoverServices().267 New component discovered: jitsi-videobridge.192.168.37.10, Version[JVB(0.1.752,Linux)@-346597982Jicofo 2016-08-11 14:40:36.297 INFO: [15] org.jitsi.jicofo.BridgeSelector.addJvbAddress().148 Added videobridge: jitsi-videobridge.192.168.37.10 v: Version[JVB(0.1.752,Linux)@-346597982Jicofo 2016-08-11 14:40:36.302 WARNING: [15] org.jitsi.jicofo.BridgeSelector.addJvbAddress().160 No pub-sub node mapped for jitsi-videobridge.192.168.37.10Jicofo 2016-08-11 14:40:36.333 INFO: [15] org.jitsi.jicofo.ComponentsDiscovery.scheduleRediscovery().190 Services re-discovery interval: 30000Jicofo 2016-08-11 14:40:36.349 INFO: [15] org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP provider reg state: RegistrationState=RegisteredJicofo 2016-08-11 14:40:36.370 INFO: [15] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider Jabber:focus@auth.192.168.37.10/focus81163091971349@localhost connected (JID: focus@auth.192.168.37.10/focus81163091971349)Jicofo 2016-08-11 14:40:36.399 INFO: [40] org.jitsi.jicofo.JvbDoctor.info() Scheduled health-check task for: jitsi-videobridge.192.168.37.10
netstat -tunpl
Active Internet connections (only servers)Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program nametcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 1214/nginxtcp 0 0 0.0.0.0:5269 0.0.0.0:* LISTEN 1241/lua5.1tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1100/sshdtcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 1214/nginxtcp 0 0 0.0.0.0:5280 0.0.0.0:* LISTEN 1241/lua5.1tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN 1241/lua5.1tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN 1241/lua5.1tcp6 0 0 :::8080 :::* LISTEN 30973/javatcp6 0 0 :::80 :::* LISTEN 1214/nginxtcp6 0 0 :::5269 :::* LISTEN 1241/lua5.1tcp6 0 0 :::8888 :::* LISTEN 2066/javatcp6 0 0 192.168.111.9:4443 :::* LISTEN 30973/javatcp6 0 0 :::5280 :::* LISTEN 1241/lua5.1tcp6 0 0 ::1:5347 :::* LISTEN 1241/lua5.1tcp6 0 0 :::5222 :::* LISTEN 1241/lua5.1udp 0 0 0.0.0.0:16366 0.0.0.0:* 670/dhclientudp 0 0 0.0.0.0:68 0.0.0.0:* 670/dhclientudp6 0 0 192.168.111.9:10000 :::* 30973/javaudp6 0 0 :::42980 :::* 2066/javaudp6 0 0 192.168.111.9:10761 :::* 30973/javaudp6 0 0 192.168.111.9:10762 :::* 30973/javaudp6 0 0 192.168.111.9:10763 :::* 30973/javaudp6 0 0 192.168.111.9:10764 :::* 30973/javaudp6 0 0 192.168.111.9:10765 :::* -udp6 0 0 192.168.111.9:10766 :::* -udp6 0 0 :::31234 :::* 670/dhclientudp6 0 0 :::16767 :::* 30973/java
The issue is port 8080 is listening on IPV6 and we have not configured IPV6 on our Server. Can you please advise on this.
Apologies Ravi, if have made your conversation messy. Pls let me know, in that case, We will have a new thread opened for this.
Thanking in advance toyou both..
cheersSY

···

From: rc.chaudhary@gmail.com
Date: Thu, 11 Aug 2016 01:55:38 +0530
To: users@jitsi.org
Subject: Re: [jitsi-users] Enabling REST API on Jitsi Videobridge

Greetings Damencho,

Thanks a ton.

Yes, i hadn't registered the 'focus' user in prosody.

Could you perhaps site an example inorder to collect the statistics on Jitsi Videobridge. Do we need to enable port 8080 for Colibri, in some other config as well?
There isn't any firewall blocking port 8080.

ubuntu@ubuntu16:~$ telnet 10.20.130.50 8080
Trying 10.20.130.50...
Connected to 10.20.130.50.
Escape character is '^]'.

Regards,
Ravi C

On Thu, Aug 11, 2016 at 1:04 AM, Damian Minkov <damencho@jitsi.org> wrote:
Maybe its a firewall issue connecting to 8080.

Jicofo is using to xmpp connections, one is registering as a component

and the second one is as a user. Maybe your secret for the user

account is wrong this is JICOFO_AUTH_PASSWORD? Check whether the user

focus is available in prosody.

The user is created with the following command: prosodyctl register

$JICOFO_AUTH_USER $JICOFO_AUTH_DOMAIN $JICOFO_AUTH_PASSWORD

https://github.com/jitsi/jitsi-meet/blob/master/debian/jitsi-meet-prosody.postinst#L94

On Wed, Aug 10, 2016 at 1:58 PM, Ravi Chaudhary <rc.chaudhary@gmail.com> wrote:

Greetings Damencho,

Thanks again for the pointers.

Update the respective values in < /etc/jitsi/videobridge/config > &

</etc/prosody/conf.d/10.20.130.50.cfg.lua>

O/P of netstat -anp | grep 8080

tcp6 0 0 :::8080 :::* LISTEN

6297/java

We are still unable to view any statistics on <

http://10.20.130.50:8080/colibri/stats >

O/P of /root/.sip-communicator/sip-communicator.properties

org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart

org.jitsi.videobridge.rest.jetty.port=8080

org.jitsi.videobridge.ENABLE_STATISTICS=True

org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

org.jitsi.videobridge.STATISTICS_INTERVAL=1000

O/P of /var/log/jitsi/jicofo.log:

Jicofo 2016-08-10 18:47:50.517 SEVERE: [16]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to connect:

SASL authentication DIGEST-MD5 failed: text

SASL authentication DIGEST-MD5 failed: text:

        at

org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)

        at

org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:223)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)

        at

org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)

        at

java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

        at java.util.concurrent.FutureTask.run(FutureTask.java:266)

        at

java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)

        at

java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)

        at

java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

        at

java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

        at java.lang.Thread.run(Thread.java:745)

Jicofo 2016-08-10 18:47:50.526 SEVERE: [1961]

org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet

java.io.IOException: Stream closed

        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)

        at java.io.BufferedWriter.write(BufferedWriter.java:221)

        at java.io.Writer.write(Writer.java:157)

        at

org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:210)

        at

org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)

        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)

Jicofo 2016-08-10 18:47:50.527 SEVERE: [1973]

org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet

java.io.IOException: Stream closed

        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)

        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)

        at java.io.BufferedWriter.flush(BufferedWriter.java:253)

        at

org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)

        at

org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)

        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)

Jicofo 2016-08-10 18:47:50.527 SEVERE: [1981]

org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet

java.io.IOException: Stream closed

        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)

        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)

        at java.io.BufferedWriter.flush(BufferedWriter.java:253)

        at

org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)

        at

org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)

        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)

Jicofo 2016-08-10 18:47:50.528 SEVERE: [1985]

org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet

java.io.IOException: Stream closed

        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)

        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)

        at java.io.BufferedWriter.flush(BufferedWriter.java:253)

        at

org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)

        at

org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)

        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)

Jicofo 2016-08-10 18:47:50.529 SEVERE: [1969]

org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet

java.io.IOException: Stream closed

        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)

        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)

        at java.io.BufferedWriter.flush(BufferedWriter.java:253)

        at

org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)

        at

org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)

        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)

Jicofo 2016-08-10 18:47:50.531 SEVERE: [1965]

org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet

java.io.IOException: Stream closed

        at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)

        at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)

        at java.io.BufferedWriter.flush(BufferedWriter.java:253)

        at

org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)

        at

org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)

        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:80)

Jicofo 2016-08-10 18:47:50.676 SEVERE: [1986]

org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the

connection temporary

java.io.EOFException: no more data available - expected end tag

</stream:stream> to close start tag <stream:stream> from line 1, parser

stopped on END_TAG seen

...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...

@1:613

        at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:3035)

        at org.xmlpull.mxp1.MXParser.more(MXParser.java:3046)

        at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1144)

        at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)

        at

org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:329)

        at

org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)

        at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:74)

Jicofo 2016-08-10 18:47:50.677 SEVERE: [1986]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() XMPP connection

closed on error: no more data available - expected end tag </stream:stream>

to close start tag <stream:stream> from line 1, parser stopped on END_TAG

seen

...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...

@1:613

Jicofo 2016-08-10 18:47:50.677 INFO: [1986]

org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP provider

reg state: RegistrationState=Unregistered

Jicofo 2016-08-10 18:47:51.677 INFO: [1989]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting

in: 8

Jicofo 2016-08-10 18:47:52.677 INFO: [1989]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting

in: 7

Jicofo 2016-08-10 18:47:53.677 INFO: [1989]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting

in: 6

Jicofo 2016-08-10 18:47:54.677 INFO: [1989]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnecting

in: 5

Jicofo 2016-08-10 18:47:55.576 INFO: [16]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP reconnection

successful

Jicofo 2016-08-10 18:47:55.576 SEVERE: [16]

org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged().142 null

java.lang.NullPointerException

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.discoverItems(XmppProtocolProvider.java:488)

        at

org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.getItems(OpSetSimpleCapsImpl.java:53)

        at

org.jitsi.jicofo.ComponentsDiscovery.discoverServices(ComponentsDiscovery.java:238)

        at

org.jitsi.jicofo.ComponentsDiscovery.firstTimeDiscovery(ComponentsDiscovery.java:308)

        at

org.jitsi.jicofo.ComponentsDiscovery.registrationStateChanged(ComponentsDiscovery.java:343)

        at

org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(ProtocolProviderHandler.java:138)

        at

net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:187)

        at

net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:141)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.notifyConnected(XmppProtocolProvider.java:255)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$300(XmppProtocolProvider.java:46)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$XmppConnectionListener.reconnectionSuccessful(XmppProtocolProvider.java:569)

        at

org.jivesoftware.smack.PacketReader.notifyReconnection(PacketReader.java:193)

        at

org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:589)

        at

org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection.java:532)

        at

org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:968)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:210)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)

        at

org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)

        at

java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

        at java.util.concurrent.FutureTask.run(FutureTask.java:266)

        at

java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)

        at

java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)

        at

java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

        at

java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

        at java.lang.Thread.run(Thread.java:745)

Jicofo 2016-08-10 18:47:55.577 INFO: [16]

org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP provider

reg state: RegistrationState=Registered

Jicofo 2016-08-10 18:47:55.582 SEVERE: [16]

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to connect:

SASL authentication DIGEST-MD5 failed: text

SASL authentication DIGEST-MD5 failed: text:

at

org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:341)

        at

org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:223)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:46)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:191)

        at

org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:186)

        at

org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)

        at

java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

        at java.util.concurrent.FutureTask.run(FutureTask.java:266)

        at

java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)

        at

java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)

        at

java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

        at

java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

        at java.lang.Thread.run(Thread.java:745)

Awaiting on your inputs to gather the statistics

Regards,

Ravi C

On Wed, Aug 10, 2016 at 8:52 PM, Damian Minkov <damencho@jitsi.org> wrote:

On Wed, Aug 10, 2016 at 10:15 AM, Ravi Chaudhary <rc.chaudhary@gmail.com> >> wrote:

> Greetings Damencho,

> Thanks for the pointer. Here is the config of jicofo, videobridge &

> prosody

> files.

>

> /etc/jitsi/jicofo/config

> # sets the secret used to authenticate as an XMPP component

> JICOFO_SECRET=6h85vKcQ

>

> # sets the port to use for the XMPP component connection

> JICOFO_PORT=5347

>

> /etc/jitsi/videobridge/config

> # sets the port of the XMPP server (default: 5275)

> JVB_PORT=5347

>

> # sets the shared secret used to authenticate to the XMPP server

> JVB_SECRET=217TkZFo

>

> # extra options to pass to the JVB daemon

> JVB_OPTS="--apis=rest"

in order jicofo to work you need JVB_OPTS="--apis=xmpp,rest"

>

>

> cat /etc/prosody/conf.d/10.20.130.50.cfg.lua

> VirtualHost "10.20.130.50"

> authentication = "anonymous"

> ssl = {

> key = "/var/lib/prosody/10.20.130.50.key";

> certificate = "/var/lib/prosody/10.20.130.50.crt";

> }

> modules_enabled = {

> "bosh";

> "pubsub";

> }

>

> VirtualHost "auth.10.20.130.50"

> authentication = "internal_plain"

>

> Component "conference.10.20.130.50" "muc"

> Component "jitsi-videobridge.10.20.130.50"

> component_secret = "YOURSECRET1"

> Component "focus.10.20.130.50"

> component_secret = "YOURSECRET2"

>

> 1) Do we need to update the 'prosody' file with the respective SECRET of

> Videobridge & Jicofo?

YOURSECRET1 should be 217TkZFo and YOURSECRET2 should be 6h85vKcQ.

>

> 2) Also how can i verify, if the Colibri stats are being accessible on

> port

> 8080?

>

> FYI: O/P of cat /root/.sip-communicator/sip-communicator.properties

>

> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart

>

> org.jitsi.videobridge.rest.jetty.port=8080

>

> org.jitsi.videobridge.ENABLE_STATISTICS=True

>

> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

>

> org.jitsi.videobridge.STATISTICS_INTERVAL=1000

>

> Regards,

> Ravi C

>

>

> On Wed, Aug 10, 2016 at 7:25 PM, Damian Minkov <damencho@jitsi.org> >> > wrote:

>>

>> Hi,

>>

>> you definitely had problems registering the components to prosody,

>> check your secret in prosody config and in jicofo and jvb config, did

>> they match?

>> Also to enable rest you need in /etc/jitsi/videobridge/config

>> JVB_OPTS="--apis=xmpp,rest"

>>

>> Regards

>> damencho

>>

>>

>> On Wed, Aug 10, 2016 at 7:18 AM, Ravi Chaudhary >> >> <rc.chaudhary@gmail.com> >> >> wrote:

>> > Correction:

>> >

>> > But even after that, we aren't able to gather any stats on

>> > http://<IP>:8080/colibri/stats.

>> >

>> > Few interesting error logs:

>> >

>> >

>> > 1. /var/log/jitsi/jicofo.log

>> >

>> >

>> >

>> > Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]

>> > org.jitsi.meet.ComponentMain.call().278 not-authorized,

>> > host:localhost,

>> > port:5347

>> >

>> >

>> >

>> > 2. /var/log/jitsi/jvb.log

>> >

>> >

>> >

>> > JVB 2016-08-10 11:51:02.302 SEVERE: [17]

>> > org.jitsi.meet.ComponentMain.call().278 not-authorized,

>> > host:localhost,

>> > port:5347

>> >

>> >

>> >

>> > 3. /var/log/prosody/prosody.log

>> >

>> >

>> >

>> > Aug 10 11:52:50 c2s30a8fb0 info Client connected

>> >

>> > Aug 10 11:52:50 sasl warn Client is violating RFC 3920 (section

>> > 6.1,

>> > point 7).

>> >

>> > Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component

>> > connection

>> >

>> > Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component

>> > connection

>> >

>> > Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component info

>> > Component authentication failed for jitsi-videobridge.10.20.130.50

>> >

>> > Aug 10 11:52:52 mod_component info Disconnecting component,

>> > <stream:error> is: <stream:error><not-authorized

>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text

>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not

>> > match

>> > calculated token</text></stream:error>

>> >

>> > Aug 10 11:52:52 jcp4ac19d0 info component disconnected:

>> > jitsi-videobridge.10.20.130.50 (false)

>> >

>> > Aug 10 11:52:52 focus.10.20.130.50:component info Component

>> > authentication failed for focus.10.20.130.50

>> >

>> > Aug 10 11:52:52 mod_component info Disconnecting component,

>> > <stream:error> is: <stream:error><not-authorized

>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text

>> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not

>> > match

>> > calculated token</text></stream:error>

>> >

>> > Aug 10 11:52:52 jcp40b6b90 info component disconnected:

>> > focus.10.20.130.50 (false)

>> >

>> >

>> >

>> >

>> > On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary >> >> > <rc.chaudhary@gmail.com> >> >> > wrote:

>> >>

>> >> Greetings,

>> >>

>> >> Inorder to capture statistics using the REST, we have configured

>> >> "sip-communicator.properties" on Jitsi Videobridge and rebooted:

>> >>

>> >> root@ubuntu16:~/.sip-communicator# cat sip-communicator.properties

>> >>

>> >>

>> >>

>> >> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=falseRestart

>> >>

>> >> org.jitsi.videobridge.rest.jetty.port=8080

>> >>

>> >> org.jitsi.videobridge.ENABLE_STATISTICS=True

>> >>

>> >> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri

>> >>

>> >> org.jitsi.videobridge.STATISTICS_INTERVAL=1000

>> >>

>> >> But even after that, we are able to gather any stats on

>> >> http://<IP>:8080/colibri/stats.

>> >>

>> >> Could you please let us know, if we are missing any other

>> >> configuration.

>> >>

>> >> Thanks in advance.

>> >>

>> >> Regards,

>> >> Ravi C

>> >

>> >

>> >

>> > _______________________________________________

>> > users mailing list

>> > users@jitsi.org

>> > Unsubscribe instructions and other list options:

>> > http://lists.jitsi.org/mailman/listinfo/users

>>

>> _______________________________________________

>> users mailing list

>> users@jitsi.org

>> Unsubscribe instructions and other list options:

>> http://lists.jitsi.org/mailman/listinfo/users

>

>

>

> _______________________________________________

> users mailing list

> users@jitsi.org

> Unsubscribe instructions and other list options:

> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________

users mailing list

users@jitsi.org

Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

HI,

I have the similar problem but I don't see the port 8080 opened as
for rest.jetty.port, it is not started
and rest.jetty.tls.port is listening on ipv6 along with tcp_harvester.

Not sure what is wrong there

···

On Thu, Aug 11, 2016 at 11:13 AM, shyam yeduru <yedurushyam@hotmail.com> wrote:

Greetings Damencho and Ravi,

We have made changes in /etc/jitsi/videobridge/sip-communicator.properties

org.jitsi.videobridge.ENABLE_STATISTICS=True
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.STATISTICS_INTERVAL=1000
org.jitsi.videobridge.PUBSUB_SERVICE=PubSub service
org.jitsi.videobridge.PUBSUB_NODE=PubSub node

# service jits-videobridge restart; service jicofo restart

Log details from /var/log/prosody/prosody.log
Aug 11 14:24:36 jcp1d60c90 info component disconnected:
jitsi-videobridge.192.168.37.10 (closed)
Aug 11 14:24:46 jitsi-videobridge.192.168.37.10:component warn
Component not connected, bouncing error for: <iq id='OiCrT-307' type='get'
to='jitsi-videobridge.192.168.37.10' from='focus@auth.192.168.37.10
/focus79574579721707'>
Aug 11 14:25:15 jcp1dacca0 info Incoming Jabber component
connection
Aug 11 14:25:15 jitsi-videobridge.192.168.37.10:component info
External component successfully authenticated
Aug 11 14:27:00 jcp1c30010 info component disconnected:
focus.192.168.37.10 (false)
Aug 11 14:27:01 c2s1ec5db0 info Client disconnected: closed
Aug 11 14:27:15 c2s1e05d70 info Client connected
Aug 11 14:27:20 jcp1cd41c0 info Incoming Jabber component
connection
Aug 11 14:27:20 focus.192.168.37.10:component info External
component successfully authenticated
Aug 11 14:27:28 sasl warn Client is violating RFC 3920 (section
6.1, point 7).
Aug 11 14:27:28 c2s1e05d70 info Authenticated as
focus@auth.192.168.37.10

/var/log/jitsi/jicofo.log

Jicofo 2016-08-11 14:40:17.238 INFO: [10] impl.netaddr.
NetworkAddressManagerServiceImpl.start().92 Network Address Manager
  ...[ STARTED ]
Jicofo 2016-08-11 14:40:17.242 INFO: [10] impl.netaddr.
NetworkAddressManagerServiceImpl.start().98 Network Address Manager
Service ...[REGISTERED]
Jicofo 2016-08-11 14:40:17.336 INFO: [10] org.jitsi.version.
AbstractVersionActivator.start().119 JiCoFo Version: JiCoFo 1.0.1.0-268
Jicofo 2016-08-11 14:40:21.399 INFO: [10] org.jitsi.jicofo.
JitsiMeetGlobalConfig.init().140 Jibri requests in PENDING state will be
timed out after: 90 seconds
Jicofo 2016-08-11 14:40:21.784 INFO: [10] org.jitsi.jicofo.BridgeSelector.init().539
Bridge failure reset threshold: 300000
Jicofo 2016-08-11 14:40:25.297 INFO: [10] org.eclipse.jetty.server.Server.doStart()
jetty-8.1.16.v20140903
Jicofo 2016-08-11 14:40:26.705 INFO: [10] org.eclipse.jetty.server.AbstractConnector.doStart()
Started SelectChannelConnector@0.0.0.0:8888
Jicofo 2016-08-11 14:40:27.124 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().176
Component org.jitsi.jicofo. config:
Jicofo 2016-08-11 14:40:27.146 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().177
  ping interval: 10000 ms
Jicofo 2016-08-11 14:40:27.149 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().178
  ping timeout: 5000 ms
Jicofo 2016-08-11 14:40:27.152 INFO: [1] org.jitsi.xmpp.component.ComponentBase.loadConfig().179
  ping threshold: 3
Jicofo 2016-08-11 14:40:35.929 INFO: [15] org.jitsi.jicofo.
ComponentsDiscovery.discoverServices().267 New component discovered:
auth.192.168.37.10, Version[Prosody(0.9.1,Linux)@-1121594909
Jicofo 2016-08-11 14:40:35.934 INFO: [15] org.jitsi.jicofo.
JitsiMeetServices.newNodeDiscovered().244 Detected XMPP server version:
Version[Prosody(0.9.1,Linux)@-1121594909
Jicofo 2016-08-11 14:40:35.968 INFO: [15] org.jitsi.jicofo.
ComponentsDiscovery.discoverServices().267 New component discovered:
conference.192.168.37.10, null
Jicofo 2016-08-11 14:40:35.971 INFO: [15] org.jitsi.jicofo.
JitsiMeetServices.newNodeDiscovered().236 MUC component discovered:
conference.192.168.37.10
Jicofo 2016-08-11 14:40:36.156 INFO: [15] org.jitsi.jicofo.
ComponentsDiscovery.discoverServices().267 New component discovered:
focus.192.168.37.10, null
Jicofo 2016-08-11 14:40:36.293 INFO: [15] org.jitsi.jicofo.
ComponentsDiscovery.discoverServices().267 New component discovered:
jitsi-videobridge.192.168.37.10, Version[JVB(0.1.752,Linux)@-346597982
Jicofo 2016-08-11 14:40:36.297 INFO: [15] org.jitsi.jicofo.
BridgeSelector.addJvbAddress().148 Added videobridge:
jitsi-videobridge.192.168.37.10 v: Version[JVB(0.1.752,Linux)@-346597982
Jicofo 2016-08-11 14:40:36.302 WARNING: [15] org.jitsi.jicofo.
BridgeSelector.addJvbAddress().160 No pub-sub node mapped for
jitsi-videobridge.192.168.37.10
Jicofo 2016-08-11 14:40:36.333 INFO: [15] org.jitsi.jicofo.
ComponentsDiscovery.scheduleRediscovery().190 Services re-discovery
interval: 30000
Jicofo 2016-08-11 14:40:36.349 INFO: [15] org.jitsi.jicofo.FocusManager.registrationStateChanged().531
XMPP provider reg state: RegistrationState=Registered
Jicofo 2016-08-11 14:40:36.370 INFO: [15] org.jitsi.impl.protocol.xmpp.
XmppProtocolProvider.info() XMPP provider Jabber:focus@auth.192.168.37.
10/focus81163091971349@localhost connected (JID: focus@auth.192.168.37.10/
focus81163091971349)
Jicofo 2016-08-11 14:40:36.399 INFO: [40] org.jitsi.jicofo.JvbDoctor.info()
Scheduled health-check task for: jitsi-videobridge.192.168.37.10

netstat -tunpl

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
      PID/Program name
tcp 0 0 0.0.0.0:80 0.0.0.0:*
LISTEN 1214/nginx
tcp 0 0 0.0.0.0:5269 0.0.0.0:*
LISTEN 1241/lua5.1
tcp 0 0 0.0.0.0:22 0.0.0.0:*
LISTEN 1100/sshd
tcp 0 0 0.0.0.0:443 0.0.0.0:*
LISTEN 1214/nginx
tcp 0 0 0.0.0.0:5280 0.0.0.0:*
LISTEN 1241/lua5.1
tcp 0 0 127.0.0.1:5347 0.0.0.0:*
LISTEN 1241/lua5.1
tcp 0 0 0.0.0.0:5222 0.0.0.0:*
LISTEN 1241/lua5.1
tcp6 0 0 :::8080 :::* LISTEN
     30973/java
tcp6 0 0 :::80 :::* LISTEN
     1214/nginx
tcp6 0 0 :::5269 :::* LISTEN
     1241/lua5.1
tcp6 0 0 :::8888 :::* LISTEN
     2066/java
tcp6 0 0 192.168.111.9:4443 :::*
LISTEN 30973/java
tcp6 0 0 :::5280 :::* LISTEN
     1241/lua5.1
tcp6 0 0 ::1:5347 :::* LISTEN
     1241/lua5.1
tcp6 0 0 :::5222 :::* LISTEN
     1241/lua5.1
udp 0 0 0.0.0.0:16366 0.0.0.0:*
      670/dhclient
udp 0 0 0.0.0.0:68 0.0.0.0:*
      670/dhclient
udp6 0 0 192.168.111.9:10000 :::*
       30973/java
udp6 0 0 :::42980 :::*
     2066/java
udp6 0 0 192.168.111.9:10761 :::*
       30973/java
udp6 0 0 192.168.111.9:10762 :::*
       30973/java
udp6 0 0 192.168.111.9:10763 :::*
       30973/java
udp6 0 0 192.168.111.9:10764 :::*
       30973/java
udp6 0 0 192.168.111.9:10765 :::*
       -
udp6 0 0 192.168.111.9:10766 :::*
       -
udp6 0 0 :::31234 :::*
     670/dhclient
udp6 0 0 :::16767 :::*
     30973/java

The issue is port 8080 is listening on IPV6 and we have not configured
IPV6 on our Server. Can you please advise on this.

Apologies Ravi, if have made your conversation messy. Pls let me know, in
that case, We will have a new thread opened for this.

Thanking in advance toyou both..

cheers
SY

------------------------------
From: rc.chaudhary@gmail.com
Date: Thu, 11 Aug 2016 01:55:38 +0530
To: users@jitsi.org
Subject: Re: [jitsi-users] Enabling REST API on Jitsi Videobridge

Greetings Damencho,

Thanks a ton.

Yes, i hadn't registered the 'focus' user in prosody.

*Could you perhaps site an example inorder to collect the statistics on
Jitsi Videobridge. Do we need to enable port 8080 for Colibri, in some
other config as well?*
There isn't any firewall blocking port 8080.

*ubuntu@ubuntu16:~$ telnet 10.20.130.50 8080Trying
10.20.130.50...Connected to 10.20.130.50.Escape character is '^]'.*

Regards,
Ravi C

On Thu, Aug 11, 2016 at 1:04 AM, Damian Minkov <damencho@jitsi.org> wrote:

Maybe its a firewall issue connecting to 8080.
Jicofo is using to xmpp connections, one is registering as a component
and the second one is as a user. Maybe your secret for the user
account is wrong this is JICOFO_AUTH_PASSWORD? Check whether the user
focus is available in prosody.
The user is created with the following command: prosodyctl register
$JICOFO_AUTH_USER $JICOFO_AUTH_DOMAIN $JICOFO_AUTH_PASSWORD
https://github.com/jitsi/jitsi-meet/blob/master/debian/jitsi
-meet-prosody.postinst#L94

On Wed, Aug 10, 2016 at 1:58 PM, Ravi Chaudhary <rc.chaudhary@gmail.com> > wrote:
> Greetings Damencho,
>
> Thanks again for the pointers.
>
> Update the respective values in < /etc/jitsi/videobridge/config > &
> </etc/prosody/conf.d/10.20.130.50.cfg.lua>
>
> O/P of netstat -anp | grep 8080
> tcp6 0 0 :::8080 :::*
LISTEN
> 6297/java
>
> We are still unable to view any statistics on <
> http://10.20.130.50:8080/colibri/stats >
>
> O/P of /root/.sip-communicator/sip-communicator.properties
>
> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.
checkReplay=falseRestart
>
> org.jitsi.videobridge.rest.jetty.port=8080
>
> org.jitsi.videobridge.ENABLE_STATISTICS=True
>
> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>
> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>
>
> O/P of /var/log/jitsi/jicofo.log:
>
> Jicofo 2016-08-10 18:47:50.517 SEVERE: [16]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to
connect:
> SASL authentication DIGEST-MD5 failed: text
> SASL authentication DIGEST-MD5 failed: text:
> at
> org.jivesoftware.smack.SASLAuthentication.authenticate(SASLA
uthentication.java:341)
> at
> org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(
XmppProtocolProvider.java:223)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000
(XmppProtocolProvider.java:46)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(Xmp
pProtocolProvider.java:191)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(Xmp
pProtocolProvider.java:186)
> at
> org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
> at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFu
tureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFu
tureTask.run(ScheduledThreadPoolExecutor.java:293)
> at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPool
Executor.java:1142)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoo
lExecutor.java:617)
> at java.lang.Thread.run(Thread.java:745)
> Jicofo 2016-08-10 18:47:50.526 SEVERE: [1961]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.write(BufferedWriter.java:221)
> at java.io.Writer.write(Writer.java:157)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:210)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:
80)
> Jicofo 2016-08-10 18:47:50.527 SEVERE: [1973]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:
80)
> Jicofo 2016-08-10 18:47:50.527 SEVERE: [1981]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:
80)
> Jicofo 2016-08-10 18:47:50.528 SEVERE: [1985]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:
80)
> Jicofo 2016-08-10 18:47:50.529 SEVERE: [1969]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:
80)
> Jicofo 2016-08-10 18:47:50.531 SEVERE: [1965]
> org.jivesoftware.smack.PacketWriter.writePackets() Error writing packet
> java.io.IOException: Stream closed
> at java.io.BufferedWriter.ensureOpen(BufferedWriter.java:116)
> at java.io.BufferedWriter.flushBuffer(BufferedWriter.java:126)
> at java.io.BufferedWriter.flush(BufferedWriter.java:253)
> at
> org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:212)
> at
> org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:42)
> at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:
80)
> Jicofo 2016-08-10 18:47:50.676 SEVERE: [1986]
> org.jivesoftware.smack.PacketReader.notifyConnectionError() Closes the
> connection temporary
> java.io.EOFException: no more data available - expected end tag
> </stream:stream> to close start tag <stream:stream> from line 1, parser
> stopped on END_TAG seen
> ...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...
> @1:613
> at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:3035)
> at org.xmlpull.mxp1.MXParser.more(MXParser.java:3046)
> at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1144)
> at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)
> at
> org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:329)
> at
> org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:45)
> at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:
74)
> Jicofo 2016-08-10 18:47:50.677 SEVERE: [1986]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() XMPP
connection
> closed on error: no more data available - expected end tag
</stream:stream>
> to close start tag <stream:stream> from line 1, parser stopped on END_TAG
> seen
> ...A9ImF1dGgiLGNoYXJzZXQ9dXRmLTgsYWxnb3JpdGhtPW1kNS1zZXNz</challenge>...
> @1:613
> Jicofo 2016-08-10 18:47:50.677 INFO: [1986]
> org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP
provider
> reg state: RegistrationState=Unregistered
> Jicofo 2016-08-10 18:47:51.677 INFO: [1989]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnecting
> in: 8
> Jicofo 2016-08-10 18:47:52.677 INFO: [1989]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnecting
> in: 7
> Jicofo 2016-08-10 18:47:53.677 INFO: [1989]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnecting
> in: 6
> Jicofo 2016-08-10 18:47:54.677 INFO: [1989]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnecting
> in: 5
> Jicofo 2016-08-10 18:47:55.576 INFO: [16]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP
reconnection
> successful
> Jicofo 2016-08-10 18:47:55.576 SEVERE: [16]
> org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged().142
null
> java.lang.NullPointerException
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.discoverIt
ems(XmppProtocolProvider.java:488)
> at
> org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.getItems(Op
SetSimpleCapsImpl.java:53)
> at
> org.jitsi.jicofo.ComponentsDiscovery.discoverServices(Compon
entsDiscovery.java:238)
> at
> org.jitsi.jicofo.ComponentsDiscovery.firstTimeDiscovery(Comp
onentsDiscovery.java:308)
> at
> org.jitsi.jicofo.ComponentsDiscovery.registrationStateChange
d(ComponentsDiscovery.java:343)
> at
> org.jitsi.jicofo.ProtocolProviderHandler.registrationStateCh
anged(ProtocolProviderHandler.java:138)
> at
> net.java.sip.communicator.service.protocol.AbstractProtocolP
roviderService.fireRegistrationStateChanged(AbstractProtocol
ProviderService.java:187)
> at
> net.java.sip.communicator.service.protocol.AbstractProtocolP
roviderService.fireRegistrationStateChanged(AbstractProtocol
ProviderService.java:141)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.notifyConn
ected(XmppProtocolProvider.java:255)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$300
(XmppProtocolProvider.java:46)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$XmppConnec
tionListener.reconnectionSuccessful(XmppProtocolProvider.java:569)
> at
> org.jivesoftware.smack.PacketReader.notifyReconnection(Packe
tReader.java:193)
> at
> org.jivesoftware.smack.XMPPConnection.initConnection(XMPPCon
nection.java:589)
> at
> org.jivesoftware.smack.XMPPConnection.connectUsingConfigurat
ion(XMPPConnection.java:532)
> at
> org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:968)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(
XmppProtocolProvider.java:210)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000
(XmppProtocolProvider.java:46)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(Xmp
pProtocolProvider.java:191)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(Xmp
pProtocolProvider.java:186)
> at
> org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
> at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFu
tureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFu
tureTask.run(ScheduledThreadPoolExecutor.java:293)
> at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPool
Executor.java:1142)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoo
lExecutor.java:617)
> at java.lang.Thread.run(Thread.java:745)
> Jicofo 2016-08-10 18:47:55.577 INFO: [16]
> org.jitsi.jicofo.FocusManager.registrationStateChanged().531 XMPP
provider
> reg state: RegistrationState=Registered
> Jicofo 2016-08-10 18:47:55.582 SEVERE: [16]
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.error() Failed to
connect:
> SASL authentication DIGEST-MD5 failed: text
> SASL authentication DIGEST-MD5 failed: text:
> at
> org.jivesoftware.smack.SASLAuthentication.authenticate(SASLA
uthentication.java:341)
> at
> org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:208)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(
XmppProtocolProvider.java:223)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000
(XmppProtocolProvider.java:46)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(Xmp
pProtocolProvider.java:191)
> at
> org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(Xmp
pProtocolProvider.java:186)
> at
> org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
> at
> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFu
tureTask.access$201(ScheduledThreadPoolExecutor.java:180)
> at
> java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFu
tureTask.run(ScheduledThreadPoolExecutor.java:293)
> at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPool
Executor.java:1142)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoo
lExecutor.java:617)
> at java.lang.Thread.run(Thread.java:745)
>
> Awaiting on your inputs to gather the statistics
>
> Regards,
> Ravi C
>
>
> On Wed, Aug 10, 2016 at 8:52 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>
>> On Wed, Aug 10, 2016 at 10:15 AM, Ravi Chaudhary < > rc.chaudhary@gmail.com> > >> wrote:
>> > Greetings Damencho,
>> > Thanks for the pointer. Here is the config of jicofo, videobridge &
>> > prosody
>> > files.
>> >
>> > /etc/jitsi/jicofo/config
>> > # sets the secret used to authenticate as an XMPP component
>> > JICOFO_SECRET=6h85vKcQ
>> >
>> > # sets the port to use for the XMPP component connection
>> > JICOFO_PORT=5347
>> >
>> > /etc/jitsi/videobridge/config
>> > # sets the port of the XMPP server (default: 5275)
>> > JVB_PORT=5347
>> >
>> > # sets the shared secret used to authenticate to the XMPP server
>> > JVB_SECRET=217TkZFo
>> >
>> > # extra options to pass to the JVB daemon
>> > JVB_OPTS="--apis=rest"
>>
>> in order jicofo to work you need JVB_OPTS="--apis=xmpp,rest"
>>
>> >
>> >
>> > cat /etc/prosody/conf.d/10.20.130.50.cfg.lua
>> > VirtualHost "10.20.130.50"
>> > authentication = "anonymous"
>> > ssl = {
>> > key = "/var/lib/prosody/10.20.130.50.key";
>> > certificate = "/var/lib/prosody/10.20.130.50.crt";
>> > }
>> > modules_enabled = {
>> > "bosh";
>> > "pubsub";
>> > }
>> >
>> > VirtualHost "auth.10.20.130.50"
>> > authentication = "internal_plain"
>> >
>> > Component "conference.10.20.130.50" "muc"
>> > Component "jitsi-videobridge.10.20.130.50"
>> > component_secret = "YOURSECRET1"
>> > Component "focus.10.20.130.50"
>> > component_secret = "YOURSECRET2"
>> >
>> > 1) Do we need to update the 'prosody' file with the respective SECRET
of
>> > Videobridge & Jicofo?
>>
>> YOURSECRET1 should be 217TkZFo and YOURSECRET2 should be 6h85vKcQ.
>>
>> >
>> > 2) Also how can i verify, if the Colibri stats are being accessible on
>> > port
>> > 8080?
>> >
>> > FYI: O/P of cat /root/.sip-communicator/sip-communicator.properties
>> >
>> > org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.
checkReplay=falseRestart
>> >
>> > org.jitsi.videobridge.rest.jetty.port=8080
>> >
>> > org.jitsi.videobridge.ENABLE_STATISTICS=True
>> >
>> > org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>> >
>> > org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>> >
>> > Regards,
>> > Ravi C
>> >
>> >
>> > On Wed, Aug 10, 2016 at 7:25 PM, Damian Minkov <damencho@jitsi.org> > >> > wrote:
>> >>
>> >> Hi,
>> >>
>> >> you definitely had problems registering the components to prosody,
>> >> check your secret in prosody config and in jicofo and jvb config, did
>> >> they match?
>> >> Also to enable rest you need in /etc/jitsi/videobridge/config
>> >> JVB_OPTS="--apis=xmpp,rest"
>> >>
>> >> Regards
>> >> damencho
>> >>
>> >>
>> >> On Wed, Aug 10, 2016 at 7:18 AM, Ravi Chaudhary > >> >> <rc.chaudhary@gmail.com> > >> >> wrote:
>> >> > Correction:
>> >> >
>> >> > But even after that, we aren't able to gather any stats on
>> >> > http://<IP>:8080/colibri/stats.
>> >> >
>> >> > Few interesting error logs:
>> >> >
>> >> >
>> >> > 1. /var/log/jitsi/jicofo.log
>> >> >
>> >> >
>> >> >
>> >> > Jicofo 2016-08-10 11:48:42.175 SEVERE: [31]
>> >> > org.jitsi.meet.ComponentMain.call().278 not-authorized,
>> >> > host:localhost,
>> >> > port:5347
>> >> >
>> >> >
>> >> >
>> >> > 2. /var/log/jitsi/jvb.log
>> >> >
>> >> >
>> >> >
>> >> > JVB 2016-08-10 11:51:02.302 SEVERE: [17]
>> >> > org.jitsi.meet.ComponentMain.call().278 not-authorized,
>> >> > host:localhost,
>> >> > port:5347
>> >> >
>> >> >
>> >> >
>> >> > 3. /var/log/prosody/prosody.log
>> >> >
>> >> >
>> >> >
>> >> > Aug 10 11:52:50 c2s30a8fb0 info Client connected
>> >> >
>> >> > Aug 10 11:52:50 sasl warn Client is violating RFC 3920
(section
>> >> > 6.1,
>> >> > point 7).
>> >> >
>> >> > Aug 10 11:52:52 jcp4ac19d0 info Incoming Jabber component
>> >> > connection
>> >> >
>> >> > Aug 10 11:52:52 jcp40b6b90 info Incoming Jabber component
>> >> > connection
>> >> >
>> >> > Aug 10 11:52:52 jitsi-videobridge.10.20.130.50:component
info
>> >> > Component authentication failed for jitsi-videobridge.10.20.130.50
>> >> >
>> >> > Aug 10 11:52:52 mod_component info Disconnecting component,
>> >> > <stream:error> is: <stream:error><not-authorized
>> >> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> >> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not
>> >> > match
>> >> > calculated token</text></stream:error>
>> >> >
>> >> > Aug 10 11:52:52 jcp4ac19d0 info component disconnected:
>> >> > jitsi-videobridge.10.20.130.50 (false)
>> >> >
>> >> > Aug 10 11:52:52 focus.10.20.130.50:component info Component
>> >> > authentication failed for focus.10.20.130.50
>> >> >
>> >> > Aug 10 11:52:52 mod_component info Disconnecting component,
>> >> > <stream:error> is: <stream:error><not-authorized
>> >> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'/><text
>> >> > xmlns='urn:ietf:params:xml:ns:xmpp-streams'>Given token does not
>> >> > match
>> >> > calculated token</text></stream:error>
>> >> >
>> >> > Aug 10 11:52:52 jcp40b6b90 info component disconnected:
>> >> > focus.10.20.130.50 (false)
>> >> >
>> >> >
>> >> >
>> >> >
>> >> > On Wed, Aug 10, 2016 at 5:09 PM, Ravi Chaudhary > >> >> > <rc.chaudhary@gmail.com> > >> >> > wrote:
>> >> >>
>> >> >> Greetings,
>> >> >>
>> >> >> Inorder to capture statistics using the REST, we have configured
>> >> >> "sip-communicator.properties" on Jitsi Videobridge and rebooted:
>> >> >>
>> >> >> root@ubuntu16:~/.sip-communicator# cat
sip-communicator.properties
>> >> >>
>> >> >>
>> >> >>
>> >> >> org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.
checkReplay=falseRestart
>> >> >>
>> >> >> org.jitsi.videobridge.rest.jetty.port=8080
>> >> >>
>> >> >> org.jitsi.videobridge.ENABLE_STATISTICS=True
>> >> >>
>> >> >> org.jitsi.videobridge.STATISTICS_TRANSPORT=colibri
>> >> >>
>> >> >> org.jitsi.videobridge.STATISTICS_INTERVAL=1000
>> >> >>
>> >> >> But even after that, we are able to gather any stats on
>> >> >> http://<IP>:8080/colibri/stats.
>> >> >>
>> >> >> Could you please let us know, if we are missing any other
>> >> >> configuration.
>> >> >>
>> >> >> Thanks in advance.
>> >> >>
>> >> >> Regards,
>> >> >> Ravi C
>> >> >
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > users mailing list
>> >> > users@jitsi.org
>> >> > Unsubscribe instructions and other list options:
>> >> > http://lists.jitsi.org/mailman/listinfo/users
>> >>
>> >> _______________________________________________
>> >> users mailing list
>> >> users@jitsi.org
>> >> Unsubscribe instructions and other list options:
>> >> http://lists.jitsi.org/mailman/listinfo/users
>> >
>> >
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________ users mailing list
users@jitsi.org Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Regards,
Mirko