[jitsi-users] Enable TCP


#1

Hi Mailing List,

I am a regular user of jitsi and like it a lot. I have also registered an
account at a local VoIP provider (ventengo.de) but run into problems: Jitsi
appears to be unable to keep me 'online' with this provider. According to
feedback from the provider jitsi uses UDP for the connection and they ask me
to switch to TCP.

Can someone help me doing that? I did not find any option in the settings
menu.

Apart from that I use jitsi with sip2sip.info without any problems.

Regards,
Sascha


#2

I am a regular user of jitsi and like it a lot. I have also registered an
account at a local VoIP provider (ventengo.de) but run into problems: Jitsi
appears to be unable to keep me 'online' with this provider. According to
feedback from the provider jitsi uses UDP for the connection and they ask me
to switch to TCP.

Jitsi tries to connect to SIP servers with TLS, TCP and UDP (in that order) based on your SIP login, e.g. user@ventengo.de. Ventengo should publish their servers with NAPTR and SRV records in DNS to support this auto configuration (not only for Jitsi).

Can someone help me doing that? I did not find any option in the
settings menu.

You can manually configure the server and connection type from Tools->Options->Accounts->(Your SIP Account)->Connection->Preferred Transport.

Apart from that I use jitsi with sip2sip.info without any problems.

sip2sip.info correctly publishes SRV records in the DNS.

Regards,
Sascha

Ingo


#3

Jitsi tries to connect to SIP servers with TLS, TCP and UDP (in that order)
based on your SIP login, e.g. user@ventengo.de. Ventengo should publish
their servers with NAPTR and SRV records in DNS to support this auto
configuration (not only for Jitsi).

Ah, ok. I will foward this information to ventengo (actually their sip server
is at sip.ventengo.de but still no NAPTR info there).

> Can someone help me doing that? I did not find any option in the
> settings menu.

You can manually configure the server and connection type from
Tools->Options->Accounts->(Your SIP Account)->Connection->Preferred
Transport.

Did that, but I had to enter a proxy address, too. Having none I used
sip.ventengo.de with TCP as transport and 5060 as the port number. Still
having the Tools->Options->Accounts view open I see that the online status of
the ventengo account keeps switching between online and offline.

I am using jitsi 2.5.5223

Regards,
Sascha

ยทยทยท

On Friday 09 May 2014 00:06:36 Ingo Bauersachs wrote:


#4

You can manually configure the server and connection type from
Tools->Options->Accounts->(Your SIP Account)->Connection->Preferred
Transport.

Did that, but I had to enter a proxy address, too. Having none I used
sip.ventengo.de with TCP as transport and 5060 as the port number. Still
having the Tools->Options->Accounts view open I see that the online status of
the ventengo account keeps switching between online and offline.

Please send us your complete logs (https://jitsi.org/logs). They contain some personal information like your SIP account (but not the password), if you don't want them on the list, either send them to support@bluejimp.com or to me directly.

I am using jitsi 2.5.5223

Regards,
Sascha

Ingo