[jitsi-users] Enable G.729 support


#1

I've been reading previous threads here about how to enable G.729 support
to Jitsi.

I was able to grab libjitsi and jitsi source code, enable G.729 in Java
file, compile, do "ant run" and then get G.729 in Jitsi successfully.

The problem: Each time I run jitsi this way (ant run) some errors appear at
startup, and the recently added accounts on Jitsi get lost after closing
normally the application. Maybe I'm building this wrong? See error log at :
http://pastebin.com/1e9xNNN2

So I decided to install the latest nightly .deb package of Jitsi since I
don't know how to create a .deb from latest source code by myself with the
modified libjitsi.jar.

After installing Jitsi's nightly from source, I replaced
EncodingConfigurationImpl.class file into
/usr/share/jitsi/sc-bundles/libjitsi.jar

But, after doing that, G.729 doesn't appear yet in the list of Encodings
when running Jitsi, and if I replace the whole libjitsi.jar with the
modified one, Jitsi doesn't starts at all.

Any idea about how to address this problem to get G.729 enabled on a
nightly .deb build or by rebuilding the .deb from source?

Thanks.

Jonathan Vargas R.
Ingeniero en Soluciones Empresariales
Alkaid - Open Source Business Software
Web: http://alkaid.cr
Email: jvargas@alkaid.cr
Skype: jonathan.vargas.cr
Tel: +506 2553 5467