[jitsi-users] Echo


#1

I use Ubuntu 12.10 and it is hardly possible to make calls via Jitsi due
to echo. The other side of the calls uses Ubuntu 12.04. and has
got the same problem.

At Jitsi preferences, in the audio-section, there is no
echo-cancellation box or anything similar. I use the options PulseAudio
and internal audio.

I've already tried different codecs, without any difference.


#2

I too have found this problem using SIP. It seems that the microphone picks up whatever is coming out the speakers and gleefully passes it back to the sender, whom, if also running Jitsi and not using very sealed headphones, gleefully sends it back to me. :slight_smile: The fix would be some type of filter on input for what is currently coming out of output.

      Lee

···

On 01/24/2014 09:46 AM, sand@fantasymail.de wrote:

I use Ubuntu 12.10 and it is hardly possible to make calls via Jitsi due
to echo. The other side of the calls uses Ubuntu 12.04. and has
got the same problem.

At Jitsi preferences, in the audio-section, there is no
echo-cancellation box or anything similar. I use the options PulseAudio
and internal audio.


#3

Hi Sand,
have a look at: https://jitsi.org/Documentation/ReportingBugs
Please supply information on which versions of Jitsi you used as well as
logs.

I did experiment a little with another user and had no error
cancellation when we used silk but error cancellation worked when we
used opus.

Regards,
Philipp

···

On Fri, 24 Jan 2014 15:46:42 +0000 sand@fantasymail.de wrote:

I use Ubuntu 12.10 and it is hardly possible to make calls via Jitsi
due to echo. The other side of the calls uses Ubuntu 12.04. and has
got the same problem.

At Jitsi preferences, in the audio-section, there is no
echo-cancellation box or anything similar. I use the options
PulseAudio and internal audio.

I've already tried different codecs, without any difference.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
JID: murks@jit.si


#4

Wasapi does that for us on windows. Chenzo recently added webrtc AEC for OS
X. We still don't have anything for linux though. WebRTC's AEC sounds like
a good bet there too.

--sent from my mobile

···

On 25 Jan 2014 12:20 AM, "Lee Sharp" <leesharp@hal-pc.org> wrote:

On 01/24/2014 09:46 AM, sand@fantasymail.de wrote:

I use Ubuntu 12.10 and it is hardly possible to make calls via Jitsi due
to echo. The other side of the calls uses Ubuntu 12.04. and has
got the same problem.

At Jitsi preferences, in the audio-section, there is no
echo-cancellation box or anything similar. I use the options PulseAudio
and internal audio.

I too have found this problem using SIP. It seems that the microphone
picks up whatever is coming out the speakers and gleefully passes it back
to the sender, whom, if also running Jitsi and not using very sealed
headphones, gleefully sends it back to me. :slight_smile: The fix would be some type
of filter on input for what is currently coming out of output.

                        Lee

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

I use Jitsi 2.4.4997

Is there any private information in the log-files? If so, how can I
quickly anonymize the logs?

I got an advise in a ubuntu-forum and installed this package on ubuntu:
"libwebrtc-audio-processing-0". After that I entered in terminal "pactl
load-module module-echo-cancel". The output in terminal was "24". As a
result there was an echo cancellation option in Jitsi, which I used for
the last call, but it unfortunately did not effect the echo.

Philipp �berbacher:

···

On Fri, 24 Jan 2014 15:46:42 +0000 > sand@fantasymail.de wrote:

I use Ubuntu 12.10 and it is hardly possible to make calls via Jitsi
due to echo. The other side of the calls uses Ubuntu 12.04. and has
got the same problem.

At Jitsi preferences, in the audio-section, there is no
echo-cancellation box or anything similar. I use the options
PulseAudio and internal audio.

I've already tried different codecs, without any difference.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

Hi Sand,
have a look at: https://jitsi.org/Documentation/ReportingBugs
Please supply information on which versions of Jitsi you used as well as
logs.

I did experiment a little with another user and had no error
cancellation when we used silk but error cancellation worked when we
used opus.

Regards,
Philipp


#6

Is it possible to point Jitsi at the stable Oracle jdk 1.7_45 that I never have problem with instead of open jdk 1.7.0 under Fedora 19 64bit?

figoli


#7

I also get that effect on the Mac version, and there is a very annoying audio delay. in other words, when i'm on a Jitsi call, I hear the words i just spoke about a second or so after I speak them. That makes it very difficult to carry on a conversation.

Diesel

···

On Jan 24, 2014, at 5:58 PM, Emil Ivov <emcho@jitsi.org> wrote:

Wasapi does that for us on windows. Chenzo recently added webrtc AEC for OS X. We still don't have anything for linux though. WebRTC's AEC sounds like a good bet there too.

--sent from my mobile

On 25 Jan 2014 12:20 AM, "Lee Sharp" <leesharp@hal-pc.org> wrote:
On 01/24/2014 09:46 AM, sand@fantasymail.de wrote:
I use Ubuntu 12.10 and it is hardly possible to make calls via Jitsi due
to echo. The other side of the calls uses Ubuntu 12.04. and has
got the same problem.

At Jitsi preferences, in the audio-section, there is no
echo-cancellation box or anything similar. I use the options PulseAudio
and internal audio.

I too have found this problem using SIP. It seems that the microphone picks up whatever is coming out the speakers and gleefully passes it back to the sender, whom, if also running Jitsi and not using very sealed headphones, gleefully sends it back to me. :slight_smile: The fix would be some type of filter on input for what is currently coming out of output.

                        Lee

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Make sure you select the "Core Audio" sound system and then check
"Enable echo cancellation"

Emil

···

On Sat, Jan 25, 2014 at 6:31 PM, David Brown <dbrown.45@att.net> wrote:

I also get that effect on the Mac version, and there is a very annoying
audio delay. in other words, when i'm on a Jitsi call, I hear the words i
just spoke about a second or so after I speak them. That makes it very
difficult to carry on a conversation.

Diesel

On Jan 24, 2014, at 5:58 PM, Emil Ivov <emcho@jitsi.org> wrote:

Wasapi does that for us on windows. Chenzo recently added webrtc AEC for OS
X. We still don't have anything for linux though. WebRTC's AEC sounds like a
good bet there too.

--sent from my mobile

On 25 Jan 2014 12:20 AM, "Lee Sharp" <leesharp@hal-pc.org> wrote:

On 01/24/2014 09:46 AM, sand@fantasymail.de wrote:

I use Ubuntu 12.10 and it is hardly possible to make calls via Jitsi due
to echo. The other side of the calls uses Ubuntu 12.04. and has
got the same problem.

At Jitsi preferences, in the audio-section, there is no
echo-cancellation box or anything similar. I use the options PulseAudio
and internal audio.

I too have found this problem using SIP. It seems that the microphone
picks up whatever is coming out the speakers and gleefully passes it back to
the sender, whom, if also running Jitsi and not using very sealed
headphones, gleefully sends it back to me. :slight_smile: The fix would be some type of
filter on input for what is currently coming out of output.

                        Lee

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#9

I can confirm echo on my Mac, CoreAudio+Echo cancellation already
improved significantly, echo not very disturbing for me but did not test
if both partners use Mac.
headset on both ends would probably be the best solution instead of
using external speakers.

MS with latest 5058nb on Mac
(using Core Audio with echo cancellation on Mac, partner with Ubuntu
12.04 with webcam-mic and external speakers

···

On 1/25/14 7:25 PM, Emil Ivov wrote:

Make sure you select the "Core Audio" sound system and then check
"Enable echo cancellation"

Emil

On Sat, Jan 25, 2014 at 6:31 PM, David Brown <dbrown.45@att.net> wrote:

I also get that effect on the Mac version, and there is a very annoying
audio delay. in other words, when i'm on a Jitsi call, I hear the words i
just spoke about a second or so after I speak them. That makes it very
difficult to carry on a conversation.

Diesel

On Jan 24, 2014, at 5:58 PM, Emil Ivov <emcho@jitsi.org> wrote:

Wasapi does that for us on windows. Chenzo recently added webrtc AEC for OS
X. We still don't have anything for linux though. WebRTC's AEC sounds like a
good bet there too.

--sent from my mobile

On 25 Jan 2014 12:20 AM, "Lee Sharp" <leesharp@hal-pc.org> wrote:

On 01/24/2014 09:46 AM, sand@fantasymail.de wrote:

I use Ubuntu 12.10 and it is hardly possible to make calls via Jitsi due
to echo. The other side of the calls uses Ubuntu 12.04. and has
got the same problem.

At Jitsi preferences, in the audio-section, there is no
echo-cancellation box or anything similar. I use the options PulseAudio
and internal audio.

I too have found this problem using SIP. It seems that the microphone
picks up whatever is coming out the speakers and gleefully passes it back to
the sender, whom, if also running Jitsi and not using very sealed
headphones, gleefully sends it back to me. :slight_smile: The fix would be some type of
filter on input for what is currently coming out of output.

                        Lee

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users