[jitsi-users] DNS look-up for local SIP server


#1

I’m trying to use Jitsi with a SIP server on our local network. I can refer to it by IP address, but not by its DNS host name.

Using Wireshark, it looks as though Jitsi is querying some other DNS server 8.8.4.4, rather than the one we’ve set up on our local network. It looks as though it’s related to the “Backup resolver” advanced settings.

It looks as though it's using the backup-resolver.jitsi.net immediately, and never using the local DNS (except to lookup the IP address of backup-resolver.jitsi.net itself).

If I uncheck option "Enable parallel DNS resolving", then it looks as though Jitsi doesn't do any DNS look-ups, and fails immediately.

How can I get Jitsi to correctly lookup our local SIP server host name on our local DNS server?

I'm using Jitsi 1.0-build.3967 on Windows XP SP3.

Regards,
Craig McQueen


#2

Hi,

windows by default do DNS caching. Try pinging the host by its name
whether that works better. If not, you may try commands "ipconfig
/flushdns" or "ipconfig /renew", or even rebooting the machine.

HTH

Tomas

···

On 30.4.2012 3:45, Craig McQueen wrote:

I’m trying to use Jitsi with a SIP server on our local network. I can
refer to it by IP address, but not by its DNS host name.

Using Wireshark, it looks as though Jitsi is querying some other DNS
server 8.8.4.4, rather than the one we’ve set up on our local
network. It looks as though it’s related to the “Backup resolver”
advanced settings.

It looks as though it's using the backup-resolver.jitsi.net
immediately, and never using the local DNS (except to lookup the IP
address of backup-resolver.jitsi.net itself).

If I uncheck option "Enable parallel DNS resolving", then it looks as
though Jitsi doesn't do any DNS look-ups, and fails immediately.

How can I get Jitsi to correctly lookup our local SIP server host
name on our local DNS server?

I'm using Jitsi 1.0-build.3967 on Windows XP SP3.

Regards, Craig McQueen


#3

Hey Craig,

I’m trying to use Jitsi with a SIP server on our local network. I can
refer to it by IP address, but not by its DNS host name.

Using Wireshark, it looks as though Jitsi is querying some other DNS
server 8.8.4.4, rather than the one we’ve set up on our local
network. It looks as though it’s related to the “Backup resolver”
advanced settings.

It is indeed. We generally do that when we get no response from the
primary DNS server. Have you checked whether your local DNS respondes to
NAPTR and SRV queries?

It looks as though it's using the backup-resolver.jitsi.net
immediately, and never using the local DNS (except to lookup the IP
address of backup-resolver.jitsi.net itself).

That's odd. Could you please send us pcap-s? You can mail them
support@bluejimp.com if you are worried about sending them publicly.

The Jitis logs would be also worth having a look at.

If I uncheck option "Enable parallel DNS resolving", then it looks as
though Jitsi doesn't do any DNS look-ups, and fails immediately.

How can I get Jitsi to correctly lookup our local SIP server host
name on our local DNS server?

Again, we always try to use the local server first. If we are using the
backup resolver then queries to the local DNS must have failed for one
reason or another.

Cheers,
Emil

···

On 30.04.12 04:45, Craig McQueen wrote:

I'm using Jitsi 1.0-build.3967 on Windows XP SP3.

Regards, Craig McQueen

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#4

Ping works fine.

Another SIP client (X-Lite) works fine. In Wireshark I can see it look up the DNS info for the host name, and SRV records such as _sip._udp (I added SRV records for the hostname to our DNS server).

So, it looks as though it's a problem with Jitsi. It is not using the right DNS server, and is going straight for 8.8.4.4.

Regards,
Craig McQueen

···

-----Original Message-----
From: Tomas Kopal [mailto:Tomas.Kopal@altap.cz]
Sent: Tuesday, 1 May 2012 5:20 AM
To: users@jitsi.java.net
Subject: [jitsi-users] Re: DNS look-up for local SIP server

Hi,

windows by default do DNS caching. Try pinging the host by its name
whether that works better. If not, you may try commands "ipconfig
/flushdns" or "ipconfig /renew", or even rebooting the machine.

HTH

Tomas

On 30.4.2012 3:45, Craig McQueen wrote:
> I’m trying to use Jitsi with a SIP server on our local network. I can
> refer to it by IP address, but not by its DNS host name.
>
> Using Wireshark, it looks as though Jitsi is querying some other DNS
> server 8.8.4.4, rather than the one we’ve set up on our local
network.
> It looks as though it’s related to the “Backup resolver”
> advanced settings.
>
> It looks as though it's using the backup-resolver.jitsi.net
> immediately, and never using the local DNS (except to lookup the IP
> address of backup-resolver.jitsi.net itself).
>
> If I uncheck option "Enable parallel DNS resolving", then it looks as
> though Jitsi doesn't do any DNS look-ups, and fails immediately.
>
> How can I get Jitsi to correctly lookup our local SIP server host
name
> on our local DNS server?
>
> I'm using Jitsi 1.0-build.3967 on Windows XP SP3.
>
> Regards, Craig McQueen
>


#5

From: Emil Ivov [mailto:emcho@jitsi.org]

Hey Craig,

> I’m trying to use Jitsi with a SIP server on our local network. I can
> refer to it by IP address, but not by its DNS host name.
>
> Using Wireshark, it looks as though Jitsi is querying some other DNS
> server 8.8.4.4, rather than the one we’ve set up on our local
network.
> It looks as though it’s related to the “Backup resolver”
> advanced settings.

It is indeed. We generally do that when we get no response from the
primary DNS server. Have you checked whether your local DNS respondes
to NAPTR and SRV queries?

The DNS server has SRV records, which I have confirmed with 'dig' on Linux. But it doesn't have NAPTR records--unfortunately it is Windows Server 2003, which doesn't support NAPTR.

Could it be that Jitsi is using the backup resolver because of the lack of NAPTR? It would be good if it could still work with SRV records only, which I think is RFC 2543 compliant.

> It looks as though it's using the backup-resolver.jitsi.net
> immediately, and never using the local DNS (except to lookup the IP
> address of backup-resolver.jitsi.net itself).

That's odd. Could you please send us pcap-s? You can mail them
support@bluejimp.com if you are worried about sending them publicly.

Sure, will do. I've got two files, one with Jitsi, another with X-Lite. Before each, I did 'ipconfig /flushdns'.

The Jitis logs would be also worth having a look at.

Attached. I've removed the pcap files, since they didn't contain any DNS stuff.

> I'm using Jitsi 1.0-build.3967 on Windows XP SP3.

Regards,
Craig McQueen

2012-05-04@10.23.57-logs.zip (28 KB)

···

On 30.04.12 04:45, Craig McQueen wrote: