[jitsi-users] Desktop 2.10 Voicemail Dial


#1

What's the trick to making 'Voicemail check URI' work?

We use '101' to dial voicemail. If I populate that field with 101, or
101@sipdomain the system is still calling userextension@sipdomain.

Thanks,
  Mike


#2

This looks like a bug...

It looks like that Jitsi is calling the "Voicemail Subscription URI". Jitsi
should call the "Voicemail check URI".

Is there a way to file this?

Thanks,
  Mike

Michael Picher, VP of Product Innovation
eZuce, Inc.

300 Brickstone Square

Suite 104

Andover, MA. 01810
O.978-296-1005 X2015
M.207-956-0262
@mpicher <http://twitter.com/mpicher>
linkedin <http://www.linkedin.com/profile/view?id=35504760&trk=tab_pro>
www.ezuce.com

Notice: This transmittal and/or attachments may be privileged or
confidential. It is intended solely for the addressee(s) named above. Any
dissemination, or copying is strictly prohibited. If you received this
transmittal in error, please notify us immediately by reply and immediately
delete this message and all its attachments. Thank you. FMS

···

On Thu, Feb 16, 2017 at 5:30 AM, Michael Picher <mpicher@ezuce.com> wrote:

What's the trick to making 'Voicemail check URI' work?

We use '101' to dial voicemail. If I populate that field with 101, or
101@sipdomain the system is still calling userextension@sipdomain.

Thanks,
  Mike


#3

What's the trick to making 'Voicemail check URI' work?

We use '101' to dial voicemail. If I populate that field with 101, or
101@sipdomain the system is still calling userextension@sipdomain.

The UI to edit these properties was broken when sometime in 2013/2014. This should be fixed in the next build.

The voicemail check URI however is only applied if your SIP server doesn't send the "Message-Account" attribute as defined in RFC3842. If it is sent by your server, the URI specified there is used.

Thanks,
  Mike

Ingo


#4

Great, thanks!

Michael Picher, VP of Product Innovation
eZuce, Inc.

300 Brickstone Square

Suite 104

Andover, MA. 01810
O.978-296-1005 X2015
M.207-956-0262
@mpicher <http://twitter.com/mpicher>
linkedin <http://www.linkedin.com/profile/view?id=35504760&trk=tab_pro>
www.ezuce.com

Notice: This transmittal and/or attachments may be privileged or
confidential. It is intended solely for the addressee(s) named above. Any
dissemination, or copying is strictly prohibited. If you received this
transmittal in error, please notify us immediately by reply and immediately
delete this message and all its attachments. Thank you. FMS

···

On Tue, Feb 28, 2017 at 2:25 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> What's the trick to making 'Voicemail check URI' work?
>
> We use '101' to dial voicemail. If I populate that field with 101, or
> 101@sipdomain the system is still calling userextension@sipdomain.

The UI to edit these properties was broken when sometime in 2013/2014.
This should be fixed in the next build.

The voicemail check URI however is only applied if your SIP server doesn't
send the "Message-Account" attribute as defined in RFC3842. If it is sent
by your server, the URI specified there is used.

> Thanks,
> Mike

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Thanks again Ingo. I think this logic is a bit backwards on deciding what
URI is used to dial back the voicemail.

I would think that if you want to force a particular number to dial you
would enter it and the application should honor it. Using the
'Message-Account' simply forces the client to dial that same extension.
RFC3842 doesn't really address 'how' voicemail is dialed, it just defines
the notifies.

Could you consider changing this behavior? I would think that if it were
changed there would be no impact. Most won't have enabled it. If they have
enabled it, it's likely that it's not working for them anyway.

Thanks,
  Mike

PM for sipXcom Project

Michael Picher, VP of Product Innovation
eZuce, Inc.

300 Brickstone Square

Suite 104

Andover, MA. 01810
O.978-296-1005 X2015
M.207-956-0262
@mpicher <http://twitter.com/mpicher>
linkedin <http://www.linkedin.com/profile/view?id=35504760&trk=tab_pro>
www.ezuce.com

Notice: This transmittal and/or attachments may be privileged or
confidential. It is intended solely for the addressee(s) named above. Any
dissemination, or copying is strictly prohibited. If you received this
transmittal in error, please notify us immediately by reply and immediately
delete this message and all its attachments. Thank you. FMS

···

On Tue, Feb 28, 2017 at 2:33 AM, Michael Picher <mpicher@ezuce.com> wrote:

Great, thanks!

Michael Picher, VP of Product Innovation
eZuce, Inc.

300 Brickstone Square

Suite 104

Andover, MA. 01810
O.978-296-1005 X2015 <(978)%20296-1005>
M.207-956-0262 <(207)%20956-0262>
@mpicher <http://twitter.com/mpicher>
linkedin <http://www.linkedin.com/profile/view?id=35504760&trk=tab_pro>
www.ezuce.com

Notice: This transmittal and/or attachments may be privileged or
confidential. It is intended solely for the addressee(s) named above. Any
dissemination, or copying is strictly prohibited. If you received this
transmittal in error, please notify us immediately by reply and immediately
delete this message and all its attachments. Thank you. FMS

On Tue, Feb 28, 2017 at 2:25 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> What's the trick to making 'Voicemail check URI' work?
>
> We use '101' to dial voicemail. If I populate that field with 101, or
> 101@sipdomain the system is still calling userextension@sipdomain.

The UI to edit these properties was broken when sometime in 2013/2014.
This should be fixed in the next build.

The voicemail check URI however is only applied if your SIP server
doesn't send the "Message-Account" attribute as defined in RFC3842. If it
is sent by your server, the URI specified there is used.

> Thanks,
> Mike

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Thanks again Ingo. I think this logic is a bit backwards on deciding what URI
is used to dial back the voicemail.

I would think that if you want to force a particular number to dial you would
enter it and the application should honor it. Using the 'Message-Account'
simply forces the client to dial that same extension. RFC3842 doesn't really
address 'how' voicemail is dialed, it just defines the notifies.

I only referenced the RFC to indicate which message account property I was talking about, not about any content.

Could you consider changing this behavior? I would think that if it were
changed there would be no impact. Most won't have enabled it. If they have
enabled it, it's likely that it's not working for them anyway.

I'm not sure why the implementation is how it is now. Asterisk (or FreePBX) for example don't send the Message-Account property and you can configure it in Jitsi. I assume the idea was to simply augment the received notifies if they were lacking information.

What's the point of delivering a Message-Account header that doesn't work? Can't you fix that on the server so the correct message account is sent?

If not I don't mind having a FORCE_CONFIGURED_MESSAGE or similar option.

Thanks,
  Mike
PM for sipXcom Project

Ingo


#7

The purpose of delivering a Message-Account header is for those accounts
that may subscribe to multiple accounts. Likewise, multiple SIP users may
subscribe to the same account. The Notifies then come back with message
counts for the particular mailboxes.

We utilize freeswitch for voicemail in sipXcom. So this is how it works
with FS.

An option to force the configured value would be great if that what you
think is needed for Jitsi (a check box for manual configuration would be
appreciated as well). It seems unnecessary to me because if you're adding a
configured value you would assume that you'd want to use it, but you know
your application and users best.

Thanks,
  Mike

Michael Picher, VP of Product Innovation
eZuce, Inc.

300 Brickstone Square

Suite 104

Andover, MA. 01810
O.978-296-1005 X2015
M.207-956-0262
@mpicher <http://twitter.com/mpicher>
linkedin <http://www.linkedin.com/profile/view?id=35504760&trk=tab_pro>
www.ezuce.com

Notice: This transmittal and/or attachments may be privileged or
confidential. It is intended solely for the addressee(s) named above. Any
dissemination, or copying is strictly prohibited. If you received this
transmittal in error, please notify us immediately by reply and immediately
delete this message and all its attachments. Thank you. FMS

···

On Sat, Mar 4, 2017 at 4:32 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> Thanks again Ingo. I think this logic is a bit backwards on deciding
what URI
> is used to dial back the voicemail.
>
> I would think that if you want to force a particular number to dial you
would
> enter it and the application should honor it. Using the 'Message-Account'
> simply forces the client to dial that same extension. RFC3842 doesn't
really
> address 'how' voicemail is dialed, it just defines the notifies.

I only referenced the RFC to indicate which message account property I was
talking about, not about any content.

> Could you consider changing this behavior? I would think that if it were
> changed there would be no impact. Most won't have enabled it. If they
have
> enabled it, it's likely that it's not working for them anyway.

I'm not sure why the implementation is how it is now. Asterisk (or
FreePBX) for example don't send the Message-Account property and you can
configure it in Jitsi. I assume the idea was to simply augment the received
notifies if they were lacking information.

What's the point of delivering a Message-Account header that doesn't work?
Can't you fix that on the server so the correct message account is sent?

If not I don't mind having a FORCE_CONFIGURED_MESSAGE or similar option.

> Thanks,
> Mike
> PM for sipXcom Project

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Hi,
It was long time since this was implemented, and haven't check the
code recently. But in asterisk there is an option, vmexten ( Dialplan
extension to reach mailbox. Default asterisk.), when you set it I
think it fills that Message-Account header and when you click to dial
in the UI you can reach your mailbox. Of course you need to configure
the extension you put in vmexten to reach the mailbox using the
dialplan.

Regards
damencho

···

On Sat, Mar 4, 2017 at 4:06 AM, Michael Picher <mpicher@ezuce.com> wrote:

The purpose of delivering a Message-Account header is for those accounts
that may subscribe to multiple accounts. Likewise, multiple SIP users may
subscribe to the same account. The Notifies then come back with message
counts for the particular mailboxes.

We utilize freeswitch for voicemail in sipXcom. So this is how it works with
FS.

An option to force the configured value would be great if that what you
think is needed for Jitsi (a check box for manual configuration would be
appreciated as well). It seems unnecessary to me because if you're adding a
configured value you would assume that you'd want to use it, but you know
your application and users best.

Thanks,
  Mike

Michael Picher, VP of Product Innovation
eZuce, Inc.

300 Brickstone Square

Suite 104

Andover, MA. 01810

O.978-296-1005 X2015
M.207-956-0262
@mpicher <http://twitter.com/mpicher>
linkedin
www.ezuce.com

Notice: This transmittal and/or attachments may be privileged or
confidential. It is intended solely for the addressee(s) named above. Any
dissemination, or copying is strictly prohibited. If you received this
transmittal in error, please notify us immediately by reply and immediately
delete this message and all its attachments. Thank you. FMS

On Sat, Mar 4, 2017 at 4:32 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:

> Thanks again Ingo. I think this logic is a bit backwards on deciding
> what URI
> is used to dial back the voicemail.
>
> I would think that if you want to force a particular number to dial you
> would
> enter it and the application should honor it. Using the
> 'Message-Account'
> simply forces the client to dial that same extension. RFC3842 doesn't
> really
> address 'how' voicemail is dialed, it just defines the notifies.

I only referenced the RFC to indicate which message account property I was
talking about, not about any content.

> Could you consider changing this behavior? I would think that if it were
> changed there would be no impact. Most won't have enabled it. If they
> have
> enabled it, it's likely that it's not working for them anyway.

I'm not sure why the implementation is how it is now. Asterisk (or
FreePBX) for example don't send the Message-Account property and you can
configure it in Jitsi. I assume the idea was to simply augment the received
notifies if they were lacking information.

What's the point of delivering a Message-Account header that doesn't work?
Can't you fix that on the server so the correct message account is sent?

If not I don't mind having a FORCE_CONFIGURED_MESSAGE or similar option.

> Thanks,
> Mike
> PM for sipXcom Project

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Not so sure about Asterisk (we use fs), but the way I read what you posted
is that by default it is set for you to dial *@server vs. ext@server and
you must change the default to make it work as ext@server. So, out of the
box against Asterisk, you would program Jitsi to dial *@server (and that
would work because the server isn't sending the Message-Account header in
the Notify).

I'm just looking for a way to override that if the Message-Account is being
sent. This is useful if you have many users checking the same mailbox or
one user checking multiple mailboxes. Also I don't want to change the
dialing and mess up how all hard phones work (they seem to ignore the
Message-Account if you have the extension set to dial to check VM)

Thanks,
  Mike

Michael Picher, VP of Product Innovation
eZuce, Inc.

300 Brickstone Square

Suite 104

Andover, MA. 01810
O.978-296-1005 X2015
M.207-956-0262
@mpicher <http://twitter.com/mpicher>
linkedin <http://www.linkedin.com/profile/view?id=35504760&trk=tab_pro>
www.ezuce.com

Notice: This transmittal and/or attachments may be privileged or
confidential. It is intended solely for the addressee(s) named above. Any
dissemination, or copying is strictly prohibited. If you received this
transmittal in error, please notify us immediately by reply and immediately
delete this message and all its attachments. Thank you. FMS

···

On Sat, Mar 4, 2017 at 11:08 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,
It was long time since this was implemented, and haven't check the
code recently. But in asterisk there is an option, vmexten ( Dialplan
extension to reach mailbox. Default asterisk.), when you set it I
think it fills that Message-Account header and when you click to dial
in the UI you can reach your mailbox. Of course you need to configure
the extension you put in vmexten to reach the mailbox using the
dialplan.

Regards
damencho

On Sat, Mar 4, 2017 at 4:06 AM, Michael Picher <mpicher@ezuce.com> wrote:
> The purpose of delivering a Message-Account header is for those accounts
> that may subscribe to multiple accounts. Likewise, multiple SIP users may
> subscribe to the same account. The Notifies then come back with message
> counts for the particular mailboxes.
>
> We utilize freeswitch for voicemail in sipXcom. So this is how it works
with
> FS.
>
> An option to force the configured value would be great if that what you
> think is needed for Jitsi (a check box for manual configuration would be
> appreciated as well). It seems unnecessary to me because if you're
adding a
> configured value you would assume that you'd want to use it, but you know
> your application and users best.
>
> Thanks,
> Mike
>
>
> Michael Picher, VP of Product Innovation
> eZuce, Inc.
>
> 300 Brickstone Square
>
> Suite 104
>
> Andover, MA. 01810
>
> O.978-296-1005 X2015
> M.207-956-0262
> @mpicher <http://twitter.com/mpicher>
> linkedin
> www.ezuce.com
>
> Notice: This transmittal and/or attachments may be privileged or
> confidential. It is intended solely for the addressee(s) named above. Any
> dissemination, or copying is strictly prohibited. If you received this
> transmittal in error, please notify us immediately by reply and
immediately
> delete this message and all its attachments. Thank you. FMS
>
> On Sat, Mar 4, 2017 at 4:32 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:
>>
>> > Thanks again Ingo. I think this logic is a bit backwards on deciding
>> > what URI
>> > is used to dial back the voicemail.
>> >
>> > I would think that if you want to force a particular number to dial
you
>> > would
>> > enter it and the application should honor it. Using the
>> > 'Message-Account'
>> > simply forces the client to dial that same extension. RFC3842 doesn't
>> > really
>> > address 'how' voicemail is dialed, it just defines the notifies.
>>
>> I only referenced the RFC to indicate which message account property I
was
>> talking about, not about any content.
>>
>> > Could you consider changing this behavior? I would think that if it
were
>> > changed there would be no impact. Most won't have enabled it. If they
>> > have
>> > enabled it, it's likely that it's not working for them anyway.
>>
>> I'm not sure why the implementation is how it is now. Asterisk (or
>> FreePBX) for example don't send the Message-Account property and you can
>> configure it in Jitsi. I assume the idea was to simply augment the
received
>> notifies if they were lacking information.
>>
>> What's the point of delivering a Message-Account header that doesn't
work?
>> Can't you fix that on the server so the correct message account is sent?
>>
>> If not I don't mind having a FORCE_CONFIGURED_MESSAGE or similar option.
>>
>> > Thanks,
>> > Mike
>> > PM for sipXcom Project
>>
>> Ingo
>>
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

Not so sure about Asterisk (we use fs), but the way I read what you
posted is that by default it is set for you to dial *@server vs.
ext@server and you must change the default to make it work as
ext@server. So, out of the box against Asterisk, you would program Jitsi
to dial *@server (and that would work because the server isn't sending
the Message-Account header in the Notify).

I'm just looking for a way to override that if the Message-Account is being
sent. This is useful if you have many users checking the same mailbox or one
user checking multiple mailboxes. Also I don't want to change the dialing and
mess up how all hard phones work (they seem to ignore the Message-Account if
you have the extension set to dial to check VM)

Can you please open an issue on Github? I don't have time to work on it for a while and don't want to forget.

Thanks,
  Mike

Ingo