[jitsi-users] Default 10000-20000 UDP port change


#1

Greetings All

Does anyone where I can go to to change the default UDP port range? Is it
in jvb.sh? If what would be the parameter? It tried the below and it does
not work:

--min-port=25000
--max-port:30000

and/or

min-port=25000
max-port:30000

Hope to hear from someone. Thank you in advance.

···

--
-john-


#2

Hi
Even I have tried changing them but it didn't work. I guess udp ports are hard coded..

Shyam Yeduru

···

On 26-Sep-2016, at 3:55 AM, John Finding <findingjohn@gmail.com> wrote:

Greetings All

Does anyone where I can go to to change the default UDP port range? Is it in jvb.sh? If what would be the parameter? It tried the below and it does not work:

--min-port=25000
--max-port:30000

and/or

min-port=25000
max-port:30000

Hope to hear from someone. Thank you in advance.

--
-john-
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Does anyone from jitsi have any info in this?

···

On Sun, Sep 25, 2016 at 3:21 PM, John Finding <findingjohn@gmail.com> wrote:

Greetings All

Does anyone where I can go to to change the default UDP port range? Is it
in jvb.sh? If what would be the parameter? It tried the below and it does
not work:

--min-port=25000
--max-port:30000

and/or

min-port=25000
max-port:30000

Hope to hear from someone. Thank you in advance.

--
-john-

--
-john-


#4

Hi,

No the ports are not hardcoded.
Passing --min-port=25000 --max-port=30000 should work.
How did you confirm it is not working?

Default values are 10001 to 20000. And port 10000 is the single port
which by default is used by chrome and the ports above are fallback.
The single port can be configured in the properties file by changing
the property:
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT

Regards
damencho

···

On Tue, Sep 27, 2016 at 12:48 AM, John Finding <findingjohn@gmail.com> wrote:

Does anyone from jitsi have any info in this?

On Sun, Sep 25, 2016 at 3:21 PM, John Finding <findingjohn@gmail.com> wrote:

Greetings All

Does anyone where I can go to to change the default UDP port range? Is it
in jvb.sh? If what would be the parameter? It tried the below and it does
not work:

--min-port=25000
--max-port:30000

and/or

min-port=25000
max-port:30000

Hope to hear from someone. Thank you in advance.

--
-john-

--
-john-

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

@Damian, when you say "Passing --min-port=25000 --max-port=30000 should
work", are you talking about port forward translation from the firewall
side?

···

On Tue, Sep 27, 2016 at 7:27 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

No the ports are not hardcoded.
Passing --min-port=25000 --max-port=30000 should work.
How did you confirm it is not working?

Default values are 10001 to 20000. And port 10000 is the single port
which by default is used by chrome and the ports above are fallback.
The single port can be configured in the properties file by changing
the property:
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT

Regards
damencho

On Tue, Sep 27, 2016 at 12:48 AM, John Finding <findingjohn@gmail.com> > wrote:
> Does anyone from jitsi have any info in this?
>
> On Sun, Sep 25, 2016 at 3:21 PM, John Finding <findingjohn@gmail.com> > wrote:
>>
>> Greetings All
>>
>> Does anyone where I can go to to change the default UDP port range? Is
it
>> in jvb.sh? If what would be the parameter? It tried the below and it
does
>> not work:
>>
>> --min-port=25000
>> --max-port:30000
>>
>> and/or
>>
>> min-port=25000
>> max-port:30000
>>
>> Hope to hear from someone. Thank you in advance.
>>
>> --
>> -john-
>
>
>
>
> --
> -john-
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
-john-


#6

I mean passing those parameters to jitsi-videobridge startup script,
should change the behavior of jvb, which will start using that range.
Nothing about firewall, if jvb is behind NAT you need to forward those
ports so incoming packets will reach jvb.

···

On Tue, Sep 27, 2016 at 10:16 AM, John Finding <findingjohn@gmail.com> wrote:

@Damian, when you say "Passing --min-port=25000 --max-port=30000 should
work", are you talking about port forward translation from the firewall
side?

On Tue, Sep 27, 2016 at 7:27 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

No the ports are not hardcoded.
Passing --min-port=25000 --max-port=30000 should work.
How did you confirm it is not working?

Default values are 10001 to 20000. And port 10000 is the single port
which by default is used by chrome and the ports above are fallback.
The single port can be configured in the properties file by changing
the property:
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT

Regards
damencho

On Tue, Sep 27, 2016 at 12:48 AM, John Finding <findingjohn@gmail.com> >> wrote:
> Does anyone from jitsi have any info in this?
>
> On Sun, Sep 25, 2016 at 3:21 PM, John Finding <findingjohn@gmail.com> >> > wrote:
>>
>> Greetings All
>>
>> Does anyone where I can go to to change the default UDP port range? Is
>> it
>> in jvb.sh? If what would be the parameter? It tried the below and it
>> does
>> not work:
>>
>> --min-port=25000
>> --max-port:30000
>>
>> and/or
>>
>> min-port=25000
>> max-port:30000
>>
>> Hope to hear from someone. Thank you in advance.
>>
>> --
>> -john-
>
>
>
>
> --
> -john-
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
-john-

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

One more:
why not using TCP only?
By

···

On Tue, Sep 27, 2016 at 4:27 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

No the ports are not hardcoded.
Passing --min-port=25000 --max-port=30000 should work.
How did you confirm it is not working?

Default values are 10001 to 20000. And port 10000 is the single port
which by default is used by chrome and the ports above are fallback.
The single port can be configured in the properties file by changing
the property:
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT

Regards
damencho

On Tue, Sep 27, 2016 at 12:48 AM, John Finding <findingjohn@gmail.com> > wrote:
> Does anyone from jitsi have any info in this?
>
> On Sun, Sep 25, 2016 at 3:21 PM, John Finding <findingjohn@gmail.com> > wrote:
>>
>> Greetings All
>>
>> Does anyone where I can go to to change the default UDP port range? Is
it
>> in jvb.sh? If what would be the parameter? It tried the below and it
does
>> not work:
>>
>> --min-port=25000
>> --max-port:30000
>>
>> and/or
>>
>> min-port=25000
>> max-port:30000
>>
>> Hope to hear from someone. Thank you in advance.
>>
>> --
>> -john-
>
>
>
>
> --
> -john-
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

[image: Andrea Magatti on about.me]

Andrea Magatti
about.me/amagatti
  <http://about.me/amagatti>


#8

@Damian Is there some documentation config sample to look at that kind of
explain what you mentioned?

···

On Tue, Sep 27, 2016 at 9:08 AM, Damian Minkov <damencho@jitsi.org> wrote:

I mean passing those parameters to jitsi-videobridge startup script,
should change the behavior of jvb, which will start using that range.
Nothing about firewall, if jvb is behind NAT you need to forward those
ports so incoming packets will reach jvb.

On Tue, Sep 27, 2016 at 10:16 AM, John Finding <findingjohn@gmail.com> > wrote:
> @Damian, when you say "Passing --min-port=25000 --max-port=30000 should
> work", are you talking about port forward translation from the firewall
> side?
>
> On Tue, Sep 27, 2016 at 7:27 AM, Damian Minkov <damencho@jitsi.org> > wrote:
>>
>> Hi,
>>
>> No the ports are not hardcoded.
>> Passing --min-port=25000 --max-port=30000 should work.
>> How did you confirm it is not working?
>>
>> Default values are 10001 to 20000. And port 10000 is the single port
>> which by default is used by chrome and the ports above are fallback.
>> The single port can be configured in the properties file by changing
>> the property:
>> org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT
>>
>> Regards
>> damencho
>>
>>
>> On Tue, Sep 27, 2016 at 12:48 AM, John Finding <findingjohn@gmail.com> > >> wrote:
>> > Does anyone from jitsi have any info in this?
>> >
>> > On Sun, Sep 25, 2016 at 3:21 PM, John Finding <findingjohn@gmail.com> > >> > wrote:
>> >>
>> >> Greetings All
>> >>
>> >> Does anyone where I can go to to change the default UDP port range?
Is
>> >> it
>> >> in jvb.sh? If what would be the parameter? It tried the below and it
>> >> does
>> >> not work:
>> >>
>> >> --min-port=25000
>> >> --max-port:30000
>> >>
>> >> and/or
>> >>
>> >> min-port=25000
>> >> max-port:30000
>> >>
>> >> Hope to hear from someone. Thank you in advance.
>> >>
>> >> --
>> >> -john-
>> >
>> >
>> >
>> >
>> > --
>> > -john-
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
>
> --
> -john-
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
-john-


#9

If you are talking about configuration when behind NAT:
https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md#orgjitsivideobridgenat_harvester_local_address
You need to set those two properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS

···

On Tue, Sep 27, 2016 at 11:17 AM, John Finding <findingjohn@gmail.com> wrote:

@Damian Is there some documentation config sample to look at that kind of
explain what you mentioned?

On Tue, Sep 27, 2016 at 9:08 AM, Damian Minkov <damencho@jitsi.org> wrote:

I mean passing those parameters to jitsi-videobridge startup script,
should change the behavior of jvb, which will start using that range.
Nothing about firewall, if jvb is behind NAT you need to forward those
ports so incoming packets will reach jvb.

On Tue, Sep 27, 2016 at 10:16 AM, John Finding <findingjohn@gmail.com> >> wrote:
> @Damian, when you say "Passing --min-port=25000 --max-port=30000 should
> work", are you talking about port forward translation from the firewall
> side?
>
> On Tue, Sep 27, 2016 at 7:27 AM, Damian Minkov <damencho@jitsi.org> >> > wrote:
>>
>> Hi,
>>
>> No the ports are not hardcoded.
>> Passing --min-port=25000 --max-port=30000 should work.
>> How did you confirm it is not working?
>>
>> Default values are 10001 to 20000. And port 10000 is the single port
>> which by default is used by chrome and the ports above are fallback.
>> The single port can be configured in the properties file by changing
>> the property:
>> org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT
>>
>> Regards
>> damencho
>>
>>
>> On Tue, Sep 27, 2016 at 12:48 AM, John Finding <findingjohn@gmail.com> >> >> wrote:
>> > Does anyone from jitsi have any info in this?
>> >
>> > On Sun, Sep 25, 2016 at 3:21 PM, John Finding <findingjohn@gmail.com> >> >> > wrote:
>> >>
>> >> Greetings All
>> >>
>> >> Does anyone where I can go to to change the default UDP port range?
>> >> Is
>> >> it
>> >> in jvb.sh? If what would be the parameter? It tried the below and
>> >> it
>> >> does
>> >> not work:
>> >>
>> >> --min-port=25000
>> >> --max-port:30000
>> >>
>> >> and/or
>> >>
>> >> min-port=25000
>> >> max-port:30000
>> >>
>> >> Hope to hear from someone. Thank you in advance.
>> >>
>> >> --
>> >> -john-
>> >
>> >
>> >
>> >
>> > --
>> > -john-
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
>
> --
> -john-
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
-john-

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

Thanks Damian, I do have those set.

···

On Tue, Sep 27, 2016 at 9:22 AM, Damian Minkov <damencho@jitsi.org> wrote:

If you are talking about configuration when behind NAT:
https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md#
orgjitsivideobridgenat_harvester_local_address
You need to set those two properties:

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS

On Tue, Sep 27, 2016 at 11:17 AM, John Finding <findingjohn@gmail.com> > wrote:
> @Damian Is there some documentation config sample to look at that kind
of
> explain what you mentioned?
>
> On Tue, Sep 27, 2016 at 9:08 AM, Damian Minkov <damencho@jitsi.org> > wrote:
>>
>> I mean passing those parameters to jitsi-videobridge startup script,
>> should change the behavior of jvb, which will start using that range.
>> Nothing about firewall, if jvb is behind NAT you need to forward those
>> ports so incoming packets will reach jvb.
>>
>>
>> On Tue, Sep 27, 2016 at 10:16 AM, John Finding <findingjohn@gmail.com> > >> wrote:
>> > @Damian, when you say "Passing --min-port=25000 --max-port=30000
should
>> > work", are you talking about port forward translation from the
firewall
>> > side?
>> >
>> > On Tue, Sep 27, 2016 at 7:27 AM, Damian Minkov <damencho@jitsi.org> > >> > wrote:
>> >>
>> >> Hi,
>> >>
>> >> No the ports are not hardcoded.
>> >> Passing --min-port=25000 --max-port=30000 should work.
>> >> How did you confirm it is not working?
>> >>
>> >> Default values are 10001 to 20000. And port 10000 is the single port
>> >> which by default is used by chrome and the ports above are fallback.
>> >> The single port can be configured in the properties file by changing
>> >> the property:
>> >> org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT
>> >>
>> >> Regards
>> >> damencho
>> >>
>> >>
>> >> On Tue, Sep 27, 2016 at 12:48 AM, John Finding < > findingjohn@gmail.com> > >> >> wrote:
>> >> > Does anyone from jitsi have any info in this?
>> >> >
>> >> > On Sun, Sep 25, 2016 at 3:21 PM, John Finding < > findingjohn@gmail.com> > >> >> > wrote:
>> >> >>
>> >> >> Greetings All
>> >> >>
>> >> >> Does anyone where I can go to to change the default UDP port
range?
>> >> >> Is
>> >> >> it
>> >> >> in jvb.sh? If what would be the parameter? It tried the below and
>> >> >> it
>> >> >> does
>> >> >> not work:
>> >> >>
>> >> >> --min-port=25000
>> >> >> --max-port:30000
>> >> >>
>> >> >> and/or
>> >> >>
>> >> >> min-port=25000
>> >> >> max-port:30000
>> >> >>
>> >> >> Hope to hear from someone. Thank you in advance.
>> >> >>
>> >> >> --
>> >> >> -john-
>> >> >
>> >> >
>> >> >
>> >> >
>> >> > --
>> >> > -john-
>> >> >
>> >> > _______________________________________________
>> >> > users mailing list
>> >> > users@jitsi.org
>> >> > Unsubscribe instructions and other list options:
>> >> > http://lists.jitsi.org/mailman/listinfo/users
>> >>
>> >> _______________________________________________
>> >> users mailing list
>> >> users@jitsi.org
>> >> Unsubscribe instructions and other list options:
>> >> http://lists.jitsi.org/mailman/listinfo/users
>> >
>> >
>> >
>> >
>> > --
>> > -john-
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
>
> --
> -john-
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
-john-