[jitsi-users] customizing home page in latest stable


#1

Hi everybody,

first of all let me thank all the jitsi fellows for the great job done and for the value of this application.

I'm running jitsi-meet stable on debian8 since a long time and always updated without issues.. after update I used to change title.html and index.html as well as favicon and watermaks PNGs to customize my home page for the application.
that was easy since I had just to edit the html structure in index.html and I was good to go.

nowI have 2 questions about jitsi-meet:

1- now I see that index.html is completely changed and after I've updated and the stable/jitsi-meet-web_1.0.1592-1_all.deb got installed... I cannot figure out where to go for editing the "features" <div> to add my content.
can you please tell me where to look for?

2- I'm succesfully using the jidesha chrome extension and also already published on chrome web store... is there a way to point users that haven't installed my extension to the relative chrome web store page instead of displaying the error message "Permission Denied: Failed to install desktop sharing extension" when they click on the desktop sharing icon?

thanks a lot for any suggestion.

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)


#2

Hi,

Hi everybody,

first of all let me thank all the jitsi fellows for the great job done and
for the value of this application.

I'm running jitsi-meet stable on debian8 since a long time and always
updated without issues.. after update I used to change title.html and
index.html as well as favicon and watermaks PNGs to customize my home page
for the application.
that was easy since I had just to edit the html structure in index.html and
I was good to go.

nowI have 2 questions about jitsi-meet:

1- now I see that index.html is completely changed and after I've updated
and the stable/jitsi-meet-web_1.0.1592-1_all.deb got installed... I cannot
figure out where to go for editing the "features" <div> to add my content.
can you please tell me where to look for?

So we are in a process of reactifying the whole project, this is the
reason that the index.html changed you need to edit the source and
build it from source. The

2- I'm succesfully using the jidesha chrome extension and also already
published on chrome web store... is there a way to point users that haven't
installed my extension to the relative chrome web store page instead of
displaying the error message "Permission Denied: Failed to install desktop
sharing extension" when they click on the desktop sharing icon?

Did you edit your config.js file adding the id of your extension?
Installation will be automatic for them.

Regards
damencho

···

On Thu, Feb 2, 2017 at 4:57 AM, Lorenzo Faleschini <lorenzo@nordest.systems> wrote:

thanks a lot for any suggestion.

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi,

thanks for the quick reply.

so the only way to keep the home customized is to build from source and thus I cannot use the repo anymore?

I have my extension id set in the desktopSharingChromeExtId field correctly filled in my /etc/jitsi/meet/myhost.mydomain.tld-config.js but users aren't being redirected to the chrome store

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'ibdeb____SOMETHING____dfo',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

any other setting to enable that?

thanks again

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----

···

Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 16:28:31
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi,

On Thu, Feb 2, 2017 at 4:57 AM, Lorenzo Faleschini <lorenzo@nordest.systems> wrote:

Hi everybody,

first of all let me thank all the jitsi fellows for the great job done and
for the value of this application.

I'm running jitsi-meet stable on debian8 since a long time and always
updated without issues.. after update I used to change title.html and
index.html as well as favicon and watermaks PNGs to customize my home page
for the application.
that was easy since I had just to edit the html structure in index.html and
I was good to go.

nowI have 2 questions about jitsi-meet:

1- now I see that index.html is completely changed and after I've updated
and the stable/jitsi-meet-web_1.0.1592-1_all.deb got installed... I cannot
figure out where to go for editing the "features" <div> to add my content.
can you please tell me where to look for?

So we are in a process of reactifying the whole project, this is the
reason that the index.html changed you need to edit the source and
build it from source. The

2- I'm succesfully using the jidesha chrome extension and also already
published on chrome web store... is there a way to point users that haven't
installed my extension to the relative chrome web store page instead of
displaying the error message "Permission Denied: Failed to install desktop
sharing extension" when they click on the desktop sharing icon?

Did you edit your config.js file adding the id of your extension?
Installation will be automatic for them.

Regards
damencho

thanks a lot for any suggestion.

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi again,

Hi,

thanks for the quick reply.

so the only way to keep the home customized is to build from source and thus I cannot use the repo anymore?

Well if there are no hooks to add your stuff, as we do with
title.html, you can purpose some in the context of react and
contribute a PR so you can use later the repo and just plug your
stuff.

I have my extension id set in the desktopSharingChromeExtId field correctly filled in my /etc/jitsi/meet/myhost.mydomain.tld-config.js but users aren't being redirected to the chrome store

Did you mark your plugin as inline install?

Regards
damencho

···

On Thu, Feb 2, 2017 at 9:58 AM, Lorenzo Faleschini <lorenzo@nordest.systems> wrote:

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'ibdeb____SOMETHING____dfo',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

any other setting to enable that?

thanks again

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 16:28:31
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi,

On Thu, Feb 2, 2017 at 4:57 AM, Lorenzo Faleschini > <lorenzo@nordest.systems> wrote:

Hi everybody,

first of all let me thank all the jitsi fellows for the great job done and
for the value of this application.

I'm running jitsi-meet stable on debian8 since a long time and always
updated without issues.. after update I used to change title.html and
index.html as well as favicon and watermaks PNGs to customize my home page
for the application.
that was easy since I had just to edit the html structure in index.html and
I was good to go.

nowI have 2 questions about jitsi-meet:

1- now I see that index.html is completely changed and after I've updated
and the stable/jitsi-meet-web_1.0.1592-1_all.deb got installed... I cannot
figure out where to go for editing the "features" <div> to add my content.
can you please tell me where to look for?

So we are in a process of reactifying the whole project, this is the
reason that the index.html changed you need to edit the source and
build it from source. The

2- I'm succesfully using the jidesha chrome extension and also already
published on chrome web store... is there a way to point users that haven't
installed my extension to the relative chrome web store page instead of
displaying the error message "Permission Denied: Failed to install desktop
sharing extension" when they click on the desktop sharing icon?

Did you edit your config.js file adding the id of your extension?
Installation will be automatic for them.

Regards
damencho

thanks a lot for any suggestion.

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

hi..

thanks for the hint about inline install. I'll modify it and test again.

as for the hook to add stuff to the homepage I'm not able to code it but I think it will be very useful for a lot of users/admins.
do you think I can file an issue on github to describe a feature request?
what I'd love to have is the option to remove the feature block and replace it with custom html taken from a file to be placed in the
/usr/share/jitsi-meet/ folder.

thanks again for your speedy answers

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----

···

Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 17:07:45
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi again,

On Thu, Feb 2, 2017 at 9:58 AM, Lorenzo Faleschini <lorenzo@nordest.systems> wrote:

Hi,

thanks for the quick reply.

so the only way to keep the home customized is to build from source and thus I cannot use the repo anymore?

Well if there are no hooks to add your stuff, as we do with
title.html, you can purpose some in the context of react and
contribute a PR so you can use later the repo and just plug your
stuff.

I have my extension id set in the desktopSharingChromeExtId field correctly filled in my /etc/jitsi/meet/myhost.mydomain.tld-config.js but users aren't being redirected to the chrome store

Did you mark your plugin as inline install?

Regards
damencho

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'ibdeb____SOMETHING____dfo',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

any other setting to enable that?

thanks again

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 16:28:31
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi,

On Thu, Feb 2, 2017 at 4:57 AM, Lorenzo Faleschini > <lorenzo@nordest.systems> wrote:

Hi everybody,

first of all let me thank all the jitsi fellows for the great job done and
for the value of this application.

I'm running jitsi-meet stable on debian8 since a long time and always
updated without issues.. after update I used to change title.html and
index.html as well as favicon and watermaks PNGs to customize my home page
for the application.
that was easy since I had just to edit the html structure in index.html and
I was good to go.

nowI have 2 questions about jitsi-meet:

1- now I see that index.html is completely changed and after I've updated
and the stable/jitsi-meet-web_1.0.1592-1_all.deb got installed... I cannot
figure out where to go for editing the "features" <div> to add my content.
can you please tell me where to look for?

So we are in a process of reactifying the whole project, this is the
reason that the index.html changed you need to edit the source and
build it from source. The

2- I'm succesfully using the jidesha chrome extension and also already
published on chrome web store... is there a way to point users that haven't
installed my extension to the relative chrome web store page instead of
displaying the error message "Permission Denied: Failed to install desktop
sharing extension" when they click on the desktop sharing icon?

Did you edit your config.js file adding the id of your extension?
Installation will be automatic for them.

Regards
damencho

thanks a lot for any suggestion.

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Issue will not help, but if you want open one just to have it logged
with description. I don't think we have this thing in our roadmap
currently so any contribution is welcome.

···

On Thu, Feb 2, 2017 at 10:21 AM, Lorenzo Faleschini <lorenzo@nordest.systems> wrote:

hi..

thanks for the hint about inline install. I'll modify it and test again.

as for the hook to add stuff to the homepage I'm not able to code it but I think it will be very useful for a lot of users/admins.
do you think I can file an issue on github to describe a feature request?
what I'd love to have is the option to remove the feature block and replace it with custom html taken from a file to be placed in the
/usr/share/jitsi-meet/ folder.

thanks again for your speedy answers

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 17:07:45
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi again,

On Thu, Feb 2, 2017 at 9:58 AM, Lorenzo Faleschini > <lorenzo@nordest.systems> wrote:

Hi,

thanks for the quick reply.

so the only way to keep the home customized is to build from source and thus I cannot use the repo anymore?

Well if there are no hooks to add your stuff, as we do with
title.html, you can purpose some in the context of react and
contribute a PR so you can use later the repo and just plug your
stuff.

I have my extension id set in the desktopSharingChromeExtId field correctly filled in my /etc/jitsi/meet/myhost.mydomain.tld-config.js but users aren't being redirected to the chrome store

Did you mark your plugin as inline install?

Regards
damencho

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'ibdeb____SOMETHING____dfo',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

any other setting to enable that?

thanks again

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 16:28:31
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi,

On Thu, Feb 2, 2017 at 4:57 AM, Lorenzo Faleschini >> <lorenzo@nordest.systems> wrote:

Hi everybody,

first of all let me thank all the jitsi fellows for the great job done and
for the value of this application.

I'm running jitsi-meet stable on debian8 since a long time and always
updated without issues.. after update I used to change title.html and
index.html as well as favicon and watermaks PNGs to customize my home page
for the application.
that was easy since I had just to edit the html structure in index.html and
I was good to go.

nowI have 2 questions about jitsi-meet:

1- now I see that index.html is completely changed and after I've updated
and the stable/jitsi-meet-web_1.0.1592-1_all.deb got installed... I cannot
figure out where to go for editing the "features" <div> to add my content.
can you please tell me where to look for?

So we are in a process of reactifying the whole project, this is the
reason that the index.html changed you need to edit the source and
build it from source. The

2- I'm succesfully using the jidesha chrome extension and also already
published on chrome web store... is there a way to point users that haven't
installed my extension to the relative chrome web store page instead of
displaying the error message "Permission Denied: Failed to install desktop
sharing extension" when they click on the desktop sharing icon?

Did you edit your config.js file adding the id of your extension?
Installation will be automatic for them.

Regards
damencho

thanks a lot for any suggestion.

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

ok, thanks... don't want to bother so. If I can find out a way eventually I'll do a PR.

last thing on the jidesha app..
seems that even enabling the inline install option the installation is not working.

maybe I should stick with the default app name?
so that the final link will be:

https://chrome.google.com/webstore/detail/custom-name/ibdeSOMETHINGjefbdfo
https://chrome.google.com/webstore/detail/jitsi-desktop-streamer/ibdeSOMETHINGjefbdfo

or it should not matter at all?

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----

···

Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 17:31:11
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Issue will not help, but if you want open one just to have it logged
with description. I don't think we have this thing in our roadmap
currently so any contribution is welcome.

On Thu, Feb 2, 2017 at 10:21 AM, Lorenzo Faleschini <lorenzo@nordest.systems> wrote:

hi..

thanks for the hint about inline install. I'll modify it and test again.

as for the hook to add stuff to the homepage I'm not able to code it but I think it will be very useful for a lot of users/admins.
do you think I can file an issue on github to describe a feature request?
what I'd love to have is the option to remove the feature block and replace it with custom html taken from a file to be placed in the
/usr/share/jitsi-meet/ folder.

thanks again for your speedy answers

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 17:07:45
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi again,

On Thu, Feb 2, 2017 at 9:58 AM, Lorenzo Faleschini > <lorenzo@nordest.systems> wrote:

Hi,

thanks for the quick reply.

so the only way to keep the home customized is to build from source and thus I cannot use the repo anymore?

Well if there are no hooks to add your stuff, as we do with
title.html, you can purpose some in the context of react and
contribute a PR so you can use later the repo and just plug your
stuff.

I have my extension id set in the desktopSharingChromeExtId field correctly filled in my /etc/jitsi/meet/myhost.mydomain.tld-config.js but users aren't being redirected to the chrome store

Did you mark your plugin as inline install?

Regards
damencho

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'ibdeb____SOMETHING____dfo',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

any other setting to enable that?

thanks again

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 16:28:31
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi,

On Thu, Feb 2, 2017 at 4:57 AM, Lorenzo Faleschini >> <lorenzo@nordest.systems> wrote:

Hi everybody,

first of all let me thank all the jitsi fellows for the great job done and
for the value of this application.

I'm running jitsi-meet stable on debian8 since a long time and always
updated without issues.. after update I used to change title.html and
index.html as well as favicon and watermaks PNGs to customize my home page
for the application.
that was easy since I had just to edit the html structure in index.html and
I was good to go.

nowI have 2 questions about jitsi-meet:

1- now I see that index.html is completely changed and after I've updated
and the stable/jitsi-meet-web_1.0.1592-1_all.deb got installed... I cannot
figure out where to go for editing the "features" <div> to add my content.
can you please tell me where to look for?

So we are in a process of reactifying the whole project, this is the
reason that the index.html changed you need to edit the source and
build it from source. The

2- I'm succesfully using the jidesha chrome extension and also already
published on chrome web store... is there a way to point users that haven't
installed my extension to the relative chrome web store page instead of
displaying the error message "Permission Denied: Failed to install desktop
sharing extension" when they click on the desktop sharing icon?

Did you edit your config.js file adding the id of your extension?
Installation will be automatic for them.

Regards
damencho

thanks a lot for any suggestion.

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Name doesn't matter, the important part is the id. Sometimes
publishing new version can take long, so I suggest testing tomorrow.

···

On Thu, Feb 2, 2017 at 10:42 AM, Lorenzo Faleschini <lorenzo@nordest.systems> wrote:

ok, thanks... don't want to bother so. If I can find out a way eventually I'll do a PR.

last thing on the jidesha app..
seems that even enabling the inline install option the installation is not working.

maybe I should stick with the default app name?
so that the final link will be:

https://chrome.google.com/webstore/detail/custom-name/ibdeSOMETHINGjefbdfo
https://chrome.google.com/webstore/detail/jitsi-desktop-streamer/ibdeSOMETHINGjefbdfo

or it should not matter at all?

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 17:31:11
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Issue will not help, but if you want open one just to have it logged
with description. I don't think we have this thing in our roadmap
currently so any contribution is welcome.

On Thu, Feb 2, 2017 at 10:21 AM, Lorenzo Faleschini > <lorenzo@nordest.systems> wrote:

hi..

thanks for the hint about inline install. I'll modify it and test again.

as for the hook to add stuff to the homepage I'm not able to code it but I think it will be very useful for a lot of users/admins.
do you think I can file an issue on github to describe a feature request?
what I'd love to have is the option to remove the feature block and replace it with custom html taken from a file to be placed in the
/usr/share/jitsi-meet/ folder.

thanks again for your speedy answers

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 17:07:45
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi again,

On Thu, Feb 2, 2017 at 9:58 AM, Lorenzo Faleschini >> <lorenzo@nordest.systems> wrote:

Hi,

thanks for the quick reply.

so the only way to keep the home customized is to build from source and thus I cannot use the repo anymore?

Well if there are no hooks to add your stuff, as we do with
title.html, you can purpose some in the context of react and
contribute a PR so you can use later the repo and just plug your
stuff.

I have my extension id set in the desktopSharingChromeExtId field correctly filled in my /etc/jitsi/meet/myhost.mydomain.tld-config.js but users aren't being redirected to the chrome store

Did you mark your plugin as inline install?

Regards
damencho

    // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
    desktopSharingChromeMethod: 'ext',
    // The ID of the jidesha extension for Chrome.
    desktopSharingChromeExtId: 'ibdeb____SOMETHING____dfo',
    // The media sources to use when using screen sharing with the Chrome
    // extension.
    desktopSharingChromeSources: ['screen', 'window'],
    // Required version of Chrome extension
    desktopSharingChromeMinExtVersion: '0.1',

any other setting to enable that?

thanks again

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

----- Messaggio originale -----
Da: "Damian Minkov" <damencho@jitsi.org>
A: "users" <users@jitsi.org>
Inviato: Giovedì, 2 febbraio 2017 16:28:31
Oggetto: Re: [jitsi-users] customizing home page in latest stable

Hi,

On Thu, Feb 2, 2017 at 4:57 AM, Lorenzo Faleschini >>> <lorenzo@nordest.systems> wrote:

Hi everybody,

first of all let me thank all the jitsi fellows for the great job done and
for the value of this application.

I'm running jitsi-meet stable on debian8 since a long time and always
updated without issues.. after update I used to change title.html and
index.html as well as favicon and watermaks PNGs to customize my home page
for the application.
that was easy since I had just to edit the html structure in index.html and
I was good to go.

nowI have 2 questions about jitsi-meet:

1- now I see that index.html is completely changed and after I've updated
and the stable/jitsi-meet-web_1.0.1592-1_all.deb got installed... I cannot
figure out where to go for editing the "features" <div> to add my content.
can you please tell me where to look for?

So we are in a process of reactifying the whole project, this is the
reason that the index.html changed you need to edit the source and
build it from source. The

2- I'm succesfully using the jidesha chrome extension and also already
published on chrome web store... is there a way to point users that haven't
installed my extension to the relative chrome web store page instead of
displaying the error message "Permission Denied: Failed to install desktop
sharing extension" when they click on the desktop sharing icon?

Did you edit your config.js file adding the id of your extension?
Installation will be automatic for them.

Regards
damencho

thanks a lot for any suggestion.

Lorenzo Faleschini
IT Manager

Nord Est Systems srl
Loc. Chiavines, 4 - 33090 Vito d'Asio (PN)

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users