[jitsi-users] Current nightly stops at loading screen


#1

Dear All,

wanted to give the current nightly try, but it hangs at the
"NimbuzzAvatars" message, see screenshot. Waited for roughly 40mins,
then terminated it.

BR Florian


#2

wanted to give the current nightly try, but it hangs at the
"NimbuzzAvatars" message, see screenshot. Waited for roughly 40mins,
then terminated it.

If you're running Windows, can you please check if you have a folder %username%\.sip-communicator? If so, delete it.

BR Florian

Ingo


#3

Is it in env´s USERPROFILE path? There is no such folder, but folders like
.gimp-2.8, .local and .thumbnails so I would think its the right place.
Can I enable sone logging for this?

BR

···

Am 24.10.2015 um 14:19 schrieb Ingo Bauersachs:

If you're running Windows, can you please check if you have a folder %username%\.sip-communicator? If so, delete it.

BR Florian

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Is it in env´s USERPROFILE path? There is no such folder, but folders like
.gimp-2.8, .local and .thumbnails so I would think its the right place.

Yes, sorry, meant userprofile.

Can I enable sone logging for this?

You can take a look at the regular logs (see https://jitsi.org/logs), but they probably won't show anything. If you have a JDK installed or if you can get a hand on jvisualvm, it would be helpful to see the list of JVM arguments and System Properties.

Did you have a previous Jitsi version installed? Which one? Does deleting %localappdata%\jitsi help?

BR

Ingo


#5

Hi,

yes I had 2.8-54xx installed before manually, and then tried the "update
through provisioning URL"way to switch to the 2.9 nightly. Deleting the
Jitsi folder does not make any difference. I can try to debug the JVM
arguments a bit, but for the moment I have only JRE installed.

BR Florian

···

Am 24.10.2015 um 18:12 schrieb Ingo Bauersachs:

Is it in env´s USERPROFILE path? There is no such folder, but folders like
.gimp-2.8, .local and .thumbnails so I would think its the right place.

Yes, sorry, meant userprofile.

Can I enable sone logging for this?

You can take a look at the regular logs (see https://jitsi.org/logs), but they probably won't show anything. If you have a JDK installed or if you can get a hand on jvisualvm, it would be helpful to see the list of JVM arguments and System Properties.

Did you have a previous Jitsi version installed? Which one? Does deleting %localappdata%\jitsi help?

BR

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

yes I had 2.8-54xx installed before manually, and then tried the "update
through provisioning URL"way to switch to the 2.9 nightly.

Thanks. I'll need to prepare a clean VM to investigate this.

Deleting the
Jitsi folder does not make any difference. I can try to debug the JVM
arguments a bit, but for the moment I have only JRE installed.

You can obtain jvsisualvm without a JDK from here: https://visualvm.java.net/download.html

BR Florian

Ingo


#7

Hi,

got visualvm to run (download is without JDK, but then it complains it
needs a JDK so I installed 1.8.65 :P)

See attached pictures, and tell me what infos you need. Specifically
interesting is the increase in memory use while it is unresponsive. This
stops around 20mins after start. The heap contains then mainly char[]
objects. Dont ask me what is is doing, but its all in an RMI TCP thread :wink:

BR Florian

···

Am 25.10.2015 um 20:19 schrieb Ingo Bauersachs:

yes I had 2.8-54xx installed before manually, and then tried the "update
through provisioning URL"way to switch to the 2.9 nightly.

Thanks. I'll need to prepare a clean VM to investigate this.

Deleting the
Jitsi folder does not make any difference. I can try to debug the JVM
arguments a bit, but for the moment I have only JRE installed.

You can obtain jvsisualvm without a JDK from here: https://visualvm.java.net/download.html

BR Florian

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

got visualvm to run (download is without JDK, but then it complains it
needs a JDK so I installed 1.8.65 :P)

Sorry, I thought it works standalone.

See attached pictures, and tell me what infos you need. Specifically
interesting is the increase in memory use while it is unresponsive. This
stops around 20mins after start. The heap contains then mainly char[]
objects. Dont ask me what is is doing, but its all in an RMI TCP thread :wink:

I found the problem and committed a fix, the next nightly should be fine. You can manually work around the problem by changing the file lib/felix.client.run.properties

felix.auto.start.14= \
to
felix.auto.start.13= \

(near the beginning, not at the end)

BR Florian

Ingo


#9

Confirmed to work, thanks! :wink:

BR Florian

···

Am 28.10.2015 um 00:48 schrieb Ingo Bauersachs:

I found the problem and committed a fix, the next nightly should be fine. You can manually work around the problem by changing the file lib/felix.client.run.properties