[jitsi-users] Configuring a custom XMPP (server) port


#1

Hi,

is there a way to configure jicofo to target a non default XMPP port?

I see this in the jicofo sources;

        int serverPort
            = getAccountID().getAccountPropertyInt(
                    ProtocolProviderFactory.SERVER_PORT, 5222);

is there any way to override ProtocolProviderFactory.SERVER_PORT?

Thanks,


#2

it looks like I might be able to override it in a properties file, as per:
https://github.com/jitsi/jitsi/blob/master/lib/jitsi-defaults.properties

i.e.

net.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5222

I'm guessing I need to put this
in /etc/jitsi/jicofo/sip-communicator.properties

···

On Tue, Apr 12, 2016 at 11:00 PM, Raoul Duke <rduke496@gmail.com> wrote:

Hi,

is there a way to configure jicofo to target a non default XMPP port?

I see this in the jicofo sources;

        int serverPort
            = getAccountID().getAccountPropertyInt(
                    ProtocolProviderFactory.SERVER_PORT, 5222);

is there any way to override ProtocolProviderFactory.SERVER_PORT?


#3

ok that didn't work. it just seems to be ignored. I also tried adding
-Dnet.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5223

to the JAVA_SYS_PROPS in /etc/jitsi/jicofo/config

but no joy there either.

can someone knowledgeable in this area please give me a quick pointer to
say if I'm vaguely on the right track or if this port is even configurable
in the way I'm attempting to do it.

Thanks,
RD

···

On Sat, Apr 16, 2016 at 2:34 AM, Raoul Duke <rduke496@gmail.com> wrote:

On Tue, Apr 12, 2016 at 11:00 PM, Raoul Duke <rduke496@gmail.com> wrote:

Hi,

is there a way to configure jicofo to target a non default XMPP port?

I see this in the jicofo sources;

        int serverPort
            = getAccountID().getAccountPropertyInt(
                    ProtocolProviderFactory.SERVER_PORT, 5222);

is there any way to override ProtocolProviderFactory.SERVER_PORT?

it looks like I might be able to override it in a properties file, as per:
https://github.com/jitsi/jitsi/blob/master/lib/jitsi-defaults.properties

i.e.

net.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5222

I'm guessing I need to put this
in /etc/jitsi/jicofo/sip-communicator.properties


#4

Hi,

no, I took a look at the code and as I saw this is not configurable.

Regards
damencho

···

On Mon, Apr 18, 2016 at 9:25 AM, Raoul Duke <rduke496@gmail.com> wrote:

On Sat, Apr 16, 2016 at 2:34 AM, Raoul Duke <rduke496@gmail.com> wrote:

On Tue, Apr 12, 2016 at 11:00 PM, Raoul Duke <rduke496@gmail.com> wrote:

Hi,

is there a way to configure jicofo to target a non default XMPP port?

I see this in the jicofo sources;

        int serverPort
            = getAccountID().getAccountPropertyInt(
                    ProtocolProviderFactory.SERVER_PORT, 5222);

is there any way to override ProtocolProviderFactory.SERVER_PORT?

it looks like I might be able to override it in a properties file, as per:
https://github.com/jitsi/jitsi/blob/master/lib/jitsi-defaults.properties

i.e.

net.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5222

I'm guessing I need to put this in
/etc/jitsi/jicofo/sip-communicator.properties

ok that didn't work. it just seems to be ignored. I also tried adding
-Dnet.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5223

to the JAVA_SYS_PROPS in /etc/jitsi/jicofo/config

but no joy there either.

can someone knowledgeable in this area please give me a quick pointer to say
if I'm vaguely on the right track or if this port is even configurable in
the way I'm attempting to do it.

Thanks,
RD

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi,

no, I took a look at the code and as I saw this is not configurable.

damencho: thanks for getting back to me. would you folks be open to a pull
request to make this configurable?

Thanks

···

On Mon, Apr 18, 2016 at 4:14 PM, Damian Minkov <damencho@jitsi.org> wrote:

On Mon, Apr 18, 2016 at 9:25 AM, Raoul Duke <rduke496@gmail.com> wrote:
>
>
> On Sat, Apr 16, 2016 at 2:34 AM, Raoul Duke <rduke496@gmail.com> wrote:
>>
>>
>>
>>
>> On Tue, Apr 12, 2016 at 11:00 PM, Raoul Duke <rduke496@gmail.com> > wrote:
>>>
>>> Hi,
>>>
>>> is there a way to configure jicofo to target a non default XMPP port?
>>>
>>> I see this in the jicofo sources;
>>>
>>> int serverPort
>>> = getAccountID().getAccountPropertyInt(
>>> ProtocolProviderFactory.SERVER_PORT, 5222);
>>>
>>> is there any way to override ProtocolProviderFactory.SERVER_PORT?
>>
>>
>> it looks like I might be able to override it in a properties file, as
per:
>>
https://github.com/jitsi/jitsi/blob/master/lib/jitsi-defaults.properties
>>
>> i.e.
>>
>> net.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5222
>>
>> I'm guessing I need to put this in
>> /etc/jitsi/jicofo/sip-communicator.properties
>
>
> ok that didn't work. it just seems to be ignored. I also tried adding
> -Dnet.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5223
>
> to the JAVA_SYS_PROPS in /etc/jitsi/jicofo/config
>
> but no joy there either.
>
> can someone knowledgeable in this area please give me a quick pointer to
say
> if I'm vaguely on the right track or if this port is even configurable in
> the way I'm attempting to do it.
>
> Thanks,
> RD
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Yes

···

On Mon, Apr 18, 2016 at 10:27 AM, Raoul Duke <rduke496@gmail.com> wrote:

On Mon, Apr 18, 2016 at 4:14 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

no, I took a look at the code and as I saw this is not configurable.

damencho: thanks for getting back to me. would you folks be open to a pull
request to make this configurable?

Thanks

On Mon, Apr 18, 2016 at 9:25 AM, Raoul Duke <rduke496@gmail.com> wrote:
>
>
> On Sat, Apr 16, 2016 at 2:34 AM, Raoul Duke <rduke496@gmail.com> wrote:
>>
>>
>>
>>
>> On Tue, Apr 12, 2016 at 11:00 PM, Raoul Duke <rduke496@gmail.com> >> >> wrote:
>>>
>>> Hi,
>>>
>>> is there a way to configure jicofo to target a non default XMPP port?
>>>
>>> I see this in the jicofo sources;
>>>
>>> int serverPort
>>> = getAccountID().getAccountPropertyInt(
>>> ProtocolProviderFactory.SERVER_PORT, 5222);
>>>
>>> is there any way to override ProtocolProviderFactory.SERVER_PORT?
>>
>>
>> it looks like I might be able to override it in a properties file, as
>> per:
>>
>> https://github.com/jitsi/jitsi/blob/master/lib/jitsi-defaults.properties
>>
>> i.e.
>>
>> net.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5222
>>
>> I'm guessing I need to put this in
>> /etc/jitsi/jicofo/sip-communicator.properties
>
>
> ok that didn't work. it just seems to be ignored. I also tried adding
> -Dnet.java.sip.communicator.service.protocol.jabber.SERVER_PORT=5223
>
> to the JAVA_SYS_PROPS in /etc/jitsi/jicofo/config
>
> but no joy there either.
>
> can someone knowledgeable in this area please give me a quick pointer to
> say
> if I'm vaguely on the right track or if this port is even configurable
> in
> the way I'm attempting to do it.
>
> Thanks,
> RD
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users