[jitsi-users] config is not defined - config.tokenAuthUrl


#1

Hi,

I have installed jitsi-meet latest debian unstable, and getting the
following error:

Uncaught ReferenceError: config is not defined
    at Object.<anonymous> (AuthHandler.js:16)

And looking at line 16.

let isTokenAuthEnabled
    = typeof config.tokenAuthUrl === "string" && config.tokenAuthUrl.length;

It's a default install so I think in default we do not have token auth do
we?.

Regards,
JSZ


#2

Hi,

The problem is that config is not defined. Config is server side
included in the index.html, can you check the source of the index.html
and check whether you have some 404s ...
When config is included successfully you should see something like:
<script>var config = {
....

Regards
damencho

···

On Wed, Jul 12, 2017 at 9:47 AM, JSZ <jitterbuffer@gmail.com> wrote:

Hi,

I have installed jitsi-meet latest debian unstable, and getting the
following error:

Uncaught ReferenceError: config is not defined
    at Object.<anonymous> (AuthHandler.js:16)

And looking at line 16.

let isTokenAuthEnabled
    = typeof config.tokenAuthUrl === "string" && config.tokenAuthUrl.length;

It's a default install so I think in default we do not have token auth do
we?.

Regards,
JSZ

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

HI damencho,

Thanks for replying.

Actually "view-source" does have config so config was loaded. i think it's
about some auth config issue, thoughts?

index.html source : https://pastebin.com/4RZQg4CT

<script>/* jshint maxlen:false */

var config = { // eslint-disable-line no-unused-vars
// configLocation: './config.json', // see ./modules/HttpConfigFetch.js
hosts: {
domain:

..
..

···

On Wed, Jul 12, 2017 at 7:59 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

The problem is that config is not defined. Config is server side
included in the index.html, can you check the source of the index.html
and check whether you have some 404s ...
When config is included successfully you should see something like:
<script>var config = {
....

Regards
damencho

On Wed, Jul 12, 2017 at 9:47 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Hi,
>
> I have installed jitsi-meet latest debian unstable, and getting the
> following error:
>
>
> Uncaught ReferenceError: config is not defined
> at Object.<anonymous> (AuthHandler.js:16)
>
>
> And looking at line 16.
>
> let isTokenAuthEnabled
> = typeof config.tokenAuthUrl === "string" &&
config.tokenAuthUrl.length;
>
>
> It's a default install so I think in default we do not have token auth do
> we?.
>
>
> Regards,
> JSZ
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hum,

The error states "config is not defined" so apparently it doesn't find
config variable.
Can you check in the js console if you execute config, does it print
something?

Regards
damencho

···

On Wed, Jul 12, 2017 at 11:04 AM, JSZ <jitterbuffer@gmail.com> wrote:

HI damencho,

Thanks for replying.

Actually "view-source" does have config so config was loaded. i think it's
about some auth config issue, thoughts?

index.html source : https://pastebin.com/4RZQg4CT

<script>/* jshint maxlen:false */

var config = { // eslint-disable-line no-unused-vars
// configLocation: './config.json', // see ./modules/HttpConfigFetch.js
hosts: {
domain:

..
..

On Wed, Jul 12, 2017 at 7:59 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

The problem is that config is not defined. Config is server side
included in the index.html, can you check the source of the index.html
and check whether you have some 404s ...
When config is included successfully you should see something like:
<script>var config = {
....

Regards
damencho

On Wed, Jul 12, 2017 at 9:47 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Hi,
>
> I have installed jitsi-meet latest debian unstable, and getting the
> following error:
>
>
> Uncaught ReferenceError: config is not defined
> at Object.<anonymous> (AuthHandler.js:16)
>
>
> And looking at line 16.
>
> let isTokenAuthEnabled
> = typeof config.tokenAuthUrl === "string" &&
config.tokenAuthUrl.length;
>
>
> It's a default install so I think in default we do not have token auth
do
> we?.
>
>
> Regards,
> JSZ
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

got it. Thanks damencho

Regards,
JSZ

···

On Wed, Jul 12, 2017 at 9:12 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hum,

The error states "config is not defined" so apparently it doesn't find
config variable.
Can you check in the js console if you execute config, does it print
something?

Regards
damencho

On Wed, Jul 12, 2017 at 11:04 AM, JSZ <jitterbuffer@gmail.com> wrote:

HI damencho,

Thanks for replying.

Actually "view-source" does have config so config was loaded. i think
it's about some auth config issue, thoughts?

index.html source : https://pastebin.com/4RZQg4CT

<script>/* jshint maxlen:false */

var config = { // eslint-disable-line no-unused-vars
// configLocation: './config.json', // see ./modules/HttpConfigFetch.js
hosts: {
domain:

..
..

On Wed, Jul 12, 2017 at 7:59 PM, Damian Minkov <damencho@jitsi.org> >> wrote:

Hi,

The problem is that config is not defined. Config is server side
included in the index.html, can you check the source of the index.html
and check whether you have some 404s ...
When config is included successfully you should see something like:
<script>var config = {
....

Regards
damencho

On Wed, Jul 12, 2017 at 9:47 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Hi,
>
> I have installed jitsi-meet latest debian unstable, and getting the
> following error:
>
>
> Uncaught ReferenceError: config is not defined
> at Object.<anonymous> (AuthHandler.js:16)
>
>
> And looking at line 16.
>
> let isTokenAuthEnabled
> = typeof config.tokenAuthUrl === "string" &&
config.tokenAuthUrl.length;
>
>
> It's a default install so I think in default we do not have token auth
do
> we?.
>
>
> Regards,
> JSZ
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users