[jitsi-users] Completely disabling STUN/ICE


#1

Hello

"Why do I see “ICE failed” errors when trying to make calls.

Jitsi implements a number of NAT traversal methods as described here. In many situations we will be able to setup a call directly between you and other users"

I have a private Astlinux based pbx with (now only) jitsi clients. I've been experimenting with pairing a lot of different voip softphones like ekiga, jitsi, bria, kphone, qutecom, linphone, sipdroid etc. and Jitsi come out of it the best.

Most of the free softphone clients are lack of the XMPP feature, that was also main reason why I decided next to Jitsi and please correct me if I'm wrong but the best is if I use the same VOIP software on all the clients.

When I was using others like bria which had android counterpart back then I ran into all kinds of issues like sometimes the voice come through, sometimes it didn't. Sometimes the first call failed but it set something up with ICE then the 2nd succeeded. This unexpected behaviour is intolerable, I was told that this "voip infrastructure" only really stable with using hardphones, which is just ridicolous.

One thing I noticed about Jitsi is that there is no way to completely disable STUN/ICE detection, which I think causes most of the problems. Because how can that be that I setup a pbx, it runs with the same config since 7 months, the clients run the same jitsi version then all the sudden calls cannot be made or the voice doesnt go through etc.

The bad quality of ALL voip software (http://en.wikipedia.org/wiki/Comparison_of_VoIP_software) so pisses me off that I considering on buying bria for all the computers and mobile devices and not because it has any extra feature I need but just purely because I hope it's gonna work Today, next week and all the time.

In my setup basically all the voip clients are either connecting from a private LAN ip range 10.4.x.x or getting there through openvpn with routing mode from 10.10.x.x, there is no network address translation done anywhere just pure routing so I do not need any kind of ICE/STUN still it seems that it's impossible to disable this feature.

For example I have a windows7 box with jitsi which would try to call a debian workstation. If port 5030 udp is not allowed on that workstation the call won't go through. I do not want any kind of P2P calls. I want all the SIP audio, video, XMPP sessions to go through the PBX machine.

Is it possible to force jitsi to do this, disable ICE/STUN and then lock the configuration into a read only mode so it's going to be impossible to mess up anything by clicking on wrong audio input device for example?

Thank you


#2

ICE can be switched on/off for a specific account by ticking/unticking the "Use ICE" checkbox under the "ICE" tab in the account preferences.

Boris

···

On 18/08/14 15:46, Toney Mareo wrote:

Hello

"Why do I see “ICE failed” errors when trying to make calls.

Jitsi implements a number of NAT traversal methods as described here. In many situations we will be able to setup a call directly between you and other users"

I have a private Astlinux based pbx with (now only) jitsi clients. I've been experimenting with pairing a lot of different voip softphones like ekiga, jitsi, bria, kphone, qutecom, linphone, sipdroid etc. and Jitsi come out of it the best.

Most of the free softphone clients are lack of the XMPP feature, that was also main reason why I decided next to Jitsi and please correct me if I'm wrong but the best is if I use the same VOIP software on all the clients.

When I was using others like bria which had android counterpart back then I ran into all kinds of issues like sometimes the voice come through, sometimes it didn't. Sometimes the first call failed but it set something up with ICE then the 2nd succeeded. This unexpected behaviour is intolerable, I was told that this "voip infrastructure" only really stable with using hardphones, which is just ridicolous.

One thing I noticed about Jitsi is that there is no way to completely disable STUN/ICE detection, which I think causes most of the problems. Because how can that be that I setup a pbx, it runs with the same config since 7 months, the clients run the same jitsi version then all the sudden calls cannot be made or the voice doesnt go through etc.

The bad quality of ALL voip software (http://en.wikipedia.org/wiki/Comparison_of_VoIP_software) so pisses me off that I considering on buying bria for all the computers and mobile devices and not because it has any extra feature I need but just purely because I hope it's gonna work Today, next week and all the time.

In my setup basically all the voip clients are either connecting from a private LAN ip range 10.4.x.x or getting there through openvpn with routing mode from 10.10.x.x, there is no network address translation done anywhere just pure routing so I do not need any kind of ICE/STUN still it seems that it's impossible to disable this feature.

For example I have a windows7 box with jitsi which would try to call a debian workstation. If port 5030 udp is not allowed on that workstation the call won't go through. I do not want any kind of P2P calls. I want all the SIP audio, video, XMPP sessions to go through the PBX machine.

Is it possible to force jitsi to do this, disable ICE/STUN


#3

Hello

First of all to be honest, I doubt that what you just said disables it completely. Jitsi will still try to send out all kind of wierd packets on start to bogon addresses. Secondly there is no such option in the Android client for SIP only for XMPP (Jabber), what's working so I don't care about that.

···

Sent: Monday, August 18, 2014 at 3:06 PM
From: "Boris Grozev" <boris@jitsi.org>
To: "Jitsi Users" <users@jitsi.org>
Subject: Re: [jitsi-users] Completely disabling STUN/ICE
On 18/08/14 15:46, Toney Mareo wrote:

Hello

"Why do I see “ICE failed” errors when trying to make calls.

Jitsi implements a number of NAT traversal methods as described here. In many situations we will be able to setup a call directly between you and other users"

I have a private Astlinux based pbx with (now only) jitsi clients. I've been experimenting with pairing a lot of different voip softphones like ekiga, jitsi, bria, kphone, qutecom, linphone, sipdroid etc. and Jitsi come out of it the best.

Most of the free softphone clients are lack of the XMPP feature, that was also main reason why I decided next to Jitsi and please correct me if I'm wrong but the best is if I use the same VOIP software on all the clients.

When I was using others like bria which had android counterpart back then I ran into all kinds of issues like sometimes the voice come through, sometimes it didn't. Sometimes the first call failed but it set something up with ICE then the 2nd succeeded. This unexpected behaviour is intolerable, I was told that this "voip infrastructure" only really stable with using hardphones, which is just ridicolous.

One thing I noticed about Jitsi is that there is no way to completely disable STUN/ICE detection, which I think causes most of the problems. Because how can that be that I setup a pbx, it runs with the same config since 7 months, the clients run the same jitsi version then all the sudden calls cannot be made or the voice doesnt go through etc.

The bad quality of ALL voip software (http://en.wikipedia.org/wiki/Comparison_of_VoIP_software) so pisses me off that I considering on buying bria for all the computers and mobile devices and not because it has any extra feature I need but just purely because I hope it's gonna work Today, next week and all the time.

In my setup basically all the voip clients are either connecting from a private LAN ip range 10.4.x.x or getting there through openvpn with routing mode from 10.10.x.x, there is no network address translation done anywhere just pure routing so I do not need any kind of ICE/STUN still it seems that it's impossible to disable this feature.

For example I have a windows7 box with jitsi which would try to call a debian workstation. If port 5030 udp is not allowed on that workstation the call won't go through. I do not want any kind of P2P calls. I want all the SIP audio, video, XMPP sessions to go through the PBX machine.

Is it possible to force jitsi to do this, disable ICE/STUN

ICE can be switched on/off for a specific account by ticking/unticking
the "Use ICE" checkbox under the "ICE" tab in the account preferences.

Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]


#4

Hi Toney

What are those "bogon addresses" ? I am curious from privacy point of view.

thanks

···

19.08.2014, 17:42, "Toney Mareo" <halflife4@gmx.com>:

Hello

First of all to be honest, I doubt that what you just said disables it completely. Jitsi will still try to send out all kind of wierd packets on start to bogon addresses. Secondly there is no such option in the Android client for SIP only for XMPP (Jabber), what's working so I don't care about that.

Sent:�Monday, August 18, 2014 at 3:06 PM
From:�"Boris Grozev" <boris@jitsi.org>
To:�"Jitsi Users" <users@jitsi.org>
Subject:�Re: [jitsi-users] Completely disabling STUN/ICE
On 18/08/14 15:46, Toney Mareo wrote:

�Hello


#5

Hello

First of all to be honest, I doubt that what you just said disables it

completely.

It really does.

Jitsi will still try to send out all kind of wierd packets on start to

bogon addresses.

Could you please describe the packets that you are seeing and that you
believe shouldn't be sent?

Secondly there is no such option in the Android client for SIP only for

XMPP (Jabber),

We do not support use of ICE (and hence STUN) for SIP.

--sent from my mobile

what's working so I don't care about that.

Sent: Monday, August 18, 2014 at 3:06 PM
From: "Boris Grozev" <boris@jitsi.org>
To: "Jitsi Users" <users@jitsi.org>
Subject: Re: [jitsi-users] Completely disabling STUN/ICE
> Hello
>
> "Why do I see “ICE failed” errors when trying to make calls.
>
> Jitsi implements a number of NAT traversal methods as described here.

In many situations we will be able to setup a call directly between you and
other users"

>
> I have a private Astlinux based pbx with (now only) jitsi clients. I've

been experimenting with pairing a lot of different voip softphones like
ekiga, jitsi, bria, kphone, qutecom, linphone, sipdroid etc. and Jitsi come
out of it the best.

>
> Most of the free softphone clients are lack of the XMPP feature, that

was also main reason why I decided next to Jitsi and please correct me if
I'm wrong but the best is if I use the same VOIP software on all the
clients.

>
> When I was using others like bria which had android counterpart back

then I ran into all kinds of issues like sometimes the voice come through,
sometimes it didn't. Sometimes the first call failed but it set something
up with ICE then the 2nd succeeded. This unexpected behaviour is
intolerable, I was told that this "voip infrastructure" only really stable
with using hardphones, which is just ridicolous.

>
> One thing I noticed about Jitsi is that there is no way to completely

disable STUN/ICE detection, which I think causes most of the problems.
Because how can that be that I setup a pbx, it runs with the same config
since 7 months, the clients run the same jitsi version then all the sudden
calls cannot be made or the voice doesnt go through etc.

>
> The bad quality of ALL voip software (

http://en.wikipedia.org/wiki/Comparison_of_VoIP_software) so pisses me off
that I considering on buying bria for all the computers and mobile devices
and not because it has any extra feature I need but just purely because I
hope it's gonna work Today, next week and all the time.

>
>
> In my setup basically all the voip clients are either connecting from a

private LAN ip range 10.4.x.x or getting there through openvpn with routing
mode from 10.10.x.x, there is no network address translation done anywhere
just pure routing so I do not need any kind of ICE/STUN still it seems that
it's impossible to disable this feature.

>
> For example I have a windows7 box with jitsi which would try to call a

debian workstation. If port 5030 udp is not allowed on that workstation the
call won't go through. I do not want any kind of P2P calls. I want all the
SIP audio, video, XMPP sessions to go through the PBX machine.

>
> Is it possible to force jitsi to do this, disable ICE/STUN

ICE can be switched on/off for a specific account by ticking/unticking
the "Use ICE" checkbox under the "ICE" tab in the account preferences.

Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:

http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]

···

On 19 Aug 2014 3:41 PM, "Toney Mareo" <halflife4@gmx.com> wrote:

On 18/08/14 15:46, Toney Mareo wrote:

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users