[jitsi-users] Client issues


#1

Windows client

The event notification still auto turn back on when receiving IMs. The same thing for the Mac client.

Mac client
It would be nice to have window selector for users with multiple monitors

Recent twitch attacks.

Greetings,
The recent twitch attacks have been a very public and messy situation here in the U.S. What I have noticed is that my Mac sends to be immune to the attack. However I have noticed that the attack piggy backs onto a Jitsi audio / video stream. I have noticed that if I pause the stream the attack no longer is heard. It's been bleeding into the screen sharing feature of Jitsi. I have been looking for a decent pocket sniffer that works with Yosemite so I can submit detailed logs.

Fuzzy
Gamer extraordinaire


#2

Hey Sean,

Windows client

The event notification still auto turn back on when receiving IMs. The same thing for the Mac client.

I don't understand what this means. You have disabled some events from the event configuration window and this is not working?

What events are those?

Mac client
It would be nice to have window selector for users with multiple monitors

I am not sure what this means either. If you have multiple monitors, just put Jitsi on the one where you want it. What's the issue here?

Recent twitch attacks.

Greetings,
The recent twitch attacks have been a very public and messy situation here in the U.S. What I have noticed is that my Mac sends to be immune to the attack. However I have noticed that the attack piggy backs onto a Jitsi audio / video stream. I have noticed that if I pause the stream the attack no longer is heard. It's been bleeding into the screen sharing feature of Jitsi. I have been looking for a decent pocket sniffer that works with Yosemite so I can submit detailed logs.

I am awfully sorry, but this one also leaves me baffled. Are you saying that you are worried your computer sends packets as part of a DDoS attack and those packets are leaving out of the same source ports as the Jitsi media but are going to a different destination?

Could you please let us know how you reached this conclusion?

As for the packet sniffer: isn't Wireshark working on Yosemite?

Emil

···

On 20.10.14, 14:49, Sean Richards wrote:

--
https://jitsi.org


#3

Hi,

The event notification still auto turn back on when receiving IMs.
The same thing for the Mac client.

same here. If you turn off all pop-up notifications it will be ignored next time you receiver a message.
After receiving the first message it is also automatically re-enabled in the settings.

Jitsi Version 2.5.5304 (Windows) with German language settings.

- lulkas


#4

Yes, correct. Every time I log back into my computer that setting reverts back to default.

Fuzzy
Gamer extraordinaire

···

On Oct 20, 2014, at 11:22 AM, Emil Ivov <emcho@jitsi.org> wrote:

On 20.10.14, 16:00, Lukas Rademacher wrote:
Hi,

The event notification still auto turn back on when receiving IMs.
The same thing for the Mac client.

same here. If you turn off all pop-up notifications it will be ignored
next time you receiver a message.
After receiving the first message it is also automatically re-enabled in
the settings.

Jitsi Version 2.5.5304 (Windows) with German language settings.

Just to be clear. You disable this in Preferences->Events, then you scroll to "Incoming Mesage" then you click on the small balloon with the three dots so that it disappears as on the screenshot, right?

Emil

--
https://jitsi.org
<Screen Shot 2014-10-20 at 17.22.25.png>
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

I am just a regular user. This behavior happens for both Windows and Mac. Every system I have installed it on it does this. When I get home from work I will get you the requested information

Fuzzy
Gamer extraordinaire

···

On Oct 20, 2014, at 11:37 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:

On 2014-10-20 22:25, Sean Richards wrote:
Yes, correct. Every time I log back into my computer that setting reverts
back to default.

Are you (or perhaps your company?) using the provisioning service?

I just tried to change that setting and it is persisted for me on the 2.4
stable. The code behind the event system hasn't been changed for ages, so I
don't see why this wouldn't work for you. Can you please send us the lines
of your configuration file (sip-communicator.properties, see [1] to find
that) that start with
net.java.sip.communicator.impl.notifications.eventType, before you make a
change in the events GUI, directly afterwards, and then again after a
restart of Jitsi?

Fuzzy
Gamer extraordinaire

Ingo

[1] https://jitsi.org/Documentation/FAQ#jitsi-home

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

I am running both Windows and Mac. I get the same results for both.

Fuzzy
Gamer extraordinaire

···

On Oct 20, 2014, at 11:53 AM, Emil Ivov <emcho@jitsi.org> wrote:

You say that you are running Windows right? Could it be that something is rewriting your configuration file?

Could you please open the property editor in the advanced configuration tab and look up "IncomingMessage" (see attachment), and then copy, in the filter, the numbers you see after "eventType" in the property name. In the screenshot this looks like this:

eventType1396103880362

The property that says whether this is enabled will start the same way but will and with actionType<someothernumber>.enabled and will then have a value of "true" or "false depending on whether it is enabled or not.

(Note that you need <someothernumber> to match the one used for PopupMessageAction and NOT some other action).

You can also look up the same property in sip-communicator.properties

OK so once you've jumped through all these hoops (thanks for that) and managed to locate the name of the property in the config file you can track it's state while, after and before you run Jitsi.

This way you would be able to clearly know exactly when the value of the property changes and that will help diagnose the problem.

Sounds manageable?

Emil

On 20.10.14, 17:25, Sean Richards wrote:
Yes, correct. Every time I log back into my computer that setting reverts back to default.

Fuzzy
Gamer extraordinaire

On Oct 20, 2014, at 11:22 AM, Emil Ivov <emcho@jitsi.org> wrote:

On 20.10.14, 16:00, Lukas Rademacher wrote:
Hi,

The event notification still auto turn back on when receiving IMs.
The same thing for the Mac client.

same here. If you turn off all pop-up notifications it will be ignored
next time you receiver a message.
After receiving the first message it is also automatically re-enabled in
the settings.

Jitsi Version 2.5.5304 (Windows) with German language settings.

Just to be clear. You disable this in Preferences->Events, then you scroll to "Incoming Mesage" then you click on the small balloon with the three dots so that it disappears as on the screenshot, right?

Emil

--
https://jitsi.org
<Screen Shot 2014-10-20 at 17.22.25.png>
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org
<Screen Shot 2014-10-20 at 17.50.29.png>
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Just to be clear. You disable this in Preferences->Events, then you scroll to "Incoming Mesage" then you click on the small balloon with the three dots so that it disappears as on the screenshot, right?

Emil

···

On 20.10.14, 16:00, Lukas Rademacher wrote:

Hi,

The event notification still auto turn back on when receiving IMs.
The same thing for the Mac client.

same here. If you turn off all pop-up notifications it will be ignored
next time you receiver a message.
After receiving the first message it is also automatically re-enabled in
the settings.

Jitsi Version 2.5.5304 (Windows) with German language settings.

--
https://jitsi.org


#8

You say that you are running Windows right? Could it be that something is rewriting your configuration file?

Could you please open the property editor in the advanced configuration tab and look up "IncomingMessage" (see attachment), and then copy, in the filter, the numbers you see after "eventType" in the property name. In the creenshot this looks like this:

eventType1396103880362

The property that says whether this is enabled will start the same way but will and with actionType<someothernumber>.enabled and will then have a value of "true" or "false depending on whether it is enabled or not.

(Note that you need <someothernumber> to match the one used for PopupMessageAction and NOT some other action).

You can also look up the same property in sip-communicator.properties

OK so once you've jumped through all these hoops (thanks for that) and managed to locate the name of the property in the config file you can track it's state while, after and before you run Jitsi.

This way you would be able to clearly know exactly when the value of the property changes and that will help diagnose the problem.

Sounds manageable?

Emil

···

On 20.10.14, 17:25, Sean Richards wrote:

Yes, correct. Every time I log back into my computer that setting reverts back to default.

Fuzzy
Gamer extraordinaire

On Oct 20, 2014, at 11:22 AM, Emil Ivov <emcho@jitsi.org> wrote:

On 20.10.14, 16:00, Lukas Rademacher wrote:
Hi,

The event notification still auto turn back on when receiving IMs.
The same thing for the Mac client.

same here. If you turn off all pop-up notifications it will be ignored
next time you receiver a message.
After receiving the first message it is also automatically re-enabled in
the settings.

Jitsi Version 2.5.5304 (Windows) with German language settings.

Just to be clear. You disable this in Preferences->Events, then you scroll to "Incoming Mesage" then you click on the small balloon with the three dots so that it disappears as on the screenshot, right?

Emil

--
https://jitsi.org
<Screen Shot 2014-10-20 at 17.22.25.png>
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#9

You say that you are running Windows right? Could it be that something is rewriting your configuration file?

Could you please open the property editor in the advanced configuration tab and look up "IncomingMessage" (see attachment), and then copy, in the filter, the numbers you see after "eventType" in the property name. In the screenshot this looks like this:

eventType1396103880362

The property that says whether this is enabled will start the same way but will and with actionType<someothernumber>.enabled and will then have a value of "true" or "false depending on whether it is enabled or not.

(Note that you need <someothernumber> to match the one used for PopupMessageAction and NOT some other action).

You can also look up the same property in sip-communicator.properties

OK so once you've jumped through all these hoops (thanks for that) and managed to locate the name of the property in the config file you can track it's state while, after and before you run Jitsi.

This way you would be able to clearly know exactly when the value of the property changes and that will help diagnose the problem.

Sounds manageable?

Emil

···

On 20.10.14, 17:25, Sean Richards wrote:

Yes, correct. Every time I log back into my computer that setting reverts back to default.

Fuzzy
Gamer extraordinaire

On Oct 20, 2014, at 11:22 AM, Emil Ivov <emcho@jitsi.org> wrote:

On 20.10.14, 16:00, Lukas Rademacher wrote:
Hi,

The event notification still auto turn back on when receiving IMs.
The same thing for the Mac client.

same here. If you turn off all pop-up notifications it will be ignored
next time you receiver a message.
After receiving the first message it is also automatically re-enabled in
the settings.

Jitsi Version 2.5.5304 (Windows) with German language settings.

Just to be clear. You disable this in Preferences->Events, then you scroll to "Incoming Mesage" then you click on the small balloon with the three dots so that it disappears as on the screenshot, right?

Emil

--
https://jitsi.org
<Screen Shot 2014-10-20 at 17.22.25.png>
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#10

Yes, correct. Every time I log back into my computer that setting reverts
back to default.

Are you (or perhaps your company?) using the provisioning service?

I just tried to change that setting and it is persisted for me on the 2.4
stable. The code behind the event system hasn't been changed for ages, so I
don't see why this wouldn't work for you. Can you please send us the lines
of your configuration file (sip-communicator.properties, see [1] to find
that) that start with
net.java.sip.communicator.impl.notifications.eventType, before you make a
change in the events GUI, directly afterwards, and then again after a
restart of Jitsi?

Fuzzy
Gamer extraordinaire

Ingo

[1] https://jitsi.org/Documentation/FAQ#jitsi-home

···

On 2014-10-20 22:25, Sean Richards wrote: