[jitsi-users] Changing default Payload Types used by Jitsi/Jigasi


#1

One SIP client that I am testing with with does not set the Opus send payload type correctly to match what Jitsi is expecting and the result is one way audio despite bi-directional RTP.
The solution would be to change the payload type of Jigasi to match that of the buggy SIP client.

Is there a config file setting that can achieve this or at least allow the starting point of the dynamic payload types?
Worse case I suppose is to rebuild the libs to patch this on the Jigasi side ...

Thanks,
ToM


#2

Hi,

there is a property to override this. Here is an example used for speex:
net.java.sip.communicator.impl.neomedia.dynamicPayloadTypePreferences.99={clockRate\:32000,encoding\:speex}
But not sure about it, as it may affect both sides you can fix the sip
side, but brake the other, just experiment and see the results.

Regards
damencho

ยทยทยท

On Thu, Nov 12, 2015 at 2:41 AM, Tom McGuinness <tommcguinness@maaii.com> wrote:

One SIP client that I am testing with with does not set the Opus send payload type correctly to match what Jitsi is expecting and the result is one way audio despite bi-directional RTP.
The solution would be to change the payload type of Jigasi to match that of the buggy SIP client.

Is there a config file setting that can achieve this or at least allow the starting point of the dynamic payload types?
Worse case I suppose is to rebuild the libs to patch this on the Jigasi side ...

Thanks,
ToM
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users