[jitsi-users] Can't add a contact ("add" greyed out)


#1

Hi Jitsi folks,

Thanks for the great software, I use Jitsi many times a day!

Unfortunately I'm never been able to add contacts on my Jitsi Desktop client,
which means I can’t get Jitsi to tell me the name of who is calling. I
click "Add new contact", enter a number and name, but the "add" button
remains deactivated. It’s been like this for as long as I’ve been using
Jitsi - maybe a year or two - I just hadn’t made time to report the
issue.

I’m running Jitsi Desktop 2.10.5550 on Trisquel GNU/Linux with a single
SIP account.

(I’m reporting this here as the CONTRIBUTING.md doc advises to start my
emailing the list rather than adding to the bug tracker directly.)

Regards,
Ben

···

--
Ben Sturmfels

Sturm - Software Engineering
www.sturm.com.au
(03) 9024 2467


#2

PS. The mailing list search function seems to not be working for me. The
following URL times out trying to connect to shish-e.org:

http://lists.jitsi.org/swish_mm?query=contact&submit=Search!&metaname=swishdefault&sort=swishrank


#3

I've also just tried the nightly build 2.11.5601 and still see the add
button deactivated.

Regards,
Ben

···

On Wed, 08 Nov 2017, Ben Sturmfels wrote:

I’m running Jitsi Desktop 2.10.5550 on Trisquel GNU/Linux with a single
SIP account.


#4

Hi,

If you open your sip account settings, under Presence tab, do you have
Contactlist Options Type selected to local?
Works fine here. If you have that setting, do you have any exceptions
in the logs?

Regards
damencho

···

On Tue, Nov 7, 2017 at 8:24 PM, Ben Sturmfels <ben@sturm.com.au> wrote:

On Wed, 08 Nov 2017, Ben Sturmfels wrote:

I’m running Jitsi Desktop 2.10.5550 on Trisquel GNU/Linux with a single
SIP account.

I've also just tried the nightly build 2.11.5601 and still see the add
button deactivated.

Regards,
Ben

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi Damencho,

Yes "local" is selected. I'm running `jitsi --debug` but only see a
dozen or so audio related messages on the console.

Fwiw, I spotted this Stack Overflow post from an Ubuntu user facing a
similar issue:
https://stackoverflow.com/questions/46902582/unable-to-add-contacts-to-jitsi

Regards,
Ben

···

On Wed, 08 Nov 2017, Damian Minkov wrote:

Hi,

If you open your sip account settings, under Presence tab, do you have
Contactlist Options Type selected to local?
Works fine here. If you have that setting, do you have any exceptions
in the logs?

Regards
damencho

On Tue, Nov 7, 2017 at 8:24 PM, Ben Sturmfels <ben@sturm.com.au> wrote:

On Wed, 08 Nov 2017, Ben Sturmfels wrote:

I’m running Jitsi Desktop 2.10.5550 on Trisquel GNU/Linux with a single
SIP account.

I've also just tried the nightly build 2.11.5601 and still see the add
button deactivated.

Regards,
Ben

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Ben Sturmfels

Sturm - Software Engineering
www.sturm.com.au
(03) 9024 2467


#6

The add contact dialog should have four input fields, not three as shown in the screenshot on SO (the account dropdown is missing). This is probably because the chosen desktop theme uses an insanely large height for the text input fields, which messes up the entire dialog.
Try resizing the dialog's height (not sure if that's possible) and see if the field starts appearing near the bottom.

Ingo

Freundliche Grüsse,
Ingo Bauersachs

-- Sent from my tablet

···

On 08.11.2017, at 05:54, Ben Sturmfels <ben@sturm.com.au> wrote:

Hi Damencho,

Yes "local" is selected. I'm running `jitsi --debug` but only see a
dozen or so audio related messages on the console.

Fwiw, I spotted this Stack Overflow post from an Ubuntu user facing a
similar issue:
https://stackoverflow.com/questions/46902582/unable-to-add-contacts-to-jitsi

Regards,
Ben

On Wed, 08 Nov 2017, Damian Minkov wrote:

Hi,

If you open your sip account settings, under Presence tab, do you have
Contactlist Options Type selected to local?
Works fine here. If you have that setting, do you have any exceptions
in the logs?

Regards
damencho

On Tue, Nov 7, 2017 at 8:24 PM, Ben Sturmfels <ben@sturm.com.au> wrote:

On Wed, 08 Nov 2017, Ben Sturmfels wrote:

I’m running Jitsi Desktop 2.10.5550 on Trisquel GNU/Linux with a single
SIP account.

I've also just tried the nightly build 2.11.5601 and still see the add
button deactivated.

Regards,
Ben

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Ben Sturmfels

Sturm - Software Engineering
www.sturm.com.au
(03) 9024 2467

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Ah, yes, I'm seeing the same three fields (see attached screenshot). The
dialog isn't resizable, so I tried increasing the height in
AddContactDialog.java and this allowed the account field to show up and
"add" to be enabled.

Shall I create a bug report on GitHub?

Regards,
Ben

···

On 08/11/17 17:17, Ingo Bauersachs wrote:

The add contact dialog should have four input fields, not three as shown in the screenshot on SO (the account dropdown is missing). This is probably because the chosen desktop theme uses an insanely large height for the text input fields, which messes up the entire dialog.
Try resizing the dialog's height (not sure if that's possible) and see if the field starts appearing near the bottom.

Ingo

Freundliche Grüsse,
Ingo Bauersachs

-- Sent from my tablet

On 08.11.2017, at 05:54, Ben Sturmfels <ben@sturm.com.au> wrote:

Hi Damencho,

Yes "local" is selected. I'm running `jitsi --debug` but only see a
dozen or so audio related messages on the console.

Fwiw, I spotted this Stack Overflow post from an Ubuntu user facing a
similar issue:
https://stackoverflow.com/questions/46902582/unable-to-add-contacts-to-jitsi

Regards,
Ben

On Wed, 08 Nov 2017, Damian Minkov wrote:

Hi,

If you open your sip account settings, under Presence tab, do you have
Contactlist Options Type selected to local?
Works fine here. If you have that setting, do you have any exceptions
in the logs?

Regards
damencho

On Tue, Nov 7, 2017 at 8:24 PM, Ben Sturmfels <ben@sturm.com.au> wrote:

On Wed, 08 Nov 2017, Ben Sturmfels wrote:

I’m running Jitsi Desktop 2.10.5550 on Trisquel GNU/Linux with a single
SIP account.

I've also just tried the nightly build 2.11.5601 and still see the add
button deactivated.

Regards,
Ben

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Ben Sturmfels

Sturm - Software Engineering
www.sturm.com.au
(03) 9024 2467

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

This is a theming issue of your desktop manager. The only thing I could do is to make the dialog resizable.
Since you apparantly can deal with Java, a pull request insted of an issue would help.

Ingo

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

On 8 Nov 2017, at 08:12, Ben Sturmfels <ben@sturm.com.au> wrote:

Ah, yes, I'm seeing the same three fields (see attached screenshot). The
dialog isn't resizable, so I tried increasing the height in
AddContactDialog.java and this allowed the account field to show up and
"add" to be enabled.

Shall I create a bug report on GitHub?

Regards,
Ben

On 08/11/17 17:17, Ingo Bauersachs wrote:
The add contact dialog should have four input fields, not three as shown in the screenshot on SO (the account dropdown is missing). This is probably because the chosen desktop theme uses an insanely large height for the text input fields, which messes up the entire dialog.
Try resizing the dialog's height (not sure if that's possible) and see if the field starts appearing near the bottom.

Ingo

Freundliche Grüsse,
Ingo Bauersachs

-- Sent from my tablet

On 08.11.2017, at 05:54, Ben Sturmfels <ben@sturm.com.au> wrote:

Hi Damencho,

Yes "local" is selected. I'm running `jitsi --debug` but only see a
dozen or so audio related messages on the console.

Fwiw, I spotted this Stack Overflow post from an Ubuntu user facing a
similar issue:
https://stackoverflow.com/questions/46902582/unable-to-add-contacts-to-jitsi

Regards,
Ben

On Wed, 08 Nov 2017, Damian Minkov wrote:

Hi,

If you open your sip account settings, under Presence tab, do you have
Contactlist Options Type selected to local?
Works fine here. If you have that setting, do you have any exceptions
in the logs?

Regards
damencho

On Tue, Nov 7, 2017 at 8:24 PM, Ben Sturmfels <ben@sturm.com.au> wrote:

On Wed, 08 Nov 2017, Ben Sturmfels wrote:

I’m running Jitsi Desktop 2.10.5550 on Trisquel GNU/Linux with a single
SIP account.

I've also just tried the nightly build 2.11.5601 and still see the add
button deactivated.

Regards,
Ben

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Ben Sturmfels

Sturm - Software Engineering
www.sturm.com.au
(03) 9024 2467

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

<Screenshot from 2017-11-08 18:05:06.png>
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users