[jitsi-users] camera doesn't work


#1

Hi, I'm using debian wheezy 64bit and jitsi2.2.4603.9615.

Tools/options/video

I only see black screen.
I tried to change resolution to 640x480 instead of auto but nothing changed.

The device is /dev/video0.

I can tell you that camera works fine because with the program "cheese" it
works out of the box with resolution 640x480.

Is there some log I can report?
Any hint?

My laptop is an Asus K52J.

lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev
18)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root
Port (rev 18)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series
Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2
Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High
Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI
Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI
Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI
Express Root Port 3 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI
Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2
Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface
Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4
port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus
Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI
RV710 [Mobility Radeon HD 4500/5100 Series]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV710/730 HDMI
Audio [Radeon HD 4000 series]
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless
Network Adapter (PCI-Express) (rev 01)
05:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
(rev 80)
05:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host
Controller (rev 80)
05:00.3 System peripheral: JMicron Technology Corp. MS Host Controller (rev
80)
05:00.4 System peripheral: JMicron Technology Corp. xD Host Controller (rev
80)
05:00.5 Ethernet controller: JMicron Technology Corp. JMC250 PCI Express
Gigabit Ethernet Controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath
Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath
Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev
05)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)


#2

it is probably related to Debian - I have posted previously similar
issue however with no reply from the Devs.
I am using multiboot with WinXP, Debian 7.1 and Ubuntu 12.04 - on Debian
the camera does not work, dont know the reasons.

PGP.sig (489 Bytes)

···

On 12/14/13 8:54 AM, Valerio Pachera wrote:

Hi, I'm using debian wheezy 64bit and jitsi2.2.4603.9615.

Tools/options/video

I only see black screen.
I tried to change resolution to 640x480 instead of auto but nothing
changed.

The device is /dev/video0.

I can tell you that camera works fine because with the program
"cheese" it works out of the box with resolution 640x480.

Is there some log I can report?
Any hint?

My laptop is an Asus K52J.

lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller
(rev 18)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16
Root Port (rev 18)
00:16.0 Communication controller: Intel Corporation 5 Series/3400
Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset
USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset
High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI
Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI
Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI
Express Root Port 3 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI
Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset
USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC
Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series
Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus
Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee
ATI RV710 [Mobility Radeon HD 4500/5100 Series]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV710/730
HDMI Audio [Radeon HD 4000 series]
03:00.0 Network controller: Atheros Communications Inc. AR9285
Wireless Network Adapter (PCI-Express) (rev 01)
05:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host
Controller (rev 80)
05:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host
Controller (rev 80)
05:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
(rev 80)
05:00.4 System peripheral: JMicron Technology Corp. xD Host Controller
(rev 80)
05:00.5 Ethernet controller: JMicron Technology Corp. JMC250 PCI
Express Gigabit Ethernet Controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath
Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath
Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0
(rev 05)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Here (Debian Wheezy) it works just fine.

···

On Mon, Dec 16, 2013 at 10:55:46AM +0100, Mr.Smith wrote:

it is probably related to Debian - I have posted previously similar
issue however with no reply from the Devs.
I am using multiboot with WinXP, Debian 7.1 and Ubuntu 12.04 - on Debian
the camera does not work, dont know the reasons.

--
Tzafrir Cohen | tzafrir@jabber.org | VIM is
http://tzafrir.org.il | | a Mutt's
tzafrir@cohens.org.il | | best
tzafrir@debian.org | | friend