[jitsi-users] CallControlMucActivator


#1

Hi!

I have not working conference calls.
Tet-a-tet works fine, but not conference.

Installation from github sourses on FreeBSD in a jail
(jitsi meet, videobridge, jicofo, jigasi, prosody, nginx)

I've found in jigasi log:
WARNING: [12] org.jitsi.jigasi.xmpp.CallControlMucActivator.start().95 MUC
call control disabled.

jigasi/src/main/java/org/jitsi/jigasi/xmpp/CallControlMucActivator.java
has the following:
/**
* A property to enable or disable muc call control, disabled by default.
*/
private static final String BREWERY_ENABLED_PROP =
"org.jitsi.jigasi.BREWERY_ENABLED";

I'm not familiar with java. How do i need to change the code to enable this
functionality?

Thanks in advance!


#2

Hi,

Please, do not cross-post in both lists, choosing the more appropriate
one is enough.

Can you give more details about the problem you have? "I have not
working conference calls. Tet-a-tet works fine ..." for me means that
you have no problem with peer-to-peer, two participants, but adding
third and it doesn't work.
The problem you have can be related to jvb not configured correctly (a
common mistake when having jvb behind nat) or problem with jicofo
connecting to prosody client port and joining the muc (usual problems
with auth.domain certificates). This problem has nothing to do with
jigasi, nor with CallControlMucActivator. CallControlMuc is just
another method to configure jigasi, to use a xmpp muc for controlling
multiple jigasis, rather than using the xmpp component.

Are you running jvb on a machine without a public address, if so have
you configured this:
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration
?
Do you have any errors in the jicofo logs?

Regards
damencho

···

On Mon, Jan 22, 2018 at 2:59 AM, Aleksei Kostiushenko <aleksei.kostiushenko@gmail.com> wrote:

Hi!

I have not working conference calls.
Tet-a-tet works fine, but not conference.

Installation from github sourses on FreeBSD in a jail
(jitsi meet, videobridge, jicofo, jigasi, prosody, nginx)

I've found in jigasi log:
WARNING: [12] org.jitsi.jigasi.xmpp.CallControlMucActivator.start().95 MUC
call control disabled.

jigasi/src/main/java/org/jitsi/jigasi/xmpp/CallControlMucActivator.java
has the following:
/**
* A property to enable or disable muc call control, disabled by default.
*/
private static final String BREWERY_ENABLED_PROP =
"org.jitsi.jigasi.BREWERY_ENABLED";

I'm not familiar with java. How do i need to change the code to enable this
functionality?

Thanks in advance!

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Hi Aleksei,

Hi!

I have not working conference calls.
Tet-a-tet works fine, but not conference.

Installation from github sourses on FreeBSD in a jail
(jitsi meet, videobridge, jicofo, jigasi, prosody, nginx)

I've found in jigasi log:
WARNING: [12] org.jitsi.jigasi.xmpp.CallControlMucActivator.start().95 MUC call control disabled.

If a conference (3 or more participants) does not work, you should resolve that problem first and then get jigasi. Jigasi is only used for calls to SIP and transcription. Check the logs of jitsi-videobridge first.

jigasi/src/main/java/org/jitsi/jigasi/xmpp/CallControlMucActivator.java
has the following:
/**
* A property to enable or disable muc call control, disabled by default.
*/
private static final String BREWERY_ENABLED_PROP = "org.jitsi.jigasi.BREWERY_ENABLED";

I'm not familiar with java. How do i need to change the code to enable this functionality?

No, you can add a line to the jigasi configuration file. Look at the start of the logs to see which file is used (the file name is probably "sip-communicator.properties").

Regards,
Boris

···

On 22/01/2018 02:59, Aleksei Kostiushenko wrote:


#4

Hi!

for me means that you have no problem with peer-to-peer, two

participants, but adding third and it doesn't work.

That's it. Adding 3-rd makes only messaging are working but video comes to
black screen.
And in general the target is to fix this issue.

Jicofo log has one warning:
Jicofo 2018-01-22 20:06:07.073 WARNING: [27]
org.jitsi.jicofo.BridgeSelector.addJvbAddress().253 No pub-sub node mapped
for jitsi-videobridge.jvb.domain.com

JVB log see in attachment (has warnings about missed classes)
I have network without NAT, with real IP address.

Also in attachment prosody config

prosody.cfg.lua.txt (9.78 KB)

jvb.log (57.2 KB)

···

2018-01-22 18:32 GMT+03:00 Damian Minkov <damencho@jitsi.org>:

Hi,

Please, do not cross-post in both lists, choosing the more appropriate
one is enough.

Can you give more details about the problem you have? "I have not
working conference calls. Tet-a-tet works fine ..." for me means that
you have no problem with peer-to-peer, two participants, but adding
third and it doesn't work.
The problem you have can be related to jvb not configured correctly (a
common mistake when having jvb behind nat) or problem with jicofo
connecting to prosody client port and joining the muc (usual problems
with auth.domain certificates). This problem has nothing to do with
jigasi, nor with CallControlMucActivator. CallControlMuc is just
another method to configure jigasi, to use a xmpp muc for controlling
multiple jigasis, rather than using the xmpp component.

Are you running jvb on a machine without a public address, if so have
you configured this:
https://github.com/jitsi/jitsi-meet/blob/master/doc/
quick-install.md#advanced-configuration
?
Do you have any errors in the jicofo logs?

Regards
damencho

On Mon, Jan 22, 2018 at 2:59 AM, Aleksei Kostiushenko > <aleksei.kostiushenko@gmail.com> wrote:
> Hi!
>
> I have not working conference calls.
> Tet-a-tet works fine, but not conference.
>
> Installation from github sourses on FreeBSD in a jail
> (jitsi meet, videobridge, jicofo, jigasi, prosody, nginx)
>
> I've found in jigasi log:
> WARNING: [12] org.jitsi.jigasi.xmpp.CallControlMucActivator.start().95
MUC
> call control disabled.
>
> jigasi/src/main/java/org/jitsi/jigasi/xmpp/CallControlMucActivator.java
> has the following:
> /**
> * A property to enable or disable muc call control, disabled by default.
> */
> private static final String BREWERY_ENABLED_PROP =
> "org.jitsi.jigasi.BREWERY_ENABLED";
>
> I'm not familiar with java. How do i need to change the code to enable
this
> functionality?
>
> Thanks in advance!
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Thanks a lot for your notice about sip-communicator.properties
It is helped me to figure out that jigasi not a key factor in my problem.

I've sent in other email to users@jitsi.org with attached jvb.log and
prosody config with hope to find right way to solution.

···

2018-01-22 20:33 GMT+03:00 Boris Grozev <boris@jitsi.org>:

Hi Aleksei,

On 22/01/2018 02:59, Aleksei Kostiushenko wrote:

Hi!

I have not working conference calls.
Tet-a-tet works fine, but not conference.

Installation from github sourses on FreeBSD in a jail
(jitsi meet, videobridge, jicofo, jigasi, prosody, nginx)

I've found in jigasi log:
WARNING: [12] org.jitsi.jigasi.xmpp.CallControlMucActivator.start().95
MUC call control disabled.

If a conference (3 or more participants) does not work, you should resolve
that problem first and then get jigasi. Jigasi is only used for calls to
SIP and transcription. Check the logs of jitsi-videobridge first.

jigasi/src/main/java/org/jitsi/jigasi/xmpp/CallControlMucActivator.java
has the following:
/**
  * A property to enable or disable muc call control, disabled by default.
  */
private static final String BREWERY_ENABLED_PROP =
"org.jitsi.jigasi.BREWERY_ENABLED";

I'm not familiar with java. How do i need to change the code to enable
this functionality?

No, you can add a line to the jigasi configuration file. Look at the start
of the logs to see which file is used (the file name is probably
"sip-communicator.properties").

Regards,
Boris