[jitsi-users] callcontrol Component not connected


#1

Hi All,

I am trying to connect jitsi-meet <---> jigasi <----> pbx.

jigasi is installed from debain stable, and peer is connected to PBX and I
can see it online and OPTIONS packet flowing.

Also when tried to route call from PBX to Jigasi I can see call landing on
Jigasi server in jigasi/logs with the required header.

Earlier added callcontrol xmpp connection in prosody and restarted I get
the following bouncing error, which seems to be the reason of disconnection
between components.

*Log:*
Jun 14 03:52:28 callcontrol.xmpp.my-domain.com:component warn *Component
not connected*, bouncing error for: <iq id='O17WJ-1418915' type='get' to='
*callcontrol*.xmpp.my-domain.com' from='
focus@auth.xmpp.my-domain.com/focus8328552234658234'>

Please advise. thanks

Regards,
JSZ


#2

Hi,

Have you checked jigasi logs for any errors?

Regards
damencho

···

On Wed, Jun 14, 2017 at 1:26 AM, JSZ <jitterbuffer@gmail.com> wrote:

Hi All,

I am trying to connect jitsi-meet <---> jigasi <----> pbx.

jigasi is installed from debain stable, and peer is connected to PBX and I
can see it online and OPTIONS packet flowing.

Also when tried to route call from PBX to Jigasi I can see call landing on
Jigasi server in jigasi/logs with the required header.

Earlier added callcontrol xmpp connection in prosody and restarted I get the
following bouncing error, which seems to be the reason of disconnection
between components.

Log:

Jun 14 03:52:28 callcontrol.xmpp.my-domain.com:component warn Component
not connected, bouncing error for: <iq id='O17WJ-1418915' type='get'
to='callcontrol.xmpp.my-domain.com'
from='focus@auth.xmpp.my-domain.com/focus8328552234658234'>

Please advise. thanks

Regards,
JSZ

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi damencho,

Thanks for replying. The connection error was due to localhost vs actual
domain missing, got it fixed.

But now I am getting this error for an incoming call to jigasi. Can you
confirm if this *RegistrationState=Connection Failed* is due to SIP trunk
with PBX or registering in JVB? I do see jigasi peer online in PBX.

*Jigasi Logs*

2017-06-14 15:54:57.687 INFO: [50]
impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using
proxy 54.X.X.X:5060/UDP as hop instead of an address resolved by the SIP
router

2017-06-14 15:54:57.689 INFO: [263]
impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack:
Setting SIPMessage peerPacketSource to: /54.X.X.X:5060

2017-06-14 15:54:58.726 INFO: [264]
impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack:
Setting SIPMessage peerPacketSource to: /54.X.X.X:5060

2017-06-14 15:54:58.728 INFO: [264]
org.jitsi.jigasi.SipGateway.incomingCallReceived().302 Incoming call
received...

2017-06-14 15:54:58.728 INFO: [265]
org.jitsi.jigasi.GatewaySession.run().891 Wait thread cancelled

2017-06-14 15:54:58.730 INFO: [264]
org.jitsi.jigasi.JvbConference.setXmppProvider().501
15ca750a328@xmpp.my-domain.com will use ProtocolProviderServiceJabberImpl(
15ca750a328@xmpp.my-domain.com (Jabber))

2017-06-14 15:54:58.736 INFO: [266]
org.jitsi.jigasi.JvbConference.registrationStateChanged().540 XMPP (
15ca750a328@xmpp.my-domain.com): RegistrationStateChangeEvent[
oldState=Unregistered; newState=*RegistrationState=Connection Failed*;
reasonCode=8; reason=null]

Thanks

Regards,
JSZ

···

On Wed, Jun 14, 2017 at 6:54 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Have you checked jigasi logs for any errors?

Regards
damencho

On Wed, Jun 14, 2017 at 1:26 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Hi All,
>
> I am trying to connect jitsi-meet <---> jigasi <----> pbx.
>
> jigasi is installed from debain stable, and peer is connected to PBX and
I
> can see it online and OPTIONS packet flowing.
>
> Also when tried to route call from PBX to Jigasi I can see call landing
on
> Jigasi server in jigasi/logs with the required header.
>
> Earlier added callcontrol xmpp connection in prosody and restarted I get
the
> following bouncing error, which seems to be the reason of disconnection
> between components.
>
> Log:
>
> Jun 14 03:52:28 callcontrol.xmpp.my-domain.com:component warn
Component
> not connected, bouncing error for: <iq id='O17WJ-1418915' type='get'
> to='callcontrol.xmpp.my-domain.com'
> from='focus@auth.xmpp.my-domain.com/focus8328552234658234'>
>
>
> Please advise. thanks
>
>
> Regards,
> JSZ
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

This is the anonymous jigasi user that tries to join the room is
failing to connect, do you have authentication enabled for your
xmpp.my-domain?

···

On Wed, Jun 14, 2017 at 11:22 AM, JSZ <jitterbuffer@gmail.com> wrote:

Hi damencho,

Thanks for replying. The connection error was due to localhost vs actual
domain missing, got it fixed.

But now I am getting this error for an incoming call to jigasi. Can you
confirm if this RegistrationState=Connection Failed is due to SIP trunk with
PBX or registering in JVB? I do see jigasi peer online in PBX.

Jigasi Logs

2017-06-14 15:54:57.687 INFO: [50]
impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode, using
proxy 54.X.X.X:5060/UDP as hop instead of an address resolved by the SIP
router

2017-06-14 15:54:57.689 INFO: [263]
impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack:
Setting SIPMessage peerPacketSource to: /54.X.X.X:5060

2017-06-14 15:54:58.726 INFO: [264]
impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack:
Setting SIPMessage peerPacketSource to: /54.X.X.X:5060

2017-06-14 15:54:58.728 INFO: [264]
org.jitsi.jigasi.SipGateway.incomingCallReceived().302 Incoming call
received...

2017-06-14 15:54:58.728 INFO: [265]
org.jitsi.jigasi.GatewaySession.run().891 Wait thread cancelled

2017-06-14 15:54:58.730 INFO: [264]
org.jitsi.jigasi.JvbConference.setXmppProvider().501
15ca750a328@xmpp.my-domain.com will use
ProtocolProviderServiceJabberImpl(15ca750a328@xmpp.my-domain.com (Jabber))

2017-06-14 15:54:58.736 INFO: [266]
org.jitsi.jigasi.JvbConference.registrationStateChanged().540 XMPP
(15ca750a328@xmpp.my-domain.com): RegistrationStateChangeEvent[
oldState=Unregistered; newState=RegistrationState=Connection Failed;
reasonCode=8; reason=null]

Thanks

Regards,
JSZ

On Wed, Jun 14, 2017 at 6:54 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Have you checked jigasi logs for any errors?

Regards
damencho

On Wed, Jun 14, 2017 at 1:26 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Hi All,
>
> I am trying to connect jitsi-meet <---> jigasi <----> pbx.
>
> jigasi is installed from debain stable, and peer is connected to PBX and
> I
> can see it online and OPTIONS packet flowing.
>
> Also when tried to route call from PBX to Jigasi I can see call landing
> on
> Jigasi server in jigasi/logs with the required header.
>
> Earlier added callcontrol xmpp connection in prosody and restarted I get
> the
> following bouncing error, which seems to be the reason of disconnection
> between components.
>
> Log:
>
> Jun 14 03:52:28 callcontrol.xmpp.my-domain.com:component warn
> Component
> not connected, bouncing error for: <iq id='O17WJ-1418915' type='get'
> to='callcontrol.xmpp.my-domain.com'
> from='focus@auth.xmpp.my-domain.com/focus8328552234658234'>
>
>
> Please advise. thanks
>
>
> Regards,
> JSZ
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Yes, I currently have authentication = "anonymous". Would it not work in
general case for anonymous case? or is there are different approach?

I do eventually have to make it non-anonymous, but afterwards.

···

On Wed, Jun 14, 2017 at 9:38 PM, Damian Minkov <damencho@jitsi.org> wrote:

This is the anonymous jigasi user that tries to join the room is
failing to connect, do you have authentication enabled for your
xmpp.my-domain?

On Wed, Jun 14, 2017 at 11:22 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Hi damencho,
>
> Thanks for replying. The connection error was due to localhost vs actual
> domain missing, got it fixed.
>
> But now I am getting this error for an incoming call to jigasi. Can you
> confirm if this RegistrationState=Connection Failed is due to SIP trunk
with
> PBX or registering in JVB? I do see jigasi peer online in PBX.
>
>
> Jigasi Logs
>
> 2017-06-14 15:54:57.687 INFO: [50]
> impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode,
using
> proxy 54.X.X.X:5060/UDP as hop instead of an address resolved by the SIP
> router
>
> 2017-06-14 15:54:57.689 INFO: [263]
> impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack:
> Setting SIPMessage peerPacketSource to: /54.X.X.X:5060
>
> 2017-06-14 15:54:58.726 INFO: [264]
> impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack:
> Setting SIPMessage peerPacketSource to: /54.X.X.X:5060
>
> 2017-06-14 15:54:58.728 INFO: [264]
> org.jitsi.jigasi.SipGateway.incomingCallReceived().302 Incoming call
> received...
>
> 2017-06-14 15:54:58.728 INFO: [265]
> org.jitsi.jigasi.GatewaySession.run().891 Wait thread cancelled
>
> 2017-06-14 15:54:58.730 INFO: [264]
> org.jitsi.jigasi.JvbConference.setXmppProvider().501
> 15ca750a328@xmpp.my-domain.com will use
> ProtocolProviderServiceJabberImpl(15ca750a328@xmpp.my-domain.com
(Jabber))
>
> 2017-06-14 15:54:58.736 INFO: [266]
> org.jitsi.jigasi.JvbConference.registrationStateChanged().540 XMPP
> (15ca750a328@xmpp.my-domain.com): RegistrationStateChangeEvent[
> oldState=Unregistered; newState=RegistrationState=Connection Failed;
> reasonCode=8; reason=null]
>
>
> Thanks
>
>
> Regards,
> JSZ
>
> On Wed, Jun 14, 2017 at 6:54 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>
>> Hi,
>>
>> Have you checked jigasi logs for any errors?
>>
>> Regards
>> damencho
>>
>> On Wed, Jun 14, 2017 at 1:26 AM, JSZ <jitterbuffer@gmail.com> wrote:
>> > Hi All,
>> >
>> > I am trying to connect jitsi-meet <---> jigasi <----> pbx.
>> >
>> > jigasi is installed from debain stable, and peer is connected to PBX
and
>> > I
>> > can see it online and OPTIONS packet flowing.
>> >
>> > Also when tried to route call from PBX to Jigasi I can see call
landing
>> > on
>> > Jigasi server in jigasi/logs with the required header.
>> >
>> > Earlier added callcontrol xmpp connection in prosody and restarted I
get
>> > the
>> > following bouncing error, which seems to be the reason of
disconnection
>> > between components.
>> >
>> > Log:
>> >
>> > Jun 14 03:52:28 callcontrol.xmpp.my-domain.com:component warn
>> > Component
>> > not connected, bouncing error for: <iq id='O17WJ-1418915' type='get'
>> > to='callcontrol.xmpp.my-domain.com'
>> > from='focus@auth.xmpp.my-domain.com/focus8328552234658234'>
>> >
>> >
>> > Please advise. thanks
>> >
>> >
>> > Regards,
>> > JSZ
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Well by default is uses anonymous, but when you make it non-anonymous
you should make sure that you have created a user for jigasi and had
configured jigasi to use it.

So I suppose prosody and jigasi are on the same machine, by default
jigasi tries to connect using port 5222 on 127.0.0.1, you can check
that, whether jigasi has access to that port. I don't see in your logs
any exception stack trace, so I'm just guessing what can be the
problem.

···

On Wed, Jun 14, 2017 at 11:57 AM, JSZ <jitterbuffer@gmail.com> wrote:

Yes, I currently have authentication = "anonymous". Would it not work in
general case for anonymous case? or is there are different approach?

I do eventually have to make it non-anonymous, but afterwards.

On Wed, Jun 14, 2017 at 9:38 PM, Damian Minkov <damencho@jitsi.org> wrote:

This is the anonymous jigasi user that tries to join the room is
failing to connect, do you have authentication enabled for your
xmpp.my-domain?

On Wed, Jun 14, 2017 at 11:22 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Hi damencho,
>
> Thanks for replying. The connection error was due to localhost vs actual
> domain missing, got it fixed.
>
> But now I am getting this error for an incoming call to jigasi. Can you
> confirm if this RegistrationState=Connection Failed is due to SIP trunk
> with
> PBX or registering in JVB? I do see jigasi peer online in PBX.
>
>
> Jigasi Logs
>
> 2017-06-14 15:54:57.687 INFO: [50]
> impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode,
> using
> proxy 54.X.X.X:5060/UDP as hop instead of an address resolved by the SIP
> router
>
> 2017-06-14 15:54:57.689 INFO: [263]
> impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack:
> Setting SIPMessage peerPacketSource to: /54.X.X.X:5060
>
> 2017-06-14 15:54:58.726 INFO: [264]
> impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP stack:
> Setting SIPMessage peerPacketSource to: /54.X.X.X:5060
>
> 2017-06-14 15:54:58.728 INFO: [264]
> org.jitsi.jigasi.SipGateway.incomingCallReceived().302 Incoming call
> received...
>
> 2017-06-14 15:54:58.728 INFO: [265]
> org.jitsi.jigasi.GatewaySession.run().891 Wait thread cancelled
>
> 2017-06-14 15:54:58.730 INFO: [264]
> org.jitsi.jigasi.JvbConference.setXmppProvider().501
> 15ca750a328@xmpp.my-domain.com will use
> ProtocolProviderServiceJabberImpl(15ca750a328@xmpp.my-domain.com
> (Jabber))
>
> 2017-06-14 15:54:58.736 INFO: [266]
> org.jitsi.jigasi.JvbConference.registrationStateChanged().540 XMPP
> (15ca750a328@xmpp.my-domain.com): RegistrationStateChangeEvent[
> oldState=Unregistered; newState=RegistrationState=Connection Failed;
> reasonCode=8; reason=null]
>
>
> Thanks
>
>
> Regards,
> JSZ
>
> On Wed, Jun 14, 2017 at 6:54 PM, Damian Minkov <damencho@jitsi.org> >> > wrote:
>>
>> Hi,
>>
>> Have you checked jigasi logs for any errors?
>>
>> Regards
>> damencho
>>
>> On Wed, Jun 14, 2017 at 1:26 AM, JSZ <jitterbuffer@gmail.com> wrote:
>> > Hi All,
>> >
>> > I am trying to connect jitsi-meet <---> jigasi <----> pbx.
>> >
>> > jigasi is installed from debain stable, and peer is connected to PBX
>> > and
>> > I
>> > can see it online and OPTIONS packet flowing.
>> >
>> > Also when tried to route call from PBX to Jigasi I can see call
>> > landing
>> > on
>> > Jigasi server in jigasi/logs with the required header.
>> >
>> > Earlier added callcontrol xmpp connection in prosody and restarted I
>> > get
>> > the
>> > following bouncing error, which seems to be the reason of
>> > disconnection
>> > between components.
>> >
>> > Log:
>> >
>> > Jun 14 03:52:28 callcontrol.xmpp.my-domain.com:component warn
>> > Component
>> > not connected, bouncing error for: <iq id='O17WJ-1418915' type='get'
>> > to='callcontrol.xmpp.my-domain.com'
>> > from='focus@auth.xmpp.my-domain.com/focus8328552234658234'>
>> >
>> >
>> > Please advise. thanks
>> >
>> >
>> > Regards,
>> > JSZ
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

they are on different servers. So I have 3 machines:

1- prosody + jitsi meet
2- videobridge and jigasi
3- jicofo

Jigasi is up, and prosody on it's server is on 5222. Also when I restart
jigasi I see success:

*Jun 14 18:07:23 callcontrol.xmpp.my-domain.com:component info External
component successfully authenticated*

I Re-checked my prosody configs, I have the following should I also change
auth.domain to anonymus as well ?

BTW each component is connected with password and I do have admins = { "
focus@auth.xmpp.my-domain.com" }, I think i am confusing auth domain vs
host domain authentication.

VirtualHost "xmpp.my-domain.com"

        *authentication = "anonymous"*
AND

VirtualHost "auth.xmpp.my-domain.com <http://auth.xmpp1dev.publicvine.com/>"

* authentication = "internal_plain"*

Kindly clarify this one for me. Thanks

···

On Wed, Jun 14, 2017 at 10:45 PM, Damian Minkov <damencho@jitsi.org> wrote:

Well by default is uses anonymous, but when you make it non-anonymous
you should make sure that you have created a user for jigasi and had
configured jigasi to use it.

So I suppose prosody and jigasi are on the same machine, by default
jigasi tries to connect using port 5222 on 127.0.0.1, you can check
that, whether jigasi has access to that port. I don't see in your logs
any exception stack trace, so I'm just guessing what can be the
problem.

On Wed, Jun 14, 2017 at 11:57 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Yes, I currently have authentication = "anonymous". Would it not work in
> general case for anonymous case? or is there are different approach?
>
> I do eventually have to make it non-anonymous, but afterwards.
>
> On Wed, Jun 14, 2017 at 9:38 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>
>> This is the anonymous jigasi user that tries to join the room is
>> failing to connect, do you have authentication enabled for your
>> xmpp.my-domain?
>>
>> On Wed, Jun 14, 2017 at 11:22 AM, JSZ <jitterbuffer@gmail.com> wrote:
>> > Hi damencho,
>> >
>> > Thanks for replying. The connection error was due to localhost vs
actual
>> > domain missing, got it fixed.
>> >
>> > But now I am getting this error for an incoming call to jigasi. Can
you
>> > confirm if this RegistrationState=Connection Failed is due to SIP
trunk
>> > with
>> > PBX or registering in JVB? I do see jigasi peer online in PBX.
>> >
>> >
>> > Jigasi Logs
>> >
>> > 2017-06-14 15:54:57.687 INFO: [50]
>> > impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode,
>> > using
>> > proxy 54.X.X.X:5060/UDP as hop instead of an address resolved by the
SIP
>> > router
>> >
>> > 2017-06-14 15:54:57.689 INFO: [263]
>> > impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP
stack:
>> > Setting SIPMessage peerPacketSource to: /54.X.X.X:5060
>> >
>> > 2017-06-14 15:54:58.726 INFO: [264]
>> > impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP
stack:
>> > Setting SIPMessage peerPacketSource to: /54.X.X.X:5060
>> >
>> > 2017-06-14 15:54:58.728 INFO: [264]
>> > org.jitsi.jigasi.SipGateway.incomingCallReceived().302 Incoming call
>> > received...
>> >
>> > 2017-06-14 15:54:58.728 INFO: [265]
>> > org.jitsi.jigasi.GatewaySession.run().891 Wait thread cancelled
>> >
>> > 2017-06-14 15:54:58.730 INFO: [264]
>> > org.jitsi.jigasi.JvbConference.setXmppProvider().501
>> > 15ca750a328@xmpp.my-domain.com will use
>> > ProtocolProviderServiceJabberImpl(15ca750a328@xmpp.my-domain.com
>> > (Jabber))
>> >
>> > 2017-06-14 15:54:58.736 INFO: [266]
>> > org.jitsi.jigasi.JvbConference.registrationStateChanged().540 XMPP
>> > (15ca750a328@xmpp.my-domain.com): RegistrationStateChangeEvent[
>> > oldState=Unregistered; newState=RegistrationState=Connection Failed;
>> > reasonCode=8; reason=null]
>> >
>> >
>> > Thanks
>> >
>> >
>> > Regards,
>> > JSZ
>> >
>> > On Wed, Jun 14, 2017 at 6:54 PM, Damian Minkov <damencho@jitsi.org> > >> > wrote:
>> >>
>> >> Hi,
>> >>
>> >> Have you checked jigasi logs for any errors?
>> >>
>> >> Regards
>> >> damencho
>> >>
>> >> On Wed, Jun 14, 2017 at 1:26 AM, JSZ <jitterbuffer@gmail.com> wrote:
>> >> > Hi All,
>> >> >
>> >> > I am trying to connect jitsi-meet <---> jigasi <----> pbx.
>> >> >
>> >> > jigasi is installed from debain stable, and peer is connected to
PBX
>> >> > and
>> >> > I
>> >> > can see it online and OPTIONS packet flowing.
>> >> >
>> >> > Also when tried to route call from PBX to Jigasi I can see call
>> >> > landing
>> >> > on
>> >> > Jigasi server in jigasi/logs with the required header.
>> >> >
>> >> > Earlier added callcontrol xmpp connection in prosody and restarted
I
>> >> > get
>> >> > the
>> >> > following bouncing error, which seems to be the reason of
>> >> > disconnection
>> >> > between components.
>> >> >
>> >> > Log:
>> >> >
>> >> > Jun 14 03:52:28 callcontrol.xmpp.my-domain.com:component warn
>> >> > Component
>> >> > not connected, bouncing error for: <iq id='O17WJ-1418915'
type='get'
>> >> > to='callcontrol.xmpp.my-domain.com'
>> >> > from='focus@auth.xmpp.my-domain.com/focus8328552234658234'>
>> >> >
>> >> >
>> >> > Please advise. thanks
>> >> >
>> >> >
>> >> > Regards,
>> >> > JSZ
>> >> >
>> >> > _______________________________________________
>> >> > users mailing list
>> >> > users@jitsi.org
>> >> > Unsubscribe instructions and other list options:
>> >> > http://lists.jitsi.org/mailman/listinfo/users
>> >>
>> >> _______________________________________________
>> >> users mailing list
>> >> users@jitsi.org
>> >> Unsubscribe instructions and other list options:
>> >> http://lists.jitsi.org/mailman/listinfo/users
>> >
>> >
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

So jigasi has to xmpp connections, one is as component that is used
for the controlling part and the other is when joining an actual room.

In your /etc/jitsi/jigasi/sip-communicator.properties files by default you have:
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
You should adjust that ip address to be the address of the prosody and
make sure jigasi can access port 5222.

···

On Wed, Jun 14, 2017 at 1:15 PM, JSZ <jitterbuffer@gmail.com> wrote:

they are on different servers. So I have 3 machines:

1- prosody + jitsi meet
2- videobridge and jigasi
3- jicofo

Jigasi is up, and prosody on it's server is on 5222. Also when I restart
jigasi I see success:

Jun 14 18:07:23 callcontrol.xmpp.my-domain.com:component info External
component successfully authenticated

I Re-checked my prosody configs, I have the following should I also change
auth.domain to anonymus as well ?

BTW each component is connected with password and I do have admins = {
"focus@auth.xmpp.my-domain.com" }, I think i am confusing auth domain vs
host domain authentication.

VirtualHost "xmpp.my-domain.com"

        authentication = "anonymous"

AND

VirtualHost "auth.xmpp.my-domain.com"

    authentication = "internal_plain"

Kindly clarify this one for me. Thanks

On Wed, Jun 14, 2017 at 10:45 PM, Damian Minkov <damencho@jitsi.org> wrote:

Well by default is uses anonymous, but when you make it non-anonymous
you should make sure that you have created a user for jigasi and had
configured jigasi to use it.

So I suppose prosody and jigasi are on the same machine, by default
jigasi tries to connect using port 5222 on 127.0.0.1, you can check
that, whether jigasi has access to that port. I don't see in your logs
any exception stack trace, so I'm just guessing what can be the
problem.

On Wed, Jun 14, 2017 at 11:57 AM, JSZ <jitterbuffer@gmail.com> wrote:
> Yes, I currently have authentication = "anonymous". Would it not work in
> general case for anonymous case? or is there are different approach?
>
> I do eventually have to make it non-anonymous, but afterwards.
>
> On Wed, Jun 14, 2017 at 9:38 PM, Damian Minkov <damencho@jitsi.org> >> > wrote:
>>
>> This is the anonymous jigasi user that tries to join the room is
>> failing to connect, do you have authentication enabled for your
>> xmpp.my-domain?
>>
>> On Wed, Jun 14, 2017 at 11:22 AM, JSZ <jitterbuffer@gmail.com> wrote:
>> > Hi damencho,
>> >
>> > Thanks for replying. The connection error was due to localhost vs
>> > actual
>> > domain missing, got it fixed.
>> >
>> > But now I am getting this error for an incoming call to jigasi. Can
>> > you
>> > confirm if this RegistrationState=Connection Failed is due to SIP
>> > trunk
>> > with
>> > PBX or registering in JVB? I do see jigasi peer online in PBX.
>> >
>> >
>> > Jigasi Logs
>> >
>> > 2017-06-14 15:54:57.687 INFO: [50]
>> > impl.protocol.sip.ProxyRouter.getNextHop().167 Outbound proxy mode,
>> > using
>> > proxy 54.X.X.X:5060/UDP as hop instead of an address resolved by the
>> > SIP
>> > router
>> >
>> > 2017-06-14 15:54:57.689 INFO: [263]
>> > impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP
>> > stack:
>> > Setting SIPMessage peerPacketSource to: /54.X.X.X:5060
>> >
>> > 2017-06-14 15:54:58.726 INFO: [264]
>> > impl.protocol.sip.SipLogger.logInfo().196 Info from the JAIN-SIP
>> > stack:
>> > Setting SIPMessage peerPacketSource to: /54.X.X.X:5060
>> >
>> > 2017-06-14 15:54:58.728 INFO: [264]
>> > org.jitsi.jigasi.SipGateway.incomingCallReceived().302 Incoming call
>> > received...
>> >
>> > 2017-06-14 15:54:58.728 INFO: [265]
>> > org.jitsi.jigasi.GatewaySession.run().891 Wait thread cancelled
>> >
>> > 2017-06-14 15:54:58.730 INFO: [264]
>> > org.jitsi.jigasi.JvbConference.setXmppProvider().501
>> > 15ca750a328@xmpp.my-domain.com will use
>> > ProtocolProviderServiceJabberImpl(15ca750a328@xmpp.my-domain.com
>> > (Jabber))
>> >
>> > 2017-06-14 15:54:58.736 INFO: [266]
>> > org.jitsi.jigasi.JvbConference.registrationStateChanged().540 XMPP
>> > (15ca750a328@xmpp.my-domain.com): RegistrationStateChangeEvent[
>> > oldState=Unregistered; newState=RegistrationState=Connection Failed;
>> > reasonCode=8; reason=null]
>> >
>> >
>> > Thanks
>> >
>> >
>> > Regards,
>> > JSZ
>> >
>> > On Wed, Jun 14, 2017 at 6:54 PM, Damian Minkov <damencho@jitsi.org> >> >> > wrote:
>> >>
>> >> Hi,
>> >>
>> >> Have you checked jigasi logs for any errors?
>> >>
>> >> Regards
>> >> damencho
>> >>
>> >> On Wed, Jun 14, 2017 at 1:26 AM, JSZ <jitterbuffer@gmail.com> wrote:
>> >> > Hi All,
>> >> >
>> >> > I am trying to connect jitsi-meet <---> jigasi <----> pbx.
>> >> >
>> >> > jigasi is installed from debain stable, and peer is connected to
>> >> > PBX
>> >> > and
>> >> > I
>> >> > can see it online and OPTIONS packet flowing.
>> >> >
>> >> > Also when tried to route call from PBX to Jigasi I can see call
>> >> > landing
>> >> > on
>> >> > Jigasi server in jigasi/logs with the required header.
>> >> >
>> >> > Earlier added callcontrol xmpp connection in prosody and restarted
>> >> > I
>> >> > get
>> >> > the
>> >> > following bouncing error, which seems to be the reason of
>> >> > disconnection
>> >> > between components.
>> >> >
>> >> > Log:
>> >> >
>> >> > Jun 14 03:52:28 callcontrol.xmpp.my-domain.com:component warn
>> >> > Component
>> >> > not connected, bouncing error for: <iq id='O17WJ-1418915'
>> >> > type='get'
>> >> > to='callcontrol.xmpp.my-domain.com'
>> >> > from='focus@auth.xmpp.my-domain.com/focus8328552234658234'>
>> >> >
>> >> >
>> >> > Please advise. thanks
>> >> >
>> >> >
>> >> > Regards,
>> >> > JSZ
>> >> >
>> >> > _______________________________________________
>> >> > users mailing list
>> >> > users@jitsi.org
>> >> > Unsubscribe instructions and other list options:
>> >> > http://lists.jitsi.org/mailman/listinfo/users
>> >>
>> >> _______________________________________________
>> >> users mailing list
>> >> users@jitsi.org
>> >> Unsubscribe instructions and other list options:
>> >> http://lists.jitsi.org/mailman/listinfo/users
>> >
>> >
>> >
>> > _______________________________________________
>> > users mailing list
>> > users@jitsi.org
>> > Unsubscribe instructions and other list options:
>> > http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users