[jitsi-users] "Call not secure"


#1

Friends,

I am a newbie so I apologize if this question has already been solved. However, couldn't find a direct answer in my research.

When I am calling a contact, the "secure button" in the caller field is red, and the mouse-over says "call not secure".

Now, I have found an exchange of messages o the user list (see here: http://lists.jitsi.org/pipermail/dev/2013-May/016961.html) where it says that the problem is merely a GUI issue; but they are talking about conference calls.

Could someone enlighten me where I go wrong, if indeed I do something wrong (I have the ZRTP turned to 'Standard')

Thanks much in advance


#2

Which client is your partner using? Not many clients support S/ZRTP

- --
Yannik V�lker

···

Am 22.08.2013 13:03, schrieb haldenwang@posteo.de:

Friends,

I am a newbie so I apologize if this question has already been
solved. However, couldn't find a direct answer in my research.

When I am calling a contact, the "secure button" in the caller
field is red, and the mouse-over says "call not secure".

Now, I have found an exchange of messages o the user list (see
here: http://lists.jitsi.org/pipermail/dev/2013-May/016961.html)
where it says that the problem is merely a GUI issue; but they are
talking about conference calls.

Could someone enlighten me where I go wrong, if indeed I do
something wrong (I have the ZRTP turned to 'Standard')


#3

Thanks for the prompt response, Yannik!

The same client I use: XMPP. This does not go via any chat service but is a direct XMPP account at both ends (via 'File, Add new account' etc)

···

Am 22.08.2013 15:31 schrieb Yannik Völker:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am 22.08.2013 13:03, schrieb haldenwang@posteo.de:

Friends,

I am a newbie so I apologize if this question has already been
solved. However, couldn't find a direct answer in my research.

When I am calling a contact, the "secure button" in the caller
field is red, and the mouse-over says "call not secure".

Now, I have found an exchange of messages o the user list (see
here: http://lists.jitsi.org/pipermail/dev/2013-May/016961.html)
where it says that the problem is merely a GUI issue; but they are
talking about conference calls.

Could someone enlighten me where I go wrong, if indeed I do
something wrong (I have the ZRTP turned to 'Standard')

Which client is your partner using? Not many clients support S/ZRTP

- --
Yannik Völker
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.20 (GNU/Linux)

iQIcBAEBAgAGBQJSFhKUAAoJEDqk81AiCyXKBY8P/jqE3rb90kEWy8VbfHoTDaXX
kfJ6+Ri/e9ciXptz/sacOKfB+EQkm7ELKy/dRK9noY++FoZkqrZxv8oy7isvC8E0
wPsME8DQ4yzJZnIMkfNfvxzv3LxL4buKA3F28+XizO6t+enp7m00kqI88hZpFfoT
Cnyt1BU5KOkpIAq9vwE+cTiq+GwOivjb/TVaCEWQQYGo8tdmzNqXuy8krJbHVBmd
V/7G5oi9Q2BYzmU9Lmwpwaw0a2mQoCNzgp2gkQ9iZ7dDoW0DudOwra7AJGaGjvrV
CQtcxsxGOyobTWykgftg8MbF18FUfRb5L9vmOAhoo6aH23ggRuj9CoIh/Om2f74C
TtS9gkhYiEcqxuaGkFx9pPboKyijFWdpHbQiE1DIHFpEmDTQswEiweOWhb3zypz7
le/E7bzz6acW9SR17Gx/Fi9UsMz+6tczQg7fzEib6HnNGZ9RtJDol+3oXxawMIuQ
rOpwb8SZAyXI29t/PB2eCPNSpbWcey6UIPICJ84U316dpvzFdJ9PZzclZb199Gak
BN/M0iCC8OcfkdZR5zNiiy0lvwLlXtwP7PWk2LLK84+0/lTbL2Tix6TgNKXO9WxL
uglD4MkKKqf6hHmUkOxq2jUSXKe4OcFSOZZDGUhKHEiG+szOsKQBUPcAS9ViZY8t
Jf2Nt1ZKxaNZlgHq6Ofz
=lmCK
-----END PGP SIGNATURE-----

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
~~~~~~~
sent from my smartphone. Layout and paragraph formatting possibly lacking


#4

Thanks for the prompt response, Yannik!

The same client I use: XMPP. This does not go via any chat service but is a direct XMPP account at both ends (via 'File, Add new account' etc)

···

Am 22.08.2013 15:31 schrieb Yannik Völker:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am 22.08.2013 13:03, schrieb haldenwang@posteo.de:

Friends,

I am a newbie so I apologize if this question has already been
solved. However, couldn't find a direct answer in my research.

When I am calling a contact, the "secure button" in the caller
field is red, and the mouse-over says "call not secure".

Now, I have found an exchange of messages o the user list (see
here: http://lists.jitsi.org/pipermail/dev/2013-May/016961.html)
where it says that the problem is merely a GUI issue; but they are
talking about conference calls.

Could someone enlighten me where I go wrong, if indeed I do
something wrong (I have the ZRTP turned to 'Standard')

Which client is your partner using? Not many clients support S/ZRTP

- --
Yannik Völker
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.20 (GNU/Linux)

iQIcBAEBAgAGBQJSFhKUAAoJEDqk81AiCyXKBY8P/jqE3rb90kEWy8VbfHoTDaXX
kfJ6+Ri/e9ciXptz/sacOKfB+EQkm7ELKy/dRK9noY++FoZkqrZxv8oy7isvC8E0
wPsME8DQ4yzJZnIMkfNfvxzv3LxL4buKA3F28+XizO6t+enp7m00kqI88hZpFfoT
Cnyt1BU5KOkpIAq9vwE+cTiq+GwOivjb/TVaCEWQQYGo8tdmzNqXuy8krJbHVBmd
V/7G5oi9Q2BYzmU9Lmwpwaw0a2mQoCNzgp2gkQ9iZ7dDoW0DudOwra7AJGaGjvrV
CQtcxsxGOyobTWykgftg8MbF18FUfRb5L9vmOAhoo6aH23ggRuj9CoIh/Om2f74C
TtS9gkhYiEcqxuaGkFx9pPboKyijFWdpHbQiE1DIHFpEmDTQswEiweOWhb3zypz7
le/E7bzz6acW9SR17Gx/Fi9UsMz+6tczQg7fzEib6HnNGZ9RtJDol+3oXxawMIuQ
rOpwb8SZAyXI29t/PB2eCPNSpbWcey6UIPICJ84U316dpvzFdJ9PZzclZb199Gak
BN/M0iCC8OcfkdZR5zNiiy0lvwLlXtwP7PWk2LLK84+0/lTbL2Tix6TgNKXO9WxL
uglD4MkKKqf6hHmUkOxq2jUSXKe4OcFSOZZDGUhKHEiG+szOsKQBUPcAS9ViZY8t
Jf2Nt1ZKxaNZlgHq6Ofz
=lmCK
-----END PGP SIGNATURE-----

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Thanks for the prompt response, Yannik!

The same client I use: XMPP. This does not go via any chat service but
is a direct XMPP account at both ends (via 'File, Add new account' etc)

XMPP is a protocol, not a client. Jitsi on the other hand is a client (which supports multiple protocols and accounts).

Ingo


#6

Sorry for the confusion.

But then I don't understand the question - both parties are obviously using Jitsi as a client and no 3rd party SW involved

So what can I do in order to make these calls secure? Anything I need to change in the configuration?
MH

···

Am 22.08.2013 16:34 schrieb Ingo Bauersachs:

Thanks for the prompt response, Yannik!

The same client I use: XMPP. This does not go via any chat service but
is a direct XMPP account at both ends (via 'File, Add new account' etc)

XMPP is a protocol, not a client. Jitsi on the other hand is a client
(which supports multiple protocols and accounts).

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Sorry for the confusion.

But then I don't understand the question - both parties are
obviously using Jitsi as a client and no 3rd party SW involved

Exactly that is not obvious, thanks for the clarification.

So what can I do in order to make these calls secure? Anything I
need to change in the configuration?

If you changed something change it back, otherwise please send your logs.

- --
Yannik V�lker

···

Am 22.08.2013 17:16, schrieb haldenwang@posteo.de:


#8

Alright then.

Attached find the log covering the last call with "call not secure" message. It is rather verbose, I'm afraid :slight_smile:

M.H.

jitsi0.log - Copy.2 (73.6 KB)

···

Am 22.08.2013 19:34 schrieb Yannik Völker:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Am 22.08.2013 17:16, schrieb haldenwang@posteo.de:

Sorry for the confusion.

But then I don't understand the question - both parties are
obviously using Jitsi as a client and no 3rd party SW involved

Exactly that is not obvious, thanks for the clarification.

So what can I do in order to make these calls secure? Anything I
need to change in the configuration?

If you changed something change it back, otherwise please send your logs.

- --
Yannik Völker
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.21 (GNU/Linux)

iQIcBAEBAgAGBQJSFkuYAAoJEDqk81AiCyXKosIP/A0AChdCg5IUN1TwsT988NBO
na229G66kgFad5EKSW4WPWblUx2NcrnUtYvB+BZyLDXQo6ZqHnvJ1FafMM6CsNoE
akK5fUkwkGPgvIwdvQSyR7JIxCzdkMai53TiijPhRFa+FMPnBq/15Nxw8KJsTcl/
4YByn5n1qqUsvwTU/aqeM6MXB2wSs1PwDDqPOVSphZlJDBdt9Reivilwq+E9n1my
A4HPfmcHJPrOusGQEdSCzf0v0D0eqflzsPGISj4DI0Sic2xpM3R3uq3uBXLM0/3H
q/J2huwBUOVhesmxX7YyAuL7zzOJU+F4d6vBbLtpLHRBfcNAanEIzHpJEJAIc6U8
9L6RlM5MJs342np2ILm4OFOzfr6SqZPTJDddISgEIy7FDF/bZo/k7e1tFoyGrG8o
dDNh1j340+N/ct65AtJ/ykk226nn0ydALUCuB4kP5nCdFThPAWPPzAhOyYrYKUji
8ZR5iAA9YsAij+041wnGUS0abe257c7FkR+xbrKsBM8IbR2B9Ytixy6HuzcSo5GK
/EliOCy8qcv49T9WLim09mTWPx36DNnHVBBcEGw1Z+8yHDS5bYn5gSb1z0clgkZ7
Anyf0CquDVbG6ReyYKq8tdAsykyz480LIU/gndOEFkiEBRw++HCHOhHk3AbyZQdr
YW16xWlE1SYAbdhwKgWD
=o/hY
-----END PGP SIGNATURE-----

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Alright then.

Attached find the log covering the last call with "call not secure"
message. It is rather verbose, I'm afraid :slight_smile:

The log shows problems with the audio system. Please make sure that you can hear the test sound and see the level bar moving for the mic when you go to Tools->Options->Audio.

You might also try switching the AudioSystem to PortAudio if it doesn't work with WASAPI.

M.H.

Ingo