[jitsi-users] "call not secure" (02)


#1

Sorry, had a wrong subject line. Here again

-------- Originalnachricht --------

Thanks a lot Ingo; I think we are getting somewhere.

1) Audio
Please note that I can hear the other person well; and he me. I also played
with changing from WASAPI to PortAudio. As to the testsound for the mic: my
version does not give me an option for that (only Audio Out; see attached

2) this brings to the "rogue server". We ARE hearing each other well
(sometimes with a little echo, that's all) but the secure button stays red.
What could be an issue is the location of the other party; namely Moscow /
Russia. I wouldn't rule rogue servers in that direction

M.H.

ยทยทยท

++++++++++++++++++++++++++++++++++++++++++++++++

Alright then.

Attached find the log covering the last call with "call not secure"
message. It is rather verbose, I'm afraid :slight_smile:

The log shows problems with the audio system. Please make sure that you can
hear the test sound and see the level bar moving for the mic when you go to
Tools->Options->Audio.

You might also try switching the AudioSystem to PortAudio if it doesn't
work with WASAPI.

M.H.

Ingo

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I'd like to rephrase my question in order to narrow down on this issue.

Here it is:

quote Is there anything in the configuration of Jitsi that must
absolutely be done at both ends (caller and receiver) so that a call
will be secure? unquote

No. By default ZRTP is enabled as an encryption protocol both for SIP and
XMPP. If ZRTP negotiation doesn't succeed, then it is likely that a normal
audio-connection also doesn't work as the media transport between the two
clients cannot be established.
If a call between two ZRTP capable clients stays unencrypted AND you hear
each other, the only thing that comes to mind is a "rogue" server in
between the two clients that blocks ZRTP packets (e.g. for SIP an Asterisk
server that does codec translation).