[jitsi-users] Bug: Severe issues with keyboard layout switching (ignores in Win7, crashes in WinXP SP2)


#1

This is the FIRST time I ever saw an app that ignores keyboard layout (no matter how I switch it: with Alt+Tab or using the language panel in the taskbar)

In Windows 7, jitsi happily ignores the current layout. When I type in the chat window, it's always in Latin.

In Windows XP SP2, jitsi locks up if I try to switch the layout (again, no matter the method). It also causes the keyboard switcher to stop working and sometimes, the Explorer application to crash -- which equals to the system becoming unusable as there is no way to restart it by typing "explorer.exe" if the layout is stuck on Russian.

If I simply copy&paste Russian text from another application, jitsi has no issues working with it.

What did you do, devs?


#2

Hello chebmaster,

This is a known problem that many users have reported for Russian layouts. We haven't been able to reproduce it so far and Cyrillic layouts work without an issue for us. Patches are welcome.

Emil

ยทยทยท

On 03.09.14, 16:10, Cheb wrote:

This is the FIRST time I ever saw an app that ignores keyboard layout
(no matter how I switch it: with Alt+Tab or using the language panel in
the taskbar)

In Windows 7, jitsi happily ignores the current layout. When I type in
the chat window, it's always in Latin.

In Windows XP SP2, jitsi locks up if I try to switch the layout (again,
no matter the method). It also causes the keyboard switcher to stop
working and sometimes, the Explorer application to crash -- which equals
to the system becoming unusable as there is no way to restart it by
typing "explorer.exe" if the layout is stuck on Russian.

If I simply copy&paste Russian text from another application, jitsi has
no issues working with it.

What did you do, devs?

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org