[jitsi-users] [BUG] Jitsi with Openfire goes offline time to time


#1

There is problem in Jitsi Windows and Mac with Openfire interaperability. Jitsi goes offline and online time to time (Xmpp account). Jitsi latest stable and nightly versions are affected - older too. I use newest openfire version 3.9.3.
Jitsi logs:

09:57:29.414 SEVERE: [258] impl.protocol.jabber.extensions.keepalive.KeepAliveManager.run().220 un-registering not received ping packet for: pkrajci@192.168.110.31 (Jabber)
09:57:29.642 INFO: [301] plugin.reconnectplugin.ReconnectPluginActivator.run().610 Reconnect pkrajci@192.168.110.31 (Jabber) after 5000 ms.
09:57:34.643 INFO: [302] plugin.reconnectplugin.ReconnectPluginActivator.run().946 Start reconnecting pkrajci@192.168.110.31 (Jabber)
09:57:34.644 SEVERE: [302] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectUsingSRVRecords().904 No SRV addresses found for _xmpp-client._tcp.192.168.110.31
09:57:35.168 INFO: [302] impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().106 Jingle : ON
09:57:35.196 INFO: [312] impl.protocol.jabber.JingleNodesServiceDiscovery.run().95 Start Jingle Nodes discovery!
09:57:35.397 INFO: [312] impl.protocol.jabber.JingleNodesServiceDiscovery.run().128 Jingle Nodes discovery terminated!
09:57:35.397 INFO: [312] impl.protocol.jabber.JingleNodesServiceDiscovery.run().129 Found 0 Jingle Nodes relay for account: pkrajci@192.168.110.31 in 202 ms.

Firewalls is off on both sides and ping work. Tried also modify Openfire client connection settings, but with no effect. Openfire with Spark client work well, so I assume it is not Openfire problem. Calls (jingle) are not affected.


#2

Hi,

09:57:29.414 SEVERE: [258]
impl.protocol.jabber.extensions.keepalive.KeepAliveManager.run().220
un-registering not received ping packet for: pkrajci@192.168.110.31 (Jabber)

This log shows that Jitsi has send a simple xmpp packet (ping) and has
not received any answer or any error in response for it. It can be
network issue ... or the openfire to be busy and responding too
slowly... The default time to wait is 30 seconds. You can check in the
pcap log for the sent packet, and whether any ping is received at all.

Regards
damencho

···

On Thu, Sep 18, 2014 at 12:47 PM, <peter@krajci.sk> wrote:


#3

Hi,
I checked pcap file from log and you are right jitsi send out xmpp packet type xmlns="urn:xmpp:ping" to openfire, but with no respond. I searched thousands lines of pcap file, but openfire never responds. Then jitsi reconnect after some random time - 121, 275, 486, 393 seconds...
Is there some option to disable that ping packet from jitsi?
Normal ping to openfire works well.

Thank you.

Damian Minkov <damencho@jitsi.org>:

···

Hi,
On Thu, Sep 18, 2014 at 12:47 PM, <peter@krajci.sk> wrote:

09:57:29.414 SEVERE: [258]
impl.protocol.jabber.extensions.keepalive.KeepAliveManager.run().220
un-registering not received ping packet for: pkrajci@192.168.110.31 (Jabber)

This log shows that Jitsi has send a simple xmpp packet (ping) and has
not received any answer or any error in response for it. It can be
network issue ... or the openfire to be busy and responding too
slowly... The default time to wait is 30 seconds. You can check in the
pcap log for the sent packet, and whether any ping is received at all.

Regards
damencho

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi,

you can disable this only by adding an account property in your
configuration(first stop Jitsi before editing the file) or if you are
provisioning your account by adding an extra property -
KEEP_ALIVE_METHOD.
Main will be: net.java.sip.communicator.impl.protocol.jabber.acc1379593885895.
KEEP_ALIVE_METHOD =disabled
But this way Jitsi will not detect server connection failures and you
can experience message lost or some other problems. There should be a
reason why openfire doesn't return a response or at least an error for
that packet.

I can see locally ping responses coming from openfire:
<iq id="mrrq3-1861" to="...@jit.si/jitsi-37ao1im" from="jit.si"
type="result"></iq>

Regards
damencho

···

On Fri, Sep 19, 2014 at 3:26 PM, <peter@krajci.sk> wrote:

Hi,
I checked pcap file from log and you are right jitsi send out xmpp packet
type xmlns="urn:xmpp:ping" to openfire, but with no respond. I searched
thousands lines of pcap file, but openfire never responds. Then jitsi
reconnect after some random time - 121, 275, 486, 393 seconds...
Is there some option to disable that ping packet from jitsi?
Normal ping to openfire works well.

Thank you.

Damian Minkov <damencho@jitsi.org>:

Hi,
On Thu, Sep 18, 2014 at 12:47 PM, <peter@krajci.sk> wrote:

09:57:29.414 SEVERE: [258]
impl.protocol.jabber.extensions.keepalive.KeepAliveManager.run().220
un-registering not received ping packet for: pkrajci@192.168.110.31
(Jabber)

This log shows that Jitsi has send a simple xmpp packet (ping) and has
not received any answer or any error in response for it. It can be
network issue ... or the openfire to be busy and responding too
slowly... The default time to wait is 30 seconds. You can check in the
pcap log for the sent packet, and whether any ping is received at all.

Regards
damencho

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hello,

Can you verify that the packet is sent to the correct recipient (the "to" attribute of "iq", it should be the server hostname), or share the pcap? I seem to remember seeing pings sent to the wrong place, but I can't remember what was the cause...

Boris

···

On 19/09/14 15:26, peter@krajci.sk wrote:

Hi,
I checked pcap file from log and you are right jitsi send out xmpp
packet type xmlns="urn:xmpp:ping" to openfire, but with no respond. I
searched thousands lines of pcap file, but openfire never responds.
Then jitsi reconnect after some random time - 121, 275, 486, 393
seconds...
Is there some option to disable that ping packet from jitsi?
Normal ping to openfire works well.

Thank you.


#6

Hello,
thank you for your help Boris. Everything works now perfect for 3 days without reconnecting. It was misconfiguration fault. Openfire was configured with dns name and jitsi was with ip address. After reconfiguration jitsi from @<IP ADDRESS> to @<DNS NAME>, works like a charm.

Thank you again.

Cit�t Boris Grozev <boris@jitsi.org>:

···

On 19/09/14 15:26, peter@krajci.sk wrote:

Hi,
I checked pcap file from log and you are right jitsi send out xmpp
packet type xmlns="urn:xmpp:ping" to openfire, but with no respond. I
searched thousands lines of pcap file, but openfire never responds.
Then jitsi reconnect after some random time - 121, 275, 486, 393
seconds...
Is there some option to disable that ping packet from jitsi?
Normal ping to openfire works well.

Thank you.

Hello,

Can you verify that the packet is sent to the correct recipient (the "to" attribute of "iq", it should be the server hostname), or share the pcap? I seem to remember seeing pings sent to the wrong place, but I can't remember what was the cause...

Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users