[jitsi-users] Bug: Hardcoded icon path for GNU/Linux systems


#1

Hi,

currently the icon path specified in the created launcher file is set to:
Icon=/usr/share/pixmaps/jitsi.svg

This prevents icon theming without editing the launcher file.

I'd like to ask you to change the icon path line in the launcher according
to the freedesktop.org standards.

···

-----------------------------------------------
Please find more info here:
http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html
https://github.com/Foggalong/hardcode-fixer/wiki/What,-Why-&-How
----------------------------------------------

Your chosen icon location (/usr/share/pixmaps) already follows the standard.
All you'd have to do is changing the icon path line to a simple (in case
the icon file is jitsi.svg or jitsi.png):

Icon=jitsi

If the icon ist stored in /usr/share/icons/hicolor/<size>/ or
/usr/share/pixmaps
you needn't specify the full path nor the file extension in order to have
it displayed properly.

Thank you very much indeed and best regards.


#2

Hi,

this will be fixed in next nightly. Thanks.

Regards
damencho

···

On Sat, Mar 28, 2015 at 1:39 PM, Willi Wacker <wxwacker32@gmail.com> wrote:

Hi,

currently the icon path specified in the created launcher file is set to:
Icon=/usr/share/pixmaps/jitsi.svg

This prevents icon theming without editing the launcher file.

I'd like to ask you to change the icon path line in the launcher according
to the freedesktop.org standards.

-----------------------------------------------
Please find more info here:
http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html
https://github.com/Foggalong/hardcode-fixer/wiki/What,-Why-&-How
----------------------------------------------

Your chosen icon location (/usr/share/pixmaps) already follows the standard.
All you'd have to do is changing the icon path line to a simple (in case the
icon file is jitsi.svg or jitsi.png):

Icon=jitsi

If the icon ist stored in /usr/share/icons/hicolor/<size>/ or
/usr/share/pixmaps
you needn't specify the full path nor the file extension in order to have it
displayed properly.

Thank you very much indeed and best regards.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users