[jitsi-users] Basic Installation, configuring internal_plain


#1

Hello all,

It's been a while since I've used Jitsi and I'm trying to set up a quick
installation for a demo later in the week.

As far as I recall, it used to be possible to require a basic level of
authentication on Jitsi Meet by simply configuring the prosody domain to
non-anonymous.

So I would edit the [domain].cfg.lua file in /etc/prosody/avail, change the
authentication method on the VirtualHost from "anonymous" to
"internal_plain" and add some test users with "prosodyctl adduser
[username]@[domain].

However, when I try this today, the client does not connect properly to
prosody.

I see the following in the javascript console for meet (I've tried to trim
for brevity):

Strophe status changed to CONNECTING null
strophe.min.js?v=2:1 XHR finished loading: POST “https://
[domain]/http-bind”.sendFunc
Strophe status changed to CONNFAIL x-strophe-bad-non-anon-jid
Strophe status changed to DISCONNECTING x-strophe-bad-non-anon-jid
XHR finished loading: POST “https://[domain]/http-bind”.sendFunc
Strophe status changed to DISCONNECTED null

This seems logical - Strophe is trying to connect with an anonymous user
and failing, but isn't Jitsi Meet supposed to then retry with a
username/password?

Is there something I need to set in config.js or interface_config.js to
make Jitsi Meet request authentication details?

I can use another XMPP client to log into prosody with the user accoutns
I've setup, so that works OK.

Thanks in advance for any help - I'm sure I had this working successfully
before, so assume I've forgotten something basic...

Simon

···

--
Simon White


#2

Silly me, I'd forgotten to enable an additional "guest.mydomain"
virtualhost and uncomment the anonymous bit of the Jitsi meet config.

All working now, apologies for any time wasted,

Simon

···

On Sat, Jul 25, 2015 at 7:41 PM, Simon White <simon.white@gmail.com> wrote:

Hello all,

It's been a while since I've used Jitsi and I'm trying to set up a quick
installation for a demo later in the week.

As far as I recall, it used to be possible to require a basic level of
authentication on Jitsi Meet by simply configuring the prosody domain to
non-anonymous.

So I would edit the [domain].cfg.lua file in /etc/prosody/avail, change
the authentication method on the VirtualHost from "anonymous" to
"internal_plain" and add some test users with "prosodyctl adduser
[username]@[domain].

However, when I try this today, the client does not connect properly to
prosody.

I see the following in the javascript console for meet (I've tried to trim
for brevity):

Strophe status changed to CONNECTING null
strophe.min.js?v=2:1 XHR finished loading: POST “https://
[domain]/http-bind”.sendFunc
Strophe status changed to CONNFAIL x-strophe-bad-non-anon-jid
Strophe status changed to DISCONNECTING x-strophe-bad-non-anon-jid
XHR finished loading: POST “https://[domain]/http-bind”.sendFunc
Strophe status changed to DISCONNECTED null

This seems logical - Strophe is trying to connect with an anonymous user
and failing, but isn't Jitsi Meet supposed to then retry with a
username/password?

Is there something I need to set in config.js or interface_config.js to
make Jitsi Meet request authentication details?

I can use another XMPP client to log into prosody with the user accoutns
I've setup, so that works OK.

Thanks in advance for any help - I'm sure I had this working successfully
before, so assume I've forgotten something basic...

Simon

--
Simon White

--
Simon White