[jitsi-users] autostart jibri services


#1

Hello everyone,

Here are how to start jibri services:
Https://github.com/jitsi/jibri#support-daemon-systemd-configurations

I do not need to have jibri all the time, so I plan to turn it off for a
while and turn it on when I need it.
I am trying to automatically start jibri services:
Jibri-xorg
Jibri-icewm
Jibri-xmpp (I made my own implementation according to my needs)

I configured it like this:
Sudo systemctl enable jibri-xorg
Sudo systemctl enable jibri-icewm

But when start occurs an error with jibri-icewm shows this:
Icewmbg: can not open display:: 0. Xmust be running and $ DISPLAY

I know it's a linux problem, but such someone has done something similar,

Thank you.


#2

Hello everyone,

Here are how to start jibri services:
Https://github.com/jitsi/jibri#support-daemon-systemd-configurations

I do not need to have jibri all the time, so I plan to turn it off for a while and turn it on when I need it.
I am trying to automatically start jibri services:
Jibri-xorg
Jibri-icewm
Jibri-xmpp (I made my own implementation according to my needs)

I configured it like this:
Sudo systemctl enable jibri-xorg
Sudo systemctl enable jibri-icewm

But when start occurs an error with jibri-icewm shows this:
Icewmbg: can not open display:: 0. Xmust be running and $ DISPLAY

I know it's a linux problem, but such someone has done something similar,

When you start jibri-icewm, did jibe-xorg finish starting?

···

On May 29, 2017, at 18:47, Alfredo Guzman <alfredo.sil.gt@gmail.com> wrote:

Thank you.
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Saúl


#3

Hi, Saúl

Thanks for your answer.

I found the problem, the jibri-icewm service started at the same time as
jibri-xorg. I do not know how to create the services dependency.

The solution that worked for me was:

Change in /etc/systemd/system/jibri-icewm.service
Restart = on-failure >> Restart = Always

So it restarts until Xorg is ready and everything is perfect.

If anyone knows a better solution, I would appreciate it.

Thank you.

···

2017-05-30 3:23 GMT-05:00 Saúl Ibarra Corretgé <scorretge@atlassian.com>:

> On May 29, 2017, at 18:47, Alfredo Guzman <alfredo.sil.gt@gmail.com> > wrote:
>
> Hello everyone,
>
> Here are how to start jibri services:
> Https://github.com/jitsi/jibri#support-daemon-systemd-configurations
>
> I do not need to have jibri all the time, so I plan to turn it off for a
while and turn it on when I need it.
> I am trying to automatically start jibri services:
> Jibri-xorg
> Jibri-icewm
> Jibri-xmpp (I made my own implementation according to my needs)
>
> I configured it like this:
> Sudo systemctl enable jibri-xorg
> Sudo systemctl enable jibri-icewm
>
> But when start occurs an error with jibri-icewm shows this:
> Icewmbg: can not open display:: 0. Xmust be running and $ DISPLAY
>
> I know it's a linux problem, but such someone has done something similar,
>

When you start jibri-icewm, did jibe-xorg finish starting?

> Thank you.
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi, Saúl

Thanks for your answer.

I found the problem, the jibri-icewm service started at the same time as jibri-xorg. I do not know how to create the services dependency.

The solution that worked for me was:

Change in /etc/systemd/system/jibri-icewm.service
Restart = on-failure >> Restart = Always

You can try adding this to the jibri-icewm service:

After=jibri-xord.service

···

On May 30, 2017, at 19:00, Alfredo Guzman <alfredo.sil.gt@gmail.com> wrote:

So it restarts until Xorg is ready and everything is perfect.

If anyone knows a better solution, I would appreciate it.

Thank you.

2017-05-30 3:23 GMT-05:00 Saúl Ibarra Corretgé <scorretge@atlassian.com>:

> On May 29, 2017, at 18:47, Alfredo Guzman <alfredo.sil.gt@gmail.com> wrote:
>
> Hello everyone,
>
> Here are how to start jibri services:
> Https://github.com/jitsi/jibri#support-daemon-systemd-configurations
>
> I do not need to have jibri all the time, so I plan to turn it off for a while and turn it on when I need it.
> I am trying to automatically start jibri services:
> Jibri-xorg
> Jibri-icewm
> Jibri-xmpp (I made my own implementation according to my needs)
>
> I configured it like this:
> Sudo systemctl enable jibri-xorg
> Sudo systemctl enable jibri-icewm
>
> But when start occurs an error with jibri-icewm shows this:
> Icewmbg: can not open display:: 0. Xmust be running and $ DISPLAY
>
> I know it's a linux problem, but such someone has done something similar,
>

When you start jibri-icewm, did jibe-xorg finish starting?

> Thank you.
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Saúl