[jitsi-users] Automating Jitsi Meet Install


#1

Hello,

I am trying to install jitsi-meet on a vm via automated script .
However, the deb package prompts for a hostname. How can I set this
value from a script? I have tried using debconf-set-selections, but I
have been unable to set the value to anything but localhost. Here is
what I am doing currently:

export DEBIAN_FRONTEND=noninteractive
echo 'deb http://download.jitsi.org/nightly/deb unstable/' >>
/etc/apt/sources.list
wget -qO - https://download.jitsi.org/nightly/deb/unstable/archive.key |
apt-key add -
debconf-set-selections <<< 'jitsi-meet-prosody jitsi-meet/jvb-hostname
string "my.ip.address"';
debconf-set-selections <<< 'jitsi-meet jitsi-meet/jvb-hostname string
"my.ip.address"';
debconf-set-selections <<< 'jitsi-meet-prosody
jitsi-meet-prosody/jvb-hostname string "my.ip.address"';
debconf-set-selections <<< 'jitsi-meet jitsi-meet-prosody/jvb-hostname
string "my.ip.address"';
apt-get install -y jitsi-meet

This works in the sense that it doesn't prompt me, however, the hostname
is set incorrectly to localhost, not my.ip.address.
When I run debconf-show jitsi-meet before the script, the values seem to
be right, but after the apt-get call, they are set to localhost.

Any idea how I can automate the entry of this value?

Thanks!
Daniel


#2

Hi,

You are running debconf-set-selections for jitsi-meet and
jitsi-meet-prosody. The actual dialog asking for the hostname is
coming from jvb. You need to use debconf... and for jvb.
You can grep in the source of jitsi-meet/debian,
jicofo/resources/install/debian and
jitsi-videobridge/resources/install/debian for db_get and see all the
keys we use with debconf. If you will be doing later upgrades on those
packages, experiment with that, cause I was seeing issues with that
when you initially use debconf-set-selections.

Regards
damencho

ยทยทยท

On Mon, May 23, 2016 at 12:58 PM, Daniel Mahaffy <danielmahaffy@gmail.com> wrote:

Hello,

I am trying to install jitsi-meet on a vm via automated script .
However, the deb package prompts for a hostname. How can I set this
value from a script? I have tried using debconf-set-selections, but I
have been unable to set the value to anything but localhost. Here is
what I am doing currently:

export DEBIAN_FRONTEND=noninteractive
echo 'deb http://download.jitsi.org/nightly/deb unstable/' >>
/etc/apt/sources.list
wget -qO - https://download.jitsi.org/nightly/deb/unstable/archive.key |
apt-key add -
debconf-set-selections <<< 'jitsi-meet-prosody jitsi-meet/jvb-hostname
string "my.ip.address"';
debconf-set-selections <<< 'jitsi-meet jitsi-meet/jvb-hostname string
"my.ip.address"';
debconf-set-selections <<< 'jitsi-meet-prosody
jitsi-meet-prosody/jvb-hostname string "my.ip.address"';
debconf-set-selections <<< 'jitsi-meet jitsi-meet-prosody/jvb-hostname
string "my.ip.address"';
apt-get install -y jitsi-meet

This works in the sense that it doesn't prompt me, however, the hostname
is set incorrectly to localhost, not my.ip.address.
When I run debconf-show jitsi-meet before the script, the values seem to
be right, but after the apt-get call, they are set to localhost.

Any idea how I can automate the entry of this value?

Thanks!
Daniel

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users