[jitsi-users] Audio device selection problem


#1

Hello,

I'm on macOS 10.12.5 and I use Soundflower [1] to route audio from VoIP apps (Jitsi, WebEx, and FaceTime) through an audio mixing app. I use two Soundflower instances, one to feed audio to the VoIP app's input (called "Soundflower (2ch)"), and one to capture the VoIP app's output (called "Soundflower (64ch)"). Soundflower is a kernel extension, so in user-land they appear as normal audio devices.

In Jitsi's audio device prefs, both devices appear in the drop-down menus as expected. When I select the 64ch one, the setting flips back top the 2ch one, however. The 2ch device is used fine, and audio flows between it an Jitsi. I just can't get Jitsi to use the 64ch device.

FaceTime and WebEx can use the 64ch device just fine.

Any hints appreciated.

Many thanks in advance and cheers,

  --alexander

[1] https://github.com/mattingalls/Soundflower


#2

Hi,

No reactions on this yet. Maybe too exotic for most?

Should I file a github issue?

Many thanks and cheers,

  --alexander

···

On 2017-05-24, at 19:25 , Alexander Adolf <alexander.adolf@condition-alpha.com> wrote:

Hello,

I'm on macOS 10.12.5 and I use Soundflower [1] to route audio from VoIP apps (Jitsi, WebEx, and FaceTime) through an audio mixing app. I use two Soundflower instances, one to feed audio to the VoIP app's input (called "Soundflower (2ch)"), and one to capture the VoIP app's output (called "Soundflower (64ch)"). Soundflower is a kernel extension, so in user-land they appear as normal audio devices.

In Jitsi's audio device prefs, both devices appear in the drop-down menus as expected. When I select the 64ch one, the setting flips back top the 2ch one, however. The 2ch device is used fine, and audio flows between it an Jitsi. I just can't get Jitsi to use the 64ch device.

FaceTime and WebEx can use the 64ch device just fine.

Any hints appreciated.

Many thanks in advance and cheers,

--alexander

[1] https://github.com/mattingalls/Soundflower


#3

Hi,

No reactions on this yet. Maybe too exotic for most?

Should I file a github issue?

Sure, feel free to do so!

···

On May 29, 2017, at 18:29, Alexander Adolf <alexander.adolf@condition-alpha.com> wrote:

Many thanks and cheers,

--alexander

On 2017-05-24, at 19:25 , Alexander Adolf <alexander.adolf@condition-alpha.com> wrote:

Hello,

I'm on macOS 10.12.5 and I use Soundflower [1] to route audio from VoIP apps (Jitsi, WebEx, and FaceTime) through an audio mixing app. I use two Soundflower instances, one to feed audio to the VoIP app's input (called "Soundflower (2ch)"), and one to capture the VoIP app's output (called "Soundflower (64ch)"). Soundflower is a kernel extension, so in user-land they appear as normal audio devices.

In Jitsi's audio device prefs, both devices appear in the drop-down menus as expected. When I select the 64ch one, the setting flips back top the 2ch one, however. The 2ch device is used fine, and audio flows between it an Jitsi. I just can't get Jitsi to use the 64ch device.

FaceTime and WebEx can use the 64ch device just fine.

Any hints appreciated.

Many thanks in advance and cheers,

--alexander

[1] https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_mattingalls_Soundflower&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=-T6Cew-S4Ei-6rhDWu1AY-o1ETORq5uAicdns9fSwgI&m=9ONzzAztRKZiuuRNs7UahNcsKQJoeV8OPG5Mbcmqua4&s=or3w1a1JUFY2OJYMUEHoit77E1FKAVXLNMbtPIjo7Fs&e=

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
https://urldefense.proofpoint.com/v2/url?u=http-3A__lists.jitsi.org_mailman_listinfo_users&d=DwIGaQ&c=wBUwXtM9sKhff6UeHOQgvw&r=-T6Cew-S4Ei-6rhDWu1AY-o1ETORq5uAicdns9fSwgI&m=9ONzzAztRKZiuuRNs7UahNcsKQJoeV8OPG5Mbcmqua4&s=i880czkiOOE03tqPHXHNL_RMOm0x5dss_hsnaIVbLWw&e=

--
Saúl