[jitsi-users] Asterisk Directmedia and Jitsi


#1

Hello List,

I having a problem configuring Jitsi to relay all it's traffic through my Asterisk server.

A quick reminder about the operational modes of Asterisk:

···

=========================================================

    Local bridge - the RTP traffic flows through Asterisk, but is not interpreted by Asterisk. In this case, each UA directs its RTP to Asterisk, and Asterisk retransmits the RTP to each UA. A minimal amount of decoding is done.
    Remote bridge - in this case, signalling is still handled between each UA and Asterisk, but Asterisk renegotiates the destination of the RTP with each UA to be the other corresponding UA. In the end, each UA sends its RTP to the other UA directly, while sending the SIP signalling information to Asterisk. This minimizes the load on Asterisk, as no RTP traffic directly goes through it.
    Native bridge - similar to a local bridge, the RTP traffic from a UA flows into Asterisk. Asterisk fully decodes the RTP into audio frames and manages the transmission of the audio frames. This occurs when Asterisk has to "understand" the contents of the RTP traffic, such as when using features.conf for DTMF transfers.

The directmedia setting informs Asterisk that the UAs optimally want to send their media between each other, and bypass Asterisk. It will attempt to send the necessary re-INVITEs to set that scenario up, once the call has been established by both UAs.

I'm using the latest stable 2.4 Client on Windows/Linux/Android. The error what I get is:

http://tinypic.com/r/120ny38/8

I have directmedia=no, allow=all in sip.conf under all the clients.

Could somebody post a working sip.conf for jitsi clients with a setup where all the traffic is relayed through Asterisk?
For me the best mode would be the Local bridge mode where without looking into the media streams it would relay everything so I can select whatever codecs I like in Jitsi on the UAs. Most likely I will leave both the Audio and the Video on default but I do need both of them to work flawlessly.

Thanks


#2

Hi,

directmedia=no is enough. The problem from the screenshot is a problem
with codecs. The list of codecs offered by Jitsi and * account are
different. Remove allow=all and test, or try adding the following for
the Jitsi account in *
disallow=all
allow=g722
allow=speex
allow=ulaw
allow=alaw

Cheers
damencho

···

On Thu, Aug 21, 2014 at 11:03 AM, Simon Vargas <simonv4@gmx.com> wrote:

Hello List,

I having a problem configuring Jitsi to relay all it's traffic through my Asterisk server.

A quick reminder about the operational modes of Asterisk:

    Local bridge - the RTP traffic flows through Asterisk, but is not interpreted by Asterisk. In this case, each UA directs its RTP to Asterisk, and Asterisk retransmits the RTP to each UA. A minimal amount of decoding is done.
    Remote bridge - in this case, signalling is still handled between each UA and Asterisk, but Asterisk renegotiates the destination of the RTP with each UA to be the other corresponding UA. In the end, each UA sends its RTP to the other UA directly, while sending the SIP signalling information to Asterisk. This minimizes the load on Asterisk, as no RTP traffic directly goes through it.
    Native bridge - similar to a local bridge, the RTP traffic from a UA flows into Asterisk. Asterisk fully decodes the RTP into audio frames and manages the transmission of the audio frames. This occurs when Asterisk has to "understand" the contents of the RTP traffic, such as when using features.conf for DTMF transfers.

The directmedia setting informs Asterisk that the UAs optimally want to send their media between each other, and bypass Asterisk. It will attempt to send the necessary re-INVITEs to set that scenario up, once the call has been established by both UAs.

I'm using the latest stable 2.4 Client on Windows/Linux/Android. The error what I get is:

http://tinypic.com/r/120ny38/8

I have directmedia=no, allow=all in sip.conf under all the clients.

Could somebody post a working sip.conf for jitsi clients with a setup where all the traffic is relayed through Asterisk?
For me the best mode would be the Local bridge mode where without looking into the media streams it would relay everything so I can select whatever codecs I like in Jitsi on the UAs. Most likely I will leave both the Audio and the Video on default but I do need both of them to work flawlessly.

Thanks

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hello

I going to answer this to help others out. I solved this problem but spent many days on not understanding whats happening in the background.

The problem had nothing to do with codecs or the directmedia=no option.

It was all about JITSI.

When you create a MERGED contact which is both SIP+JABBER at the same time, it tries to make audio/video calls through the JABBER account first which unfortunately going to act on it's own and try to connect to the other machine P2P.

To solve this you need to remove such contacts and add 2 separate contacts for the same person (1 at SIP account, 1 at XMPP account) like:

*Joe_Chat
*Joe_Video

I know it's annoying as hell because once you are chatting with Joe_Chat user 99% of the time you will tap on the Call/Video call key. I hope in the future this will be changed in Jitsi, matter of fact, XMPP shouldn't even be carrying any media information. It's purely there for the chat.

···

Sent: Thursday, August 21, 2014 at 10:18 AM
From: "Damian Minkov" <damencho@jitsi.org>
To: "Jitsi Users" <users@jitsi.org>
Subject: Re: [jitsi-users] Asterisk Directmedia and Jitsi
Hi,

directmedia=no is enough. The problem from the screenshot is a problem
with codecs. The list of codecs offered by Jitsi and * account are
different. Remove allow=all and test, or try adding the following for
the Jitsi account in *
disallow=all
allow=g722
allow=speex
allow=ulaw
allow=alaw

Cheers
damencho

On Thu, Aug 21, 2014 at 11:03 AM, Simon Vargas <simonv4@gmx.com> wrote:

Hello List,

I having a problem configuring Jitsi to relay all it's traffic through my Asterisk server.

A quick reminder about the operational modes of Asterisk:

Local bridge - the RTP traffic flows through Asterisk, but is not interpreted by Asterisk. In this case, each UA directs its RTP to Asterisk, and Asterisk retransmits the RTP to each UA. A minimal amount of decoding is done.
Remote bridge - in this case, signalling is still handled between each UA and Asterisk, but Asterisk renegotiates the destination of the RTP with each UA to be the other corresponding UA. In the end, each UA sends its RTP to the other UA directly, while sending the SIP signalling information to Asterisk. This minimizes the load on Asterisk, as no RTP traffic directly goes through it.
Native bridge - similar to a local bridge, the RTP traffic from a UA flows into Asterisk. Asterisk fully decodes the RTP into audio frames and manages the transmission of the audio frames. This occurs when Asterisk has to "understand" the contents of the RTP traffic, such as when using features.conf for DTMF transfers.

The directmedia setting informs Asterisk that the UAs optimally want to send their media between each other, and bypass Asterisk. It will attempt to send the necessary re-INVITEs to set that scenario up, once the call has been established by both UAs.

I'm using the latest stable 2.4 Client on Windows/Linux/Android. The error what I get is:

http://tinypic.com/r/120ny38/8

I have directmedia=no, allow=all in sip.conf under all the clients.

Could somebody post a working sip.conf for jitsi clients with a setup where all the traffic is relayed through Asterisk?
For me the best mode would be the Local bridge mode where without looking into the media streams it would relay everything so I can select whatever codecs I like in Jitsi on the UAs. Most likely I will leave both the Audio and the Video on default but I do need both of them to work flawlessly.

Thanks

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]


#4

Have you had a look at CUSAX?
https://jitsi.org/Documentation/CUSAX

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

Le 25.08.2014 à 17:15, "Simon Vargas" <simonv4@gmx.com> a écrit :

Hello

I going to answer this to help others out. I solved this problem but spent many days on not understanding whats happening in the background.

The problem had nothing to do with codecs or the directmedia=no option.

It was all about JITSI.

When you create a MERGED contact which is both SIP+JABBER at the same time, it tries to make audio/video calls through the JABBER account first which unfortunately going to act on it's own and try to connect to the other machine P2P.

To solve this you need to remove such contacts and add 2 separate contacts for the same person (1 at SIP account, 1 at XMPP account) like:

*Joe_Chat
*Joe_Video

I know it's annoying as hell because once you are chatting with Joe_Chat user 99% of the time you will tap on the Call/Video call key. I hope in the future this will be changed in Jitsi, matter of fact, XMPP shouldn't even be carrying any media information. It's purely there for the chat.

Sent: Thursday, August 21, 2014 at 10:18 AM
From: "Damian Minkov" <damencho@jitsi.org>
To: "Jitsi Users" <users@jitsi.org>
Subject: Re: [jitsi-users] Asterisk Directmedia and Jitsi
Hi,

directmedia=no is enough. The problem from the screenshot is a problem
with codecs. The list of codecs offered by Jitsi and * account are
different. Remove allow=all and test, or try adding the following for
the Jitsi account in *
disallow=all
allow=g722
allow=speex
allow=ulaw
allow=alaw

Cheers
damencho

On Thu, Aug 21, 2014 at 11:03 AM, Simon Vargas <simonv4@gmx.com> wrote:
Hello List,

I having a problem configuring Jitsi to relay all it's traffic through my Asterisk server.

A quick reminder about the operational modes of Asterisk:

Local bridge - the RTP traffic flows through Asterisk, but is not interpreted by Asterisk. In this case, each UA directs its RTP to Asterisk, and Asterisk retransmits the RTP to each UA. A minimal amount of decoding is done.
Remote bridge - in this case, signalling is still handled between each UA and Asterisk, but Asterisk renegotiates the destination of the RTP with each UA to be the other corresponding UA. In the end, each UA sends its RTP to the other UA directly, while sending the SIP signalling information to Asterisk. This minimizes the load on Asterisk, as no RTP traffic directly goes through it.
Native bridge - similar to a local bridge, the RTP traffic from a UA flows into Asterisk. Asterisk fully decodes the RTP into audio frames and manages the transmission of the audio frames. This occurs when Asterisk has to "understand" the contents of the RTP traffic, such as when using features.conf for DTMF transfers.

The directmedia setting informs Asterisk that the UAs optimally want to send their media between each other, and bypass Asterisk. It will attempt to send the necessary re-INVITEs to set that scenario up, once the call has been established by both UAs.

I'm using the latest stable 2.4 Client on Windows/Linux/Android. The error what I get is:

http://tinypic.com/r/120ny38/8

I have directmedia=no, allow=all in sip.conf under all the clients.

Could somebody post a working sip.conf for jitsi clients with a setup where all the traffic is relayed through Asterisk?
For me the best mode would be the Local bridge mode where without looking into the media streams it would relay everything so I can select whatever codecs I like in Jitsi on the UAs. Most likely I will leave both the Audio and the Video on default but I do need both of them to work flawlessly.

Thanks

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

OK Great, then make sure it is disabled by default from the next version of jitsi. The configuration messes up many times so I have to start with a clean config.

These settings are even more difficult on the android version where who knows where the .jitsi folder is.

I think jitsi is way too complicated to configure for the average user.

···

Sent: Monday, August 25, 2014 at 11:24 AM
From: "Ingo Bauersachs" <ingo@jitsi.org>
To: "Jitsi Users" <users@jitsi.org>
Subject: Re: [jitsi-users] Asterisk Directmedia and Jitsi
Have you had a look at CUSAX?
https://jitsi.org/Documentation/CUSAX

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 25.08.2014 à 17:15, "Simon Vargas" <simonv4@gmx.com> a écrit :

Hello

I going to answer this to help others out. I solved this problem but spent many days on not understanding whats happening in the background.

The problem had nothing to do with codecs or the directmedia=no option.

It was all about JITSI.

When you create a MERGED contact which is both SIP+JABBER at the same time, it tries to make audio/video calls through the JABBER account first which unfortunately going to act on it's own and try to connect to the other machine P2P.

To solve this you need to remove such contacts and add 2 separate contacts for the same person (1 at SIP account, 1 at XMPP account) like:

*Joe_Chat
*Joe_Video

I know it's annoying as hell because once you are chatting with Joe_Chat user 99% of the time you will tap on the Call/Video call key. I hope in the future this will be changed in Jitsi, matter of fact, XMPP shouldn't even be carrying any media information. It's purely there for the chat.

Sent: Thursday, August 21, 2014 at 10:18 AM
From: "Damian Minkov" <damencho@jitsi.org>
To: "Jitsi Users" <users@jitsi.org>
Subject: Re: [jitsi-users] Asterisk Directmedia and Jitsi
Hi,

directmedia=no is enough. The problem from the screenshot is a problem
with codecs. The list of codecs offered by Jitsi and * account are
different. Remove allow=all and test, or try adding the following for
the Jitsi account in *
disallow=all
allow=g722
allow=speex
allow=ulaw
allow=alaw

Cheers
damencho

On Thu, Aug 21, 2014 at 11:03 AM, Simon Vargas <simonv4@gmx.com> wrote:
Hello List,

I having a problem configuring Jitsi to relay all it's traffic through my Asterisk server.

A quick reminder about the operational modes of Asterisk:

Local bridge - the RTP traffic flows through Asterisk, but is not interpreted by Asterisk. In this case, each UA directs its RTP to Asterisk, and Asterisk retransmits the RTP to each UA. A minimal amount of decoding is done.
Remote bridge - in this case, signalling is still handled between each UA and Asterisk, but Asterisk renegotiates the destination of the RTP with each UA to be the other corresponding UA. In the end, each UA sends its RTP to the other UA directly, while sending the SIP signalling information to Asterisk. This minimizes the load on Asterisk, as no RTP traffic directly goes through it.
Native bridge - similar to a local bridge, the RTP traffic from a UA flows into Asterisk. Asterisk fully decodes the RTP into audio frames and manages the transmission of the audio frames. This occurs when Asterisk has to "understand" the contents of the RTP traffic, such as when using features.conf for DTMF transfers.

The directmedia setting informs Asterisk that the UAs optimally want to send their media between each other, and bypass Asterisk. It will attempt to send the necessary re-INVITEs to set that scenario up, once the call has been established by both UAs.

I'm using the latest stable 2.4 Client on Windows/Linux/Android. The error what I get is:

http://tinypic.com/r/120ny38/8[http://tinypic.com/r/120ny38/8]

I have directmedia=no, allow=all in sip.conf under all the clients.

Could somebody post a working sip.conf for jitsi clients with a setup where all the traffic is relayed through Asterisk?
For me the best mode would be the Local bridge mode where without looking into the media streams it would relay everything so I can select whatever codecs I like in Jitsi on the UAs. Most likely I will leave both the Audio and the Video on default but I do need both of them to work flawlessly.

Thanks

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users][http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users][http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]


#6

Hi,

OK Great, then make sure it is disabled by default from the next version of jitsi. The configuration messes up many times so I have to start with a clean config.

And what about the users that are using xmpp for audio and video.

These settings are even more difficult on the android version where who knows where the .jitsi folder is.

I think jitsi is way too complicated to configure for the average user.

Things like CUSAX and using it is not meant for average user, it is
normally used by those deploying a service. They configure it one time
and control it through provisioning for all their users, which at the
end do not know and do not care about the protocol used for telephony
or for chat.

If you try to configure service like this you can also check
https://jitsi.org/provisioning

Regards
damencho

···

On Mon, Aug 25, 2014 at 12:51 PM, Simon Vargas <simonv4@gmx.com> wrote:

Sent: Monday, August 25, 2014 at 11:24 AM
From: "Ingo Bauersachs" <ingo@jitsi.org>
To: "Jitsi Users" <users@jitsi.org>
Subject: Re: [jitsi-users] Asterisk Directmedia and Jitsi
Have you had a look at CUSAX?
https://jitsi.org/Documentation/CUSAX

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 25.08.2014 à 17:15, "Simon Vargas" <simonv4@gmx.com> a écrit :

Hello

I going to answer this to help others out. I solved this problem but spent many days on not understanding whats happening in the background.

The problem had nothing to do with codecs or the directmedia=no option.

It was all about JITSI.

When you create a MERGED contact which is both SIP+JABBER at the same time, it tries to make audio/video calls through the JABBER account first which unfortunately going to act on it's own and try to connect to the other machine P2P.

To solve this you need to remove such contacts and add 2 separate contacts for the same person (1 at SIP account, 1 at XMPP account) like:

*Joe_Chat
*Joe_Video

I know it's annoying as hell because once you are chatting with Joe_Chat user 99% of the time you will tap on the Call/Video call key. I hope in the future this will be changed in Jitsi, matter of fact, XMPP shouldn't even be carrying any media information. It's purely there for the chat.

Sent: Thursday, August 21, 2014 at 10:18 AM
From: "Damian Minkov" <damencho@jitsi.org>
To: "Jitsi Users" <users@jitsi.org>
Subject: Re: [jitsi-users] Asterisk Directmedia and Jitsi
Hi,

directmedia=no is enough. The problem from the screenshot is a problem
with codecs. The list of codecs offered by Jitsi and * account are
different. Remove allow=all and test, or try adding the following for
the Jitsi account in *
disallow=all
allow=g722
allow=speex
allow=ulaw
allow=alaw

Cheers
damencho

On Thu, Aug 21, 2014 at 11:03 AM, Simon Vargas <simonv4@gmx.com> wrote:
Hello List,

I having a problem configuring Jitsi to relay all it's traffic through my Asterisk server.

A quick reminder about the operational modes of Asterisk:

Local bridge - the RTP traffic flows through Asterisk, but is not interpreted by Asterisk. In this case, each UA directs its RTP to Asterisk, and Asterisk retransmits the RTP to each UA. A minimal amount of decoding is done.
Remote bridge - in this case, signalling is still handled between each UA and Asterisk, but Asterisk renegotiates the destination of the RTP with each UA to be the other corresponding UA. In the end, each UA sends its RTP to the other UA directly, while sending the SIP signalling information to Asterisk. This minimizes the load on Asterisk, as no RTP traffic directly goes through it.
Native bridge - similar to a local bridge, the RTP traffic from a UA flows into Asterisk. Asterisk fully decodes the RTP into audio frames and manages the transmission of the audio frames. This occurs when Asterisk has to "understand" the contents of the RTP traffic, such as when using features.conf for DTMF transfers.

The directmedia setting informs Asterisk that the UAs optimally want to send their media between each other, and bypass Asterisk. It will attempt to send the necessary re-INVITEs to set that scenario up, once the call has been established by both UAs.

I'm using the latest stable 2.4 Client on Windows/Linux/Android. The error what I get is:

http://tinypic.com/r/120ny38/8[http://tinypic.com/r/120ny38/8]

I have directmedia=no, allow=all in sip.conf under all the clients.

Could somebody post a working sip.conf for jitsi clients with a setup where all the traffic is relayed through Asterisk?
For me the best mode would be the Local bridge mode where without looking into the media streams it would relay everything so I can select whatever codecs I like in Jitsi on the UAs. Most likely I will leave both the Audio and the Video on default but I do need both of them to work flawlessly.

Thanks

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users][http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users][http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users[http://lists.jitsi.org/mailman/listinfo/users]

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users