[jitsi-users] Assistance with Jitsi Meet and Prosody


#1

Hi,

I was wondering if somebody would be able to assist me in configuration Prosody for authentication with Jitsi Meet/Videbrigde.

Info:

OS: Clean Ubuntu 14.04 installation and upgrade to latest patches
Installled Jitsi meet according to instructions found on:
<https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md>
(Also installed SIP client addon)

Out of the box, this seems to be working ok and sip calls are also working fine.

From this point on I'm trying to start with plain internal authentication as a test according to instructions foudn on:

<https://github.com/jitsi/jicofo#secure-domain>

I'm doing this on a internal demo server so don't worry about the passwords below. When finished I'm will do a clean install. (Internally kristof-test has a DNS record)

The result is that meetings still can be started without authentication. So basically no difference than before the config change.

I added a prosody user using command: prosodyctl adduser user@kristof-test

My Prosody file looks like following:

//////

-- Plugins path gets uncommented during jitsi-meet-tokens package install - that's where token plugin is located
--plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

VirtualHost "kristof-test"
-- enabled = false -- Remove this line to enable this host
authentication = "internal_plain"
-- Properties below are modified by jitsi-meet-tokens package config
-- and authentication above is switched to "token"
--app_id="example_app_id"
--app_secret="example_app_secret"
-- Assign this host a certificate for TLS, otherwise it would use the one
-- set in the global section (if any).
-- Note that old-style SSL on port 5223 only supports one certificate, and will always
-- use the global one.
ssl = {
key = "/etc/prosody/certs/kristof-test.key";
certificate = "/etc/prosody/certs/kristof-test.crt";
}
-- we need bosh
modules_enabled = {
"bosh";
"pubsub";
"ping"; -- Enable mod_ping
}

VirtualHost "guest.kristof-test"
-- enabled = false -- Remove this line to enable this host
authentication = "anonymous"
-- Properties below are modified by jitsi-meet-tokens package config
-- and authentication above is switched to "token"
--app_id="example_app_id"
--app_secret="example_app_secret"
-- Assign this host a certificate for TLS, otherwise it would use the one
-- set in the global section (if any).
-- Note that old-style SSL on port 5223 only supports one certificate, and will always
-- use the global one.
ssl = {
key = "/etc/prosody/certs/kristof-test.key";
certificate = "/etc/prosody/certs/kristof-test.crt";
}
-- we need bosh
modules_enabled = {
"bosh";
"pubsub";
"ping"; -- Enable mod_ping
}

Component "conference.kristof-test" "muc"
--modules_enabled = { "token_verification" }
admins = { "<focus@auth.kristof>-test" }

Component "jitsi-videobridge.kristof-test"
component_secret = "XzVKiVLd"

VirtualHost "auth.kristof-test"
authentication = "internal_plain"

Component "focus.kristof-test"
component_secret = "ZO6Ykq7M"
Component "callcontrol.kristof-test" component_secret = "coTRbvWj"

////////////

My Jitsi meet file is adjust so that there are both the authentication domain as anonymous domain
domain: 'kristof-test',
anonymousdomain: 'guest.kristof-test',

Mvg
Kristof Van Den Ouweland