[jitsi-users] anonymousdomain - working build instructions?


#1

It appears that the anonymousdomain setting in jitsi meet does not work for
many people and I can't get it to function either. It seems configuration
details needed for the anonymousdomain usage are not fully listed or
starting point assumptions aren't listed or I'm running into a bug. Does
anyone have a step by step configuration guide that works and can you share
the OS you're using?

I have tried using anonymousdomain on several jitsi-functioning systems
(with and without authentication enabled) of different OS builds and with
nginx and jetty - all recently built and up to date. Across the board,
enabling anonymousdomain causes errors and odd behaviors. For example, on
all systems it will break the regular virtualhost's root page from loading
at all, aka gray screen problem I believe - and it usually acts the same in
chat room URLs too but not always since occasionally the toolbars and
interface will appear but they never function. Errors and behavior seem to
point to authentication being skipped for the incorrect virtualhost domain
and authentication for the anonymousdomain\correct virtualhost seems to
point to other issues such as CORS. Enabling CORS in prosody and allowing
BOSH however didn't appear to help beyond they do appear to be required.
Diving into prosody and BOSH didn't seem to lead anywhere specific yet.
Disabling anonymousdomain in the jitsi meet config for the domain instantly
restores functionality, except authentication is then required for both
domains\virtual hosts.


#2

Hi,

I just tested it and it works, but there are few things. First, you have an
error in your config.js after uncommenting anonymous domain, that's why you
see the grey screen. You are missing the coma at the end of the muc:....
line.
And second, the virtual host definition for the guest domain should look
like:
VirtualHost "guest.jitsi-meet.example.com"
    authentication = "anonymous"
    c2s_require_encryption = false

I'm currently fixing this in the documentation. I've tested it on a new
virtual machine in digital ocean, I used latest Ubuntu LTS, but it should
be the same in other Debian/Ubuntu versions.

Regards
damencho

···

On Fri, Apr 27, 2018, 13:04 dyoh777 <dyoh777@gmail.com> wrote:

It appears that the anonymousdomain setting in jitsi meet does not work
for many people and I can't get it to function either. It seems
configuration details needed for the anonymousdomain usage are not fully
listed or starting point assumptions aren't listed or I'm running into a
bug. Does anyone have a step by step configuration guide that works and can
you share the OS you're using?

I have tried using anonymousdomain on several jitsi-functioning systems
(with and without authentication enabled) of different OS builds and with
nginx and jetty - all recently built and up to date. Across the board,
enabling anonymousdomain causes errors and odd behaviors. For example, on
all systems it will break the regular virtualhost's root page from loading
at all, aka gray screen problem I believe - and it usually acts the same in
chat room URLs too but not always since occasionally the toolbars and
interface will appear but they never function. Errors and behavior seem to
point to authentication being skipped for the incorrect virtualhost domain
and authentication for the anonymousdomain\correct virtualhost seems to
point to other issues such as CORS. Enabling CORS in prosody and allowing
BOSH however didn't appear to help beyond they do appear to be required.
Diving into prosody and BOSH didn't seem to lead anywhere specific yet.
Disabling anonymousdomain in the jitsi meet config for the domain instantly
restores functionality, except authentication is then required for both
domains\virtual hosts.
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users