[jitsi-users] after successful key exchange, jitsi does not encrypt my messages, but indicates private conversation


#1

As the title says, I initiate a private conversation, the padlock closes
and the conversation is shown as private,
but my messages do not get encrypted. The problem persists with
jitsi_2.6.5390-1_amd64 and jitsi_2.5-latest_amd64 on debian.
I did not purge jitsi or delete $HOME/.jitsi in between installs.
My conversation partner uses xabber on android which displays "This
message has not been encrypted" under each of my messages.
His messages get encrypted and decrypted correctly. I attached a
screenshot of the conversation in both jitsi and google talk which can
also be found at: https://imgur.com/uOAJfhe
It also occurs when I log out of my google account everywhere but in
jitsi and I had been conversing between the same accounts (both google
talk)
before flawlessly with otr.
I do not know whether it is related, but the problem first occurred on
debian wheezy after upgrading libc6 (I was running a
stable/testing/unstable mix)
and persists after upgrading to jessie (which I had to, due to some
dependency issues caused by the libc6 upgrade).
Best Wishes and Regards
Sarah


#2
ยทยทยท

Hi Sarah,

  This is a serious bug and should definitely not have happened. We are aware of a few things that make the combination of XMPP (such as Google Talk) and OTR somewhat more difficult. For example, the fact that multiple chat sessions can be established where one is encrypted and the other is not, may be confusing. So, there is room for improvement there. Still, I haven't encountered anything like this.

  Can you tell me anything about the process leading up to this. For example, were you able to immediately establish the OTR sessions, or did you have trouble? Is there any chance that more than one chat sessions might have been established? Is there a chance that more than one OTR session was established? (You would know from the feedback OTR will give if it encounters other sessions.)

  Anything else that may be worth noting? Maybe some message (from OTR) on the other end?

  @George: Do you have any idea how this would have happened?

  Danny

  On 06-02-15 03:49, Sarah Braun wrote:
As the title says, I initiate a private conversation, the padlock closes and the conversation is shown as private, but my messages do not get encrypted. The problem persists with jitsi_2.6.5390-1_amd64 and jitsi_2.5-latest_amd64 on debian. I did not purge jitsi or delete $HOME/.jitsi in between installs. My conversation partner uses xabber on android which displays "This message has not been encrypted" under each of my messages. His messages get encrypted and decrypted correctly. I attached a screenshot of the conversation in both jitsi and google talk which can also be found at: It also occurs when I log out of my google account everywhere but in jitsi and I had been conversing between the same accounts (both google talk) before flawlessly with otr. I do not know whether it is related, but the problem first occurred on debian wheezy after upgrading libc6 (I was running a stable/testing/unstable mix) and persists after upgrading to jessie (which I had to, due to some dependency issues caused by the libc6 upgrade). Best Wishes and Regards Sarah

_______________________________________________ users mailing list Unsubscribe instructions and other list options:

https://imgur.com/uOAJfheusers@jitsi.orghttp://lists.jitsi.org/mailman/listinfo/users


#3

I hope it ends up in the right thread, I was not subscribed to the list
when I posted and am unsure how to reply.

Can you tell me anything about the process leading up to this.

Well, as said, I upgraded libc6 right before it first happened on debian
wheezy and then upgraded to debian jessie altogether. Systemd got pulled
in as a dependency when I installed something else and I removed it,
which removed network-manager as well, but I doubt that can be related.
When I first noticed that my messages are not encrypted in jitsi, I
tried pidgin and there I could not log in to either my google or jabber
account due to SSL errors (failed handshake). This is also an error that
did not previously occur. After upgrading to jessie and reinstalling
pidgin after purging it and removing $HOME/.purple the error was fixed.
As I have said I did not purge jitsi or remove the folder, since I
thought it might be good to keep it as is for finding the cause of a bug
that might be harmful, depending on the situation.

were you able to immediately establish the OTR sessions, or did you

have trouble?

The OTR session was started as always. No problems there.

Is there any chance that more than one chat sessions might have been

established? Is there a chance that more than one OTR session was
established?

We absolutely double and triple checked that we had ended all other
chats and were both logged out in all other clients. I just logged in to
google for taking the screenshot, to show my messages are plaintext. We
also refreshed the otr session multiple times.

I can not think of anything else that is noteworthy. I started jitsi
from commandline as well, but there was no output during establishing
the session. Can I run it in debug mode? I tried -d, but it did not do
anything.