[jitsi-users] Adding exception to reverse proxy


#1

Hi,
Thanks to your help, I was able to solve my previous problem of configuring
Secure Jitsi Rooms (
http://lists.jitsi.org/pipermail/users/2018-January/013959.html). But I did
not get a reply to my mail which I could reply to and thank. I am just
getting the daily digest. I guess I will have to take it with the mailing
list admin to find out the issue.

Right now I would like to request for another help. Currently my jitsi-meet
(with secure rooms) is running flawlessly (On an Ubuntu 16.04 server
instance with Apache) by accessing, say, https://mydomain.com/roomname.
Since I enabled SSL using the letsencrypt script, the http to https
redirection has also been enabled.

Now, what I would like to do is to add an exception to the reverseproxy
configuration of my Apache so that http://mydomain.com/forum redirects to
another website that is hosted on another machine in the same network, say,
http://192.168.1.5/forum.

My current apache configuration under /etc/apache2/mydomain.com.conf looks
like this <https://pastebin.com/NQFrQsep>

Apache configuration is not my forte so you'll have to be gentle with me. I
tried simply changing the part where the reverse proxy for /http-bind is
set up, by redirecting it to my forum url and it kind-of works (no scripts
running) so it gives me hope that it should be possible without
re-configuring the setup entirely.

Please let me know if any other information is expected from me.

cheers!

Gaurav Kumar

···

--
Scientist/Engineer
Regional Remote Sensing Centre
NRSC/ISRO/DOS
CAZRI Campus
Jodhpur, Rajasthan


#2

Hi,

well, your question is not for this mailinglist :slight_smile:
I'm also not an apache expert, but you should edit this part
<VirtualHost *:80> and not touch the https one if you are fine with
/forum over http?
Or you want the forum to go over the https, then you need to add all
the proxy stuff that is for /http-bind to add it and for /forum... and
check on the internet how to match /forum(.*) ( everything under forum
folder) ...

Regards
damencho

···

On Tue, Jan 23, 2018 at 1:58 AM, Gaurav Kumar <gaurav1089@gmail.com> wrote:

Hi,
Thanks to your help, I was able to solve my previous problem of configuring
Secure Jitsi Rooms
(http://lists.jitsi.org/pipermail/users/2018-January/013959.html). But I did
not get a reply to my mail which I could reply to and thank. I am just
getting the daily digest. I guess I will have to take it with the mailing
list admin to find out the issue.

Right now I would like to request for another help. Currently my jitsi-meet
(with secure rooms) is running flawlessly (On an Ubuntu 16.04 server
instance with Apache) by accessing, say, https://mydomain.com/roomname.
Since I enabled SSL using the letsencrypt script, the http to https
redirection has also been enabled.

Now, what I would like to do is to add an exception to the reverseproxy
configuration of my Apache so that http://mydomain.com/forum redirects to
another website that is hosted on another machine in the same network, say,
http://192.168.1.5/forum.

My current apache configuration under /etc/apache2/mydomain.com.conf looks
like this

Apache configuration is not my forte so you'll have to be gentle with me. I
tried simply changing the part where the reverse proxy for /http-bind is set
up, by redirecting it to my forum url and it kind-of works (no scripts
running) so it gives me hope that it should be possible without
re-configuring the setup entirely.

Please let me know if any other information is expected from me.

cheers!

Gaurav Kumar
--
Scientist/Engineer
Regional Remote Sensing Centre
NRSC/ISRO/DOS
CAZRI Campus
Jodhpur, Rajasthan

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users