[jitsi-users] Account created, does not connect


#1

I tried to connect to jit.si and other jabber servers (created account before of course), but jitsi complains about a configuration error:

"19:01:24.501 INFO: impl.resources.ResourceManagementServiceImpl.getImageURL().544 Missing resource for key: service.gui.icons.RIGHT_ARROW_ICON
19:01:37.840 SCHWERWIEGEND: impl.gui.main.login.LoginManager.handleOperationFailedException().555 Provider could not be registered due to an invalid account property:
net.java.sip.communicator.service.protocol.OperationFailedException: Wrong proxy port, null does not represent an integer
         at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1068)
         at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:635)
         at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:454)
         at net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:455)
Caused by: java.lang.NumberFormatException: null
         at java.lang.Integer.parseInt(Integer.java:443)
         at java.lang.Integer.parseInt(Integer.java:514)
         at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1063)
         ... 3 more"

Using latest nightly on debian wheezy, any help appreciated :slight_smile:


#2

Seems like you have a problem with the port number you've set for the
proxy. Either make sure it's a valid port number or just disable the proxy.

Hope this helps,
Emil

···

On 08.11.12, 13:13, Gernot Super wrote:

I tried to connect to jit.si and other jabber servers (created account
before of course), but jitsi complains about a configuration error:

"19:01:24.501 INFO:
impl.resources.ResourceManagementServiceImpl.getImageURL().544 Missing
resource for key: service.gui.icons.RIGHT_ARROW_ICON
19:01:37.840 SCHWERWIEGEND:
impl.gui.main.login.LoginManager.handleOperationFailedException().555
Provider could not be registered due to an invalid account property:
net.java.sip.communicator.service.protocol.OperationFailedException:
Wrong proxy port, null does not represent an integer
         at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1068)
         at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:635)
         at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:454)
         at
net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:455)
Caused by: java.lang.NumberFormatException: null
         at java.lang.Integer.parseInt(Integer.java:443)
         at java.lang.Integer.parseInt(Integer.java:514)
         at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1063)
         ... 3 more"

Using latest nightly on debian wheezy, any help appreciated :slight_smile:

--
https://jitsi.org


#3

Emil,
I love and use Jitsi every day. When will you make a version for iPhone?
Thanks.
Jerry

Emil Ivov:

···

Seems like you have a problem with the port number you've set for the
proxy. Either make sure it's a valid port number or just disable the proxy.

Hope this helps,
Emil

On 08.11.12, 13:13, Gernot Super wrote:

I tried to connect to jit.si and other jabber servers (created account
before of course), but jitsi complains about a configuration error:

"19:01:24.501 INFO:
impl.resources.ResourceManagementServiceImpl.getImageURL().544 Missing
resource for key: service.gui.icons.RIGHT_ARROW_ICON
19:01:37.840 SCHWERWIEGEND:
impl.gui.main.login.LoginManager.handleOperationFailedException().555
Provider could not be registered due to an invalid account property:
net.java.sip.communicator.service.protocol.OperationFailedException:
Wrong proxy port, null does not represent an integer
          at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1068)
          at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:635)
          at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:454)
          at
net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:455)
Caused by: java.lang.NumberFormatException: null
          at java.lang.Integer.parseInt(Integer.java:443)
          at java.lang.Integer.parseInt(Integer.java:514)
          at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1063)
          ... 3 more"

Using latest nightly on debian wheezy, any help appreciated :slight_smile:


#4

Hey Jerry,

Emil,
I love and use Jitsi every day.

Thank you for your kind words.

When will you make a version for iPhone?

We are currently working on our Android version. We probably won't be
able to start an iPhone port before a while.

Cheers,
Emil

···

On 13.11.12, 22:24, Jerry wrote:

Thanks.
Jerry

Emil Ivov:

Seems like you have a problem with the port number you've set for the
proxy. Either make sure it's a valid port number or just disable the proxy.

Hope this helps,
Emil

On 08.11.12, 13:13, Gernot Super wrote:

I tried to connect to jit.si and other jabber servers (created account
before of course), but jitsi complains about a configuration error:

"19:01:24.501 INFO:
impl.resources.ResourceManagementServiceImpl.getImageURL().544 Missing
resource for key: service.gui.icons.RIGHT_ARROW_ICON
19:01:37.840 SCHWERWIEGEND:
impl.gui.main.login.LoginManager.handleOperationFailedException().555
Provider could not be registered due to an invalid account property:
net.java.sip.communicator.service.protocol.OperationFailedException:
Wrong proxy port, null does not represent an integer
          at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1068)
          at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:635)
          at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:454)
          at
net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:455)
Caused by: java.lang.NumberFormatException: null
          at java.lang.Integer.parseInt(Integer.java:443)
          at java.lang.Integer.parseInt(Integer.java:514)
          at
net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1063)
          ... 3 more"

Using latest nightly on debian wheezy, any help appreciated :slight_smile:

--
https://jitsi.org


#5

Hi

I'm running Jitsi daily on Ubuntu 12.04. I recently switched to Java7 and
I noticed the fonts in the UI are now bold (and ugly). Is there any way to
specify the fonts to use either in Jitsi or in Java?

Claude


#6

Hello Emil,

is there already a beta for Android to test?

Regards,
  Matteo

---- Original Messagge ----

···

From: Emil Ivov <emcho@jitsi.org>
Sent: giovedì 15 novembre 2012, 12:40
To: users@jitsi.java.net
Cc: Jerry <jerry@4spectrum.us>
Subj: [jitsi-users] Re: Jitsi for iPhone?

Hey Jerry,

On 13.11.12, 22:24, Jerry wrote:

Emil,
I love and use Jitsi every day.

Thank you for your kind words.

When will you make a version for iPhone?

We are currently working on our Android version. We probably won't be
able to start an iPhone port before a while.

Cheers,
Emil

Thanks.
Jerry

Emil Ivov:

Seems like you have a problem with the port number you've set for the
proxy. Either make sure it's a valid port number or just disable the proxy.

Hope this helps,
Emil

On 08.11.12, 13:13, Gernot Super wrote:

I tried to connect to jit.si and other jabber servers (created account
before of course), but jitsi complains about a configuration error:

"19:01:24.501 INFO:
impl.resources.ResourceManagementServiceImpl.getImageURL().544 Missing
resource for key: service.gui.icons.RIGHT_ARROW_ICON
19:01:37.840 SCHWERWIEGEND:
impl.gui.main.login.LoginManager.handleOperationFailedException().555
Provider could not be registered due to an invalid account property:
net.java.sip.communicator.service.protocol.OperationFailedException:
Wrong proxy port, null does not represent an integer
          at

net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1068)

          at

net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:635)

          at

net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:454)

          at

net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:455)

Caused by: java.lang.NumberFormatException: null
          at java.lang.Integer.parseInt(Integer.java:443)
          at java.lang.Integer.parseInt(Integer.java:514)
          at

net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1063)

          ... 3 more"

Using latest nightly on debian wheezy, any help appreciated :slight_smile:


#7

Replying to myself as I found a solution by removing the following
packages on ubuntu : 'ttf-unfonts-core' and 'fonts-unfonts-core'. These
fonts are installed with wine and somehow they alter normal rendering of
Java fonts.

···

De : Claude Durocher <Claude.Durocher@sct.gouv.qc.ca>
A : users@jitsi.java.net,
Date : 16/11/2012 11:11
Objet : [jitsi-users] Java 7 fonts

Hi

I'm running Jitsi daily on Ubuntu 12.04. I recently switched to Java7 and
I noticed the fonts in the UI are now bold (and ugly). Is there any way to
specify the fonts to use either in Jitsi or in Java?

Claude


#8

Hey Matteo,

Hello Emil,

is there already a beta for Android to test?

So far we've mostly ported our media and protocol stacks so there's
nothing that a user can run. Hopefully we'll have a beta before the end
of the year though.

Emil

···

On 15.11.12, 12:57, Matteo Calorio wrote:

Regards,

Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: giovedì 15 novembre 2012, 12:40

To: users@jitsi.java.net

Cc: Jerry <jerry@4spectrum.us>

Subj: [jitsi-users] Re: Jitsi for iPhone?

Hey Jerry,

On 13.11.12, 22:24, Jerry wrote:

Emil,

I love and use Jitsi every day.

Thank you for your kind words.

When will you make a version for iPhone?

We are currently working on our Android version. We probably won't be

able to start an iPhone port before a while.

Cheers,

Emil

Thanks.

Jerry

Emil Ivov:

Seems like you have a problem with the port number you've set for the

proxy. Either make sure it's a valid port number or just disable the

proxy.

Hope this helps,

Emil

On 08.11.12, 13:13, Gernot Super wrote:

I tried to connect to jit.si and other jabber servers (created account

before of course), but jitsi complains about a configuration error:

"19:01:24.501 INFO:

impl.resources.ResourceManagementServiceImpl.getImageURL().544 Missing

resource for key: service.gui.icons.RIGHT_ARROW_ICON

19:01:37.840 SCHWERWIEGEND:

impl.gui.main.login.LoginManager.handleOperationFailedException().555

Provider could not be registered due to an invalid account property:

net.java.sip.communicator.service.protocol.OperationFailedException:

Wrong proxy port, null does not represent an integer

at

net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1068)

at

net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:635)

at

net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:454)

at

net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:455)

Caused by: java.lang.NumberFormatException: null

at java.lang.Integer.parseInt(Integer.java:443)

at java.lang.Integer.parseInt(Integer.java:514)

at

net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.loadProxy(ProtocolProviderServiceJabberImpl.java:1063)

... 3 more"

Using latest nightly on debian wheezy, any help appreciated :slight_smile:

--
https://jitsi.org


#9

Glad to know it's working for you now and thanks for posting here. We
should probably think of a way to prevent this from happening though.

Ideas, anyone?

Emil

···

On 20.11.12, 23:56, Claude Durocher wrote:

Replying to myself as I found a solution by removing the following
packages on ubuntu : 'ttf-unfonts-core' and 'fonts-unfonts-core'. These
fonts are installed with wine and somehow they alter normal rendering of
Java fonts.

De : Claude Durocher <Claude.Durocher@sct.gouv.qc.ca>
A : users@jitsi.java.net,
Date : 16/11/2012 11:11
Objet : [jitsi-users] Java 7 fonts
------------------------------------------------------------------------

Hi

I'm running Jitsi daily on Ubuntu 12.04. I recently switched to Java7
and I noticed the fonts in the UI are now bold (and ugly). Is there any
way to specify the fonts to use either in Jitsi or in Java?

Claude

--
https://jitsi.org