[jitsi-users] A/V signal of users not transmitting


#1

Hi,

I'm running both jocofo and jvb on the same ubuntu 17.10 machine sitting
behind a NAT. I had opened up TCP 443 and 4443, UDP 10000 both on the
router and firewall.
I also added the following two lines in
/etc/jitsi/videobridge/sip-communicator.properties, according to
instructions found here:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<192.168.X.X>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

And I even tried adding an additional line
*org.jitsi.videobridge.TCP_HARVESTER_PORT*
but still no dice.

Just to make sure that it's likely a port issue, I enabled p2p and could
see the image of a second user.

If anyone knows of a way to fix it, I'd greatly appreciate it.

Cheers!


#2

Hi,

Hi,

I'm running both jocofo and jvb on the same ubuntu 17.10 machine sitting behind a NAT. I had opened up TCP 443 and 4443, UDP 10000 both on the router and firewall.

Note that these ports need to be forwarded from the NAT box to jitsi-videobridge. Check the logs of jitsi-videobridge to see if it advertises the correct addresses, and whether the failure comes from ICE.

Without a TURN server, the p2p connection might not succeed (depending on networks between the two clients).

Regards,
Boris

···

On 08/03/2018 15:37, Yang wrote:


#3

Actually, never mind. Even with the p2p feature turned on and only two
members in the same room, one still cannot see or hear the other. But the
entrance announcement and avatar can be seen by both.

···

On Thu, Mar 8, 2018 at 4:37 PM Yang <lzy7071@gmail.com> wrote:

Hi,

I'm running both jocofo and jvb on the same ubuntu 17.10 machine sitting
behind a NAT. I had opened up TCP 443 and 4443, UDP 10000 both on the
router and firewall.
I also added the following two lines in
/etc/jitsi/videobridge/sip-communicator.properties, according to
instructions found here:
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<192.168.X.X>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

And I even tried adding an additional line
*org.jitsi.videobridge.TCP_HARVESTER_PORT*
but still no dice.

Just to make sure that it's likely a port issue, I enabled p2p and could
see the image of a second user.

If anyone knows of a way to fix it, I'd greatly appreciate it.

Cheers!