[jitsi-users] a question on load balance


#1

I'm a new user of jitsi-meet, now I use two VPS to make a load balance, but
how do I check it working properly? When I use several users(about 6) to
join several meets(about 2), but I find they all joined a same
videobridge...I saw the pubsub received the information from videobridges
in prosody log and each videobridge sent their information to prosody in
jvb log


#2

I'm a new user of jitsi-meet, now I use two VPS to make a load balance, but how do I check it working properly? When I use several users(about 6) to join several meets(about 2), but I find they all joined a same videobridge...I saw the pubsub received the information from videobridges in prosody log and each videobridge sent their information to prosody in jvb log

The load balancing will happen at the room level, that is, different rooms will be allocated to different bridges. Try to create multiple rooms and check the logs.

Cheers,

···

On Apr 25, 2018, at 07:38, 岳永东 <yueyongdong@gmail.com> wrote:

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Saúl


#3

Thanks to give advise. I think it might be wrong at my configuration on
Jitsi.
I used 2 VPS for Jitsi, and they all do full install(Jicofo, Prosody, and
Videobridge), its domains are a.mydomain.com and b.mydomain.com,
I followed the guide of this:
https://github.com/jitsi/jicofo/blob/master/doc/load_balancing.md
but at last it can't use, I think it might because in this guide it use 3
differenct domains, example.com as jicofo, jvb1.example.com as videobridge1
and jvb2.example as videobridge2.
Finally I follow the guide at
https://stackoverflow.com/questions/44039295/jitsi-video-bridge-component-prosody-loadbalancing
it likes to work for my situation, but as I mentioned before, it arranges
all the meets on videobridge of a.mydomain.com, and never do this at
b.mydomain.com... all the configurations are like the example of
StackOverflow...

Please help me

···

2018-04-25 15:18 GMT+08:00 Saúl Ibarra Corretgé <scorretge@atlassian.com>:

> On Apr 25, 2018, at 07:38, 岳永东 <yueyongdong@gmail.com> wrote:
>
> I'm a new user of jitsi-meet, now I use two VPS to make a load balance,
but how do I check it working properly? When I use several users(about 6)
to join several meets(about 2), but I find they all joined a same
videobridge...I saw the pubsub received the information from videobridges
in prosody log and each videobridge sent their information to prosody in
jvb log

The load balancing will happen at the room level, that is, different rooms
will be allocated to different bridges. Try to create multiple rooms and
check the logs.

Cheers,

> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

You don't need 2 full installs. You need one, let's say it is mydomain.com
<http://a.mydomain.com/>. So you need one machine with everything where by
default jvb will use component jitsi-videobridge.mydomain.com
<http://a.mydomain.com/>
You need to setup on different machine just jvb using another component
name which you need to configure in prosody, and also configure the
pubsub part for both jvbs and that's it.
Jicofo will be balancing between both jvbs.

···

On Wed, Apr 25, 2018 at 4:20 AM, 岳永东 <yueyongdong@gmail.com> wrote:

Thanks to give advise. I think it might be wrong at my configuration on
Jitsi.
I used 2 VPS for Jitsi, and they all do full install(Jicofo, Prosody, and
Videobridge), its domains are a.mydomain.com and b.mydomain.com,
I followed the guide of this: https://github.com/jitsi/
jicofo/blob/master/doc/load_balancing.md
but at last it can't use, I think it might because in this guide it use 3
differenct domains, example.com as jicofo, jvb1.example.com as
videobridge1 and jvb2.example as videobridge2.
Finally I follow the guide at https://stackoverflow.com/
questions/44039295/jitsi-video-bridge-component-prosody-loadbalancing
it likes to work for my situation, but as I mentioned before, it arranges
all the meets on videobridge of a.mydomain.com, and never do this at
b.mydomain.com... all the configurations are like the example of
StackOverflow...

Please help me

2018-04-25 15:18 GMT+08:00 Saúl Ibarra Corretgé <scorretge@atlassian.com>:

> On Apr 25, 2018, at 07:38, 岳永东 <yueyongdong@gmail.com> wrote:
>
> I'm a new user of jitsi-meet, now I use two VPS to make a load balance,
but how do I check it working properly? When I use several users(about 6)
to join several meets(about 2), but I find they all joined a same
videobridge...I saw the pubsub received the information from videobridges
in prosody log and each videobridge sent their information to prosody in
jvb log

The load balancing will happen at the room level, that is, different
rooms will be allocated to different bridges. Try to create multiple rooms
and check the logs.

Cheers,

> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Thanks to give advise! but if I set jvb sip file in b.mydomain.com like
this:

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.b.mydomain.com/.*

org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=pubsub.a.mydomain.com
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

and in prosody config file like this:

VirtualHost "a.mydomain.com"

        authentication = "internal_plain"
        ssl = {
                key = "/etc/prosody/certs/a.mydomain.com.key";
                certificate = "/etc/prosody/certs/a.mydomain.com.crt";
        }

        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
        }

        c2s_require_encryption = false
Component "pubsub.a.mydomain.com"
    admins = { "jitsi-videobridge.a.mydomain.com", "
jitsi-videobridge.b.mydomain.com" }
    modules_enabled = {
        "pubsub";
    }

Component "conference.a.mydomain.com" "muc"
    storage = "null"
admins = { "focus@auth.a.mydomain.com" }

Component "jitsi-videobridge.a.mydomain.com"
    component_secret = "yYayrxsd"
Component "jitsi-videobridge.b.mydomain.com"
    component_secret = "t3K2NCyw"

--guest
VirtualHost "guest.a.mydomain.com"
    authentication = "anonymous"
VirtualHost "auth.a.mydomain.com"
    ssl = {
        key = "/etc/prosody/certs/auth.a.mydomain.com.key";
        certificate = "/etc/prosody/certs/auth.a.mydomain.com.crt";
    }
    authentication = "internal_plain"

Component "focus.a.mydomain.com"
    component_secret = "fiO7VldJ

and in jicofo sip file like this:

org.jitsi.jicofo.auth.URL=XMPP:a.mydomain.com
org.jitsi.focus.pubsub.ADDRESS=pubsub.a.mydomain.com
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

but log of jvb show:
JVB 2018-04-26 09:18:46.715 SEVERE: [20]
org.jitsi.meet.ComponentMain.call().278 not-authorized, host:a.mydomain.com,
port:5347
org.xmpp.component.ComponentException: not-authorized

how can I solve it? Thanks.

···

2018-04-25 21:26 GMT+08:00 Damian Minkov <damencho@jitsi.org>:

You don't need 2 full installs. You need one, let's say it is mydomain.com
<http://a.mydomain.com/>. So you need one machine with everything where
by default jvb will use component jitsi-videobridge.mydomain.com
<http://a.mydomain.com/>
You need to setup on different machine just jvb using another component
name which you need to configure in prosody, and also configure the
pubsub part for both jvbs and that's it.
Jicofo will be balancing between both jvbs.

On Wed, Apr 25, 2018 at 4:20 AM, 岳永东 <yueyongdong@gmail.com> wrote:

Thanks to give advise. I think it might be wrong at my configuration on
Jitsi.
I used 2 VPS for Jitsi, and they all do full install(Jicofo, Prosody, and
Videobridge), its domains are a.mydomain.com and b.mydomain.com,
I followed the guide of this: https://github.com/jitsi/jicof
o/blob/master/doc/load_balancing.md
but at last it can't use, I think it might because in this guide it use 3
differenct domains, example.com as jicofo, jvb1.example.com as
videobridge1 and jvb2.example as videobridge2.
Finally I follow the guide at https://stackoverflow.com/q
uestions/44039295/jitsi-video-bridge-component-prosody-loadbalancing
it likes to work for my situation, but as I mentioned before, it arranges
all the meets on videobridge of a.mydomain.com, and never do this at
b.mydomain.com... all the configurations are like the example of
StackOverflow...

Please help me

2018-04-25 15:18 GMT+08:00 Saúl Ibarra Corretgé <scorretge@atlassian.com>
:

> On Apr 25, 2018, at 07:38, 岳永东 <yueyongdong@gmail.com> wrote:
>
> I'm a new user of jitsi-meet, now I use two VPS to make a load
balance, but how do I check it working properly? When I use several
users(about 6) to join several meets(about 2), but I find they all joined a
same videobridge...I saw the pubsub received the information from
videobridges in prosody log and each videobridge sent their information to
prosody in jvb log

The load balancing will happen at the room level, that is, different
rooms will be allocated to different bridges. Try to create multiple rooms
and check the logs.

Cheers,

> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

I have get the point, because the b.mydomain.com it presents the jvb2, so
the second Component of JVB in prosody config file should be b.mydomain.net
and not jitsi-videobridge.b.mydomain.com, so as the part of admins of
pubsub, it should be b.mydomain.com and not jitsi-videobridge.b.mydomain.com,
I modified those two points and it works properly! Thanks to all.

···

2018-04-26 9:33 GMT+08:00 岳永东 <yueyongdong@gmail.com>:

Thanks to give advise! but if I set jvb sip file in b.mydomain.com like
this:

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus
@auth.b.mydomain.com/.*

org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=pubsub.a.mydomain.com
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

and in prosody config file like this:

VirtualHost "a.mydomain.com"

        authentication = "internal_plain"
        ssl = {
                key = "/etc/prosody/certs/a.mydomain.com.key";
                certificate = "/etc/prosody/certs/a.mydomain.com.crt";
        }

        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
        }

        c2s_require_encryption = false
Component "pubsub.a.mydomain.com"
    admins = { "jitsi-videobridge.a.mydomain.com", "
jitsi-videobridge.b.mydomain.com" }
    modules_enabled = {
        "pubsub";
    }

Component "conference.a.mydomain.com" "muc"
    storage = "null"
admins = { "focus@auth.a.mydomain.com" }

Component "jitsi-videobridge.a.mydomain.com"
    component_secret = "yYayrxsd"
Component "jitsi-videobridge.b.mydomain.com"
    component_secret = "t3K2NCyw"

--guest
VirtualHost "guest.a.mydomain.com"
    authentication = "anonymous"
VirtualHost "auth.a.mydomain.com"
    ssl = {
        key = "/etc/prosody/certs/auth.a.mydomain.com.key";
        certificate = "/etc/prosody/certs/auth.a.mydomain.com.crt";
    }
    authentication = "internal_plain"

Component "focus.a.mydomain.com"
    component_secret = "fiO7VldJ

and in jicofo sip file like this:

org.jitsi.jicofo.auth.URL=XMPP:a.mydomain.com
org.jitsi.focus.pubsub.ADDRESS=pubsub.a.mydomain.com
org.jitsi.jicofo.STATS_PUBSUB_NODE=sharedStatsNode

but log of jvb show:
JVB 2018-04-26 09:18:46.715 SEVERE: [20] org.jitsi.meet.ComponentMain.call().278
not-authorized, host:a.mydomain.com, port:5347
org.xmpp.component.ComponentException: not-authorized

how can I solve it? Thanks.

2018-04-25 21:26 GMT+08:00 Damian Minkov <damencho@jitsi.org>:

You don't need 2 full installs. You need one, let's say it is
mydomain.com <http://a.mydomain.com/>. So you need one machine with
everything where by default jvb will use component jitsi-videobridge.
mydomain.com <http://a.mydomain.com/>
You need to setup on different machine just jvb using another component
name which you need to configure in prosody, and also configure the
pubsub part for both jvbs and that's it.
Jicofo will be balancing between both jvbs.

On Wed, Apr 25, 2018 at 4:20 AM, 岳永东 <yueyongdong@gmail.com> wrote:

Thanks to give advise. I think it might be wrong at my configuration on
Jitsi.
I used 2 VPS for Jitsi, and they all do full install(Jicofo, Prosody,
and Videobridge), its domains are a.mydomain.com and b.mydomain.com,
I followed the guide of this: https://github.com/jitsi/jicof
o/blob/master/doc/load_balancing.md
but at last it can't use, I think it might because in this guide it use
3 differenct domains, example.com as jicofo, jvb1.example.com as
videobridge1 and jvb2.example as videobridge2.
Finally I follow the guide at https://stackoverflow.com/q
uestions/44039295/jitsi-video-bridge-component-prosody-loadbalancing
it likes to work for my situation, but as I mentioned before, it
arranges all the meets on videobridge of a.mydomain.com, and never do
this at b.mydomain.com... all the configurations are like the example of
StackOverflow...

Please help me

2018-04-25 15:18 GMT+08:00 Saúl Ibarra Corretgé <scorretge@atlassian.com
>:

> On Apr 25, 2018, at 07:38, 岳永东 <yueyongdong@gmail.com> wrote:
>
> I'm a new user of jitsi-meet, now I use two VPS to make a load
balance, but how do I check it working properly? When I use several
users(about 6) to join several meets(about 2), but I find they all joined a
same videobridge...I saw the pubsub received the information from
videobridges in prosody log and each videobridge sent their information to
prosody in jvb log

The load balancing will happen at the room level, that is, different
rooms will be allocated to different bridges. Try to create multiple rooms
and check the logs.

Cheers,

> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users