Jitsi URL after changing the SSL Certifiacte (GoDaddy SSL)

Dear team, I have installed the Jitsi using default lets encrypt cert. Now i am going to change the SSL config using new GoDaddy SSL Certifiacte (.crt & .key) file. Could anyone help me with the Jitsi URL? how to check which URL should I use to access the interface after changing the new certificate ? Its a wildcard certificate @emrah could you help?

The same URL. You just changed the certificates, not the FQDN itself.

@Kenren_Taisho thanks I have changed the SSL certificate in the nginx and the interface is working fine but the the camera, microphone and other toolbar options are not working correctly. Only Hangup button is working fine. Other buttons are showing but if I click nothing will happen. Camera is not working although the permissions are gvn and its allowd to use for this site


These buttons not working. Camera is not working. @Kenren_Taisho

If the domain is changed, it doesn’t work. The domain must be the same

1 Like

Thanks @emrah , can I update the domain in the config ? default domain name might be the hostname but I have changed the certificate for accessing the url for public

There are many places to update. I think reinstalling using the current domain name will be easier

many thanks @emrah will do it and update.

Hi @emrah I tried reinstalling using required domain name (first updated the hostname with requried domain name) and then installed jitsi. After changing the certificate the same issue is there

you should test your url before testing cam and mic. Just access the welcome page and click the lock icon in the URL bar, it should be green and you should be able to see your certificate from here. If not your web server (nginx) configuration is wrong. There is nothing specific to Jitsi-meet here. Once it’s fixed media devices will work.

hi @gpatel-fr , kindly find the images. Its showing secure connection and valid certificate and when i click on the certificate I am able to see the certificate


It’s not a certificate problem then. Maybe a browser problem ? did you try with latest Chrome or Firefox (not sure what is your browser from the screens you pasted) ?
Edit: additional question; what happens if you click on the mic icon (for example) ?

I tried in chrome and firefox, Chrome version is - Version 94.0.4606.61. If I click on the camera or microphone, nothing will happen. I can see that the Camera flash is on which means the system is accessing camera but its not reflecting on the jitsi page

IIUC the problem is changed. Before you could not enable the mic icon, now it’s possible to enable it but no sound on the other side. Is this right?

Please find some screesnhots. When I hover/select camera up arrow its showing the cam. also when try using select background option, its showing the cam like this.


@emrah Mic is also not working. If i click on the Mic -up arrow i can see the settings and microphone activity but the actual Mic control is not working on the Toolbar.

Probably the reinstalling is not completed correctly because of the old config files. What is your distro and its version?

How can I check the version ? What I have done is i have replaced the new certificate and key files in the /etc/jitsi/meet/ folder. Since the crt and key files were generated with required domain name (same as hostname), editing cert files -names in /etc/nginx/sites-available/.conf file was not required. let me know if any other configurations needs to be done.

Ubuntu or Debian?
Which version?

Im using - Ubuntu 20.04.
I followed the information on this (till step 10) then i replaced the cert files - How to Install Jitsi Meet on Ubuntu Server – InMotion Hosting Support Center