Jitsi transmitting sound from other applications

Hi, when I am in a call on meet.jit.si the other participants can hear the sound that my PC is sending to its output, for example videos on youtube and music played locally. How can I disable this? I am using Firefox.

Just mute yourself & unmute when required

I am doing that, but jitsi should not send the output of my PC. I also don’t understand the interaction, since the others can hear everything I hear except for themselves.

Try moving your speakers away from the mic