A couple of comments inline:
Adds security started event, indicating when security initialization has really started.
--- trunk/src/net/java/sip/communicator/service/protocol/media/MediaAwareCallPeer.java (revision 9511)
+++ trunk/src/net/java/sip/communicator/service/protocol/media/MediaAwareCallPeer.java (revision 9512)
@@ -693,6 +693,19 @@
+ * Indicates that the other party has timeouted replying to our
+ * offer to secure the connection.
This doesn't sound right. Copy paste error?
+ * @param sessionType the type of the call session - audio or video.
+ public void securityStarted(int sessionType)
+ CallPeerSecurityStartedEvent evt =
+ new CallPeerSecurityStartedEvent(this, sessionType);
If I understand correctly, we fire this event once the ZRTP
negotiation starts. A "SecurityStarted" name may lead people to
believing that we have "started being secure". Could we rename this to
"SecurityNegotiationStarted" please? Unless I missed something of
On Thu, Apr 5, 2012 at 4:39 PM, <firstname.lastname@example.org> wrote: