[jitsi~svn:9137] Change "proactive notification" to "typing notification"


#1

Hey Ingo,

На 23.11.11 14:03, ibauersachs@java.net написа:

-plugin.notificationconfig.event.ProactiveNotification=Proactive Notification
+plugin.notificationconfig.event.ProactiveNotification=Typing Notifications

I am not sure I understand this one. Could you please comment a bit?

Emil


#2

Hey

На 23.11.11 14:03, ibauersachs@java.net написа:

-plugin.notificationconfig.event.ProactiveNotification=Proactive Notification
+plugin.notificationconfig.event.ProactiveNotification=Typing Notifications

I am not sure I understand this one. Could you please comment a bit?

The event PROACTIVE_NOTIFICATIONS of the notification manager is (only) fired by the typing notifications. Therefore the rename from "proactive" to "typing"
Before I translated the notification config UI, the plugin simply showed the enum names (converted from Pascal-Casing to "Spaced-Casing"). During the translation I simply took the same name as it was before because I didn't knew better.

Maybe you remember that I told you I disabled the typing notifications, but receive them despite the setting? Well, no wonder: The setting behind the checkbox in Options->General->Message is not used anywhere.

Ingo


#3

Hey Ingo,

На 24.11.11 15:33, Bauersachs Ingo написа:

Hey

На 23.11.11 14:03, ibauersachs@java.net написа:

-plugin.notificationconfig.event.ProactiveNotification=Proactive Notification
+plugin.notificationconfig.event.ProactiveNotification=Typing Notifications

I am not sure I understand this one. Could you please comment a bit?

The event PROACTIVE_NOTIFICATIONS of the notification manager is (only)
fired by the typing notifications. Therefore the rename from "proactive"
to "typing"

Any "Proactive Notification" is a typing notification received while
there were no windows open with the contact that generated it. So yes
you are right: PROACTIVE_NOTIFICATIONs are only generated by typing
notifications. That still keeps them different from regular typing
notifications that you get in the chat window during a conversation with
someone.

Before I translated the notification config UI, the plugin simply showed
the enum names (converted from Pascal-Casing to "Spaced-Casing").

I don't understand. Where was this happening? Is this related to your
change? In your example, what is the difference between Pascal-Casing to
"Spaced-Casing"?

During
the translation I simply took the same name as it was before because I
didn't knew better.

Maybe you remember that I told you I disabled the typing notifications,
but receive them despite the setting? Well, no wonder: The setting
behind the checkbox in Options->General->Message is not used anywhere.

OK. Just to be clear, this is not related to your string change, right?

IIRC, that setting was meant to prevent Jitsi from sending typing
notifications. It could have been broken along the way of course and if
so then we should have a look at it.

Emil


#4

Hi,

Hey Ingo,

На 24.11.11 15:33, Bauersachs Ingo написа:

Hey

На 23.11.11 14:03, ibauersachs@java.net написа:

-plugin.notificationconfig.event.ProactiveNotification=Proactive Notification
+plugin.notificationconfig.event.ProactiveNotification=Typing Notifications

I am not sure I understand this one. Could you please comment a bit?

The event PROACTIVE_NOTIFICATIONS of the notification manager is (only)
fired by the typing notifications. Therefore the rename from "proactive"
to "typing"

Any "Proactive Notification" is a typing notification received while
there were no windows open with the contact that generated it. So yes
you are right: PROACTIVE_NOTIFICATIONs are only generated by typing
notifications. That still keeps them different from regular typing
notifications that you get in the chat window during a conversation with
someone.

Before I translated the notification config UI, the plugin simply showed
the enum names (converted from Pascal-Casing to "Spaced-Casing").

I don't understand. Where was this happening? Is this related to your
change? In your example, what is the difference between Pascal-Casing to
"Spaced-Casing"?

During
the translation I simply took the same name as it was before because I
didn't knew better.

Maybe you remember that I told you I disabled the typing notifications,
but receive them despite the setting? Well, no wonder: The setting
behind the checkbox in Options->General->Message is not used anywhere.

OK. Just to be clear, this is not related to your string change, right?

IIRC, that setting was meant to prevent Jitsi from sending typing
notifications. It could have been broken along the way of course and if
so then we should have a look at it.

Well I looked at it and tested it. Its working fine when I disable
typing notifications in Options->General->Message, typing
notifications are not sent.

Its used in impl.gui.main.chat.ChatWritePanel
... void keyTyped(KeyEvent e)
    {
        if (ConfigurationManager.isSendTypingNotifications())

Regards
damencho

···

On Thu, Nov 24, 2011 at 6:19 PM, Emil Ivov <emcho@jitsi.org> wrote: